SCEGLI (funzione SCEGLI)

Questo articolo descrive la sintassi della formula e l'uso della funzione SCEGLI in Microsoft Excel.

Descrizione

Usa indice per restituire un valore dall'elenco degli argomenti valore. Usare la funzione SCEGLI per selezionare da uno a 254 valori in base al numero di indice. Ad esempio, se i valori da valore1 a valore7 sono i giorni della settimana, SCEGLI restituirà uno dei giorni quando verrà usato come indice un numero da 1 a 7.

Sintassi

SCEGLI(indice; valore1; [valore2]; ...)

Gli argomenti della sintassi della funzione SCEGLI sono i seguenti:

  • Indice    Obbligatorio. Specifica quale argomento val viene selezionato. È necessario che indice sia un numero compreso tra 1 e 254 oppure una formula o un riferimento a una cella contenente un numero compreso tra 1 e 254.

    • Se indice è 1, SCEGLI restituirà valore1, se è 2, SCEGLI restituirà valore2 e così via.

    • Se indice è un numero minore di 1 o maggiore del numero dell'ultimo valore dell'elenco, SCEGLI restituirà il valore di errore #VALORE!.

    • Se indice è una frazione, la parte decimale verrà troncata.

  • Valore1; valore2;...     Il valore 1 è obbligatorio, i valori successivi sono facoltativi. Da 1 a 254 argomenti tra i quali SCEGLI seleziona un valore o un'operazione da eseguire in base a indice. Gli argomenti possono essere numeri, riferimenti di cella, nomi definiti, formule, funzioni o testo.

Osservazioni

  • Se indice è una matrice, eseguendo la funzione SCEGLI verrà calcolato ciascun valore.

  • Gli argomenti valore specificati per SCEGLI possono essere sia riferimenti ad intervalli che valori singoli.

    Ad esempio, la formula:

=SOMMA(SCEGLI(2;A1:A10;B1:B10;C1:C10))

dà come risultato:

=SOMMA(B1:B10)

che restituisce quindi un valore sulla base dei valori contenuti nell'intervallo B1:B10.

La funzione SCEGLI viene calcolata per prima e restituisce il riferimento B1:B10. La funzione SOMMA viene quindi calcolata usando come argomento B1:B10, il risultato della funzione SCEGLI.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, è possibile regolare la larghezza delle colonne per visualizzare tutti i dati.

Dati

 

Chiodi

Viti

Dadi

Prodotto finito

Bulloni

Formula

Descrizione

Risultato

=SCEGLI(2;A2;A3;A4;A5)

Valore del secondo argomento dell'elenco (valore della cella A3)

=SCEGLI(4;B2;B3;B4;B5)

Valore del quarto argomento dell'elenco (valore della cella B5)

Bulloni

=SCEGLI(3;"Grande";115;"mondo";8)

Valore del terzo argomento dell'elenco

mondo

Esempio 2

Dati

23

45

12

10

Formula

Descrizione (risultato)

Risultato

=SOMMA(A2:SCEGLI(2;A3;A4;A5))

Somma dell'intervallo A2:A4. La funzione SCEGLI restituisce A4 come seconda parte dell'intervallo per la funzione SOMMA.

80

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×