Ricerca di elementi archiviati

Ricerca di elementi archiviati

Questo articolo è stato aggiornato il 23 febbraio 2016 sulla base dei commenti ricevuti dai clienti.

È possibile che in alcune circostanze sia necessario cercare elementi in un file di dati di Outlook. Questo articolo spiega come cercare elementi e risolvere i problemi relativi alla ricerca.

Esame degli elementi archiviati

Per impostazione predefinita, l'archiviazione automatica di Outlook rimuove regolarmente gli elementi obsoleti e scaduti dalle cartelle, per consentire la gestione dello spazio nella cassetta postale o nel server della posta in uso.

È possibile impostare l'archiviazione automatica in modo che sposti o copi gli elementi meno recenti in una cartella di archivio designata o li elimini automaticamente. Se non vengono eliminati, gli elementi archiviati rimarranno disponibili nella cartella di archiviazione.

Recuperare gli elementi archiviati

Per visualizzare il percorso e le impostazioni di archiviazione e per ottenere istruzioni per disattivare l'archiviazione automatica, vedere Spostamento o eliminazione automatica di elementi meno recenti con Archiviazione automatica.

  1. Nella versione desktop di Outlook (Outlook 2016, Outlook 2013, Outlook 2010) scegliere Home > Nuovi elementi > Altri elementi > File di dati di Outlook.

    Scegliere Nuovi elementi > Altri elementi > File di dati di Outlook.

  2. Scegliere il file denominato archivio (o il nome specificato per il file archiviato).

    Selezionare il file denominato "archivio".

  3. Espandere il file di archivio nel riquadro di spostamento di Outlook per visualizzare le sottocartelle. Fare clic su ogni sottocartella per visualizzarne il contenuto.

    Espandere il file di archivio nel riquadro di spostamento per visualizzare le sottocartelle.

  4. Per cercare un messaggio di posta elettronica specifico, usare Ricerca immediata in Outlook o Windows Search.

  5. Per importare gli elementi archiviati nella cartella Posta in arrivo, seguire le istruzioni per l'importazione di un file PST. Il nome del file da importare è "archivio" e verrà importato nell'account di posta elettronica corrente.

Se i messaggi di posta elettronica archiviati non sono visibili

Nota :  Il file di dati di Outlook (con estensione pst) dell'archivio visualizza la stessa struttura di cartelle del file archiviato. Se una cartella nell'archivio è vuota, non sono stati archiviati elementi per tale cartella.

Se non si riesce ancora a visualizzare la posta elettronica archiviata, anche se sono state seguite le istruzioni precedenti per il recupero, verificare quali sono le impostazioni per l'archiviazione automatica della posta elettronica.

  1. Nella versione desktop di Outlook (Outlook 2016, Outlook 2013, Outlook 2010) scegliere File.

    In Outlook 2010 scegliere la scheda File.

  2. Scegliere Opzioni.

  3. Scegliere Avanzate > Impostazioni archiviazione automatica.

    Scegliere Avanzate e quindi Impostazioni archiviazione automatica.

    Nota : Se l'opzione Impostazioni archiviazione automatica non è visibile, tale funzionalità non è abilitata per l'organizzazione.

  4. Osservare con quale frequenza viene archiviata la posta elettronica e se il file di archivio viene eliminato dopo un periodo di tempo. In base a queste impostazioni, dovrebbero esserci messaggi di posta elettronica nella cartella di archivio?

    A questo punto è possibile scegliere le opzioni di archiviazione automatica.

  5. I messaggi di posta elettronica verranno archiviati nel percorso indicato in Sposta i vecchi elementi in.

Dove vengono archiviati i messaggi di posta elettronica?

In Outlook 2016, Outlook 2013 e Outlook 2010 i nuovi file di archivio vengono salvati nei percorsi seguenti:

  • Windows Vista, Windows 7, 8 e 10    unità:\Users\utente\Documents\Outlook Files\archive.pst

  • Windows XP   unità:\Documents and Settings\utente\Local Settings\Application Data\Microsoft\Outlook\archive.pst

Nelle versioni precedenti di Outlook il file di archivio viene salvato nei percorsi seguenti:

  • Windows 7 e Windows Vista   unità:\Users\utente\AppData\Local\Microsoft\Outlook\archive.pst

  • Windows XP   unità:\Documents and Settings\utente\Local Settings\Application Data\Microsoft\Outlook\archive.pst

Tutti i messaggi, le informazioni di contatto, i calendari e gli altri dati creati in Microsoft Outlook vengono conservati in un File delle cartelle personali (.pst) oppure, se si usa un account di Microsoft Exchange Server, nel server di Exchange dell'organizzazione. Outlook offre una funzione di archiviazione che consente di eliminare i contenuti meno recenti che non sono necessari, ma che si preferisce non cancellare definitivamente, dalle cartelle di uso più comune. È possibile eseguire automaticamente questa operazione con Archiviazione automatica oppure eseguire l'archiviazione in modo manuale.

Il contenuto archiviato non comparirà più nel cartelle di uso comune, ma è comunque accessibile e recuperabile se si vuole eseguirne il ripristino.

Note : 

  • L'archiviazione può essere utile per ridurre le dimensioni degli account di posta elettronica aziendale, per cui in alcune aziende vengono fissati dei limiti. Allo stesso tempo, i file archiviati spesso devono rimanere accessibili per poter essere ripristinati se ciò è previsto dai requisiti di conformità.

  • Outlook non può archiviare file attivi o correnti. Non è ad esempio possibile archiviare una riunione ricorrente, a meno che tutte le relative occorrenze non siano nel passato. In presenza di occorrenze pianificate nel futuro, la riunione viene considerata come elemento corrente e quindi non può essere archiviata.

Usare la funzionalità Ricerca immediata per trovare elementi

  • È possibile che l'indicizzazione dei file di dati non sia completa. L'indicizzazione consente alla funzionalità Ricerca immediata di individuare rapidamente gli elementi.

    Nota : Quando si inizia a usare Ricerca immediata per la prima volta, Outlook deve indicizzare i file di dati in modo da offrire risultati di ricerca rapidi e completi. Questo processo potrebbe richiedere alcuni minuti.

  • Si intende cercare messaggi con firma non crittografata (un metodo di crittografia) e la ricerca viene effettuata in un File delle cartelle personali (.pst) o in un file delle cartelle offline (con estensione ost).

    Nota : Questo problema può verificarsi se per cercare i messaggi si usa Ricerca sul desktop di Windows oppure Outlook (Ricerca immediata o Ricerca avanzata).

    Vedere Risoluzione dei problemi relativi a messaggi con firma non crittografata.

Verifica della possibilità di indicizzare i file di dati di Outlook

Outlook indicizza i file di dati seguenti:

  • File delle cartelle personali (con estensione pst)

  • File delle cartelle offline (con estensione ost)

Sono inclusi account di posta elettronica POP, IMAP e Microsoft Windows Live Mail. Se si usa un account di Microsoft Exchange, molto più comune nei sistemi di posta elettronica aziendali rispetto a un account personale o familiare, per l'indicizzazione dei messaggi tramite Ricerca immediata è necessario essere connessi al server che esegue Exchange e usare la modalità cache. La modalità cache usa un file delle cartelle offline (con estensione ost) per salvare le informazioni nel computer. Per verificare quali siano i file di dati indicizzati, eseguire le operazioni seguenti:

  1. Scegliere Ricerca immediata dal menu Strumenti e quindi fare clic su Opzioni di ricerca.

    In alternativa, fare clic sulla freccia nel riquadro Ricerca immediata e quindi su Opzioni di ricerca nel menu.

  2. In Indicizzazione verificare che i file di dati da includere nella ricerca siano selezionati nell'elenco Indicizza messaggi nei seguenti file di dati.

Verifica del completamento dell'indicizzazione

Per verificare lo stato di indicizzazione, eseguire le operazioni seguenti:

  1. Scegliere Ricerca immediata dal menu Strumenti e quindi fare clic su Stato indicizzazione.

    In alternativa, fare clic sulla freccia nel riquadro Ricerca immediata e quindi su Stato indicizzazione nel menu.

  2. Verificare che nella finestra di dialogo venga visualizzato 0 elementi rimanenti. In caso contrario, l'indicizzazione non è completa ed è necessario completarla prima di poter eseguire la ricerca in tutti gli elementi di Outlook.

Risultati della ricerca non corretti anche se in Stato indicizzazione è visualizzato "0 elementi rimanenti"

Se in Stato indicizzazione è visualizzato 0 elementi rimanenti e Ricerca immediata non restituisce ancora risultati corretti, chiudere Outlook e riavviare il computer. Al riavvio di Outlook, eseguire le operazioni seguenti per verificare che Outlook indicizzi correttamente gli elementi:

  1. Scegliere Ricerca immediata dal menu Strumenti e quindi fare clic su Stato indicizzazione.

    In alternativa, fare clic sulla freccia nel riquadro Ricerca immediata e quindi su Stato indicizzazione nel menu.

  2. Verificare che il numero di elementi nella finestra di dialogo Stato indicizzazione sia aumentato. Se il numero non è aumentato, per i risultati è necessario attendere il completamento dell'indicizzazione.

Mancata restituzione dei risultati corretti tramite Ricerca immediata nonostante il riavvio del computer

Se nonostante il riavvio non vengono restituiti risultati, il passaggio successivo consiste nel ricreare il catalogo di ricerca. Il catalogo di ricerca è un file in cui vengono indicizzati tutti gli elementi di Outlook e Microsoft Windows. Per ricreare il catalogo di ricerca, eseguire le operazioni seguenti:

  1. Uscire da Outlook.

  2. In Microsoft Windows fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

  3. Eseguire una delle operazioni seguenti:

    • Windows Vista     Fare clic su Sistema e manutenzione e quindi fare clic su Opzioni di indicizzazione.

      Nota : Nella visualizzazione classica fare doppio clic su Opzioni di indicizzazione.

    • Microsoft Windows XP     In Vedere anche fare clic su Altre opzioni del Pannello di controllo e quindi fare clic su Opzioni di indicizzazione.

      Nota : Nella visualizzazione classica fare doppio clic su Opzioni di indicizzazione.

  4. Fare clic su Avanzate.

  5. Fare clic su Ricrea.

  6. Riavviare Outlook.

Risoluzione dei problemi relativi a messaggi con firma non crittografata

Se un messaggio con firma non crittografata è archiviato in un file delle cartelle personali (con estensione pst) o un file delle cartelle offline (con estensione ost), non verrà trovato in Ricerca immediata di Outlook (e Windows Desktop Search). Il modo in cui Outlook crittografa, o "comprime", il testo del corpo del messaggio quando è firmato con una tecnologia di crittografia con firma non crittografata non consente di eseguire ricerche nel testo del messaggio.

Per altre informazioni sulla tecnologia di firma e crittografia, vedere Concetti relativi alla crittografia a chiave pubblica.

È però possibile usare la procedura seguente per verificare se il percorso del file costituisce una parte del problema.

  1. Determinare se si intende cercare un file PST oppure OST.

    Procedura

    1. Nella cartella Posta in arrivo fare clic sulla piccola freccia singola accanto alla casella In tutti gli elementi di posta.

    2. Fare clic su Opzioni di ricerca.

    3. Nella sezione Indicizzazione verificare che le caselle di controllo seguenti siano selezionate:

      • Cartelle personali

      • Cassetta postale - <nome utente>

  2. Se si ritiene che i messaggi siano archiviati in altri file di dati, oltre a quelli PST oppure OST, deselezionare le caselle di controllo (se necessario) e ripetere la ricerca.

Se si sta eseguendo la ricerca in un file di dati diverso da uno PST oppure OST e i messaggi non vengono ancora trovati con Ricerca immediata, verificare se l'account di posta elettronica di Outlook non sia impostato per l'uso della modalità cache. In tal caso, disattivare la modalità cache e ripetere la ricerca.

Procedura

  1. Scegliere Impostazioni account dal menu Strumenti.

  2. Nella scheda Posta elettronica selezionare l'account di posta elettronica di Exchange Server e quindi fare clic su Cambia.

  3. In Server di Microsoft Exchange deselezionare la casella di controllo Usa modalità cache.

  4. Chiudere e riavviare Outlook.

Se pur avendo disattivato la modalità cache non si riesce comunque a ottenere i risultati previsti, provare a usare un profilo Outlook diverso. Se non è stato configurato un altro profilo, è possibile crearne uno. In ogni caso, è necessario disattivare la modalità cache come descritto nella procedura precedente.

Copiare tutti gli elementi da una posizione di archiviazione

Gli elementi archiviati possono essere copiati nelle cartelle originali, ad esempio dalla Posta in arrivo archiviata alla Posta in arrivo corrente, oppure in una nuova cartella specificata.

  1. Nel menu File fare clic su Importa ed esporta per aprire l'Importazione/Esportazione guidata.

  2. Fare clic su Importa dati da altri programmi o file e quindi su Avanti.

  3. Fare clic su File delle cartelle personali (.pst), quindi su Avanti.

    Importante : Se non si riesce a trovare il file PST, è possibile che sia nascosto e che sia necessario visualizzarne il percorso prima di continuare con il passaggio successivo.

  4. Nella casella File da importare sostituire il nome predefinito del file (backup.pst) nel percorso evidenziato con il nome del file di archivio da cui si vogliono importare i dati. In alternativa, fare clic su Sfoglia per trovare il file da cui importare.

  5. In Opzioni specificare come devono essere gestiti gli elementi duplicati.

  6. Fare clic su Avanti.

  7. Fare clic sulla cartella da cui importare. Selezionare la casella di controllo Includi sottocartelle se la cartella da importare contiene sottocartelle che devono essere importate.

  8. Selezionare una delle opzioni di destinazione:

    • Importa gli elementi nella cartella corrente: i dati vengono importati nella cartella selezionata.

    • Importa gli elementi nella stessa cartella in: i dati vengono importati nella cartella di destinazione con lo stesso nome della cartella di origine, ad esempio da Posta in arrivo a Posta in arrivo.

  9. Fare clic su Fine.

Non si riesce a trovare il file PST

Il file di archivio è un particolare tipo di file di dati, denominato File delle cartelle personali (pst). La prima volta che si esegue l'archiviazione automatica, Outlook crea automaticamente il file di archivio nei seguenti percorsi:

  • Windows Vista     C:\Utenti\NomeUtente\AppData\Local\Microsoft\Outlook\Archive.pst

  • Microsoft Windows XP     C:\Documents and Settings\NomeUtente\Impostazioni locali\Dati applicazioni\Microsoft\Outlook\Archive.pst

Se la cartella Impostazioni locali o Local non è visibile, è possibile che sia nascosta. Per visualizzare un file PST nascosto, completare la procedura relativa al sistema operativo in uso.

Windows 7 e Windows Vista

  1. Fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

  2. Fare clic su Aspetto e personalizzazione.

    Nota : Se si usa la visualizzazione classica del Pannello di controllo, fare doppio clic su Opzioni cartella e tornare al passaggio 4 in Copiare tutti gli elementi da una posizione di archiviazione.

  3. Fare clic su Opzioni cartella.

  4. Nel riquadro Impostazioni avanzate della scheda Visualizzazione, in Cartelle e file nascosti nel gruppo File e cartelle, selezionare Visualizza cartelle, file e unità nascosti.

Windows XP

  1. Fare clic su Start e quindi su Pannello di controllo.

  2. Fare clic su Opzioni cartella.

    Finestra di dialogo Opzioni cartella

  3. Nella scheda Visualizzazione fare clic sull'opzione Visualizza cartelle e file nascosti.

Spostare singoli elementi da una posizione di archiviazione

  1. Nel menu Vai fare clic su Elenco cartelle, quindi su Cartelle archivio (o il nome usato per la posizione di archiviazione).

  2. Fare clic sulla cartella contenente gli elementi da spostare.

  3. Selezionare gli elementi da spostare e trascinarli nella cartella originale nell'Elenco cartelle o in un'altra cartella.

Nota : Se viene visualizzato un messaggio di errore che indica che il file PST è già in uso, è possibile che presenti problemi di dimensioni o sia danneggiato. Lo strumento Manutenzione Posta in arrivo di Outlook può risolvere molti di questi problemi. Dopo avere eseguito lo strumento, provare di nuovo a ripristinare i file.

Argomenti correlati

Informazioni generali sui profili di posta elettronica di Outlook
Passare a un altro profilo di posta elettronica di Outlook
Creare un nuovo profilo di posta elettronica
Eseguire il backup, ripristinare o eliminare elementi usando Archiviazione automatica
Archiviare elementi manualmente
Trovare elementi archiviati
Aprire e trovare elementi in un archivio di Outlook per Mac 2011

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×