Pubblicare una versione aggiornata di un modello di modulo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Quando si pubblica un modello di modulo che sono stati modificati, InfoPath possibile aggiornare il modello di modulo (xsn) e i moduli esistenti (file con estensione XML) basato su tale modello. Per impostazione predefinita, InfoPath sostituisce automaticamente la versione precedente del modello di modulo con la versione più recente. È possibile scegliere il metodo di aggiornamento che si preferisce per i moduli utente esistenti.

In questo articolo

Prevenire perdite di dati in moduli utente esistenti

Pubblicare un modello di modulo aggiornato

Consentire agli utenti di scegliere se aggiornare i modelli di modulo

Prevenire perdite di dati in moduli utente esistenti

Se è necessario aggiornare un modello di modulo esistente, è possibile modificarlo, pubblicarlo e distribuirlo agli utenti. Tuttavia, determinati tipi di modifiche potrebbero impedire l'accesso ai dati nei moduli completati basati sul modello di modulo originale.

Se si apporta modifiche a un modello di modulo che potrebbe causare la perdita di dati o errori nei moduli che hanno già compilati, verrà visualizzato un messaggio. Quando si aggiungono nuove, i campi obbligatori a un modello di modulo o quando si rinomina o rimuovere campi o gruppi dal modello di modulo, è spesso verrà visualizzato il messaggio.

Messaggio di errore indicante la possibile perdita di dati

Quando viene visualizzato questo messaggio, fare clic su e continuare con le modifiche apportate, potrebbe non essere possibile accedere ai dati nei moduli esistenti dopo la pubblicazione del modello di modulo aggiornato. In alcuni casi può trattarsi accettabile. È necessario decidere di volta in base alla situazione specifica.

Per fare in modo che è possibile accedere ai dati già raccolti dagli utenti, seguire queste linee guida quando si apportano modifiche al modello di modulo originale:

  • Non rinominare i campi esistenti e i gruppi nell'origine dati.

  • Non spostare i campi esistenti e i gruppi nell'origine dati.

  • Non eliminare i campi esistenti e i gruppi dell'origine dati. È possibile eliminare controlli dal modello di modulo senza problemi, purché si lascia il controllo campo o gruppo corrispondente nell'origine dati.

Inizio pagina

Pubblicare un modello di modulo aggiornato

Si supponga di voler apportare modifiche a un modello di modulo già in uso in ambito aziendale. Se le modifiche implicano la modifica dell'origine dati sottostante di tale modello, è necessario adottare una soluzione che consenta di aggiornare in modo efficace la versione del modello di modulo pubblicata in precedenza e che garantisca l'uso della versione aggiornata da parte di tutti gli utenti. È inoltre possibile specificare come gestire i moduli esistenti basati sul modello di modulo originale.

  1. Aprire il modello di modulo che si desidera aggiornare.

  2. Apportare le eventuali modifiche necessarie al modello di modulo.

  3. Scegliere Opzioni modulo dal menu Strumenti.

  4. Nell'elenco categoria fare clic su controllo delle versioni.

    A questo punto è necessario specificare come si desidera gestire i moduli esistenti (file con estensione xml) compilati tramite il modello di modulo originale.

  5. Nell'elenco Quando la versione viene aggiornata in Versione modello modulo eseguire una delle operazioni seguenti:

    • Per convertire automaticamente le versioni obsolete del modulo nella versione aggiornata, fare clic su Aggiorna automaticamente i moduli esistenti. Quando si seleziona questa opzione, agli utenti non verrà chiesto di aggiornare i moduli esistenti in quanto l'aggiornamento verrà eseguito automaticamente alla successiva apertura di un modulo nuovo o esistente.

    • Per scrivere il codice personalizzato per la gestione automatica del processo di aggiornamento, fare clic su Utilizza evento personalizzato e quindi sul pulsante Modifica. È quindi possibile utilizzare l'evento OnVersionUpgrade, che si verifica quando il numero di versione di un modulo di InfoPath aperto è meno recente rispetto a quello del modello di modulo su cui è basato. Per ulteriori informazioni sull'evento OnVersionUpgrade, fare riferimento alla documentazione per gli sviluppatori di InfoPath.

    • Per impedire che i moduli vengano aggiornati, fare clic su Nessuna operazione (è possibile che i moduli esistenti non funzionino correttamente). Quando viene selezionata questa opzione, sarà possibile compilare i moduli basati sul modello di modulo aggiornato, ma non sarà possibile aprire i moduli esistenti. Seppur sia possibile aprire moduli esistenti, non sarà comunque possibile modificarne i campi appena aggiunti.

  6. Scegliere Pubblica dal menu File ed eseguire i passaggi della Pubblicazione guidata.

    Quando gli utenti aprono un modulo basato sul modello di modulo, ricevono automaticamente la nuova versione del modello. Se tentano di aprire moduli creati con la versione precedente del modello, verranno applicate le modifiche specificate al passaggio 5.

Inizio pagina

Consentire agli utenti di scegliere se aggiornare i modelli di modulo

Quando si pubblica una versione aggiornata di un modello di modulo, la copia del modello archiviata nei computer degli utenti viene aggiornata con la versione più recente. Tale operazione viene eseguita automaticamente quando gli utenti aprono un modulo basato sul modello di modulo aggiornato. Questa è in genere l'azione preferita nella maggior parte dei casi. È tuttavia possibile visualizzare una finestra di dialogo che consente agli utenti di scegliere se aggiornare il modello di modulo quando viene resa disponibile una nuova versione.

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco categoria fare clic su controllo delle versioni.

  3. In versione modello di modulo, selezionare la casella di controllo Consenti agli utenti di scegliere se eseguire l'aggiornamento a una nuova versione del modello di modulo e quindi fare clic su OK.

    Nota : Per impostazione predefinita, i dati per il valore del Registro di sistema EnableAutoUpdatePrompt sono uguali a 0 (off). Verrà richiesto di aggiornare il modulo solo se un l'amministratore di sistema ha modificato i dati per il valore EnableAutoUpdatePrompt da 0 (off) a 1 (on).

  4. Scegliere Pubblica dal menu File ed eseguire i passaggi della Pubblicazione guidata.

Alla successiva apertura di un modulo basato sul modello di modulo, all'utente verrà chiesto di scegliere se mantenere il modello di modulo esistente o se invece sostituirlo con la nuova versione. Se non viene visualizzata la finestra di dialogo, allora i dati per il valore EnableAutoUpdatePrompt saranno con molta probabilità 0 (off) invece di 1 (on).

Nota : Prima di aprire effettivamente un modulo, gli utenti possono scegliere di recuperare l'ultima versione di un particolare modello di modulo (file con estensione xsn) facendo clic sul collegamento Recupera aggiornamento di questo modulo oppure Recupera aggiornamenti dei moduli di questa categoria nella finestra di dialogo Compila modulo. I collegamenti rimangono attivi anche se gli utenti dispongono già della versione più recente del modello di modulo nel computer in uso. In questo scenario quando un utente fa clic su uno dei collegamenti per l'aggiornamento, viene semplicemente archiviato nuovamente il modello di modulo più recente nel computer dell'utente.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×