Pubblicare una cartella di lavoro in una raccolta di SharePoint in Excel 2016 per Windows

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile pubblicare una cartella di lavoro in una raccolta di Microsoft SharePoint per consentire ad altre persone di visualizzarla o modificarla in un Web browser, anche se non hanno installato Excel nel proprio computer. La pubblicazione è essenzialmente analoga al salvataggio, ma offre in più alcune opzioni predefinite che consentono di controllare i contenuti che le altre persone possono visualizzare quando aprono la cartella di lavoro in un browser.

L'adozione dell'abitudine di salvare o pubblicare, a livello di organizzazione, una cartella di lavoro in un sito di SharePoint centrale può evitare il diffondersi di versioni leggermente diverse della stessa cartella di lavoro quando viene inviata tramite posta elettronica all'interno dell'organizzazione.

Impostando alcune opzioni di pubblicazione è inoltre possibile evidenziare aree specifiche della cartella di lavoro, ad esempio i grafici, o escluderne altre dalla visualizzazione nel browser. Ad esempio, è possibile visualizzare un grafico, ma non i dati sottostanti oppure mostrare solo certi fogli di lavoro alle persone che hanno l'esigenza di vederli e nascondere gli altri.

Questo articolo illustra come pubblicare una cartella di lavoro da Excel 2016, ma non tratta la connessione di una cartella di lavoro o dei dati di una cartella di lavoro a una Web part Excel Web Access in una pagina di SharePoint.

Quando si pubblica una cartella di lavoro in un sito di SharePoint, l'intera cartella di lavoro viene salvata in SharePoint. Un utente con le necessarie autorizzazioni di SharePoint può visualizzare e usare l'intera cartella di lavoro nel browser nell'applicazione desktop Excel.

Se Office Online viene distribuito in SharePoint, è possibile visualizzare e usare i dati nel browser in modo molto simile a quanto avviene con l'applicazione desktop Excel. Ma a differenza dell'applicazione desktop Excel, più utenti possono modificare contemporaneamente una cartella di lavoro nel browser. Se quando si apre una cartella di lavoro nel browser è visualizzato il pulsante Modifica in Excel Online, significa che Office Online è pronto per l'uso.

Comando Modifica in Excel Online nel menu Modifica cartella di lavoro

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro è possibile scegliere di selezionare solo i fogli di lavoro o gli elementi che si desidera rendere visibili nel browser. È tuttavia necessario ricordare che, sebbene sia possibile limitare gli elementi da rendere visibili in questa modalità, sul server di SharePoint viene comunque salvato tutto il contenuto della cartella di lavoro.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Per consentire agli utenti di immettere un valore in una cella per usare una formula in un'altra cella, impostare la cella come nome definito in Excel prima di pubblicare la cartella di lavoro. Aggiungere quindi il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni visualizzazione browser.

Ad esempio, di seguito è illustrata una cella D2 con il nome definito "Tariffa". Nel browser l'utente immette il valore 5,625 nella casella Tariffa del riquadro Parametri e quindi fa clic su Applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Il parametro immesso nel riquadro viene usato nella cella D2

Nota : Se si crea un filtro dei dati per una tabella di Excel e si definisce un nome per l'intervallo di celle contenenti la tabella e il filtro, non sarà possibile applicare tale filtro alla tabella nel browser se si pubblica l'intervallo definito. Se si pubblica la tabella o l'intero foglio di lavoro o la relativa cartella di lavoro, il filtro funzionerà come previsto nel browser.

Pubblicare la cartella di lavoro

  1. Fare clic sulla scheda File, su Salva con nome e quindi su SharePoint.

  2. Se è presente la cartella di SharePoint in corrente, recenti o meno, fare clic sulla cartella desiderata.

    Verrà visualizzata la finestra di dialogo Salva con nome.


    In caso contrario, fare clic su Sfoglia, immettere l'indirizzo web del sito di SharePoint e quindi passare alla cartella in cui si desidera pubblicare la cartella di lavoro.

    Fare clic su una cartella di SharePoint oppure su Sfoglia
  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare dalla cartella di lavoro, fare clic su Opzioni visualizzazione browser.

    Nella finestra di dialogo Salva con nome fare clic su Opzioni visualizzazione browser

    Verranno visualizzate le schede Mostra e Parametri.

  4. Se si vuole pubblicare l'intera cartella di lavoro, fare clic su Salva. In caso contrario, eseguire una delle operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, nella scheda Mostra selezionare Tutta la cartella nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, nella scheda Mostra selezionare Fogli nella casella di riepilogo e quindi deselezionare le caselle di controllo corrispondenti ai fogli che non si vuole nascondere.

      Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere rapidamente visibili tutti i fogli dopo aver deselezionato alcune caselle di controllo, selezionare la casella di controllo Tutti i fogli.

    • Per visualizzare solo elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabelle pivot, nella scheda Mostra selezionare Elementi nella cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle di controllo degli elementi che si vuole visualizzare.

    • Nella scheda Parametri aggiungere i nomi definiti da usare per specificare le celle che devono risultare modificabili quando gli utenti visualizzano la cartella di lavoro nel browser, quindi fare clic su OK.

  5. Salvare la cartella di lavoro.

Note : 

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×