Pubblicare una cartella di lavoro in un sito di SharePoint in Excel per Windows

È possibile pubblicare una cartella di lavoro in una raccolta di Microsoft SharePoint per consentire ad altre persone di visualizzarla o modificarla in un Web browser, anche se non hanno installato Excel nel proprio computer. La pubblicazione è essenzialmente analoga al salvataggio, ma offre in più alcune opzioni predefinite che consentono di controllare i contenuti che le altre persone possono visualizzare quando aprono la cartella di lavoro in un browser.

L'adozione dell'abitudine di salvare o pubblicare, a livello di organizzazione, una cartella di lavoro in un sito di SharePoint centrale può evitare il diffondersi di versioni leggermente diverse della stessa cartella di lavoro quando viene inviata tramite posta elettronica all'interno dell'organizzazione.

Impostando alcune opzioni di pubblicazione, è possibile enfatizzare parti specifiche della cartella di lavoro, ad esempio i grafici, o escludere altre parti dall'essere visualizzate nel browser. Ad esempio, è possibile visualizzare un grafico ma non i dati sottostanti. In alternativa, è possibile visualizzare solo determinati fogli di lavoro per gli utenti che devono vederli e nascondere gli altri fogli di lavoro.

Questo articolo illustra come pubblicare una cartella di lavoro da Excel per Windows e non riguarda la connessione di una cartella di lavoro o i dati di una cartella di lavoro a una Web part Excel Web Access in una pagina di SharePoint.

Quando si pubblica una cartella di lavoro in un sito di SharePoint, l'intera cartella di lavoro viene salvata in SharePoint. Un utente con le necessarie autorizzazioni di SharePoint può visualizzare e usare l'intera cartella di lavoro nel browser nell'applicazione desktop Excel.

Se Office per il Web viene distribuito in SharePoint, è possibile visualizzare e usare i dati nel browser in modo molto simile a quanto avviene con l'applicazione desktop Excel. Ma a differenza dell'applicazione desktop Excel, più utenti possono modificare contemporaneamente una cartella di lavoro nel browser. Se quando si apre una cartella di lavoro nel browser è visualizzato il pulsante Modifica in Excel Online, significa che Office per il Web è pronto per l'uso.

Comando Modifica in Excel Online nel menu Modifica cartella di lavoro

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro è possibile scegliere di selezionare solo i fogli di lavoro o gli elementi che si desidera rendere visibili nel browser. È tuttavia necessario ricordare che, sebbene sia possibile limitare gli elementi da rendere visibili in questa modalità, sul server di SharePoint viene comunque salvato tutto il contenuto della cartella di lavoro.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Per consentire agli utenti di immettere un valore in una cella per usare una formula in un'altra cella, impostare la cella come nome definito in Excel prima di pubblicare la cartella di lavoro. Aggiungere quindi il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni visualizzazione browser.

Ad esempio, di seguito è illustrata una cella D2 con il nome definito "Tariffa". Nel browser l'utente immette il valore 5,625 nella casella Tariffa del riquadro Parametri e quindi fa clic su Applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Il parametro immesso nel riquadro viene usato nella cella D2

Nota: Se si crea un filtro dei dati per una tabella di Excel e si definisce un nome per l'intervallo di celle contenenti la tabella e il filtro, non sarà possibile applicare tale filtro alla tabella nel browser se si pubblica l'intervallo definito. Se si pubblica la tabella o l'intero foglio di lavoro o la relativa cartella di lavoro, il filtro funzionerà come previsto nel browser.

Pubblicare la cartella di lavoro

  1. Fare clic sulla scheda File, su Salva con nome e quindi su SharePoint.

  2. Se la cartella di SharePoint viene visualizzata in Current, recentio versioni precedenti, fare clic sulla cartella desiderata.

    Verrà visualizzata la finestra di dialogo Salva con nome.


    In caso contrario, fare clic su Sfoglia, immettere l'indirizzo Web del sito di SharePoint e passare alla cartella in cui si vuole pubblicare la cartella di lavoro.

    Fare clic su una cartella di SharePoint oppure su Sfoglia
  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare dalla cartella di lavoro, fare clic su Opzioni visualizzazione browser.

    Nella finestra di dialogo Salva con nome fare clic su Opzioni visualizzazione browser

    Verranno visualizzate le schede Mostra e Parametri.

  4. Se si vuole pubblicare l'intera cartella di lavoro, fare clic su Salva. In caso contrario, eseguire una delle operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, nella scheda Mostra selezionare Tutta la cartella nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, nella scheda Mostra selezionare Fogli nella casella di riepilogo e quindi deselezionare le caselle di controllo corrispondenti ai fogli che non si vuole nascondere.

      Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere rapidamente visibili tutti i fogli dopo aver deselezionato alcune caselle di controllo, selezionare la casella di controllo Tutti i fogli.

    • Per visualizzare solo elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabelle pivot, nella scheda Mostra selezionare Elementi nella cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle di controllo degli elementi che si vuole visualizzare.

    • Nella scheda Parametri aggiungere i nomi definiti da usare per specificare le celle che devono risultare modificabili quando gli utenti visualizzano la cartella di lavoro nel browser, quindi fare clic su OK.

  5. Salvare la cartella di lavoro.

Note: 

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

Se Office per il Web viene distribuito in SharePoint, è possibile visualizzare e usare i dati nel browser in modo molto simile a quanto avviene con l'applicazione desktop Excel. Ma a differenza dell'applicazione desktop Excel, più utenti possono modificare contemporaneamente una cartella di lavoro nel browser. Se quando si apre una cartella di lavoro nel browser è visualizzato il pulsante Modifica in Excel Online, significa che Office per il Web è pronto per l'uso.

Comando Modifica in Excel Online nel menu Modifica cartella di lavoro

Per altre informazioni, vedere l'articolo differenze tra l'uso di una cartella di lavoro in Excel ed Excel Services.

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro è possibile scegliere di selezionare solo i fogli di lavoro o gli elementi che si desidera rendere visibili nel browser. È tuttavia necessario ricordare che, sebbene sia possibile limitare gli elementi da rendere visibili in questa modalità, sul server di SharePoint viene comunque salvato tutto il contenuto della cartella di lavoro.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Per consentire agli utenti di immettere un valore in una cella per usare una formula in un'altra cella, impostare la cella come nome definito in Excel prima di pubblicare la cartella di lavoro. Aggiungere quindi il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni visualizzazione browser.

Ad esempio, di seguito è illustrata una cella D2 con il nome definito "Tariffa". Nel browser un utente immette un valore, 5,625, nella casella nel riquadro parametri e fa clic su applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Vedere la Guida di Excel per informazioni su come definire gli intervalli.

Il parametro immesso nel riquadro viene usato nella cella D2

Nota: Se si crea un filtro dei dati per una tabella di Excel e si definisce un nome per l'intervallo di celle contenenti la tabella e il filtro, non sarà possibile applicare tale filtro alla tabella nel browser se si pubblica l'intervallo definito. Se si pubblica la tabella o l'intero foglio di lavoro o la relativa cartella di lavoro, il filtro funzionerà come previsto nel browser.

Pubblicare la cartella di lavoro

  1. Fare clic su File > salva con nome >SharePoint.

  2. Se viene visualizzata la cartella di SharePointnella cartella corrente o nelle cartelle recenti, fare clic sulla cartella desiderata. In caso contrario, fare clic su Sfoglia e immettere l'indirizzo Web per il sito di SharePoint. Passare quindi alla cartella in cui si vuole pubblicare la cartella di lavoro. Verrà visualizzata la finestra di dialogo Salva con nome.

  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare dalla cartella di lavoro, fare clic su Opzioni visualizzazione browser. Verrà visualizzata una scheda Mostra e una scheda parametri . Se si vuole pubblicare l'intera cartella di lavoro, fare clic su Salva. In caso contrario, eseguire una delle operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, nella scheda Mostra selezionare Tutta la cartella nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, nella scheda Mostra selezionare fogli nella casella di riepilogo e quindi deselezionare le caselle per i fogli che non si vuole nascondere nel browser.

      Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere più rapidamente visibili tutti i fogli dopo aver deselezionato alcune delle caselle, selezionare la casella di controllo tutti i fogli .

    • Per visualizzare solo gli elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabella pivot, nella scheda Mostra selezionare elementi nella cartella di lavoro nella casella di riepilogo e quindi controllare le caselle relative agli elementi che si desidera visualizzare.

    • Nella scheda parametri aggiungere i nomi definiti che si desidera utilizzare per specificare le celle modificabili quando gli utenti visualizzano la cartella di lavoro nel browser. Quindi fare clic su OK per chiudere la finestra di dialogo.

  4. Salvare la cartella di lavoro.

Note: 

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

Per altre informazioni sulle web part di Excel Web Access, vedere l'articolo visualizzare una cartella di lavoro in una Web part Excel Web Access.

Quando si pubblica una cartella di lavoro in un server SharePoint, l'intero contenuto della cartella di lavoro viene salvato nel server e può essere visualizzato e usato se si apre la cartella di lavoro nell'applicazione desktop Excel. Se Office Web Apps è distribuito in SharePoint Server, la visualizzazione e l'uso dei dati nel Web browser può essere molto simile all'uso dei dati nell'applicazione desktop Excel. In realtà, la modifica simultanea di una cartella di lavoro è possibile nella griglia del browser quando vengono distribuite le app Web di Office. Quando si visualizza una cartella di lavoro nel browser, se il pulsante modifica nel browser è visibile, significa che Office Web Apps è disponibile.

Pulsante Modifica nel browser

Per altre informazioni, vedere l'articolo differenze tra l'uso di una cartella di lavoro in Excel ed Excel Services.

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro, è possibile (nella finestra di dialogo Opzioni di pubblicazione ) selezionare i fogli o gli elementi che si desidera visualizzare nel browser quando la modifica non è stata abilitata facendo clic sul pulsante modifica nel browser . Basta tenere presente che, anche se è possibile selezionare la visualizzazione in questa modalità, l'intero contenuto della cartella di lavoro viene ancora salvato in SharePoint Server.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Se si vuole consentire agli utenti di specificare un parametro per una formula quando si visualizza un foglio di lavoro in un browser, impostare una cella come nome definito. È quindi possibile aggiungere il nome definito come parametro nella scheda parametri nella finestra di dialogo Opzioni di pubblicazione .

Ad esempio, nell'immagine seguente che mostra un foglio di lavoro nel browser, la cella D2 ha la frequenza dei nomi definita. Nel browser un utente ha immesso un valore, 5,625, nella casella nel riquadro parametri e quindi su applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Utilizzo di un parametro nel browser

Vedere la Guida di Excel per informazioni su come definire gli intervalli.

Pubblicare la cartella di lavoro

  1. Fare clic sulla scheda File e quindi su Salva e invia.

  2. Fare clic su Salva in SharePoint.
    Nota    se il comando Salva in SharePoint non è disponibile, è comunque possibile salvare la cartella di lavoro in un sito di SharePoint usando il comando Salva con nome . La finestra di dialogo Opzioni di pubblicazione non sarà disponibile. È anche possibile caricare direttamente la cartella di lavoro da una raccolta di SharePoint. Gli utenti possono visualizzare e modificare il contenuto della cartella di lavoro nel browser accedendo direttamente al sito in cui viene salvata la cartella di lavoro.

    Comando Salva con nome

  3. Per selezionare singoli fogli o elementi da pubblicare nella cartella di lavoro, fare clic sul pulsante Opzioni di pubblicazione . In caso contrario, se si vuole pubblicare l'intera cartella di lavoro, passare direttamente al passaggio 4.
    Nella scheda Mostra eseguire le operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, selezionare intera cartella di lavoro nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, selezionare fogli nella casella di riepilogo e quindi deselezionare le caselle di controllo relative ai fogli che non si desidera rendere visibili.
      Nota    per impostazione predefinita, tutti i fogli sono selezionati. Per rendere rapidamente visibili tutti i fogli dopo avere cancellato alcune caselle di controllo, è possibile selezionare la casella di controllo tutti i fogli .

    • Per visualizzare solo gli elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabella pivot, selezionare gli elementi della cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle di controllo degli elementi che si desidera visualizzare.
      Nota se selezioni elementi con lo stesso nome, ad esempio un grafico e la relativa tabella di dati sottostante, solo uno di questi elementi sarà disponibile nel browser. Per visualizzare tutti gli elementi, è necessario assicurarsi che ogni elemento della cartella di lavoro abbia un nome univoco. È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nella scheda formule del gruppo nomi definiti .
      Selezione di elementi o fogli di lavoro

    • Nella scheda parametri aggiungere i nomi definiti che si desidera utilizzare per specificare le celle modificabili quando gli utenti visualizzano la cartella di lavoro nel browser. Quindi fare clic su OK per chiudere la finestra di dialogo.
      Impostazione di parametri

  4. Scegliere un percorso in cui pubblicare la cartella di lavoro.
    Potrebbero essere già presenti percorsi del server salvati in posizione corrente, posizioni recentio percorsi da cui è possibile scegliere. Se non ci sono posizioni di questo tipo o si vuole salvare in una nuova posizione, in posizionifare doppio clic su Cerca posizione.

  5. Nella finestra di dialogo Salva con nome immettere l'indirizzo Web per il sito di SharePoint e quindi passare al sito o alla raccolta in cui si vuole salvare la cartella di lavoro.

  6. Se non sono già stati selezionati singoli fogli di lavoro o elementi o si impostano parametri, fare clic sul pulsante Opzioni di pubblicazione .

  7. Nella casella nome file accettare il nome suggerito per la cartella di lavoro oppure digitare un nuovo nome, se si vuole.

  8. Per visualizzare il contenuto della cartella di lavoro in una finestra del browser subito dopo il completamento dell'operazione di pubblicazione, verificare che la casella di controllo Apri con Excel nel browser sia selezionata.

  9. Fare clic su Salva.

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×