Pubblicare un modello di modulo su un server che esegue Microsoft Windows SharePoint Services

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile pubblicare un modello di modulo in una nuova raccolta documenti oppure come nuovo tipo di contenuto del sito per un server che esegue Windows SharePoint Services 3.0.

Contenuto dell'articolo

Panoramica

Prima di iniziare

Pubblicare un modello di modulo in una nuova raccolta documenti

Pubblicare un modello di modulo come un nuovo tipo di contenuto del sito

Panoramica

Quando si pubblica un modello di modulo in una raccolta documenti, ogni modulo creato nella raccolta documenti sarà basato su tale modello. Pubblicare un modello di modulo in una raccolta documenti consente di distribuire rapidamente un modulo monouso, ad esempio un sondaggio informale sulle preferenze relative ai ristoranti per un pranzo di gruppo.

Se si pubblica un modello di modulo a un server che esegue Windows SharePoint Services 3.0, è possibile procedere come segue:

Pubblicare un modello di modulo come un tipo di contenuto del sito     Quando si pubblica un modello di modulo come tipo di contenuto del sito, consente agli utenti per assegnare più modelli di modulo a una singola raccolta documenti o per assegnare il modello di modulo a più raccolte in una raccolta siti. Una raccolta siti è un insieme di siti Web in un server virtuale che hanno lo stesso proprietario e condividere le impostazioni di amministrazione. Ogni raccolta siti contiene un sito Web principale e può contenere uno o più siti secondari. Possono essere presenti più raccolte siti di ogni server virtuale. Utilizzare un tipo di contenuto del sito quando si desidera riutilizzare ampiamente informazioni o per abilitare la raccolta di dati provenienti da più moduli in un'unica posizione.

Consentire agli utenti di modificare i campi tramite una visualizzazione Foglio dati    È possibile consentire agli utenti di aggiungere o modificare i dati per un campo tramite una visualizzazione Foglio dati o se la modifica delle proprietà per un modulo nella raccolta documenti. In questo modo agli utenti di aggiungere o aggiornare i dati per uno o più maschere senza aprirli.

Nota : Visualizzazioni Foglio dati sono abilitate nel Web browser solo per gli utenti che hanno Microsoft Office Access 2007 installato.

Nota : Supporto per le raccolte e tipi di contenuto del sito varia a seconda che il server è in esecuzione Microsoft Windows SharePoint Services 2.0 o Windows SharePoint Services 3.0. Di conseguenza, rivolgersi all'amministratore del server se non si sa quale versione di Windows SharePoint Services è in esecuzione nel server.

Se si pubblica un modello di modulo compatibile con browser, utilizzare il controllo grafico per identificare eventuali problemi di compatibilità nel modello di modulo prima di pubblicarlo in una nuova raccolta documenti. Il controllo grafico consente di verificare che il modello di modulo funzioni su un server che esegue InfoPath Forms Services. Se vengono individuati errori nel modello di modulo, sarà necessario correggerli prima di pubblicare il modello di modulo su un server che esegue InfoPath Forms Services.

Per pubblicare il modello di modulo in una nuova raccolta documenti, utilizzare la Pubblicazione guidata per creare la raccolta documenti, modificare il modello di modulo per l'utilizzo nella nuova raccolta documenti e quindi salvare il modello di modulo sul server come modello predefinito per tale raccolta documenti. Per pubblicare il modello di modulo come tipo di contenuto del sito, è possibile utilizzare la Pubblicazione guidata per modificare il modello di modulo per l'utilizzo come tipo di contenuto del sito e quindi salvare il modello di modulo come tipo di contenuto del sito.

Pubblicare un modello di modulo non corrisponde al salvataggio di un modello di modulo. Quando si pubblica un modello di modulo, la pubblicazione guidata aggiunge il percorso di pubblicazione e l'elaborazione di istruzioni per il modello di modulo in modo che gli utenti possono aprire i moduli basati sul modello di modulo. Quando si salva un modello di modulo, si salva una copia del modello di modulo, esattamente come quando si salva un file nel computer in uso. Utilizzare la pubblicazione guidata sempre quando si desidera rendere disponibile per gli utenti di compilare il modello di modulo.

Torna all'inizio

Prima di iniziare

Prima di pubblicare il modello di modulo su un server che esegue Windows SharePoint Services 3.0, rivolgersi all'amministratore del server per verificare quando segue:

  • Che i diritti di cui si dispone consentano di creare una nuova raccolta documenti o pubblicare un nuovo tipo di contenuto del sito sul server.

  • Che gli utenti dispongano dei diritti necessari per utilizzare la raccolta documenti sul server.

Torna all'inizio

Pubblicare un modello di modulo in una nuova raccolta documenti

  1. Se si intende pubblicare un modello di modulo compatibile con browser, eseguire il controllo grafico e risolvere gli eventuali problemi di compatibilità riscontrati.

    Procedura

    1. Scegliere Controllo grafico dal menu Strumenti.

    2. Correggere gli errori sono elencati nel riquadro attività Controllo grafico e quindi fare clic su Aggiorna per determinare se sono ancora presenti.

  2. Scegliere Pubblica dal menu File.

  3. Nella Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata digitare il percorso del sito di SharePoint nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Raccolta documenti e quindi su Avanti.

  6. Nella pagina successiva della procedura guidata fare clic su Crea nuova raccolta documenti e quindi su Avanti.

  7. Nella pagina successiva della procedura guidata digitare un nome e una descrizione per la nuova raccolta documenti e quindi fare clic su Avanti.

  8. Selezionare i campi nel modello di modulo che si desidera visualizzare come colonne nella visualizzazione predefinita della raccolta documenti.

    Procedura

    1. Fare clic su Aggiungi.

    2. Selezionare il campo che si desidera aggiungere come colonna nella raccolta documenti e quindi eseguire una delle operazioni seguenti:

      • Digitare un nome per la colonna nella casella nome colonna.

      • Selezionare la colonna del sito nell'elenco gruppo di colonne sito, selezionare un nome nella casella nome colonna e quindi fare clic su OK.

        Nota : Se si seleziona un campo ripetuto per visualizzare i dati nella raccolta documenti, è possibile definire come si desidera visualizzare il campo nella raccolta documenti, fare clic su un valore nell'elenco funzione. È possibile scegliere se visualizzare il primo valore nel campo, l'ultimo valore nel campo o un conteggio di tutte le occorrenze del campo o se unire tutti i valori.

    3. Scegliere OK.

    Per ulteriori informazioni sulla visualizzazione dei dati in colonne in una raccolta documenti, fare clic sui collegamenti nella sezione Vedere anche.

  9. Fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

    Se il modello di modulo è stato pubblicato, verrà visualizzata una conferma nell'ultima pagina della procedura guidata.

  11. Eseguire una delle operazioni seguenti:

    1. Per aprire la raccolta documenti e verificare il processo per la compilazione di un modulo basato su questo modello di modulo, selezionare la casella di controllo Apri raccolta documenti e quindi fare clic su Chiudi. La raccolta documenti verrà aperta in un browser. Quando si fa clic su Nuovo sulla barra degli strumenti Elenco, verrà aperto un nuovo modulo basato sul modello di modulo in InfoPath.

      Suggerimento : Se si desidera notificare agli utenti che il modello di modulo è disponibile per la compilazione, inviare un messaggio di posta elettronica con un collegamento alla raccolta documenti in cui è stato pubblicato il modello di modulo.

    2. Per inviare agli utenti un messaggio di posta elettronica con il modulo e il modello di modulo, selezionare la casella di controllo Invia il modulo come messaggio di posta elettronica e quindi fare clic su Chiudi.

      Verrà aperto un messaggio di posta elettronica con il modulo nel corpo del messaggio, da compilare e inviare agli utenti. Se gli utenti hanno Microsoft Office Outlook 2007, possono compilare il modulo quando aprono il messaggio di posta elettronica. Gli utenti con versioni precedenti di Outlook o altre applicazioni di posta elettronica riceveranno un messaggio con il modulo e il modello di modulo allegati. Gli utenti possono aprire il modello di modulo allegato per installarlo nel computer. Possono quindi aprire il modulo allegato e compilarlo in InfoPath.

      Suggerimento : Nella casella Introduzione nel messaggio di posta elettronica digitare un promemoria per ricordare agli utenti di aprire solo gli allegati provenienti da un mittente attendibile.

Torna all'inizio

Pubblicare un modello di modulo come nuovo tipo di contenuto del sito

  1. Se si intende pubblicare un modello di modulo compatibile con browser, eseguire il controllo grafico e risolvere gli eventuali problemi di compatibilità riscontrati.

    Procedura

    1. Scegliere Controllo grafico dal menu Strumenti.

    2. Correggere gli errori sono elencati nel riquadro attività Controllo grafico e quindi fare clic su Aggiorna per determinare se sono ancora presenti.

  2. Scegliere Pubblica dal menu File.

  3. Nella Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare il percorso del sito di SharePoint in cui si desidera pubblicare il modello di modulo e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Tipo di contenuto del sito (avanzate) e quindi su Avanti.

  6. Nella pagina successiva della procedura guidata fare clic su Crea nuovo tipo di contenuto. Fare clic su Modulo nell'elenco Basa il tipo di contenuto su e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata digitare un nome e una descrizione per il nuovo tipo di contenuto e quindi fare clic su Avanti.

  8. Nella pagina successiva della procedura guidata digitare il percorso del sito di SharePoint nella casella Specificare percorso e nome di file per il modello di modulo e quindi fare clic su Sfoglia.

  9. Individuare la posizione sul server in cui si desidera pubblicare il modello di modulo come tipo di contenuto del sito. Nella casella Nome file digitare il nome del modello di modulo e quindi fare clic su Salva.

  10. Fare clic su Avanti.

  11. Selezionare i campi nel modello di modulo che si desidera visualizzare come colonne nella visualizzazione predefinita della raccolta documenti.

    Procedura

    1. Fare clic su Aggiungi.

    2. Selezionare il campo che si desidera aggiungere come colonna nella raccolta documenti e quindi eseguire una delle operazioni seguenti:

      • Digitare un nome per la colonna nella casella nome colonna.

      • Selezionare la colonna del sito nell'elenco gruppo di colonne sito, selezionare un nome nella casella nome colonna e quindi fare clic su OK.

        Nota : Se si seleziona un campo ripetuto per visualizzare i dati nella raccolta documenti, è possibile definire come si desidera visualizzare il campo nella raccolta documenti, fare clic su un valore nell'elenco funzione. È possibile scegliere se visualizzare il primo valore nel campo, l'ultimo valore nel campo o un conteggio di tutte le occorrenze del campo o se unire tutti i valori.

    3. Scegliere OK.

    Per ulteriori informazioni sulla visualizzazione dei dati in colonne in una raccolta documenti, fare clic sui collegamenti nella sezione Vedere anche.

  12. Fare clic su Avanti.

  13. Nella pagina successiva della procedura guidata verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

  14. Verificare che il modello di modulo sia un tipo di contenuto nel sito di SharePoint.

    Procedura

    1. Aprire il sito di SharePoint in un browser.

    2. Scegliere Impostazioni sito dal menu Azioni sito nell'angolo superiore destro del sito.

    3. In Impostazioni sito in raccolte fare clic su tipi di contenuto del sito.

      Il modello di modulo dovrebbe essere elencato in InfoPath i tipi di contenuto nella Raccolta di tipi di contenuto del sito.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×