Proteggere i dati con i processi di backup e ripristino

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per ripristinare l'intero database nel caso di un errore di sistema oppure un oggetto quando il comando Annulla non è sufficiente per correggere un errore, è necessario disporre di una copia di backup del database.

Se si ritiene che una copia di backup del database possa essere un inutile spreco dello spazio di archiviazione, si consideri il tempo che si potrà risparmiare evitando la perdita dei dati e della struttura. La creazione di copie di backup a intervalli regolari è importante quando il database viene aggiornato da più utenti. Senza una copia di backup non sarà possibile ripristinare oggetti danneggiati o mancanti o eventuali modifiche alla struttura del database.

Contenuto dell'articolo

Pianificare l'esecuzione di backup regolari

Eseguire il backup di un database

Eseguire il backup di un database diviso

Ripristinare un database

Ripristinare oggetti in un database

Pianificare l'esecuzione di backup regolari

Poiché non è possibile annullare alcune modifiche o errori, non si desidera attendere che la perdita di dati che venga eseguita prima che ci si accorge che devono aver creato una copia di backup del database. Ad esempio, quando si utilizza un query di comando per eliminare i record o per modificare i dati, i valori che sono stati aggiornati con la query non ripristinati utilizzando Annulla.

Suggerimento : Si consiglia di eseguire una copia di backup prima di eseguire una query di comando, soprattutto se tale query comporta la modifica o l'eliminazione di molti dati.

Se il database viene utilizzato da diversi utenti, prima di eseguirne una copia di backup è necessario verificare che tutti gli utenti abbiano chiuso il database in modo da salvare le modifiche ai dati.

La frequenza con cui è necessario creare copie di backup del database dipende in genere dalla frequenza con cui vengono apportate modifiche rilevanti al database. Di seguito sono riportate alcune linee guida generali utili per stabilire la frequenza:

  • Se il database è un archivio o se viene utilizzato solo come riferimento e raramente modificato, è sufficiente creare copie di backup solo quando la struttura o i dati vengono modificati.

  • Se il database è attivo e i dati vengono modificati frequentemente, si consiglia di definire una pianificazione per eseguire il backup del database a intervalli regolari.

  • Se il database viene utilizzato da più utenti, creare una copia di backup del database ogni volta che la struttura viene modificata.

    Nota : Per i dati in tabella collegata creare backup con tutte le caratteristiche di backup disponibili in programma che contiene le tabelle collegate. Se il database contenente le tabelle collegate a un database di Access, utilizzare la procedura descritta nella sezione Backup un database diviso.

Torna all'inizio

Eseguire il backup di un database

Quando si esegue il backup di un database in Access, gli oggetti aperti nella visualizzazione Struttura vengono salvati e chiusi e viene salvata una copia del file di database utilizzando un nome e un percorso specificati dall'utente.

Nota : Gli oggetti verranno riaperti in base al valore della relativa proprietà Visualizzazione predefinita.

  1. Aprire il database per cui si desidera creare una copia di backup.

  2. Fare clic sulla scheda File.

  3. Fare clic su Salva e pubblica.

  4. Nella sezione Salva database con nome fare clic su Backup database in Impostazioni avanzate.

  5. Nella casella Nome file della finestra di dialogo Salva con nome viene visualizzato il nome per il backup del database.

    Sebbene sia possibile modificare il nome, quello predefinito contiene sia il nome del file del database originale, sia la data in cui viene eseguito il backup.

    Suggerimento : 

    Quando si ripristinano i dati o gli oggetti da una copia di backup, è sempre utile sapere da quale database proviene tale copia e in che data è stata creata. Per questo motivo è buona norma utilizzare il nome file predefinito.

  6. Nell'elenco Tipo file selezionare il tipo di file da utilizzare per salvare il database di backup e quindi fare clic su Salva.

Torna all'inizio

Eseguire il backup di un database diviso

Un database diviso è di norma costituito da due file di database: un database back-end che contiene solo i dati presenti nelle tabelle e un database front-end che contiene i collegamenti alle tabelle nel database back-end, le query, le maschere, i report e altri oggetti del database. Tutti i dati sono memorizzati nel database back-end, mentre tutti gli oggetti dell'interfaccia utente, ad esempio query, maschere e report, si trovano nel database front-end.

Poiché quando si esegue il backup di un database diviso è necessario creare copie di backup separate dei database front-end e back-end, l'esecuzione frequente di questa operazione può richiedere molto tempo. È più importante eseguire backup regolari del database back-end, in quanto contiene i dati, mentre il backup del database front-end può essere eseguito quando si modifica la struttura. Poiché ogni utente dispone di una copia personale del database front-end e può apportare modifiche alla struttura a propria discrezione, è consigliabile chiedere agli utenti di eseguire direttamente una copia di backup del proprio database front-end.

Eseguire il backup del database back-end

È opportuno avvisare gli utenti prima di avviare il processo di backup, in quanto per eseguire il backup è necessario disporre dell'accesso esclusivo al file di database ed è possibile che gli utenti non siano in grado di utilizzare il database back-end durante l'esecuzione di tale processo.

  1. Per aprire solo il database back-end, avviare Access senza aprire un database.

  2. Fare clic su Apri e quindi selezionare il database back-end di cui si desidera eseguire il backup.

  3. Fare clic sulla freccia accanto ad Apri e quindi fare clic su Apertura esclusiva.

    Opzione per l'apertura esclusiva di un database

  4. Fare clic sulla scheda File.

  5. Fare clic su Salva e pubblica.

  6. Nella sezione Salva database con nome fare clic su Backup database in Impostazioni avanzate.

  7. Nella casella Salva database con nome della finestra di dialogo Salva con nome verificare il nome per la copia di backup del database.

Verificare il nome predefinito per la copia di backup del database. Sebbene sia possibile modificarlo, il nome predefinito contiene sia il nome file del database originale, sia la data in cui viene eseguito il backup.

Suggerimento : 

Quando si ripristinano i dati o gli oggetti da una copia di backup, è necessario sapere da quale database provenga tale copia e in che data è stata creata. Per questo motivo è buona norma utilizzare il nome file predefinito.

  1. Nella finestra di dialogo Salva con nome selezionare un percorso in cui salvare la copia di backup del database back-end e quindi fare clic su Salva.

Eseguire il backup di un database front-end

Per eseguire il backup di un database front-end dopo ogni modifica della progettazione, lasciare aperto il database immediatamente dopo aver modificato la struttura. Seguire la procedura descritta nella sezione di un database di Backup, iniziando dal passaggio 2.

Torna all'inizio

Ripristinare un database

Nota : È possibile ripristinare un database solo se si dispone di una copia di backup.

Per backup si intende una "copia in buono stato proveniente da un'origine nota" di un file di database, ovvero una copia di cui si possa garantire l'integrità e la struttura dei dati. Per eseguire un backup in Access è disponibile il comando Backup database, ma per ripristinare il database è possibile utilizzare qualsiasi copia in buono stato proveniente da un'origine nota, ad esempio una copia memorizzata su un dispositivo USB di backup esterno.

Questa operazione consiste nel sostituire un file di database danneggiato, con problemi a livello di dati o completamente mancante con una copia di backup del database.

  1. Aprire Esplora risorse e individuare la copia in buono stato del database.

  2. Copiare tale copia del database nel percorso in cui è necessario sostituire il database danneggiato o mancante. Se viene richiesto di sostituire un file esistente, scegliere di continuare.

Torna all'inizio

Ripristinare oggetti in un database

Se è necessario ripristinare solo uno o più oggetti in un database, importare tali oggetti dalla copia di backup del database nel database che contiene, o in cui mancano, gli oggetti che si desidera da ripristinare.

Importante : Se altri database o programmi sono collegati agli oggetti del database che si sta ripristinando, è fondamentale che il database venga ripristinato nel percorso corretto. In caso contrario, i collegamenti agli oggetti del database non funzioneranno e dovranno essere aggiornati.

  1. Aprire il database in cui si desidera ripristinare un oggetto.

  2. Per ripristinare un oggetto mancante, andare al passaggio 3. Per sostituire un oggetto che contiene dati errati o mancanti oppure che non funziona più correttamente, eseguire le operazioni seguenti:

    1. Se si desidera mantenere l'oggetto corrente per poterlo confrontare con la versione ripristinata, dopo l'esecuzione del processo di ripristino, rinominare l'oggetto prima di ripristinarlo. Se si desidera, ad esempio, ripristinare una maschera danneggiata denominata Estrazione, è possibile rinominarla in Estrazione_errata.

    2. Eliminare l'oggetto che si desidera sostituire.

      Nota : Prestare sempre attenzione quando si eliminano oggetti dal database, in quanto potrebbero essere collegati ad altri oggetti nello stesso database.

  3. Nella scheda Dati esterni fare clic su Access nel gruppo Importa e collega.

  4. Nella finestra di dialogo Carica dati esterni - Database di Access fare clic su Sfoglia per individuare il database di backup e quindi fare clic su Apri

  5. Selezionare Importa tabelle, query, maschere, report, macro e moduli nel database corrente e quindi fare clic su OK.

  6. Nella finestra di dialogo Importa oggetti fare clic sulla scheda che corrisponde al tipo di oggetto da ripristinare. Se, ad esempio, si desidera ripristinare una tabella, fare clic sulla scheda Tabelle.

  7. Fare clic sull'oggetto per selezionarlo.

  8. Per ripristinare più oggetti, ripetere i passaggi 6 e 7 finché non saranno stati selezionati tutti gli oggetti da ripristinare.

  9. Per verificare le opzioni di importazione prima di importare gli oggetti, nella finestra di dialogo Importa oggetti fare clic sul pulsante Opzioni.

  10. Dopo avere selezionato gli oggetti e impostato le opzioni di importazione, fare clic su OK per procedere al ripristino degli oggetti.

Per automatizzare il processo di creazione di backup, si consiglia di utilizzare un prodotto in grado di eseguire backup automatici di un file system, ad esempio un software di backup di file server o un dispositivo USB di backup esterno.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×