Progettare una visualizzazione ottimizzata per la stampa

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

I modelli di modulo di Microsoft Office InfoPath creati sono progettati per essere aperti e compilati in linea, sia in InfoPath che tramite un browser Web. Tuttavia, gli utenti possono decidere di stampare una copia di un modulo completato per i propri record personali o a scopo di archiviazione. Per questo motivo, è preferibile verificare che il modello di modulo abbia un aspetto accettabile quando viene stampato. Ad esempio, potrebbe essere necessario verificare che i controlli nel modello di modulo siano contenuti nei margini della pagina stampata e che il testo nel modulo sia leggibile.

Inoltre, è possibile utilizzare il riquadro attività Visualizzazioni per creare una versione speciale del modello di modulo , detta visualizzazione per la stampa , progettata appositamente a scopo di stampa.

In questo articolo viene descritto come progettare una visualizzazione per la stampa e altre tecniche per la creazione di modelli di modulo.

Contenuto dell'articolo

Differenza tra la stampa di un modello di modulo e un modulo

Introduzione alle visualizzazioni per stampa

Progettare una visualizzazione per stampa basata su una visualizzazione esistente

Progettare una visualizzazione per stampa specifica per Word

Differenza tra la stampa di un modello di modulo e un modulo

È possibile stampare un modello di modulo per avere un quadro generale della disposizione e dell'aspetto di controlli e altri oggetti nella pagina stampata oppure per verificare impostazioni di stampa, ad esempio intestazioni e piè di pagina. Quando si stampa un modello di modulo dalla modalità progettazione, determinati elementi, come ad esempio i pulsanti, non vengono visualizzati.

Quando si stampa un modulo basato sul modello di modulo, in InfoPath vengono apportate delle modifiche al modulo e vengono rimossi determinati elementi che non hanno senso in un contesto stampato. Ad esempio, il testo Inserisci elemento che viene visualizzato nelle tabelle di ripetizione non apparirà nel modulo stampato e pulsanti, elenchi, caselle di riepilogo o frecce di scorrimento perderanno il loro significato sulla pagina stampata.

Inizio pagina

Introduzione alle visualizzazioni per stampa

Sebbene i modelli di moduli siano progettati per la raccolta di dati in formato elettronico, è possibile creare una versione personalizzata di un modulo, definita visualizzazione per la stampa, progettata in modo specifico per la stampa. Ciò risulta utile quando si desidera che gli utenti stampino i moduli con un layout particolare o stampino solo determinate parti del modulo.

Se il modello di modulo contiene più visualizzazioni, è possibile creare una visualizzazione per la stampa per ognuna oppure impostare un'unica visualizzazione per la stampa valida per tutte le visualizzazioni disponibili nel modulo. Ad esempio, se il modulo include tre visualizzazioni distinte, si potrebbe creare una visualizzazione per la stampa in modo da presentare le informazioni principali di ogni visualizzazione in una sola pagina stampata.

Per creare ed associare una visualizzazione per stampa a una visualizzazione esistente, utilizzare il collegamento Crea versione per la stampa nel riquadro attività Visualizzazioni. Quando si fa clic su questo collegamento, in InfoPath:

  • Viene creata una nuova visualizzazione vuota denominata Versione per la stampa di nome, dove nome è il nome della visualizzazione su cui è basata la visualizzazione per stampa.

  • Viene associata la visualizzazione per stampa con la visualizzazione su cui è basata. Questa associazione è registrata nella finestra di dialogo Proprietà visualizzazione, nella scheda Impostazioni di stampa. Ad esempio, si immagini di aver creato una visualizzazione per stampa basata su una visualizzazione Approvazione nel modello di modulo. Quando si seleziona il pulsante Stampa all'interno di questa visualizzazione, vengono stampati tutti gli elementi presenti nella visualizzazione Versione per la stampa di Approvazione.

Dopo aver creato una visualizzazione per la stampa è possibile modificarne la progettazione in modo che rispecchi il risultato di stampa desiderato per il modulo. Per questa operazione è in genere necessario copiare i controlli da altre visualizzazioni nel modello di modulo e incollarli nella visualizzazioni per la stampa. Se necessario, è possibile sostituire determinati controlli per altri controlli nella visualizzazione per stampa. Ad esempio, è possibile sostituire una casella di riepilogo a discesa, che nascondi le voci della casella di riepilogo con una casella di riepilogo standard, in cui le voci sono visualizzate nel modulo stampato. Si possono inoltre impostare opzioni di stampa personalizzate, ad esempio intestazioni, piè di pagina e margini, nella finestra di dialogo Proprietà visualizzazione.

Inizio pagina

Progettare una visualizzazione per stampa basata su una visualizzazione esistente

Per impostazione predefinita, quando si stampa un modulo che non ha una determinata visualizzazione di stampa associata, la visualizzazione riportata sul computer dell'utente viene stampata. Se si crea una visualizzazione per stampa, in InfoPath viene stampata tale visualizzazione al posto di quella corrente. Qualsiasi visualizzazione esistente può essere impostata come visualizzazione per la stampa. La procedura seguente descrive come utilizzare una visualizzazione esistente come base per una visualizzazione per stampa.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Selezionare la visualizzazione che si desidera attivare nell'elenco Selezionare una visualizzazione del riquadro attività Visualizzazioni.

  3. Nel gruppo Azioni fare clic su Crea versione per la stampa.

  4. Nella finestra di dialogo Crea versione per la stampa digitare un nome per la visualizzazione e quindi fare clic su OK.

  5. Nel riquadro attività Visualizzazioni fare doppio clic sulla visualizzazione per stampa.

  6. Nella finestra di dialogo Proprietà visualizzazione selezionare le opzioni desiderate nelle schede Impostazioni di stampa e Imposta pagina, quindi fare clic su OK. Ad esempio, è possibile specificare le impostazioni dei margini predefiniti per la visualizzazione per stampa oppure aggiungere intestazioni e piè di pagina.

  7. Per passare alla visualizzazione originale, nel riquadro attività Visualizzazioni, fare clic sul nome della visualizzazione nell'elenco Selezionare una visualizzazione.

  8. Per selezionare tutti gli elementi nella visualizzazione, premere CTRL+A.

  9. Per copiare la selezione negli Appunti, premere CTRL+C.

  10. Per passare alla visualizzazione per stampa, nel riquadro attività Visualizzazioni, fare clic sul nome della visualizzazione nell'elenco Selezionare una visualizzazione.

  11. Per incollare la selezione dalla visualizzazione originale nella visualizzazione per stampa, premere CTRL+V.

  12. Eliminare tutti i controlli o gli elementi di layout non necessari oppure aggiungere altri controlli.

    Suggerimento : Per determinare rapidamente se i controlli e altri elementi di progettazione saranno contenuti in una pagina stampata, è possibile visualizzare una guida per la larghezza della pagina sul lato destro del modello di modulo facendo clic su Guida larghezza pagina nel menu Visualizza. La guida per la larghezza della pagina viene visualizzata come linea verticale tratteggiata sul modello di modulo che indica la posizione del margine destro della pagina stampata in base alla stampante predefinita per il computer.

  13. Per aggiungere interruzioni di pagina alla visualizzazione per stampa, fare clic sul punto di inizio, quindi nel menu Inserisci selezionare Interruzione di pagina.

    Nota : Un'interruzione di pagina viene visualizzata come una linea tratteggiata in un modello di modulo. Se si visualizzare in anteprima il modello di modulo, non sarà visualizzata la linea tratteggiata o altre indicazioni dell'interruzione di pagina. Per vedere come l'interruzione di pagina viene influenzata dalle stampato moduli basati sul modello di modulo, fare clic su Anteprima di stampa, Icona del pulsante sulla barra degli strumenti Standard.

Inizio pagina

Progettare una visualizzazione per stampa specifica per Word

Se si è della progettazione di moduli che conosca tecnologie XML, è possibile utilizzare la visualizzazione di stampa di aggiungere per la creazione guidata Word per creare una visualizzazione basata su Microsoft Office Word che consente di stampare i dati dei moduli direttamente da Word. In questo modo è possibile sfruttare l'intervallo di funzionalità di stampa che sono disponibili in Word. A questo scopo è necessario disporre di accesso a un file di trasformazione XSL (XSLT) esistente che consente di trasformare i dati nel modello di modulo in un formato che è adatto per la stampa da Word. Quando si stampa una maschera che contiene una visualizzazione basata su Word, i dati nel modulo verranno stampati direttamente da Word. Il file XSLT deve essere creato con Microsoft Office Word 2003 o Microsoft Office Word 2007.

Nota : Per ulteriori informazioni sulla creazione di file XSLT, fare riferimento a Microsoft Office InfoPath 2003 Software Development Kit (SDK). il SDK contiene uno strumento, denominato InfoPath Word la creazione guidata, che consente di utilizzare Word 2003 o Word 2007 per stampare i dati del modulo di InfoPath. Per individuare InfoPath 2003 SDK, vedere la sezione Vedere anche.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nel gruppo Azioni del riquadro attività Visualizzazioni fare clic su Aggiungi visualizzazione per stampa con Word.

  3. Seguire le istruzioni della Aggiunta guidata visualizzazione per stampa con Word per specificare il file XSLT che si desidera utilizzare per la visualizzazione per la stampa basata su Word.

  4. Nell'elenco Selezionare una visualizzazione nel riquadro attività Visualizzazioni fare clic sulla visualizzazione alla quale si desidera associare una visualizzazione per la stampa basata su Word e quindi fare clic su Proprietà visualizzazione.

  5. Fare clic sulla scheda Impostazioni di stampa.

  6. Nell'elenco Selezionare una visualizzazione esistente per la stampa di questa visualizzazione fare clic sulla visualizzazione basata su Word.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×