Progettare una visualizzazione in sola lettura

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In Microsoft Office InfoPath, è possibile creare visualizzazioni diverse dello stesso modello di modulo. Una visualizzazione è un'alternativa per presentare i dati in un modello di modulo. Durante la compilazione moduli basati sul modello di modulo di utenti possono passare tra le visualizzazioni per scegliere la quantità di dati rappresentati nel modulo. In un modello di modulo rapporto di stato, ad esempio, si potrebbe progettare una visualizzazione Riepilogo oltre a una visualizzazione dettagliata. Gli utenti possono quindi scegliere la visualizzazione preferiscono esaminare, a seconda di quali tipi di informazioni hanno bisogno.

In questo articolo vengono fornite istruzioni per progettare una visualizzazione che non possa essere modificata dagli utenti. Viene inoltre illustrato come utilizzare regole per passare automaticamente a una visualizzazione in sola lettura di un modulo quando un utente fa clic su un pulsante nella visualizzazione in lettura/scrittura.

Per saperne di più

Progettare una visualizzazione in sola lettura

Inserire un pulsante per il passaggio da una visualizzazione in lettura/scrittura a una visualizzazione in sola lettura

Inserire un pulsante per il passaggio a una visualizzazione in sola lettura in seguito all'invio del modulo da parte degli utenti

Progettare una visualizzazione in sola lettura

Le visualizzazioni in sola lettura sono utili quando si desidera riepilogare i dati dei moduli per gli utenti impedendo loro di modificarli inavvertitamente. Si supponga, ad esempio, di voler impedire agli utenti di modificare i dati in un modulo dopo averlo inviato a un servizio Web. Quando un utente fa clic su un pulsante Invia nel modulo, è possibile configurare il modello di modulo per il passaggio da un visualizzazione in lettura/scrittura dei dati a una visualizzazione in sola lettura. In questo modo, gli utenti potranno visualizzare i dati inviati, ma non potranno modificarli.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nella sezione Azioni del riquadro attività, fare clic su Aggiungi nuova visualizzazione.

  3. Nella finestra di dialogo Aggiungi visualizzazione digitare un nome per la visualizzazione, quindi scegliere OK.

  4. Progettare la visualizzazione aggiungendo tabelle di layout e controlli.

    Suggerimento : Se si desidera basare la progettazione della nuova visualizzazione su una visualizzazione esistente, aprire la visualizzazione, premere CTRL+A per selezionare tutti gli elementi nella visualizzazione e premere CTRL+C per copiare la selezione negli Appunti. Nel riquadro attività Visualizzazioni passare alla nuova visualizzazione e premere CTRL+V per incollare la selezione. A questo punto, è possibile eliminare i controlli o gli elementi di layout che non sono necessari.

  5. Nel riquadro attività visualizzazioni, fare clic su Visualizza proprietà.

  6. Scegliere la scheda Generale.

  7. In Impostazioni visualizzazione selezionare la casella di controllo Sola lettura, quindi scegliere OK.

  8. Per verificare che la visualizzazione sia in sola lettura, fare clic su Anteprima sulla barra degli strumenti Standard.

  9. Nella finestra Anteprima verificare che non sia possibile immettere dati nel modulo.

  10. Per tornare in modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

Inizio pagina

Inserire un pulsante per il passaggio da una visualizzazione in lettura/scrittura a una visualizzazione in sola lettura

Le visualizzazioni sono spesso progettate per l'utilizzo di pulsanti e regole, che consentono di automatizzare alcune attività in un modello di modulo in risposta ad azioni o eventi inizializzati dall'utente che compila il modulo. È possibile, ad esempio, inserire un pulsante nel modello di modulo, quindi creare una regola per il passaggio tra visualizzazioni quando si fa clic sul pulsante. Nell'esempio seguente il progettista del modulo ha creato, nella finestra di dialogo Regola, una regola per il passaggio a una visualizzazione di riepilogo in sola lettura. Questa regola viene eseguita ogni volta che un utente fa clic su un pulsante nel modulo.

Parte della finestra di dialogo Regola

Inserire un pulsante per il passaggio tra visualizzazioni

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione scegliere la visualizzazione in lettura/scrittura a cui si desidera aggiungere un pulsante.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  5. In Inserisci controlli fare clic su Pulsante.

  6. Nel modello di modulo fare doppio clic sul pulsante inserito.

  7. Scegliere la scheda Generale.

  8. Nell'elenco Azione scegliere Regole e codice personalizzato.

  9. Nella casella Etichetta digitare il testo da visualizzare sul pulsante.

  10. Fare clic su Regole.

  11. Nella finestra di dialogo Regole fare clic su Aggiungi.

  12. Nella casella Nome digitare un nome per la regola.

  13. Fare clic su Aggiungi azione.

  14. Nell'elenco Azione scegliere Cambia visualizzazione.

  15. Nell'elenco Visualizzazione fare clic sulla visualizzazione a cui si desidera passare, quindi scegliere OK.

  16. Scegliere OK per chiudere tutte le finestre di dialogo aperte.

  17. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  18. Nella finestra Anteprima fare clic sul pulsante creato.

    Verrà attivata la visualizzazione specificata al passaggio 15.

  19. Per tornare in modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

  20. Per aggiungere un secondo pulsante e un'altra regola alla visualizzazione in sola lettura, affinché gli utenti possano tornare alla visualizzazione in lettura/scrittura, aprire la visualizzazione in sola lettura, quindi ripetere i passaggi da 3 a 19.

Inizio pagina

Inserire un pulsante per il passaggio a una visualizzazione in sola lettura in seguito all'invio del modulo da parte degli utenti

Nella procedura seguente viene descritto come aggiungere un pulsante al modello di modulo per attivare una visualizzazione in sola lettura dei dati inviati. È possibile effettuare questa operazione in un modulo di rapporto di stato se si desidera consentire agli utenti di passare da una visualizzazione predefinita a una visualizzazione di riepilogo in sola lettura dei dati dei moduli.

Nota : Questa procedura è valida solo se il modello di modulo include una connessione dati esistente per l'invio dei dati dei moduli. Se non è stata ancora configurata una connessione dati per l'invio, è necessario effettuare questa operazione prima di completare la procedura, altrimenti i passaggi seguenti non funzioneranno correttamente. I collegamenti a ulteriori informazioni sulle connessioni dati sono disponibili nella sezione Vedere anche.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione fare clic sulla visualizzazione in cui si desidera aggiungere il pulsante Invia.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  5. In Inserisci controlli fare clic su Pulsante.

  6. Nel modello di modulo fare doppio clic sul pulsante inserito.

  7. Scegliere la scheda Generale.

  8. Nell'elenco Azione scegliere Invia.

  9. Se si desidera aggiungere un testo diverso da "Invia" come etichetta del pulsante, digitare il testo desiderato nella casella Etichetta.

  10. Fare clic su Opzioni invio.

  11. Nella finestra di dialogo Opzioni invio verificare che la casella di controllo Consenti agli utenti di inviare il modulo sia selezionata.

  12. Selezionare l'opzione Esegui azione personalizzata tramite regole, quindi fare clic su Regole.

  13. Nella finestra di dialogo Regole per l'invio di moduli fare clic su Aggiungi.

  14. Nella casella Nome digitare un nome per la regola, quindi fare clic su Aggiungi azione.

  15. Nell'elenco Azione scegliere Cambia visualizzazione.

  16. Nell'elenco Visualizzazione fare clic sulla visualizzazione in sola lettura a cui si desidera passare, quindi scegliere OK.

  17. Scegliere OK per chiudere tutte le finestre di dialogo.

  18. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  19. Nella finestra Anteprima fare clic sul pulsante utilizzato per inviare il modulo.

    Verrà aperta la visualizzazione in sola lettura.

  20. Per tornare in modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×