Progettare un riquadro informazioni documento tramite InfoPath

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo vengono illustrate le modalità per progettare, in Microsoft Office InfoPath, un riquadro informazioni documento associato a documenti per Microsoft Office Word 2007, Microsoft Office Excel 2007 e Microsoft Office PowerPoint 2007.

In questo articolo

Informazioni sui riquadri informazioni documento

Progettare un riquadro informazioni documento

Creare o modificare un riquadro informazioni documento personalizzato per un tipo di contenuto di SharePoint

Aggiungere un riquadro informazioni documento personalizzato a un documento

Informazioni sui riquadri informazioni documento

Il riquadro informazioni documento, visualizzato in documenti di Office Word 2007, Office Excel 2007 e Office PowerPoint 2007, consente agli utenti di visualizzare e di modificare le proprietà per un singolo file o per un tipo di contenuto salvato in un server Document Management, ad esempio una raccolta o un sito area di lavoro documenti basato su Windows SharePoint Services 3.0. Queste proprietà, denominate anche metadati, sono dettagli che descrivono o identificano un file. Gli utenti possono utilizzare queste proprietà per organizzare, identificare e cercare documenti.

Il riquadro informazioni documento è un modulo di Microsoft Office InfoPath 2007 che viene ospitato e visualizzato all'interno di un documento. Non è necessario InfoPath installato nel computer per visualizzare un riquadro informazioni documento in un documento Microsoft Office System 2007, ma è necessario Office InfoPath 2007 per progettare o personalizzare i riquadri informazioni documento. Ad esempio, se si desidera personalizzare un riquadro informazioni documento per visualizzare i dati da una risorsa esterna, ad esempio un servizio Web, è necessario utilizzare Office InfoPath 2007 per progettare il riquadro informazioni documento.

Personalizzare il riquadro informazioni documento, è possibile aggiungere logica di business, ad esempio la convalida dei dati, o aggiungere proprietà personalizzate che sono importanti per l'organizzazione. Inoltre, tramite la creazione di una parte modello per contenere campi comuni, è possibile organizzare il riutilizzo efficiente dei riquadri informazioni documento in tipi di documenti diversi versione 2007 di Office all'interno dell'organizzazione.

Inizio pagina

Progettare un riquadro informazioni documento

Quando si progetta un riquadro informazioni documento personalizzato, è possibile utilizzare con più documenti da Office Word 2007, Office Excel 2007 e Office PowerPoint 2007 oppure è possibile progettare più informazioni del documento. Ad esempio, se alcuni documenti sono associati a un progetto specifico, è consigliabile usare campi univoci per i riquadri informazioni documento utilizzati in solo tali documenti.

Anche se l'organizzazione utilizza informazioni diverse del documento, ogni può contenere diverse proprietà comuni. Per riutilizzare facilmente le proprietà comuni durante la progettazione di un riquadro informazioni documento, valutare la possibilità di utilizzo di parti modello. Con la creazione e utilizzo di parti modello, è possibile evitare assicurarsi che i metadati chiavi per la propria organizzazione è coerente in tono, struttura e comportamento. Ad esempio, l'organizzazione può richiedere ogni riquadro informazioni documento includere un campo denominato titolo oltre autore. Progettare una parte modello che utilizza tali campi comuni, è possibile riutilizzare facilmente la parte modello in più riquadri informazioni documento.

Nella procedura seguente viene descritto come progettare un riquadro informazioni documento per l'utilizzo con documenti di versione 2007 di Office.

  1. Scegliere Progetta modello modulo dal menu File.

  2. Nella sezione Progetta della finestra di dialogo Progetta modello di modulo selezionare l'opzione Modello di modulo.

  3. Nella raccolta In base a fare clic su Vuoto, quindi scegliere OK. In questo modo, è possibile definire l'origine dati durante la progettazione del modello di modulo.

    È inoltre possibile basare il modello di modulo su un documento XML o su uno schema XML, ad esempio le proprietà Dublin Core, nonché progettare il modello di modulo utilizzando un servizio Web, un database o impostazioni incluse in una raccolta connessioni dati. Le informazioni sulla progettazione di un modello di modulo basato su un'origine dati sono disponibili nella sezione Vedere anche.

  4. Progettare il modello di modulo per l'utilizzo come riquadro informazioni documento.

    Se si crea una parte modello contenente campi comuni, è possibile coordinare il riutilizzo efficiente dei riquadri informazioni documento in diversi tipi di documenti di versione 2007 di Office nell'organizzazione. Dopo avere creato una parte modello e averla aggiunta al riquadro attività Controlli, è possibile inserirla nel modello di modulo utilizzando la procedura indicata di seguito.

    1. Posizionare il cursore nel modello di modulo nel punto in cui si desidera inserire la parte modello.

    2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

    3. Nel gruppo Personalizzati dell'elenco Inserisci controlli fare clic sul nome della parte modello che si desidera inserire.

      La parte modello visualizzato all'interno di un controllo sezione nel modello di modulo. È possibile riconoscere la parte modello nel modello di modulo perché le parole sezione (parte modello: nome) vengono visualizzati come etichetta della sezione in cui nome è il nome del file parte modello.

      etichetta nel modello di modulo indicante la presenza della parte modello

  5. Rinominare la visualizzazione predefinita e altre visualizzazioni nel modello di modulo.

    Procedura

    1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

    2. Nel riquadro attività Visualizzazioni scegliere la visualizzazione che si desidera rinominare, quindi fare clic su Proprietà visualizzazione.

    3. Fare clic sulla scheda Generale.

    4. Nella casella Nome digitare un nuovo nome per la visualizzazione.

    Nota : Anche se il modello di modulo contiene solo una visualizzazione, è consigliabile assegnare alla visualizzazione un nome descrittivo, ad esempio Proprietà personalizzate, in quanto il nome della visualizzazione è disponibile nell'elenco Visualizzazioni proprietà e opzioni quando il riquadro informazioni documento viene visualizzato in un documento.

  6. Pubblicare il riquadro informazioni documento in una cartella di rete condivisa.

    Procedura

    1. Scegliere Pubblica dal menu File.

    2. Nella Pubblicazione guidata fare clic su In un percorso di rete e quindi fare clic su Avanti.

    3. Nella pagina successiva della procedura guidata fare clic su Sfoglia.

    4. Individuare la cartella di rete condivisa in cui si desidera pubblicare il modello di modulo, quindi scegliere OK.

    5. Nella pagina successiva della procedura guidata verificare che il percorso e il nome del modello di modulo indicati nella casella Nome modello di modulo siano corretti, quindi fare clic su Avanti.

    6. Nella pagina successiva della procedura guidata, se si dispone di un percorso alternativo in questa cartella di rete condivisa, ad esempio un pubblico URL Uniform Resource Locator (), digitare il percorso nella casella e quindi fare clic su Avanti.

    7. Nella pagina successiva della procedura guidata fare clic su Pubblica.

      Se il modello di modulo viene pubblicato correttamente, nell'ultima pagina della procedura guidata verrà visualizzata una conferma.

    È inoltre possibile pubblicare il riquadro informazioni documento in un sito di SharePoint. Le informazioni sulla pubblicazione in un sito di SharePoint sono disponibili nella sezione Vedere anche.

Inizio pagina

Creare o modificare un riquadro informazioni documento personalizzato per un tipo di contenuto di SharePoint

Quando si crea un tipo di contenuto di sito basato sul tipo di contenuto per documenti o Dublin Core Columns, disponibile nei server in cui è in esecuzione Microsoft Office SharePoint Server 2007, viene automaticamente creato un riquadro informazioni documento per tenere traccia delle proprietà di SharePoint. È possibile utilizzare Office InfoPath 2007 per personalizzare questo tipo di riquadro informazioni documento analogamente alla personalizzazione di qualsiasi modello di modulo di InfoPath. È possibile, ad esempio, personalizzare il riquadro informazioni documento effettuando una o più delle seguenti operazioni:

  • Aggiungere funzionalità, come la convalida dei dati o la formattazione condizionale.

  • Aggiungere una connessione dati secondaria al riquadro informazioni documento, quindi aggiungere controlli per la visualizzazione dei dati dai campi nell'origine dati.

  • Creare una nuova visualizzazione, quindi aggiungere una parte modello contenente campi comuni che possono essere utilizzati dall'organizzazione per tenere traccia dei dati.

    Nota : Quando un riquadro informazioni documento è basato sullo schema di un tipo di contenuto di SharePoint, non può essere personalizzato aggiungendo campi che non facciano parte dello schema. Per aggiungere o rimuovere campi dallo schema del tipo di contenuto, è necessario aggiungere o rimuovere colonne nel tipo di contenuto.

Creare o modificare un riquadro informazioni documento personalizzato

  1. Scegliere Progetta modello modulo dal menu File.

  2. Nella sezione Progetta della finestra di dialogo Progetta modello di modulo selezionare l'opzione Modello di modulo.

  3. Scegliere XML o schema nell'elenco In base a, quindi scegliere OK.

    Nota : Non selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser, in quanto il riquadro informazioni documento verrà visualizzato solo come parte di un documento di versione 2007 di Office e non come parte di una pagina Web.

  4. Nella Configurazione guidata origine dati digitare l'URL per il server SharePoint, quindi fare clic su Avanti.

  5. Nell'elenco Selezionare un elenco o un Web scegliere il nome del tipo di contenuto desiderato, quindi fare clic su Avanti.

  6. Fare clic su Fine.

    Verrà visualizzato il riquadro informazioni documento per lo schema del tipo di contenuto.

  7. Apportare le modifiche desiderate nel riquadro informazioni documento, quindi salvare il modello di modulo.

    Nota : Poiché il riquadro informazioni documento è basato sullo schema del tipo di contenuto, che costituisce l'origine dati principale per il modello di modulo, non è possibile personalizzare il riquadro informazioni documento tramite l'aggiunta di campi che non facciano parte dello schema. Per aggiungere o rimuovere campi dal riquadro informazioni documento tramite l'aggiunta di nuovi campi allo schema del tipo di contenuto, è necessario aggiungere o rimuovere colonne nel tipo di contenuto.

  8. Scegliere Pubblica dal menu File.

  9. Nella Pubblicazione guidata selezionare l'opzione Come modello di riquadro informazioni documento per un tipo di contenuto di sito di SharePoint o elenco (scelta consigliata), quindi fare clic su Avanti.

    Nota : L'opzione Come modello di riquadro informazioni documento per un tipo di contenuto di sito di SharePoint o elenco (scelta consigliata) viene visualizzata in questa pagina della procedura guidata solo se al passaggio 3 si è selezionato XML o schema.

  10. Nella pagina successiva della procedura guidata fare clic su Pubblica.

    Se il modello di modulo viene pubblicato correttamente, nell'ultima pagina della procedura guidata verrà visualizzata una conferma.

Inizio pagina

Aggiungere un riquadro informazioni documento personalizzato a un documento

Dopo aver creato un riquadro informazioni documento personalizzato, è necessario associarlo un documento prima di poter usare. A questo scopo è necessario attivare la scheda sviluppo sulla barra multifunzione di programmi in cui si desidera utilizzare il riquadro informazioni documento. È quindi possibile specificare la posizione del riquadro informazioni documento tramite un percorso URL, UNC o URN. Inoltre, è possibile visualizzare il riquadro informazioni documento per impostazione predefinita, quando si apre il documento. È anche possibile scegliere se le proprietà personalizzate creato sono visibili per impostazione predefinita quando si apre il documento.

Nella procedura seguente sono riportate le operazioni necessarie per associare un riquadro informazioni documento a un documento per Office Word 2007, Office Excel 2007 o Office PowerPoint 2007.

  1. Fare clic sul pulsante Microsoft Office Icona del pulsante Office , quindi scegliere Opzioni di Nome programma, dove Nome programma è il nome del programma utilizzato. Fare clic, ad esempio, su Opzioni di Word.

  2. Nella finestra di dialogo Opzioni di Nome programma fare clic su Impostazioni generali, selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione, quindi scegliere OK.

    La barra multifunzione fa parte dell'interfaccia utente Microsoft Office Fluent.

  3. Fare clic sulla scheda Sviluppo sulla barra multifunzione dell'interfaccia utente Office Fluent, quindi su Riquadro documenti.

  4. In Specificare un modello personalizzato (URL, UNC o URN) nella finestra di dialogo Riquadro informazioni documento digitare il percorso del riquadro informazioni documento che si desidera aggiungere al documento.

  5. Per visualizzare le proprietà personalizzate per impostazione predefinita nel documento, scegliere Proprietà personalizzate nell'elenco Visualizza per impostazione predefinita.

  6. Per visualizzare il riquadro informazioni documento per impostazione predefinita, selezionare la casella di controllo Mostra sempre il riquadro informazioni documento all'apertura del documento e al primo salvataggio.

Oltre a visualizzare o modificare proprietà nei riquadri informazioni documento in documenti per Office Word 2007, Office Excel 2007 e Office PowerPoint 2007, in Office Word 2007 gli utenti possono aggiungere proprietà dal riquadro informazioni documento come controlli di proprietà del documento stesso. Ad esempio, più istanze di un indirizzo della società possono essere aggiunti come i controlli di proprietà in un documento. Questi controlli proprietà verranno aggiornati come le informazioni nel riquadro informazioni documento viene modificate.

Ulteriori informazioni sull'aggiunta di proprietà a un documento di Office Word 2007 sono disponibili nella sezione Vedere anche.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×