Progettare un modulo in risposta a uno stato del flusso di lavoro

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare moduli di Microsoft Office InfoPath per visualizzare dati specifici che corrisponde allo stato corrente di un flusso di lavoro. Eseguire questa operazione la progettazione di un modello di modulo per usare le regole di avviare un'azione nei relativi moduli basati sullo stato del flusso di lavoro. Questo può semplificare i processi utilizzato dagli utenti per la compilazione dei moduli.

In questo articolo viene descritto come progettare un modello di modulo nota spese per visualizzare automaticamente diverse visualizzazioni del modello di modulo, a seconda lo stato di un flusso di lavoro di approvazione associato. Ad esempio, prima che viene avviato il flusso di lavoro, il modulo verrà visualizzata una visualizzazione spese contenente una tabella ripetuta in cui gli utenti possono immettere le spese. Quando lo stato del flusso di lavoro è In corso, la maschera verrà visualizzata una visualizzazione di riepilogo spese che mostra le spese totali per ogni categoria. Quando lo stato del flusso di lavoro è completata, il modulo visualizzazione sarà completato, che include dettagli sulle tempi rimborso stimata.

Affinché i moduli rispondano agli stati del flusso di lavoro, è necessario eseguire alcune attività sul sito Microsoft Office SharePoint Server 2007 o sul sito Windows SharePoint Services 3.0, dove si trovano i moduli, e altre in InfoPath. Sul sito SharePoint è necessario creare un flusso di lavoro e un tipo di contenuto del sito, in InfoPath è invece necessario aggiungere una connessione dati a un modello di modulo, creare una regola e pubblicare il modello di modulo.

Nota : In questo articolo viene utilizzato uno scenario di esempio in cui un modello di modulo è pubblicato come tipo di contenuto del sito. È inoltre possibile pubblicare un modello di modulo su un percorso di rete condiviso o creare una nuova raccolta documenti quando si pubblica un modello di modulo su un sito SharePoint. Nella sezione Vedere anche sono disponibili ulteriori informazioni sulla pubblicazione di modelli di modulo.

Contenuto dell'articolo

Introduzione all'utilizzo di flussi di lavoro con moduli di InfoPath

Considerazioni sulla compatibilità

Prima di iniziare

Passaggio 1: Aggiungere un flusso di lavoro Approvazione a una raccolta

Passaggio 2: Aggiungere una connessione dati a un modello di modulo

Passaggio 3: Aggiungere una regola a un modello di modulo per impostare una visualizzazione specifica

Passaggio 4: Pubblicare un modello di modulo come tipo di contenuto del sito

Passaggio 5: Aggiungere un tipo di contenuto a una raccolta documenti

Introduzione all'utilizzo di flussi di lavoro con moduli di InfoPath

I flussi di lavoro consentono di collaborare a documenti e gestire attività di progetto implementando processi aziendali specifici in documenti ed elementi in un sito Microsoft Office SharePoint Server 2007 o in un sito Windows SharePoint Services 3.0. I flussi di lavoro consentono alle organizzazioni di adottare processi aziendali coerenti oltre a migliorare l'efficienza e la produttività dell'organizzazione gestendo le attività e i passaggi relativi a processi aziendali specifici. Gli utenti che eseguono queste attività possono pertanto concentrarsi sugli aspetti pratici anziché sulla gestione del flusso di lavoro.

È possibile abilitare un modulo di InfoPath visualizzare dati specifici che corrisponde allo stato corrente di un flusso di lavoro. Eseguire questa operazione la progettazione di un modello di modulo per usare le regole di avviare un'azione del modulo in base allo stato del flusso di lavoro. Questo può semplificare i processi utilizzato dagli utenti per la compilazione dei moduli. Ad esempio, è possibile abilitare un modulo visualizzare in sola lettura quando lo stato di un flusso di lavoro è completata e pertanto non devono essere modificati i dati del modulo.

Per rendere i flussi di lavoro disponibili per l'uso in modelli di modulo di InfoPath, è necessario aggiungerli a un tipo di contenuto, a una raccolta o a un elenco SharePoint. I flussi di lavoro disponibili per un sito variano anche a seconda del tipo di sito e del fatto che siano stati creati o meno flussi di lavoro personalizzati utilizzando Microsoft Office SharePoint Designer 2007.

In questo articolo viene utilizzato il flusso di lavoro Approvazione per illustrare come i flussi di lavoro possano essere utilizzati con modelli di modulo di InfoPath. Il flusso di lavoro Approvazione instrada un modulo di InfoPath salvato in una raccolta a un gruppo di utenti per l'approvazione. Per impostazione predefinita, il flusso di lavoro Approvazione è associato al tipo di contenuto Documento ed è automaticamente disponibile nelle raccolte di moduli o di documenti.

Ogni flusso di lavoro è definita da stati distinti con nomi descrittivi, ad esempio In corso. I nomi per gli stati variano a seconda del tipo di flusso di lavoro. Ad esempio un flusso di lavoro di approvazione, che è disponibile nei server che eseguono Microsoft Office SharePoint Server 2007, ovvero include uno stato In corso, annullato e completato. Lo stato di un flusso di lavoro di tre stati, che è disponibile in Windows SharePoint Services 3.0, può essere definita dall'utente che aggiunge il flusso di lavoro in una raccolta o elenco, mentre altri flussi di lavoro utilizzano stati standard, ad esempio lo stato di Avanzamento In indicato in precedenza. Anche se il nome descrittivo è visibile all'utente, gli stati del flusso di lavoro sono rappresentati a livello di programmazione da valori numerici. Per progettare un modello di modulo in risposta a uno stato del flusso di lavoro specifica, è necessario conoscere il valore numerico per lo stato del flusso di lavoro che si desidera utilizzare. In questo modo InfoPath viene utilizzato il valore numerico del flusso di lavoro per avviare un'azione, ad esempio cambiare visualizzazione.

Come si è fatto notare in precedenza, è possibile impostare un modello di modulo di InfoPath per la visualizzazione di dati specifici corrispondenti allo stato corrente di un flusso di lavoro. Sebbene in questo articolo venga descritto come impostare un modello di modulo di nota spese in modo che appaia automaticamente una visualizzazione specifica a seconda dello stato nel flusso di lavoro, è anche possibile personalizzare il flusso di lavoro aggiungendo ulteriori azioni. Invece di impostare i moduli in modo che venga utilizzata una visualizzazione specifica, ad esempio, è possibile impostarli per la visualizzazione di un messaggio in una finestra di dialogo che indichi alcune istruzioni oppure, invece di utilizzare un flusso di lavoro Approvazione, è possibile utilizzare il flusso di lavoro in tre stati.

Nota : Se si attivano azioni diverse da quelle descritte in questo articolo, potrebbe essere necessario eseguire ulteriori passaggi per verificare che il modello di modulo funzioni correttamente con il flusso di lavoro utilizzato.

Inizio pagina

Considerazioni sulla compatibilità

Se si intende creare un modello di modulo compatibile con browser, tenere presente che la barra messaggi, visibile quando si compilano moduli in documenti di Microsoft Office, inclusi i moduli di InfoPath, non è visibile nei modelli di modulo compatibili con browser che l'utente compila in un browser. Con i flussi di lavoro è tuttavia possibile utilizzare moduli compatibili con browser. Per modificare lo stato del flusso di lavoro per tali moduli, i partecipanti al flusso di lavoro possono utilizzare le impostazioni della raccolta documenti. Ulteriori informazioni sulla modifica delle impostazioni del flusso di lavoro tramite siti SharePoint sono disponibili nella sezione Vedere anche.

Inizio pagina

Prima di iniziare

Prima di eseguire le attività di questo articolo, verificare quanto segue:

  • Rivolgersi all'amministratore della farm per avere conferma che il flusso di lavoro Approvazione sia installato e abilitato per il sito SharePoint che si desidera utilizzare.

  • Verificare di disporre di almeno un livello di autorizzazione Progettazione per il sito SharePoint. Questo livello di autorizzazione è necessario per pubblicare un modello di modulo e creare un flusso di lavoro.

  • Creare un modello di modulo con due o più visualizzazioni e personalizzare ogni visualizzazione in modo che sia disponibile il tipo di dati appropriato per ogni stato del flusso di lavoro. Per la visualizzazione che si desidera attivare automaticamente quando il flusso di lavoro è completato, ad esempio, è possibile impostare i controlli in modo da consentire l'accesso al modulo in modalità di sola lettura.

  • Creare una raccolta moduli o documenti e verificare che la raccolta sia impostata in modo da consentire più tipi di contenuto.

Inizio pagina

Passaggio 1: Aggiungere un flusso di lavoro Approvazione a una raccolta

L'argomento di questo scenario è il flusso di lavoro Approvazione, ma, se lo si desidera, è possibile utilizzare un altro tipo di flusso di lavoro. In questo caso, è possibile che le opzioni per il flusso di lavoro siano diverse da quelle descritte in questo articolo.

  1. Aprire la raccolta a cui si desidera aggiungere un flusso di lavoro.

  2. Scegliere il comando relativo alle impostazioni per il tipo di raccolta che si desidera aprire dal menu Impostazioni.

    In una raccolta documenti, ad esempio, scegliere Impostazioni raccolta documenti.

  3. Nell'area relativa alle autorizzazioni e alla gestione fare clic su Impostazioni flusso di lavoro.

  4. Fare clic su Aggiungi flusso di lavoro.

  5. Nella sezione Flusso di lavoro della pagina Aggiungi flusso di lavoro fare clic su Approvazione.

  6. Nella sezione Nome digitare un nome univoco per il flusso di lavoro.

    1. Nella sezione Elenco attività specificare un elenco di attività da utilizzare con il flusso di lavoro.

      Note : 

      • È possibile utilizzare l'elenco Attività predefinito oppure crearne uno nuovo. Se si utilizza l'elenco Attività predefinito, i partecipanti al flusso di lavoro potranno individuare e visualizzare facilmente le relative attività utilizzando la visualizzazione Attività personali dell'elenco Attività.

      • Se le attività del flusso di lavoro implicano la visualizzazione di informazioni sensibili o riservate che si desidera mantenere distinte dall'elenco Attività generale, è consigliabile creare un nuovo elenco delle attività.

      • Se per l'organizzazione saranno disponibili numerosi flussi di lavoro oppure se i flussi di lavoro implicheranno numerose attività, è consigliabile creare un nuovo elenco delle attività. In tal caso, è opportuno creare elenchi delle attività per ogni flusso di lavoro.

  7. Nella sezione Elenco cronologia selezionare un elenco della cronologia da utilizzare con il flusso di lavoro. Nell'elenco della cronologia sono visualizzati tutti gli eventi che si verificano durante ogni istanza del flusso di lavoro.

    È possibile utilizzare l'elenco Cronologia predefinito o crearne uno nuovo. Se nell'organizzazione sarà presente un numero elevato di flussi di lavoro, è possibile creare un elenco della cronologia distinto per ogni flusso di lavoro.

  8. Per consentire l'avvio manuale del flusso di lavoro, selezionare la casella di controllo Consenti l'avvio manuale del flusso di lavoro a un utente autenticato con autorizzazioni Modifica elementi nella sezione Opzioni di avvio.

  9. Per richiedere autorizzazioni aggiuntive per l'avvio del flusso di lavoro, selezionare la casella di controllo Richiedi autorizzazioni Gestione elenchi per l'avvio del flusso di lavoro.

  10. Specificare le altre opzioni necessarie, tra cui il momento desiderato per l'avvio del flusso di lavoro, quindi scegliere Avanti.

  11. Nella pagina Personalizza flusso di lavoro specificare le opzioni desiderate, inclusi la modalità di instradamento delle attività, i valori di avvio del flusso di lavoro predefinito e la modalità di completamento del flusso di lavoro, quindi scegliere OK.

    Selezionare le opzioni nelle sezioni seguenti. Non è necessario specificare opzioni in ogni sezione:

    Attività flusso di lavoro

    Per

    Operazione da eseguire

    Assegnare attività a tutti i partecipanti contemporaneamente (flusso di lavoro in parallelo)

    Selezionare Tutti i partecipanti contemporaneamente (in parallelo).

    Assegnare attività a un solo partecipante per volta, con la condizione che un partecipante completi un'attività prima che il partecipante successivo riceva un'altra attività (flusso di lavoro in sequenza)

    Selezionare Un partecipante alla volta (in sequenza).

    Consentire ai partecipanti al flusso di lavoro di riassegnare le attività ad altri utenti

    Selezionare la casella di controllo Riassegna l'attività a un'altra persona.

    Consentire ai partecipanti al flusso di lavoro di richiedere una modifica al documento o all'elemento. La modifica deve essere approvata prima del completamento dell'attività.

    Selezionare la casella di controllo Richiedi una modifica prima di completare l'attività.

    Valori predefiniti per l'avvio del flusso di lavoro

    Per

    Operazione da eseguire

    Specificare un elenco predefinito di partecipanti per tutte le istanze di questo flusso di lavoro

    Digitare i nomi dei partecipanti che si desidera includere all'avvio del flusso di lavoro oppure fare clic su Responsabili approvazione, quindi selezionare gli utenti e i gruppi dal servizio di elenchi in linea.

    Note : 

    • Separare i nomi con punto e virgola.

    • Se si imposta questo flusso di lavoro come flusso di lavoro in sequenza, aggiungere i nomi dei partecipanti al flusso di lavoro nell'ordine in cui si desidera assegnare le attività.

    Assegnare una sola attività ai gruppi, invece di assegnare singole attività a ogni membro di un gruppo

    Selezionare la casella di controllo Assegna una sola attività a ogni gruppo immesso (non espandere i gruppi).

    Consentire agli utenti che avviano il flusso di lavoro di modificare o aggiungere i partecipanti

    Selezionare la casella di controllo Consenti di modificare l'elenco dei partecipanti dopo l'avvio del flusso di lavoro.

    Specificare un messaggio predefinito da visualizzare con ogni attività

    Digitare un messaggio o istruzioni pertinenti nella casella di testo.

    Specificare una scadenza per i flussi di lavoro in parallelo

    Immettere una data in Attività in scadenza il (in parallelo).

    Specificare in quanto tempo i partecipanti a un flusso di lavoro in sequenza devono completare le attività del flusso di lavoro

    In Concedi a ogni persona la quantità di tempo seguente per finire l'attività (in sequenza) digitare un numero, quindi selezionare giorno/i o settimana/e come incremento di tempo.

    Specificare un elenco di utenti che devono ricevere avvisi (non assegnazioni di attività) all'avvio del flusso di lavoro

    In Notifica altri digitare i nomi degli utenti che si desidera informare oppure fare clic su CC e selezionare gli utenti e i gruppi dal servizio di elenchi in linea.

    Nota : Separare i nomi con punto e virgola.

    Completamento del flusso di lavoro

    Per

    Operazione da eseguire

    Specificare che un flusso di lavoro in parallelo termina dopo che un determinato numero di partecipanti ha completato le relative attività.

    Selezionare la casella di controllo È stato finito il seguente numero di attività quindi digitare un numero.

    Specificare che un flusso di lavoro è completato quando il documento o l'elemento viene rifiutato

    Selezionare la casella di controllo Il documento viene rifiutato.

    Specificare che un flusso di lavoro termina quando il documento o l'elemento viene modificato.

    Selezionare la casella di controllo Il documento viene modificato.

    Attività del flusso di lavoro dopo il completamento

    Per

    Operazione da eseguire

    Aggiornare lo stato di approvazione di un documento o elemento dopo il completamento del flusso di lavoro.

    Selezionare la casella di controllo Aggiornare lo stato di approvazione (utilizzare questo flusso di lavoro per controllare l'approvazione del contenuto).

    Note : 

    • Se si utilizza il flusso di lavoro Approvazione per gestire l'approvazione del contenuto per una raccolta ed è stata selezionata la casella di controllo Avvia il flusso di lavoro per approvare la pubblicazione di una versione principale di un elemento nella pagina Aggiungi flusso di lavoro, questa casella di controllo è selezionata per impostazione predefinita.

    • Se la casella di controllo Avvia il flusso di lavoro per approvare la pubblicazione di una versione principale di un elemento nella pagina Aggiungi flusso di lavoro non è stata selezionata perché non si desidera che questo flusso di lavoro sia quello predefinito di approvazione del contenuto per una raccolta, è possibile selezionare questa casella di controllo per impostare questo flusso di lavoro come flusso di lavoro di approvazione del contenuto secondario che utenti specifici possono avviare manualmente.

Inizio pagina

Passaggio 2: Aggiungere una connessione dati a un modello di modulo

Nella procedura riportata di seguito viene spiegato come aggiungere una connessione dati secondaria che esegue una query sullo stato del flusso di lavoro aggiunto nel Passaggio 1. Questa connessione secondaria fornisce i dati che attivano nel modulo le regole per il passaggio da una visualizzazione all'altra a seconda dello stato del flusso di lavoro.

  1. In InfoPath scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Raccolta o elenco SharePoint, quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare l'URL del sito SharePoint.

  6. Nell'elenco Selezionare un elenco o una raccolta fare clic sul nome della raccolta documenti in cui è stato aggiunto il flusso di lavoro Approvazione nel Passaggio 1, quindi scegliere Avanti.

  7. Nell'elenco Selezionare i campi della pagina successiva della procedura guidata selezionare la casella di controllo accanto al nome del campo corrispondente al nome del flusso di lavoro.

    È possibile che il nome del campo non corrisponda esattamente al nome del flusso di lavoro. Se il nome del campo inizia con un carattere speciale diverso da un carattere di sottolineatura o una lettera, il nome del flusso di lavoro sarà personalizzato nell'elenco.

  8. Selezionare la casella di controllo Includi dati solo per il modulo attivo, quindi scegliere Avanti.

  9. Deselezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo, quindi scegliere Avanti.

  10. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione dati secondaria. Questo nome verrà visualizzato nell'elenco Origine dati nel riquadro attività Origine dati.

  11. Per eseguire la query automaticamente, a ogni apertura del modulo da parte di un utente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

  12. Nell'ultima pagina della procedura guidata fare clic su Fine.

  13. Nella finestra di dialogo Connessioni dati scegliere Chiudi.

Inizio pagina

Passaggio 3: Aggiungere una regola a un modello di modulo per impostare una visualizzazione specifica

Quando si progetta un modello di modulo, è possibile utilizzare le regole per automaticamente visualizzare una finestra di dialogo, impostare il valore del campo, query o inviare dati del modulo a una connessione dati, cambiare visualizzazioni, o aprire o chiudere un modulo in risposta a determinati eventi e condizioni. Gli eventi possono essere la modifica di un particolare campo o gruppo in origine dati, fare clic su un pulsante, l'inserimento di una sezione ripetuta o una riga in un tabella ripetuta oppure l'apertura o l'invio di un modulo. Le condizioni possono includere i calcoli, XPath espressioni e ruoli utente. Le condizioni possono includere anche se il valore di un campo è vuoto, compreso in un intervallo specificato, sarà uguale al valore di un altro campo o inizia con o contiene determinati caratteri.

In questo caso, verrà creata una regola per passare da una visualizzazione all'altra in base allo stato del flusso di lavoro.

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco Categoria fare clic su Apertura e salvataggio.

  3. In Apertura fare clic su Regole.

  4. Nella finestra di dialogo Regole per l'apertura di moduli fare clic su Aggiungi.

  5. Nella casella Nome digitare un nome per la regola.

    Digitare ad esempio Passa da una visualizzazione all'altra.

  6. Per specificare una condizione per il momento di esecuzione della regola, fare clic su Imposta condizione.

  7. Nella prima casella di Condizione di applicazione della regola fare clic su Selezionare un campo o un gruppo.

  8. Nell'elenco Origine dati fare clic sul nome dell'origine dati secondaria aggiunta nel Passaggio 2, quindi scegliere OK.

  9. Fare clic sul nome del campo corrispondente allo stato del flusso di lavoro.

    Potrebbe essere necessario espandere le cartelle nella finestra fino a visualizzare il campo desiderato.

  10. Nel secondo elenco della finestra di dialogo Condizione fare clic su è uguale a.

  11. Nel terzo elenco fare clic su Digitare un numero, quindi digitare il valore corrispondente allo stato del flusso di lavoro.

    Per una visualizzazione che mostra quando il flusso di lavoro è completato, ad esempio, digitare 5.

    Valori numerici per gli stati del flusso di lavoro Approvazione

    Stato

    Valore numerico

    In corso

    2

    Completato

    5

    Annullato

    15

    Approvato

    16

    Rifiutato

    17

    Note : 

    • I valori numerici relativi agli stati negli altri flussi di lavoro potrebbero essere diversi.

    • Il valore dello stato del flusso di lavoro in InfoPath è di sola lettura. Non è pertanto possibile progettare un modello di modulo in modo che l'utente possa modificare manualmente lo stato del flusso di lavoro immettendo un valore in un controllo del modulo stesso.

  12. Scegliere OK.

  13. Nella finestra di dialogo Regola fare clic su Aggiungi azione.

  14. In Azione fare clic su Cambia visualizzazione.

  15. In Visualizzazione fare clic sul nome della visualizzazione che si desidera mostrare quando lo stato del flusso di lavoro corrisponde allo stato relativo a questa condizione, quindi scegliere OK.

    Se, ad esempio, si è digitato 2 nel passaggio 11, fare clic sul nome della visualizzazione che si desidera mostrare quando lo stato del flusso di lavoro è uguale a In corso.

  16. Nella finestra di dialogo Regola scegliere OK.

  17. Ripetere i passaggi da 4 a 16 per creare altre regole che consentano di cambiare visualizzazione e passare a una visualizzazione appropriata per ogni fase del flusso di lavoro.

Inizio pagina

Passaggio 4: Pubblicare un modello di modulo come tipo di contenuto del sito

Quando si pubblica un modello di modulo, è possibile pubblicarlo in una raccolta documenti o come tipo di contenuto del sito utilizzabile in più raccolte documenti in un insieme di siti. Poiché si è già creata una raccolta documenti a cui è stato assegnato un flusso di lavoro, è necessario pubblicare il modello di modulo come tipo di contenuto. In seguito sarà possibile associare il tipo di contenuto del sito del modello di modulo alla raccolta creata.

Oltre a pubblicare un modello di modulo come tipo di contenuto del sito, è possibile pubblicarlo anche su un percorso di rete condiviso o creare una nuova raccolta documenti, quando si pubblica un modello di modulo su un sito SharePoint. Ulteriori informazioni sulla pubblicazione di modelli di modulo sono disponibili nella sezione Vedere anche.

  1. Scegliere Salva dal menu File.

  2. Nella finestra di dialogo Salva con nome passare al percorso in cui si vuole salvare il modello di modulo e quindi fare clic su Salva.

  3. Per aprire il riquadro attività Controllo grafico, scegliere Controllo grafico dal menu Strumenti.

  4. Se nel riquadro attività Controllo grafico sono elencati errori, correggerli, quindi fare clic su Aggiorna per determinare se gli errori persistono.

  5. Scegliere Pubblica dal menu File.

  6. Nella Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare il percorso del sito di SharePoint in cui si desidera pubblicare il modello di modulo e quindi fare clic su Avanti.

  8. Per consentire agli utenti di compilare questo modulo utilizzando un browser, nella pagina successiva della procedura guidata selezionare la casella di controllo Consenti compilazione del modulo mediante browser.

  9. Fare clic su Tipo di contenuto del sito (avanzate) quindi scegliere Avanti.

  10. Nella pagina successiva della procedura guidata fare clic su Crea nuovo tipo di contenuto.

  11. Nell'elenco Basa il tipo di contenuto su fare clic su Modulo, quindi scegliere Avanti.

  12. Nella pagina successiva della procedura guidata digitare un nome e una descrizione per il nuovo tipo di contenuto, quindi fare clic su Avanti.

  13. Nella casella Specificare percorso e nome di file per il modello di modulo della pagina successiva della procedura guidata digitare il percorso del sito SharePoint, quindi fare clic su Sfoglia.

  14. Nella finestra di dialogo Sfoglia passare al percorso sul server su cui si desidera pubblicare il modello di modulo come tipo di contenuto del sito, quindi digitare il nome del modello di modulo nella casella Nome file e fare clic su Salva.

  15. Fare clic su Avanti.

  16. Selezionare i campi nel modello di modulo che si desidera visualizzare come colonne nella visualizzazione predefinita della raccolta documenti.

    Procedura

    1. Fare clic su Aggiungi.

    2. Selezionare il campo che si desidera aggiungere come colonna nella raccolta documenti e quindi eseguire una delle operazioni seguenti:

      • Digitare un nome per la colonna nella casella nome colonna.

      • Selezionare la colonna del sito nell'elenco gruppo di colonne sito, selezionare un nome nella casella nome colonna e quindi fare clic su OK.

        Se si seleziona un campo ripetuto per visualizzare i dati nella raccolta documenti, è possibile definire come si desidera visualizzare il campo nella raccolta documenti, fare clic su un valore nell'elenco funzione. È possibile scegliere se visualizzare il primo valore nel campo, l'ultimo valore nel campo o un conteggio di tutte le occorrenze del campo o se unire tutti i valori.

    3. Scegliere OK.

  17. Fare clic su Avanti.

  18. Nella pagina successiva della procedura guidata verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

  19. Fare clic su Chiudi e quindi verificare che il modello di modulo sia un tipo di contenuto sul sito di SharePoint.

    Procedura

    1. Aprire il sito di SharePoint in un browser.

    2. Scegliere Impostazioni sito dal menu Azioni sito nell'angolo superiore destro del sito.

    3. In Impostazioni sito in raccolte fare clic su tipi di contenuto del sito.

      Il modello di modulo dovrebbe essere elencato in InfoPath i tipi di contenuto nella Raccolta di tipi di contenuto del sito.

Inizio pagina

Passaggio 5: Aggiungere un tipo di contenuto a una raccolta documenti

Tipi di contenuto consentono alle organizzazioni di organizzare, gestire e gestire contenuto in modo più efficiente in una raccolta siti. La definizione di tipi di contenuto per tipi specifici di documenti di un'organizzazione garantisce che ognuno di questi gruppi di contenuto verrà gestito in modo più efficiente. È possibile impostare un elenco o una raccolta per contenere gli elementi di più tipi di elementi o documenti mediante l'aggiunta di tipi di contenuto all'elenco o alla raccolta.

Nota : Per aggiungere i tipi di contenuto a un elenco o a una raccolta, è necessario almeno il livello di autorizzazione Progettazione per l'elenco o la raccolta.

Prima di iniziare, verificare che la raccolta sia impostata per consentire più tipi di contenuto.

Consentire più tipi di contenuto

  1. Scegliere Impostazioni raccolta documenti dal menu Impostazioni.

  2. In Impostazioni generali fare clic su Impostazioni avanzate.

  3. Nella sezione Tipi di contenuto selezionare per consentire più tipi di contenuto, quindi scegliere OK.

  1. Se la raccolta o l'elenco non è già aperto, fare clic sul relativo nome sulla barra di avvio veloce.

    Nota : Se il nome dell'elenco o della raccolta non viene visualizzato, fare clic su Visualizza tutto il contenuto del sito, quindi sul nome dell'elenco o della raccolta.

  2. Scegliere Impostazioni raccolta documenti dal menu Impostazioni.

  3. In Tipi di contenuto fare clic su Aggiungi da tipi di contenuto del sito esistenti.

  4. Nell'elenco Seleziona tipi di contenuto del sito da della sezione Selezione tipi di contenuto selezionare il gruppo di tipi di contenuto del sito da cui si desidera eseguire la selezione.

  5. Nell'elenco Tipi di contenuto del sito disponibili fare clic sul tipo di contenuto desiderato, quindi fare clic su Aggiungi per spostare il tipo di contenuto selezionato nell'elenco Tipi di contenuto da aggiungere.

  6. Per aggiungere altri tipi di contenuto, ripetere i passaggi 4 e 5, quindi scegliere OK.

Dopo avere eseguito queste procedure, quando un utente crea un nuovo modulo in questa libreria, la visualizzazione del modulo rispecchia lo stato del flusso di lavoro.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×