Progettare un modello di modulo per l'utilizzo non in linea

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Informazioni sui moduli non in linea

Creazione di una connessione dati a un database SQL per l'utilizzo non in linea

Creazione di una connessione dati a un database di Access per l'utilizzo non in linea

Creazione di una connessione dati a una raccolta documenti di SharePoint per l'utilizzo non in linea

Configurazione della disponibilità dei dati

Disattivazione dell'utilizzo non in linea

Informazioni sui moduli non in linea

Potrebbe essere necessario progettare un modello di modulo di Microsoft Office InfoPath che gli utenti possano completare mentre il computer è disconnesso dalla rete. Ad esempio, è possibile progettare un modello di modulo utilizzabile da un perito assicurativo mentre svolge un'indagine sul campo per una richiesta di risarcimento. Il modello di modulo contiene connessioni dati secondarie che forniscono dati al modulo da un database esterno che il perito deve poter consultare per completare il modulo. Mentre è in ufficio e connesso alla rete, il perito può utilizzare questo modello di modulo per creare un modulo e salvarlo sul proprio computer, quindi aprilo e completarlo sul campo quando non è connesso alla rete. Una volta tornato in ufficio e avere ripristinato la connessione alla rete, il perito potrà inviare il modulo.

Per impostazione predefinita, un modulo salvato su un computer può essere utilizzato senza una connessione di rete. Quando un utente crea un modulo basato su un modello di modulo, una copia del modello di modulo viene scaricata e copiata automaticamente nel computer dell'utente. Ogni volta che l'utente apre un modulo basato su quel modello di modulo, viene innanzitutto verificato se il computer è connesso alla rete. In caso affermativo viene verificato il percorso da cui è stato scaricato il modello di modulo per determinare se è disponibile una versione aggiornata. In questo caso il modello di modulo viene aggiornato sul computer dell'utente. Se non è disponibile una connessione alla rete, viene utilizzata la versione del modello di modulo archiviata nel computer dell'utente.

Per progettare un modello di modulo per l'utilizzo non in linea, è necessario che il modello venga archiviato sul computer dell'utente e che i dati necessari per completare il modulo, ad esempio le voci di una casella di riepilogo, siano disponibili anche quando il computer dell'utente non è connesso alla rete. I dati in questi controlli vengono forniti da una connessione dati secondaria a un'origine dati esterna. Questi dati possono essere archiviati sul computer dell'utente nel modello di modulo o in un percorso di archiviazione speciale detto cache.

Quando si aggiunge una connessione dati secondaria a un modello di modulo che esegue query sui dati di un'origine dati esterna, viene inviata automaticamente una query a quell'origine dati esterna, quindi i risultati della query vengono archiviati nel modello di modulo. Quando l'utente crea un nuovo modulo basato su questo modello di modulo, i dati salvati nel modello sono resi disponibili all'utente.

Quando il modulo utilizza questa connessione dati secondaria per aggiornare il contenuto di una casella di riepilogo o di una casella combinata con i dati più recenti dell'origine dati esterna, i risultati di questa query vengono salvati in un percorso di archiviazione speciale detto cache, se il computer è connesso alla rete. I dati contenuti in questa cache vengono utilizzati da InfoPath per fornire dati ai controlli.

Per rendere disponibili agli utenti i dati da una connessione dati secondaria anche quanto il computer non è connesso a una rete, è possibile eseguire una o entrambe le operazioni descritte di seguito:

  • Archiviare i dati dell'origine dati esterna nel modello di modulo.

  • Utilizzare la connessione dati secondaria quando si apre il modulo.

Dopo avere configurato la connessione dati secondaria in modo che possa essere utilizzata quando il computer dell'utente non è in linea, è inoltre possibile configurare il modello di modulo in modo che recuperi i dati più recenti dell'origine dati esterna. Se si imposta il recupero dei dati più recenti da parte del modello di modulo, limitando la disponibilità dei dati esistenti a un numero di giorni specificato, sarà quindi possibile aggiungere un pulsante a questo scopo.

Archiviare i dati nel modello di modulo

È possibile archiviare i dati da una connessione dati secondaria in un modello di modulo selezionando la casella di controllo Memorizza una copia dei dati nel modello di modulo nella Connessione guidata dati durante la creazione della connessione dati secondaria.

Finestra di dialogo Connessione guidata dati

Se si seleziona questa casella di controllo, la connessione dati verrà utilizzata da InfoPath per recuperare i dati dall'origine dati esterna, che verranno quindi archiviati nel modello di modulo. Quando un utente crea un modulo o ne apre uno esistente basato sul modello di modulo, nel computer dell'utente vengono scaricati una copia del modello di modulo e i dati archiviati. Se il computer dell'utente è connesso alla rete quando viene creato il modulo, i dati vengono recuperati dalla connessione dati esterna ogni volta che il modulo utilizza questa connessione dati. Se l'utente non è connesso alla rete quando viene creato il modulo, vengono utilizzati i dati archiviati nel modello di modulo sul computer dell'utente.

Poiché i dati sono stati recuperati al momento della creazione della connessione dati, è possibile che l'origine dati esterna sia stata aggiornata prima che un utente crei un modulo basato su questo modello di modulo. Se si desidera che gli utenti ricevano i dati più aggiornati dall'origine dati esterna quando creano un nuovo modulo o ne aprono uno esistente basato sul modello di modulo, progettare il modulo in modo che all'apertura venga utilizzata una connessione dati esterna.

Utilizzare la connessione dati secondaria quando si apre il modulo

Se si desidera che gli utenti ricevano i dati più aggiornati da un'origine dati esterna anziché utilizzare i dati archiviati nel modello di modulo, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo nella Connessione guidata dati durante la creazione della connessione dati secondaria. Ultima pagina della Creazione guidata dati

Quando un utente crea un nuovo modulo mentre è connesso alla rete, viene utilizzata questa connessione dati secondaria per recuperare i dati più recenti dall'origine dati esterna. Questi dati vengono archiviati nella cache. Se l'utente apre un modulo esistente salvato nel computer in uso, InfoPath controlla se il computer è connesso a una rete. In questo caso vengono recuperati i dati più recenti dall'origine dati esterna utilizzando questa connessione dati. Se invece l'utente non è in linea, vengono utilizzati automaticamente i dati archiviati nella cache o nel modello di modulo.

Nota sulla sicurezza : I dati recuperati da un'origine dati secondaria archiviati nel computer come testo normale. Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Ottenere i dati più aggiornati

Se un'origine dati esterna viene aggiornata regolarmente, è possibile configurare il modello di modulo in modo da consentire agli utenti di recuperare i dati più recenti attraverso la connessione dati secondaria. A questo scopo è possibile limitare la disponibilità dei dati attualmente archiviati nella cache a un numero di giorni specificato, quindi aggiungere un pulsante per recuperare i dati da qualsiasi origine dati esterna utilizzando tutte le connessioni dati secondarie del modulo. In questo modo si avrà la certezza che gli utenti dispongano sempre dei dati più recenti.

In alternativa è possibile limitare la disponibilità dei dati da una connessione dati secondaria impostando una data di scadenza per l'intervallo di tempo in cui si desidera che i dati siano archiviati sul computer dell'utente. Finestra di dialogo Opzioni modulo

Quando si utilizza questa opzione, InfoPath rende disponibili per il modulo tutti i dati da tutte le connessioni dati secondarie solo per il numero di giorni specificato. Allo scadere del numero di giorni impostato, i dati non saranno più visualizzati nel modulo. È quindi possibile aggiungere un pulsante al modulo su cui gli utenti possono fare clic per recuperare i dati utilizzando una connessione dati secondaria specifica o tutte le connessioni dati secondarie del modulo.

Nota sulla sicurezza : Anche se i dati non sono disponibili nel modulo, rimangono nel computer dell'utente dopo la scadenza del numero di giorni impostato e saranno sovrascritti solo quando lo spazio verrà utilizzato dal sistema operativo per archiviare altri dati.

Inizio pagina

Creazione di una connessione dati a un database SQL per l'utilizzo non in linea

Prima di aggiungere una connessione dati a un database Microsoft SQL Server al modello di modulo in uso, è necessario ottenere le seguenti informazioni dall'amministratore del database.

  • Il nome del server su cui è archiviato il database che verrà utilizzato per questo modello di modulo.

  • Il nome del server che verrà utilizzato per questo modello di modulo.

  • L'autenticazione richiesta dal database. Per determinare la modalità di accesso degli utenti al database può essere utilizzata l'autenticazione di Microsoft Windows o l'autenticazione di SQL Server.

  • Il nome della tabella contenente i dati che si desidera inviare al modulo, ovvero la tabella primaria. Se si prevede di utilizzare più di una tabella nel database, è necessario disporre dei nomi delle altre tabelle, dette tabelle figlio, oltre ai nomi dei campi nelle tabelle figlio con relazioni ai campi nella tabella primaria.

  • Se è possibile archiviare in modo sicuro i risultati della query nel modulo per l'utilizzo non in linea.

Una volta ottenute queste informazioni, sarà possibile utilizzare la procedura riportata di seguito per creare la connessione dati a un database SQL per l'utilizzo non in linea.

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access), quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Seleziona database.

  6. Nella finestra di dialogo Selezione origine dati fare clic su Nuova origine.

  7. Nell'elenco Indicare l'origine dati alla quale connettersi fare clic su Microsoft SQL Server, quindi fare clic su Avanti.

  8. Nella casella Nome server digitare il nome del server su cui è archiviato il database.

  9. In Credenziali di accesso effettuare una delle seguenti operazioni:

    • Se l'autorizzazione di accesso al server viene determinata dal database in base alle credenziali utilizzate su una rete di Microsoft Windows, fare clic su Usa autenticazione di Windows.

    • Se l'autorizzazione di accesso al server viene determinata dal database in base a un nome utente e una password specificati dall'amministratore del database, fare clic su Usa nome utente e password seguenti, quindi digitare il nome utente e la password nelle caselle Nome utente e Password.

  10. Fare clic su Avanti.

  11. Nella pagina successiva della procedura guidata fare clic sul database che si desidera utilizzare nell'elenco Selezionare il database contenente i dati desiderati, selezionare la casella di controllo Connetti a una tabella specifica, fare clic sul nome della tabella primaria, quindi fare clic su Avanti.

  12. Nella pagina successiva della procedura guidata digitare nella casella Nome file il nome da assegnare al file in cui sono archiviate le informazioni sulla connessione dati.

  13. Per salvare le impostazioni, fare clic su Fine.

  14. Aggiungere le eventuali altre tabelle che si desidera utilizzare nella connessione dati per query.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  15. Fare clic su Avanti.

  16. Se si desidera che i dati da questa connessione dati secondaria siano disponibili anche quando il computer dell'utente non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo. In questo caso viene eseguita una query sull'origine dati esterna e i risultati vengono memorizzati nel modello di modulo.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  17. Fare clic su Avanti.

  18. Nella pagina successiva della procedura guidata digitare un nome descrittivo per la connessione dati secondaria. Verificare che le informazioni nella sezione Riepilogo siano corrette. Per consentire agli utenti di utilizzare questa connessione dati secondaria quando creano un nuovo modulo o aprono un modulo esistente basato sul modello di modulo corrente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

Inizio pagina

Creazione di una connessione dati a un database di Access per l'utilizzo non in linea

Prima di aggiungere una connessione dati a un database di Access al modello di modulo in uso, è necessario ottenere le seguenti informazioni dall'amministratore del database.

  • Il nome e il percorso del database.

    Nota : Sarà inoltre necessario sapere se il database si trova in un percorso di rete accessibile agli utenti. Se il modello di modulo viene utilizzato da altri utenti in rete per creare moduli, il database dovrà essere disponibile in un percorso di rete a cui gli utenti possano accedere.

  • Se dal modello di modulo verranno eseguite solo query sul database, sarà necessario conoscere il nome della tabella che fornisce i risultati della query inviata al database. Questa sarà la tabella primaria quando si configura la connessione dati per query.

  • I nomi delle tabelle tabella primaria può richiedere dati da. Nella maggior parte dei casi, tabella sono già state definite relazioni nel database. Se è necessario stabilire relazioni tra la tabella primaria e un'altra tabella, sarà necessario i nomi dei campi correlati in entrambe le tabelle.

Dopo avere ottenuto queste informazioni sarà possibile utilizzare la procedura riportata di seguito per creare la connessione dati a un database di Access per l'utilizzo non in linea.

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access), quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Seleziona database.

  6. Nella finestra di dialogo Seleziona origine dati individuare il percorso del database.

    Nota : Se il database è archiviato in un percorso di rete, passare al percorso UNC del percorso. Non visualizzare il percorso di rete tramite un'unità di rete. Se si usa un'unità di rete, i moduli creati basati su questo modello di modulo cercherà il database da un'unità di rete. Se l'utente non dispone di un'unità di rete, la maschera non troverà il database.

  7. Fare clic sul nome del database, quindi scegliere Apri.

  8. Nella finestra di dialogo Seleziona tabella fare clic sulla tabella primaria che si desidera utilizzare, quindi scegliere OK.

  9. Nella pagina successiva della procedura guidata selezionare la casella di controllo Mostra colonne tabella.

    Per impostazione predefinita tutti i campi nella tabella vengono aggiunti all'origine dati principale del modello di modulo.

  10. In Struttura origine dati deselezionare le caselle di controllo dei campi che non si desidera includere nell'origine dati principale.

    Aggiungere eventuali altre tabelle o query che si desidera utilizzare nella connessione dati.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  11. Fare clic su Avanti.

  12. Per rendere disponibili i dati da questa connessione dati secondaria anche quando il computer dell'utente non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo. In questo caso viene eseguita una query sull'origine dati esterna e i risultati della query vengono memorizzati nel modello.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  13. Fare clic su Avanti.

  14. Nella pagina successiva della procedura guidata digitare un nome descrittivo per la connessione dati secondaria. Verificare che le informazioni nella sezione Riepilogo siano corrette. Per consentire agli utenti di utilizzare questa connessione dati secondaria quando creano un nuovo modulo o aprono un modulo esistente basato sul modello di modulo corrente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

Inizio pagina

Creazione di una connessione dati a una raccolta documenti di SharePoint per l'utilizzo non in linea

Prima di aggiungere una connessione dati al modello di modulo in uso, è necessario ottenere le seguenti informazioni dall'amministratore del sito:

  • Il percorso del sito di Microsoft Windows SharePoint Services e le necessarie autorizzazioni per l'accesso.

  • Verifica della configurazione del sito per accertarsi che gli utenti siano in grado di accedere ai dati dall'elenco o dalla raccolta documenti.

  • Verifica della possibilità di archiviare i dati dall'elenco o dalla raccolta documenti sui computer degli utenti per l'utilizzo non in linea.

Dopo avere ottenuto queste informazioni sarà possibile utilizzare la procedura riportata di seguito per creare la connessione dati a un database di Access per l'utilizzo non in linea.

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Raccolta o elenco SharePoint, quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare l'URL del sito di SharePoint con la raccolta o l'elenco documenti, quindi fare clic su Avanti.

  6. Nella pagina successiva della procedura guidata fare clic sull'elenco o sulla raccolta che si desidera utilizzare nell'elenco Selezionare un elenco o una raccolta, quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata selezionare le caselle di controllo accanto ai campi che forniranno dati al modello di modulo. Se il modello di modulo verrà pubblicato nella raccolta documenti e si desidera che i moduli basati sul modello di modulo recuperino i metadati sul modulo, selezionare la casella di controllo Includi dati solo per il modulo attivo.

  8. Fare clic su Avanti.

  9. Per rendere disponibili i dati da questa connessione dati secondaria anche quando il computer dell'utente non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo. In questo caso viene eseguita una query sull'origine dati esterna e i risultati della query vengono memorizzati nel modello di modulo.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  10. Fare clic su Avanti.

  11. Nella pagina successiva della procedura guidata digitare un nome descrittivo per la connessione dati secondaria, quindi verificare che le informazioni nella sezioneRiepilogo siano corrette.

  12. Per consentire agli utenti di utilizzare questa connessione dati secondaria quando creano un nuovo modulo o aprono un modulo esistente basato sul modello di modulo corrente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

Inizio pagina

Configurazione della disponibilità dei dati

Se l'origine dati esterna viene aggiornata regolarmente con nuovi dati, è possibile configurare il modello di modulo in modo da rendere disponibili tutti i dati archiviati nella cache. I dati saranno disponibili per i moduli basati su questo modello di modulo per un numero limitato di giorni corrispondete alla pianificazione degli aggiornamenti dell'origine dati esterna. Limitando il numero di giorni di disponibilità dei dati per i moduli basati sul modello di modulo, sarà possibile chiedere agli utenti di aggiornare i dati dall'origine dati esterna a intervalli regolari.

Per aggiornare i dati, è possibile aggiungere un pulsante al modello di modulo su cui gli utenti possono fare clic per l'aggiornamento dei dati da tutte le connessioni dati secondarie utilizzate nel modello di modulo.

Nota : Se si utilizza un pulsante per aggiornare la connessione dati, chiedere agli utenti di fare clic su questo pulsante solo se sono connessi a una rete.

Specificare il numero di giorni di disponibilità dei dati nella cache

Questa impostazione si applica a tutte le connessioni dati secondarie nel modello di modulo.

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco Categoria della finestra di dialogo Opzioni modulo fare clic su Non in linea.

  3. In Non in linea selezionare la casella di controllo Memorizza dati restituiti dalle query per l'utilizzo in modalità non in linea.

  4. Fare clic su Le query archiviate scadono dopo il numero di giorni seguente.

  5. Nell'elenco selezionare il numero di giorni in cui si desidera che i dati archiviati nella cache siano disponibili per il modulo.

Aggiungere un pulsante per aggiornare la connessione dati

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante nel modello di modulo.

  4. Fare doppio clic sul pulsante aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta digitare il nome da visualizzare sul pulsante.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna effettuare una delle seguenti operazioni:

    • Per configurare il pulsante per recuperare i dati più recenti attraverso questa connessione dati, fare clic su Una origine dati secondaria.

    • Per configurare il pulsante per recuperare i dati più recenti attraverso tutte le connessioni dati secondarie, fare clic su Tutte le origini dati secondarie.

  10. Nell'elenco Selezionare l'origine dati secondaria fare clic sull'origine dati secondaria associata alla connessione dati per query.

  11. Scegliere OK per chiudere tutte le finestre di dialogo aperte.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Disattivazione dell'utilizzo non in linea

In alcuni casi è opportuno progettare un modello di modulo che consenta agli utenti di compilare un modulo solo quando sono connessi a una rete. Ad esempio, se nel modello di modulo è impostata una connessione dati a un'origine dati esterna che contiene dati riservati o confidenziali, può essere utile configurare il modello di modulo in modo che la compilazione dei moduli sia consentita solo quando è attiva una connessione alla rete. In questo modo sarà più facile proteggere i dati qualora il computer venga perso o rubato, in quanto i dati non sono archiviati sul computer dell'utente.

Per configurare il modello di modulo in modo che agli utenti sia consentito compilare il modulo solo se il computer è connesso alla rete, completare la procedura riportata di seguito.

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco Categoria della finestra di dialogo Opzioni modulo fare clic su Non in linea.

  3. In Non in linea deselezionare la casella di controllo Consenti agli utenti di compilare questo modulo se i dati non sono disponibili.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×