Progettare un modello di modulo mediante le impostazioni in una raccolta di connessioni dati

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo viene descritto come progettare un modello di modulo basato sulle impostazioni memorizzate in una raccolta di connessioni dati su un sito Microsoft Office SharePoint Server 2007 in grado di ricevere o inviare dati.

Contenuto dell'articolo

Panoramica

Prima di iniziare

Progettazione di un modello di modulo con una connessione dati per query

Progettare un modello di modulo con una connessione dati per l'invio

Panoramica

Una connessione dati secondaria è qualsiasi connessione dati a un'origine dati esterna da aggiungere a un modello di modulo. La connessione dati è la differenza tra la connessione dati principale che viene creata quando si progetta modello di modulo in base a un database, servizio Web o impostazioni in una raccolta di connessioni. Aggiungere una connessione dati secondaria solo se non è possibile eseguire una query o inviare i dati mediante la connessione dati principale.

Un modulo può avere una connessione dati primaria, detta connessione dati principale, e facoltativamente una o più connessioni dati secondarie. In base agli obiettivi del modulo, una connessione dati può richiamare o inviare i dati del modulo a un'origine dati esterna, come un database Microsoft SQL Server o un servizio Web.

Se si progetta vari modelli di modulo che utilizzano le connessioni dati simili, è consigliabile usando un file di connessione dati invece di creare una connessione dati a un'origine dati esterna per ogni modello di modulo. In questo modo, è necessario aggiornare un solo file di connessione dati quando le informazioni di connessione dati per un set di modelli di modulo correlati. Ad esempio, quando si spostano i modelli di modulo da una rete di test in una rete di produzione, è necessario aggiornare i dati impostazioni di connessione una sola volta nella raccolta di connessione anziché aggiornare la connessione dati di ogni modello di modulo. Quando un modulo basato su un modello di modulo che utilizza un file di connessione dati utilizza la connessione dati, la connessione dati viene aggiornata automaticamente con le nuove impostazioni.

Un file di connessione dati è un file XML con un'estensione di file XML o udcx che contiene le informazioni di connessione per una singola origine dati esterna. Il file è archiviato in una raccolta di connessioni dati in un server che esegue Microsoft Office SharePoint Server 2007. Da uno sviluppatore o per la conversione di una connessione dati in un modello di modulo esistente in un file di connessione dati facendo clic sul pulsante Converti nella finestra di dialogo Connessioni dati (menuStrumenti ), viene creato un file di connessione dati.

Vantaggi dell'utilizzo di file di connessione dati:

  • Più moduli è possono utilizzare lo stesso file di connessione dati, in modo che non è necessario per creare la stessa connessione dati da zero per ogni modello di modulo.

  • Se la posizione o le impostazioni di connessione per un'origine dati esterna cambiano, è necessario aggiornare soltanto il file di connessione dati e non tutti i modelli di moduli.

  • File di connessione dati può contenere le informazioni di autenticazione alternativo che possono essere usate dal server durante la compilazione di un modulo tramite un Web browser.

  • Moduli basati su un modello di modulo compatibile con browser che sono compilati in un browser è possono connettersi al server in un altro dominio solo con le connessioni dati che utilizzano i file di connessione dati.

Microsoft Office InfoPath utilizza file di connessione dati che seguono il formato di file 2.0 versione universale connessione dati. Questa versione è un insieme di versione 1.0 formato di file utilizzato da Microsoft Office FrontPage e Microsoft Office Excel. InfoPath non è possibile usare i file di connessione dati nel formato di file 1.0 versione.

Quando si crea un modello di modulo che dipende dalle impostazioni in un file di connessione dati, Microsoft Office InfoPath viene creata una connessione dati in base alle impostazioni nella raccolta di connessioni dati. Se il file di connessione dati contiene le impostazioni per una connessione dati di query, viene creata principale origine dati della maschera con campi di query, campi dati e i gruppi che corrispondono in modo che i dati vengono archiviati nell'origine dati esterna che fanno riferimento le impostazioni nel file di connessione dati. Campi di query contengono i dati nell'origine dati esterna utilizzata per determinare gli elementi da inviare al modulo. I risultati della query vengono inseriti in campi di dati. Per consentire agli utenti di eseguire una query nell'origine dati esterna, InfoPath aggiunge un pulsante Esegui Query al modello di modulo.

Poiché la struttura dei campi di query di dati deve corrispondere al modo in cui i dati sono stati memorizzati nell'origine dati esterna, non è possibile modificare i campi o i gruppi nell'origine dati principale, ma è possibile aggiungerli.

Se si utilizzano le impostazioni per una connessione dati per l'invio, il pulsante Invia nella barra degli strumenti Standard e il comando Invia nel menu File dei moduli basati su questo modello di modulo saranno abilitati. Ciò consente l'invio dei dati nei moduli all'origine dati esterna.

Inizio pagina

Prima di iniziare

Per poter progettare un modello di modulo basato sulle impostazioni in una raccolta di connessioni dati, è necessario richiedere le seguenti informazioni dall'amministratore della raccolta di connessione dati o allo sviluppatore che ha creato il file della connessione dati:

  • Il percorso del sito Office SharePoint Server 2007 con la raccolta di connessioni.

  • Il nome del file della connessione dati nella raccolta che si desidera utilizzare.

Inizio pagina

Progettazione di un modello di modulo con una connessione dati per query

Per poter progettare un modello di modulo basato su un file della connessione dati con le impostazioni per una connessione dati per query, effettuare le seguenti operazioni:

  1. Progettare il modello di modulo basato sul file della connessione dati    In questo passaggio viene creata l'origine dati principale per il modello di modulo con i campi e i gruppi appropriati basati sulle impostazioni riportate nel file della connessione dati.

  2. Aggiungere un controllo al modello di modulo in cui verranno visualizzati i risultati della query    Per visualizzare i dati memorizzati nei campi e nei gruppi nell'origine dati principale, è necessario aggiungere un controllo al modello di modulo e associarlo quindi a un campo di query o a un campo di dati nell'origine dati principale.

Passaggio 1: progettare il modello di modulo basato sul file della connessione dati

  1. Scegliere Progetta modello modulo dal menu File.

  2. Nel gruppo Progetta della finestra di dialogo Progetta modello di modulo fare clic su Modello di modulo.

  3. Nell'elenco In base a: selezionare Raccolta connessioni.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nell'elenco Sito nella Connessione guidata dati selezionare il nome del sito nel server che esegue Office SharePoint Server 2007 e che include la raccolta di connessione dati.

    Aggiunta del sito all'elenco

    1. Click Manage Sites.

    2. In the Manage Sites dialog box, click Add.

    3. In the URL box, type the location of the data connection library.

    4. In the Display name box, type a name for the data connection library. This name will appear in the Site list in the Data Connection Wizard.

    5. Click OK.

    6. Fare clic su Chiudi.

  7. Fare clic sul nome della raccolta connessione dati per visualizzare un elenco dei file della connessione dati, selezionare il nome della connessione dati che si desidera utilizzare e fare clic su Avanti.

  8. Se è stato selezionato un file di connessione dati con le impostazioni di connessione a un servizio Web, nella pagina successiva della procedura guidata potrebbe essere richiesto di specificare dei valori di esempio per ogni parametro in modo da determinare i campi o i gruppi da aggiungere all'origine dati secondaria.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  9. Se l'origine dati esterna a cui fanno riferimento le impostazioni restituisce un oggetto Microsoft ADO.NET DataSet, nella pagina successiva della procedura guidata verrà richiesto se si desidera includere tali informazioni quando vengono inviati i dati del modulo. Nella maggior parte dei casi, lasciare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati selezionata, quindi fare clic su Avanti. Se non si desidera includere le informazioni sulle modifiche, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati e fare clic su Avanti.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se le impostazioni sono per un servizio Web e il file WSDL (Web Service Description Language) indica che il servizio Web restituisce un oggetto ADO.NET DataSet.

  10. Nella pagina successiva della procedura guidata digitare un nome per la connessione dati e quindi fare clic su Fine.

Passaggio 2: aggiungere un controllo per visualizzare i dati nel campo

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo a cui si desidera associare il controllo.

Inizio pagina

Progettazione di un modello di modulo con una connessione dati per invio

Se il file della connessione dati contiene le impostazioni per una connessione dati per l'invio, è possibile configurare il modello di modulo in modo da consentire l'invio dei dati dei moduli mediante la connessione dati. Quando vengono eseguite queste operazioni, in InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File. È possibile configurare le opzioni di invio per il modulo nella finestra di dialogo Opzioni invio nel menu Strumenti. Tali opzioni sono configurate allo stesso modo delle opzioni di un modello di modulo basato su un database o un servizio Web. Per ulteriori informazioni sulla progettazione di un modello di modulo basato su un database o su un servizio Web, fare clic sui collegamenti nella sezione Vedere anche.

  1. Scegliere Progetta modello modulo dal menu File.

  2. Nella sezione Progetta della finestra di dialogo Progetta modello di modulo selezionare l'opzione Modello di modulo.

  3. Nell'elenco In base a: selezionare Raccolta connessioni.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nell'elenco Sito nella Connessione guidata dati selezionare il nome del sito nel server che esegue Office SharePoint Server 2007 e che include la raccolta di connessioni.

    Aggiunta del sito all'elenco

    1. Click Manage Sites.

    2. In the Manage Sites dialog box, click Add.

    3. In the URL box, type the location of the data connection library.

    4. In the Display name box, type a name for the data connection library. This name will appear in the Site list in the Data Connection Wizard.

    5. Click OK.

    6. Click Close.

  7. Fare clic sul nome della raccolta connessione dati per visualizzare un elenco dei file della connessione dati, selezionare il nome della connessione dati che si desidera utilizzare e fare clic su Avanti.

  8. Se è stato selezionato un file della connessione dati con le impostazioni della connessione a un servizio Web, nella pagina successiva della procedura guidata potrebbe essere richiesto di specificare valori di esempio per ogni parametro in modo da determinare il miglior campo o gruppo da aggiungere all'origine dati secondaria.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  9. Nella pagina successiva della procedura guidata digitare un nome per la connessione dati e quindi fare clic su Fine.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×