Progettare un modello di modulo basato su un servizio Web

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare un modello di modulo che può utilizzare un servizio Web per ricevere i dati, per inviarli e per riceverli e inviarli allo stesso tempo.

Contenuto dell'articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare un modello di modulo con una connessione dati di query

Progettare un modello di modulo con una connessione dati

Progettare un modello di modulo con query e inviare connessioni dati

Panoramica

Un modulo può avere una connessione dati primaria, detta connessione dati principale, e facoltativamente una o più connessioni dati secondarie. In base agli obiettivi del modulo, una connessione dati può richiamare o inviare i dati del modulo a un'origine dati esterna, come un database Microsoft SQL Server o un servizio Web.

Quando si progetta un modello di modulo basato su un servizio Web, è possibile scegliere di configurare il modello di modulo per consentire ai moduli basati su tale modello di modulo per ricevere i dati, inviare i dati, o inviare e ricevere i dati da e verso un servizio Web. Se si sta progettando un modello di modulo per consentire ai moduli ricevere dati da un servizio Web, Microsoft Office InfoPath viene creata una connessione dati di query come la connessione dati principale per il modulo. A seconda della connessione dati, viene creata una principale origine dati con campi di query, campi dati e gruppi che si basano sulle XML Schema del servizio Web. Campi di query contengono i dati che il servizio Web utilizza per determinare gli elementi da inviare al modulo. Quando i moduli basati sul modello di modulo utilizzano la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati di query al servizio Web. Il servizio Web restituisce i risultati della query al modulo mediante la connessione dati di query.

Poiché la struttura di dati dei campi di query e di dati deve corrispondere al modo in cui sono memorizzati i dati nel servizio Web, non è possibile modificare i campi o i gruppi esistenti nell'origine dati principale. È possibile aggiungere campi e gruppi solo al gruppo principale nell'origine dati principale. Per ulteriori informazioni sulle origini dati, fare clic sui collegamenti nella sezione Vedere anche.

Durante la progettazione di un modello di modulo per inviare i dati a un servizio Web, in InfoPath viene creata una connessione dati per l'invio nella connessione dati principale per il modulo. Ciò consente l'invio dei dati nei moduli al servizio Web. Viene inoltre aggiunto un comando Invio nel menu File e viene abilitato il pulsante Invia nella barra degli strumenti Standard del modulo. È inoltre possibile personalizzare le opzioni di invio per i moduli. Quando si crea la connessione dati per l'invio, InfoPath determina i parametri nel servizio Web che sono disponibili per la ricezione di dati. In base a queste informazioni, è possibile specificare i campi che si desidera inviare al servizio Web.

Durante la progettazione di un modello di modulo per inviare e ricevere i dati su un servizio Web, in InfoPath viene creata sia una connessione dati per query che una connessione dati per l'invio.

In InfoPath sono utilizzati i seguenti standard per comunicare con i servizi Web:

  • SOAP (Simple Object Access Protocol)    SOAP è il protocollo di comunicazione che definisce i messaggi XML che sono utilizzati per comunicare con il servizio Web.

  • WSDL (Web Services Description Language)    WSDL è lo standard dello schema XML utilizzato per descrivere il percorso, i protocolli di comunicazione e le interfacce di un servizio Web. InfoPath può utilizzare solo servizi Web stile documento/letterale.

  • UDDI (Universal Description Discovery and Integration)    UDDI è il servizio directory che descrive i servizi Web offerti da un'azienda.

Torna all'inizio

Considerazioni sulla compatibilità

Non è possibile configurare la connessione dati per invio in un modello di modulo compatibile con browser per consentire agli utenti di inviare le informazioni sulle modifiche insieme ai dati del modulo a un servizio Web che accetta un DataSet Microsoft ADO.NET. Le informazioni sulle modifiche sono costituite dalle modifiche che un utente apporta ai dati memorizzati in un database. Il database utilizza un servizio Web per connettere gli utenti. ADO.NET può utilizzare le informazioni sulle modifiche per determinare la modalità di aggiornamento dei dati nel database. Chiedere all'amministratore del servizio Web se il servizio Web richiede informazioni sulle modifiche per aggiornare un database. In questo caso, è necessario progettare un modello di modulo i cui moduli possano essere completati soltanto mediante InfoPath.

Torna all'inizio

Prima di iniziare

Per progettare un modello di modulo basato su un servizio Web, è necessario richiedere le seguenti informazioni all'amministratore del servizio Web:

  • Il percorso del servizio Web.

  • Verifica che il servizio Web utilizza una codifica stile documento/letterale. InfoPath può utilizzare soltanto documenti Web con questo stile.

  • Il nome dell'operazione del servizio Web che invia o riceve i dati dai moduli basati su questo modello di modulo.

Torna all'inizio

Progettazione di un modello di modulo con una connessione dati per query

Per progettare un modello di modulo con una connessione dati per query, è necessario effettuare le seguenti operazioni:

  1. Creare il modello di modulo    Quando si crea un modello di modulo in grado di ricevere dati da un servizio Web, in InfoPath viene creata una connessione dati principale con una connessione dati per query tra il servizio Web e un modulo basato su questo modello di modulo. Viene inoltre creata l'origine dati principale del modello di modulo.

  2. Aggiungere uno o più controlli per visualizzare i risultati della query    Per consentire agli utenti di visualizzare e modificare i dati nei campi dell'origine dati principale quando viene aperto il modulo, è possibile aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo nell'origine dati principale.

Passaggio 1: creazione del modello di modulo

  1. Scegliere Progetta modello di modulo dal menu File.

  2. Nel gruppo Progetta della finestra di dialogo Progetta modello di modulo fare clic su Modello di modulo.

  3. Nell'elenco In base a: selezionare Servizio Web.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. In Connessione guidata dati, fare clic su Ricezione dati e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata digitare il percorso del servizio Web e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web che restituisce i dati al modulo, quindi fare clic su Avanti.

  9. Se la Connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, nella pagina successiva della procedura potrebbe essere richiesto di specificare valori di esempio per i parametri in modo da determinare i campi o i gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  10. Se il servizio Web accetta le informazioni sulle modifiche, nella pagina successiva della procedura guidata verrà richiesto se si desidera includere tali informazioni nei dati della query. Nella maggior parte dei casi, lasciare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati selezionata, quindi fare clic su Avanti. Se non si desidera includere le informazioni sulle modifiche, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati e fare clic su Avanti.

    Questa casella di controllo è disabilitata se si progetta un modello di modulo compatibile con browser.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se il file WSDL (Web Services Description Language) per il servizio Web indica che il servizio Web restituisce un DataSet Microsoft ADO.NET.

  11. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  12. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

Passaggio 2: Aggiungere uno o più controlli per visualizzare i risultati della query

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

Torna all'inizio

Progettazione di un modello di modulo con una connessione dati per invio

Per progettare un modulo con una connessione dati per l'invio, è necessario:

  1. Creare il modello di modulo    Quando si crea un modello di modulo in grado di inviare i dati a un servizio Web, in InfoPath viene creata una connessione dati principale con una connessione dati per l'invio tra il servizio Web e un modulo basato su questo modello di modulo. Viene inoltre creata l'origine dati principale del modello.

  2. Aggiungere uno o più controlsand associarli a gruppi o campi, o impostare le proprietà del controllo per visualizzare i dati in un campo    Per consentire agli utenti di modificare i dati nei campi dell'origine dati principale, è possibile aggiungere controlli al modello di modulo e quindi associati ai campi dell'origine dati principale.

  3. Configurazione delle opzioni di invio    È possibile configurare i dati che si desidera inviare al servizio Web e le opzioni di invio per il modulo.

Passaggio 1: creazione del modello di modulo

  1. Scegliere Progetta modello di modulo dal menu File.

  2. Nel gruppo Progetta della finestra di dialogo Progetta modello di modulo fare clic su Modello di modulo.

  3. Nell'elenco In base a: selezionare Servizio Web.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. In Connessione guidata dati, fare clic su Invio dati e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web a cui gli utenti invieranno i dati, quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Fare clic su Avanti.

  9. Nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web che utilizza i dati inviati, quindi fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  11. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

Passaggio 2: Aggiungere uno o più controlli e associarli a gruppi o campi

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

  4. Ripetere i passaggi 2 e 3 per tutti gli altri controlli di cui che si desidera aggiungere al modello di modulo.

Passaggio 3: Configurare le opzioni di invio

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic sulla connessione dati per l'invio nella connessione dati principale e quindi su Modifica.

  3. In Connessione guidata dati fare clic su Avanti due volte.

  4. Nella pagina successiva della procedura guidata effettuare una delle seguenti operazioni per selezionare i dati nel modulo da inviare per ogni parametro nel servizio Web.

    Inviare i dati in un campo o gruppo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni parametro, fare clic su Campo o gruppo.

    3. Fare clic su Modifica Pulsante Origine dati .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su Solo testo ed elementi figlio per inviare solo i dati del campo selezionato e gli elementi figlio del campo o gruppo, oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati contenuti nel campo e gli elementi figlio del gruppo o campo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come stringa.

      Nota : In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

    Dettagli tecnici sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto DataSet ADO.NET, durante la configurazione della connessione dati selezionare un nodo DataSet. Se si utilizza un tipo di nodo diverso per una connessione dati a un servizio Web che richiede un dataset ActiveX Data Objects (ADO), l'azione di invio avrà esito negativo.

  5. Fare clic su Avanti.

  6. Fare clic su Fine.

  7. Fare clic su Chiudi.

  8. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  9. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      1. Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      2. Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      3. Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Progettazione di un modello di modulo con una connessione dati per query e una connessione dati per l'invio

Per progettare un modello di modulo sia con una connessione dati per query che con una connessione dati per l'invio, è necessario effettuare le seguenti operazioni:

  1. Creare il modello di modulo    Quando si crea un modello di modulo in grado sia di ricevere che di inviare i dati a un servizio Web, in InfoPath viene creata una connessione dati principale tra il modello di modulo e il servizio Web con una connessione dati per query e una connessione dati per l'invio. Viene inoltre creata l'origine dati principale del modello di modulo.

  2. Aggiungere un controllo e associarlo a un campo per visualizzare i dati in un campo    Perché gli utenti possano visualizzare e modificare i dati nei campi nell'origine dati principale, è possibile aggiungere i controlli al modello di modulo e associare quindi tali controlli ai campi nell'origine dati principale.

  3. Configurazione delle opzioni di invio    È possibile configurare i dati che si desidera inviare al servizio Web e le opzioni di invio per il modulo.

Passaggio 1: creazione del modello di modulo

  1. Scegliere Progetta modello di modulo dal menu File.

  2. In Progetta:, nella finestra Progetta modulo fare clic su Modello di modulo.

  3. Nell'elenco In base a: selezionare Servizio Web.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. In Connessione guidata dati, fare clic su Ricezione e invio dati, quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata digitare la posizione del servizio Web con l'operazione ce invia i dati al modello di modulo, quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web che restituisce i dati al modulo, quindi fare clic su Avanti.

  9. Se la Connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, nella pagina successiva della procedura potrebbe essere richiesto di specificare valori di esempio per i parametri in modo da determinare i campi o i gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  10. Se il servizio Web accetta le informazioni sulle modifiche, nella pagina successiva della procedura guidata verrà richiesto se si desidera includere tali informazioni nei dati della query. Nella maggior parte dei casi, lasciare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati selezionata, quindi fare clic su Avanti. Se non si desidera includere le informazioni sulle modifiche, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio dei dati e fare clic su Avanti.

    La casella di controllo è disabilitata se si progetta un modello di modulo compatibile con browser.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se il file WSDL (Web Services Description Language) per il servizio Web indica che il servizio Web restituisce un DataSet ADO.NET.

  11. Nella pagina successiva della procedura guidata digitare un nome per la connessione dati per query e quindi fare clic su Fine.

  12. Nella pagina successiva della procedura guidata digitare il percorso del servizio Web a cui verranno inviati i moduli degli utenti e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  13. Nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web che utilizza i dati inviati, quindi fare clic su Avanti.

  14. Nella pagina successiva della procedura guidata effettuare una delle seguenti operazioni per selezionare i dati nel modulo da inviare per ogni parametro nel servizio Web.

    Inviare i dati in un campo o gruppo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni parametro, fare clic su Campo o gruppo.

    3. Fare clic su Modifica Pulsante Origine dati .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su Solo testo ed elementi figlio per inviare solo i dati del campo selezionato e gli elementi figlio del campo o gruppo, oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati contenuti nel campo e gli elementi figlio del gruppo o campo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come stringa.

      In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

    Dettagli tecnici sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto DataSet ADO.NET, quando si configura questa connessione dati selezionare un nodo di set di dati. Se si utilizza un qualsiasi altro tipo di nodo per una connessione dati a un servizio Web che richiede un DataSet ADO.NET, l'azione di invio riporterà un errore.

  15. Fare clic su Avanti.

  16. Nella pagina successiva della procedura guidata digitare un nome per la connessione dati per l'invio, quindi fare clic su Fine.

Passaggio 2: aggiunta di un controllo e associazione a un campo per visualizzare i dati

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo che si desidera associare il controllo.

Passaggio 3: Configurare le opzioni di invio

  1. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×