Progettare un modello di modulo basato su un database di Microsoft Access

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare un modello di modulo di Microsoft Office InfoPath in grado di interagire con un database di Microsoft Office Access per eseguire una query sui dati o per eseguire una query e inviare dati. Questo modello di modulo può essere basato su un database di Microsoft Office Access 2007 (in formato accdb) o su un database di Access salvato in una versione precedente (in formato mdb).

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare il modello di modulo

Configurare le opzioni di invio

Panoramica

In un modulo possono essere presenti una connessione dati primaria, detta connessione dati principale, ed eventualmente una o più connessioni dati secondarie. È possibile utilizzare la connessione dati principale per eseguire query sui dati del modulo o inviarli a un database di Access. È inoltre possibile utilizzare connessioni dati secondarie per eseguire query sui dati e inviarli a origini dati esterne, con alcune eccezioni. Ad esempio, una connessione dati secondaria a un database di Access può essere utilizzata per l'esecuzione di query solo su quel database. Non è possibile aggiungere una connessione dati secondaria a un modulo che invia i dati direttamente a un database di Access.

Quando si progetta un modello di modulo basato su un database di Access, InfoPath crea una principale origine dati con i gruppi che contengono i campi di query e campi dati e crea anche una connessione dati di query come la connessione dati principale per il modello di modulo. Questi campi e gruppi corrispondono in modo che i dati vengono archiviati in tabelle del database.

Campi di query contengono i dati immessi nel modulo da un utente per limitare i risultati della query a record che soddisfano i dati nei campi di query. Quando una maschera in cui è basata sul modello di modulo utilizza la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati. Il database restituisce i risultati della query al modulo mediante la connessione dati. I risultati della query vengono inseriti nei campi di dati, che possono essere modificati da controlli associati ai campi di dati del modulo.

Poiché la struttura di dati dei campi di query e dei campi di dati deve corrispondere al modo in cui i dati sono memorizzati nel database, non è possibile modificare i campi o i gruppi nell'origine dati principale. È possibile aggiungere campi o gruppi nel gruppo principale nell'origine dati principale. Per ulteriori informazioni sulle origini dati, fare clic sui collegamenti nella sezione Vedere anche.

Una maschera è possibile inviare dati a un database mediante connessione dati principale del modulo se il modello di modulo che si basa la maschera e il database soddisfa i requisiti seguenti:

  • Il modello di modulo è non un modello di modulo compatibile con browser    InfoPath non creerà una connessione dati nella connessione dati principale se si sta progettando un modello di modulo compatibile con browser. Per consentire agli utenti di inviare i dati in un modulo basato su un modello di modulo compatibile con browser, utilizzare un servizio Web compatibile con il database.

  • La tabella a sinistra di ogni coppia di tabelle correlate nell'origine dati principale contiene una chiave primaria    Almeno una delle relazioni per ciascuna coppia di tabelle correlate deve includere una chiave primaria della tabella a sinistra.

  • Nessuno dei campi dati nell'origine dati principale dell'archivio di maschera, un tipo di dati binari    InfoPath verrà disabilitata la connessione dati se la query include campi contenenti un tipo di dati binari, ad esempio immagini, di immagini, oggetti OLE, file allegati, il tipo di dati memo Office Access o il tipo di dati testo SQL.

Quando in InfoPath viene abilitata una connessione dati per invio, agli utenti è consentito inviare al database i dati archiviati nei campi dati nell'origine dati principale. Le opzioni di invio per i moduli basati su questo modello di modulo possono essere personalizzate.

Torna all'inizio

Considerazioni sulla compatibilità

Non è possibile progettare un modello di modulo compatibile con browser basato su un database di Access.

Torna all'inizio

Prima di iniziare

Per poter progettare un modello di modulo basato su un database di Access, è necessario disporre delle seguenti informazioni sul database di Access:

  • Il nome e il percorso del database.

    Nota : Assicurarsi che il database si trovi in un percorso di rete accessibile agli utenti.

  • Il nome della tabella che riceverà i dati inviati, se il modello di modulo consente agli utenti di inviare moduli a un database. Questa tabella verrà utilizzata come tabella primaria quando si configura la connessione dati per invio.

  • Il nome della tabella che fornisce i risultati della query inviata al database, se il modello di modulo consente solo l'esecuzione di query sul database. Questa tabella verrà utilizzata come tabella primaria quando si configura la connessione dati per query.

  • I nomi delle tabelle dati da può implicare anche la tabella primaria. Nella maggior parte dei casi, tabella sono già state definite relazioni nel database. Se è necessario stabilire manualmente le relazioni tra la tabella primaria e un'altra tabella, sarà necessario i nomi dei campi correlati di entrambe le tabelle.

Torna all'inizio

Progettazione del modello di modulo

Per progettare un modello di modulo con una connessione dati per query, è innanzitutto necessario creare il modello di modulo. Quando si crea un modello di modulo basato su un database, in InfoPath viene creata una connessione dati per query come connessione dati principale tra il modello di modulo e il database. Questo processo crea automaticamente l'origine dati principale del modello di modulo.

Dopo avere creato il modello di modulo, è necessario aggiungervi un controllo, quindi associare il controllo a un campo nell'origine dati principale, in modo da consentire agli utenti di visualizzare i risultati della query nel modulo.

Passaggio 1: Creare il modello di modulo

  1. Scegliere Progetta modello di modulo dal menu File.

  2. Nella finestra di dialogo Progetta modello di modulo in Progetta fare clic su Modello di modulo.

  3. Nell'elenco In base a fare clic su Database, quindi scegliere OK.

    Verrà avviata la Connessione guidata dati.

  4. Nella prima pagina della Connessione guidata dati fare clic su Seleziona database.

  5. Nella finestra di dialogo Seleziona origine dati individuare il percorso del database.

    Nota : Se il database è archiviato in un percorso di rete, selezionare il percorso universal naming (naming convention) di tale posizione. Non visualizzare il percorso di rete tramite un'unità di rete. Se si usa un'unità di rete, gli utenti che creano moduli basati sul modello di modulo cercherà il database da un'unità di rete. Se l'utente non dispone di un'unità di rete, la maschera non troverà il database.

  6. Fare clic sul nome del database, quindi scegliere Apri.

  7. Nella finestra di dialogo Seleziona tabella fare clic sulla tabella o sulla query primaria che si desidera utilizzare, quindi scegliere OK.

  8. Nella pagina successiva della procedura guidata selezionare la casella di controllo Mostra colonne tabella.

  9. Per impostazione predefinita tutti i campi nella tabella vengono aggiunti all'origine dati principale del modello di modulo. Deselezionare le caselle di controllo dei campi che non si desidera includere nell'origine dati principale.

    Aggiungere eventuali ulteriori tabelle o query che si desidera utilizzare nella connessione dati per query.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  10. Fare clic su Avanti.

  11. Nell'ultima pagina della procedura guidata digitare un nome per la connessione dati principale. Questo nome verrà visualizzato nell'elenco Origine dati nel riquadro attività Origine dati.

  12. Se il modello di modulo soddisfa i requisiti nella sezione Overview , la sezione di Riepilogo in questa pagina della procedura guidata indica che InfoPath attivata la connessione dati invia la connessione dati principale.

  13. Per modificare il nome della connessione dati per invio, digitare un nome nella casella appropriata.

  14. Per consentire agli utenti di inviare i dati del modulo tramite un'altra connessione dati per invio che verrà aggiunta in seguito al modello di modulo, deselezionare la casella di controllo Consenti invio per questa connessione.

    Nota : Se il modello di modulo non soddisfa i requisiti nella sezione Overview , InfoPath disabilita la connessione dati e casella Immettere un nome per la connessione di invio e la casella di controllo Consenti invio per questa connessione non sono disponibili. Se InfoPath disabilita la connessione dati, la connessione dati principale per il modello di modulo conterrà solo una connessione dati di query.

Passaggio 2: associazione di un controllo al campo

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo che si desidera associare il controllo.

Torna all'inizio

Configurazione delle opzioni di invio

Se il modello di modulo e le tabelle selezionate nella connessione guidata dati soddisfano i requisiti nella sezione Overview , InfoPath consente di configurare il modello di modulo per inviare i dati utilizzando la connessione dati principale.

Se si sceglie di utilizzare questa connessione dati per invio, il modello di modulo verrà configurato automaticamente in modo che gli utenti possano inviare i dati del modulo al database e verranno inoltre aggiunti un pulsante Invia alla barra degli strumenti Standard e un comando Invia al menu File del modulo. Il modello di modulo verrà inoltre configurato da InfoPath in modo che quando l'utente invia il modulo, questo rimanga aperto e venga visualizzato un messaggio per indicare se l'operazione è stata completata. È possibile modificare sia il testo visualizzato sul pulsante Invia, sia il comportamento del modulo dopo che è stato inviato dall'utente.

  1. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×