Progettare un modello di modulo basato su un database Microsoft SQL Server

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare un modello di modulo che possa funzionare con un database Microsoft SQL Server per ricevere i dati o per riceverli e inviarli.

Contenuto dell'articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare il modello di modulo

Configurare le opzioni di invio

Panoramica

Un modulo può avere una connessione dati primaria, detta connessione dati principale, e facoltativamente una o più connessioni dati secondarie. In base agli obiettivi del modulo, una connessione dati può richiamare o inviare i dati del modulo a un'origine dati esterna, come un database Microsoft SQL Server o un servizio Web.

Durante la progettazione di un modello di modulo basato su un database di Microsoft Office InfoPath crea una principale origine dati con gruppi che contengono i campi di query e campi dati e una connessione dati di query come la connessione dati principale per il modello di modulo. Questi campi e gruppi corrispondono in modo che i dati vengono archiviati in tabelle del database. Campi di query contengono i dati immessi da un utente per limitare i risultati della query a record che soddisfano i dati nei campi di query. Quando un modulo basato sul modello di modulo utilizza la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati di query. Il database restituisce i risultati della query al modulo mediante la connessione dati di query. Nei campi di dati, che possono essere modificati da controlli associati a questi campi vengono inseriti i risultati della query.

Poiché la struttura di dati dei campi di query e dei campi di dati deve corrispondere al modo in cui i dati sono memorizzati nel database, non è possibile modificare i campi o i gruppi nell'origine dati principale. È possibile aggiungere campi o gruppi nel gruppo principale nell'origine dati principale. Per ulteriori informazioni sulle origini dati, fare clic sui collegamenti nella sezione Vedere anche.

Una maschera è possibile inviare dati a un database mediante connessione dati principale del modulo se il modello di modulo che si basa la maschera e il database soddisfa i requisiti seguenti:

  • Il modello di modulo è non un modello di modulo compatibile con browser    InfoPath non creerà una connessione dati nella connessione dati principale se si sta progettando un modello di modulo compatibile con browser. Per consentire agli utenti di inviare i dati in un modulo basato su un modello di modulo compatibile con browser, utilizzare un servizio Web compatibile con il database.

  • La tabella a sinistra di ogni coppia di tabelle correlate nell'origine dati principale contiene una chiave primaria    Almeno una delle relazioni per ciascuna coppia di tabelle correlate deve includere una chiave primaria della tabella a sinistra.

  • Nessuno dei campi dati nell'origine dati principale dell'archivio di maschera, un tipo di dati binari    InfoPath verrà disabilitata la connessione dati se la query include campi contenenti un tipo di dati binari, ad esempio immagini, di immagini, oggetti OLE, file allegati, il tipo di dati memo Office Access o il tipo di dati testo SQL.

Se in InfoPath la connessione dati per l'invio è abilitata, è possibile inviare i dati nei campi di dati nell'origine dati principale al database. È inoltre possibile personalizzare le opzioni di invio per i moduli basati su questo modello di modulo.

Torna all'inizio

Considerazioni sulla compatibilità

Durante la progettazione di un modello di modulo basato su un database, è possibile progettare un modello di modulo compatibile con browser. In InfoPath viene creata una connessione dati per query come connessione dati principale in un modello di modulo compatibile con browser. Tuttavia, questi tipi di modelli di modulo non possono essere configurati per inviare i dati a un database pertanto, se si sta progettando un modello di modulo basato su un database SQL Server e si desidera che gli utenti possano inviare i dati del modulo al database mediante la connessione dati principale, non è possibile rendere il modello di modulo compatibile con browser.

Torna all'inizio

Prima di iniziare

Per poter progettare un modello di modulo basato su un database SQL Server, è necessario richiedere le seguenti informazioni all'amministratore del database:

  • Il nome del server contenente il database a cui verrà collegato il modello di modulo.

  • Il nome del database che verrà utilizzato con questo modello di modulo.

  • L'autenticazione richiesta dal database. Il database può utilizzare sia l'autenticazione Microsoft Windows che l'autenticazione SQL Server per determinare il modo in cui gli utenti possono accedere al database.

  • Il nome della tabella contenente i dati da inviare al modulo o che riceverà i dati dal modulo. Questa è la tabella primaria. Se verranno utilizzate più tabelle nel database, sarà necessario conoscere i nomi delle altre tabelle figlio e i nomi dei campi in queste tabelle che hanno relazioni con i campi nella tabella primaria.

Torna all'inizio

Progettare il modello di modulo

Per progettare un modello di modulo con una connessione dati per query, è necessario effettuare le seguenti operazioni:

  1. Creare il modello di modulo    Durante la creazione di un modello di modulo basato su un database, in InfoPath viene creata una connessione dati per query come connessione dati principale tra il modello di modulo e il database. Questo processo crea automaticamente l'origine dati principale del modello di modulo.

  2. Aggiungere uno o più controlli per visualizzare i risultati della query    Per consentire agli utenti di visualizzare e modificare i dati nei campi dell'origine dati principale quando viene aperto il modulo, è possibile aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo nell'origine dati principale.

Passaggio 1: creazione del modello di modulo

  1. Scegliere Progetta modello di modulo dal menu File.

  2. Nel gruppo Progetta della finestra di dialogo Progetta modello di modulo fare clic su Modello di modulo.

  3. Nell'elenco In base a: selezionare Database.

  4. Se si sta progettando un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

    Nota : La Connessione guidata dati non consente una connessione dati per l'invio in un modello di modulo compatibile con browser. Per inviare i dati a un database da moduli basati su un modello di modulo compatibile con browser, aggiungere una connessione dati secondaria a un servizio Web funzionante con il database. Per ulteriori informazioni sulle connessioni dati secondarie, fare clic sui collegamenti nella sezione Vedere anche.

  5. Fare clic su OK.

  6. In Connessione guidata dati fare clic su Seleziona database.

  7. Nella finestra di dialogo Selezione origine dati fare clic su Nuova origine.

  8. Nell'elenco Indicare l'origine dati alla quale connettersi selezionare Microsoft SQL Server e fare clic su Avanti.

  9. Nella casella Nome server, immettere il nome del server che contiene il database SQL Server.

  10. In Credenziali di accesso, effettuare una delle seguenti operazioni:

    • Se il database determina l'utente che ha accesso in base alle credenziali utilizzate in una rete Microsoft Windows, fare clic su Usa autenticazione di Windows.

    • Se il database determina l'utente che ha accesso in base al nome utente e alla password specificati ottenuti dall'amministratore del database, fare clic su Usa nome utente e password seguenti, quindi immettere il nome utente e la password nelle caselle Nome utente e Password.

  11. Fare clic su Avanti.

  12. Nell'elenco Selezionare il database contenente i dati desiderati selezionare il nome del database da utilizzare, selezionare la casella di controllo Connetti a una tabella specifica, scegliere il nome della tabella primaria, quindi fare clic su Avanti.

  13. Nella pagina successiva della procedura guidata nella casella Nome file digitare un nome per il file in cui sono memorizzate le informazioni sulla connessione dati quindi fare clic su Fine per salvare le impostazioni.

    Se si intende utilizzare altre tabelle nella connessione dati per query, è possibile aggiungerle in questa pagina della procedura guidata.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  14. Fare clic su Avanti.

  15. Nell'ultima pagina della procedura guidata, digitare un nome per la connessione dati principale. Questo nome verrà visualizzato nell'elenco di origine dati nel riquadro attività Origine dati.

  16. Se il modello di modulo soddisfi i requisiti di nella sezione Overview , questa pagina della procedura guidata indica che InfoPath attivata la connessione dati invia la connessione dati principale. Per modificare il nome per la connessione dati, digitare un nuovo nome nella casella appropriata. Se si vuole agli utenti di inviare che i dati del modulo a un'altra connessione dati che verranno aggiunti al modello di modulo in un secondo momento, fare clic per deselezionare la casella di controllo Consenti invio per la connessione.

    Nota : Se il modello di modulo non soddisfa i requisiti nella sezione Overview , InfoPath disabilita la connessione dati e la casella Immettere un nome per la connessione di invio e la casella di controllo Consenti invio per questa connessione sono disponibili. Se InfoPath disabilita la connessione dati, la connessione dati principale per il modello di modulo avrà solo una connessione dati di query.

Passaggio 2: Aggiungere uno o più controlli per visualizzare i risultati della query

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

Torna all'inizio

Configurazione delle opzioni di invio

Se il modello di modulo e le tabelle selezionate nella connessione guidata dati soddisfano i requisiti nella sezione Overview , InfoPath consente di configurare il modello di modulo per inviare i dati mediante la connessione dati principale. Se si sceglie di usare questa connessione dati, InfoPath consente di configurare il modello di modulo in modo che gli utenti possono inviare i dati del modulo al database e lo aggiunge pulsante Invia nella barra degli strumenti Standard e il comando Invia dal menu File quando gli utenti compilano il modulo. InfoPath consente di configurare anche il modello di modulo in modo che, quando gli utenti inviano i moduli, il modulo rimane aperto e verrà visualizzato un messaggio all'utente che indica se il modulo è stato inviato. È possibile modificare il testo sul pulsante Invia e il comportamento dopo l'utente invia un modulo.

  1. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×