Preparare, pubblicare e gestire il proprio sito Web di Publisher

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Dopo aver pianificare e creare una pubblicazione Web in Microsoft Office Publisher 2007, è possibile pubblicare sul Web, un server di rete o una cartella condivisa sul proprio computer. Qualunque sia la destinazione, viene creato il file HTML filtrati dalla pubblicazione Web. È possibile aprire e leggere i file HTML in qualsiasi browser Web, ad esempio Windows Internet Explorer.

Pubblicazione Web con barra di spostamento, testo ed elementi grafici

In questo articolo

In questo articolo vengono descritte le procedure per creare e pubblicare la pubblicazione Web come file HTML e per aggiornare il sito Web modificando e pubblicando di nuovo il file con Publisher.

Preparare il sito Web

Pubblicare il sito Web

Gestire il sito Web

Preparare il sito Web

Il sito Web rappresenta l'utente, la sua attività e il suo marchio aziendale. Prima di cerarlo, è quindi opportuna un'accurata pianificazione. Per informazioni sulla procedura da seguire, vedere l'articolo Pianificazione del sito Web.

Scegliere lo strumento ottimale

Se si intende il sito e le informazioni da offrire, considerare quale strumento di creazione più adatto alle proprie esigenze. Office Publisher 2007 è un eccellente strumento di creazione da utilizzare quando si desidera creare, pubblicare e gestire siti Web semplici e statici corrispondenti nel marchio aziendale e che richiedono le revisioni di solo testo e grafica. Office Publisher 2007 non è lo strumento appropriato nei casi seguenti:

  • Se è necessario consentire l'interazione con il sito Web o la pubblicazione di contenuti basati su database, in modo che i visitatori possano rispondere in un blog o acquistare articoli in un carrello acquisti.

  • Se per il sito Web è necessaria la convalida dei dati, ad esempio per verificare numeri di carte di credito.

  • Se si prevede di modificare successivamente il codice HTML non elaborato in un editor HTML dopo aver creato il sito Web in Office Publisher 2007, che combina il codice HTML, XML e VML per creare siti Web

Microsoft® Office Live per hosting Web di base e la creazione di un sito in linea, potrebbe essere lo strumento adatto. Per informazioni, visitare il sito Web Microsoft® Office Live .

Per i siti Web interattivi, Microsoft Expression Web fornisce strumenti per la creazione di siti Web ricchi di dati basati su standard. Per informazioni, visitare il sito Microsoft Expression Web .

Creare il sito Web

È possibile creare una nuova pubblicazione Web in Office Publisher 2007. Se si desidera lavorare su un sito Web esistente per cui non si dispone di alcuna pubblicazione Web, è possibile copiare e incollare il contenuto di pagine Web pubblicate in una nuova pubblicazione Web, che ricrea il sito Web come pubblicazione Web, oppure utilizzare uno strumento di modifica HTML.

  1. Scegliere Nuovo dal menu File.

  2. Nell'elenco Tipi di pubblicazione fare clic su Sito Web.

  3. Eseguire una delle operazioni seguenti:

    • Per creare un sito Web personalizzato basato sugli obiettivi del sito, verificare che sia selezionata la casella di controllo Usa Creazione guidata sito Web nel riquadro attività Opzioni, quindi fare clic sullo schema desiderato.

    • Per creare un sito Web da zero, fare clic su Dimensioni vuote nella sezione Sito Web, quindi scegliere la dimensione desiderata.

  4. Fare clic su Crea.

  5. Se si è scelto di utilizzare la Creazione guidata sito Web, selezionare le opzioni desiderate nella finestra di dialogo Creazione guidata sito Web, quindi scegliere OK.

  6. Aggiungere il contenuto alla pubblicazione e apportare le modifiche desiderate.

    Suggerimento : Evitare di posizionare gli oggetti sulle pagine master della pubblicazione Web. Gli oggetti che vengono collocati nelle pagine master Office Publisher 2007 non vengono visualizzati correttamente quando vengono visualizzate in alcuni browser Web.

Controllare la pubblicazione Web

Prima di pubblicare il sito Web, assicurarsi che funzioni come previsto e che siano stati risolti tutti i possibili inconvenienti.

Per effettuare queste verifiche, utilizzare il controllo grafico e visualizzare il sito in anteprima.

Individuare e risolvere problemi mediante il controllo grafico

Il controllo grafico è un potente strumento per la ricerca di potenziali problemi. Molti dei suoi controlli riguardano problemi di base relativi alla formattazione, mentre altri sono specifici delle problematiche che possono riguardare le pubblicazioni Web. Per eseguire il controllo grafico, effettuare le seguenti operazioni:

  1. Scegliere Controllo grafico dal menu Strumenti.

  2. Nel riquadro attività Controllo grafico selezionare le caselle di controllo Esegui controlli generali ed Esegui controlli per sito Web.

    Nota : Verificare che la casella di controllo Esegui controlli per stampa esterna non sia selezionata.

  3. Nel riquadro attività Controllo grafico fare clic sulla freccia accanto all'elemento che si desidera correggere in Selezionare un elemento da correggere e quindi eseguire una delle operazioni seguenti:

    • Fare clic su Correzione automatica per correggere automaticamente il problema relativo all'elemento.

      La soluzione applicata per la correzione automatica varia in base al problema specifico. Nella maggior parte dei casi, non è disponibile alcuna correzione automatica.

    • Scegliere Vai a questo elemento per passare alla pagina in cui si trova l'elemento problematico selezionato.

      Sarà quindi possibile correggere il problema apportando le modifiche necessarie.

    • Fare clic su Spiegazione per visualizzare un argomento della Guida in cui viene spiegato nel dettaglio il problema e in cui vengono forniti suggerimenti per la correzione.

    • Fare clic su Non eseguire più questo controllo per disattivare il controllo.

      Facendo clic su questa opzione verranno influenzate tutte le istanze del problema.

Visualizzare in anteprima il sito Web

  • Scegliere Anteprima pagina Web dal menu File.

Il sito Web verrà visualizzato in anteprima nel browser predefinito. Verificare nell'anteprima i seguenti aspetti:

  • Il sito viene aperto correttamente ed è possibile accedere a tutte le pagine.

  • Tutti i collegamenti ipertestuali funzionano correttamente.

  • Tutti i controlli per lo spostamento funzionano correttamente.

  • Non manca alcun elemento.

  • Tutti i suoni di sottofondo vengono riprodotti correttamente.

Individuare un servizio di hosting Web

Prima di poter pubblicare il sito Web sul Web, è necessario abbonarsi a un servizio Web hosting fornito da un provider di servizi Internet (ISP). Questo servizio offre accesso a Internet, spazio di archiviazione su un server Web e un Uniform Resource Locator (URL) in modo che gli utenti potranno accedere al sito Web. Prima di pubblicare il sito Web, contattare l'ISP o amministratore di sistema per ottenere le informazioni necessarie e l'URL del sito Web o l'indirizzo del sito FTP in cui è possibile salvare i file.

In genere sono disponibili diversi ISP sul territorio. Verificare che l'ISP sottoscritto offra il tipo di supporto desiderato. Se non si è molto esperti nella pubblicazione sul Web, è opportuno scegliere un ISP che in grado di offrire assistenza per qualsiasi problema.

Torna all'inizio

Pubblicare il sito Web

Dopo avere controllato e visualizzato in anteprima la pubblicazione Web e sottoscritto un servizio di hosting Web, è possibile passare alla pubblicazione del sito.

È possibile pubblicare un sito Web a un server Web, un server di rete, un server FTP File Transfer Protocol () o una cartella sul computer.

La pubblicazione del sito in un percorso del computer in uso può avere scopi diversi:

  • Utilizzare i file pubblicati per testare il sito Web prima di rendere i file disponibili sul Web.

  • Ricorrere a un'utilità FTP per pubblicare i file sul Web caricandoli dal percorso file sul computer.

  • Conservare una copia locale dei file HTML oltre alla pubblicazione Web.

Per ottenere le informazioni necessarie sul metodo di pubblicazione più appropriato, è consigliabile rivolgersi al provider.

Se si pubblica sul Web o al computer, Office Publisher 2007 assembla tutti i file correlati che viene creato in un'unica cartella. I file Office Publisher 2007 che crea includere altri elementi grafici GIF e JPEG che utilizzate su pagine e i file per i suoni incorporati, pagine HTML che compongono il sito.

È possibile impostare Office Publisher 2007 per organizzare i file nella cartella dove si pubblica il sito Web in uno dei due modi. Per impostazione predefinita, Office Publisher 2007 crea una singola home page e una sottocartella che contiene tutti i file di supporto necessari per il sito Web. Oppure è possibile organizzare la home page con tutti i file di supporto per il sito Web in una singola cartella.

Come controllare dove Office Publisher 2007 consente di organizzare il sito Web pubblica i file?

Scegliere Opzioni dal menu Strumenti, scegliere la scheda Web, quindi effettuare una delle seguenti operazioni:

  • Per separare la home page dai file di supporto, selezionare la casella di controllo Salva i file di supporto in una cartella.

  • Per raggruppare la home page e tutti i file di supporto nella stessa cartella, deselezionare la casella di controllo Salva i file di supporto in una cartella.

Quando si pubblica una pubblicazione sul Web, Office Publisher 2007 crea un file HTML filtrati che propagano sul Web più velocemente rispetto ai file HTML non filtrati. Poiché tale Office Publisher 2007 i file HTML filtrati crea non contengono nessun tag specifici di Microsoft Office, è possibile aprire i file HTML in Office Publisher 2007 e modificarli. È necessario apportare modifiche al sito Web della pubblicazione Web e quindi ripubblicare il sito sul Web.

Pubblicare un sito Web su Internet o in una rete

Prima di seguire questa procedura, contattare il provider o l'amministratore di sistema per ottenere le informazioni necessarie per la pubblicazione e l'URL del sito Web in cui è possibile salvare i file.

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nella casella Nome file della finestra di dialogo Pubblica sul Web digitare l'URL del server Web o del server di rete in cui si desidera salvare il sito. Digitare, ad esempio, http://www.northwindtraders.com.

  3. Scegliere Salva.

  4. Se richiesto, digitare il nome utente e la password e quindi fare clic su OK.

    Nella finestra di dialogo Pubblica sul Web verrà visualizzata la directory associata all'URL.

  5. Fare doppio clic sulla cartella in cui si desidera salvare il sito Web.

  6. Nella casella Nome file selezionare index come nome predefinito per la home page e quindi fare clic su Salva.

    Nota : Index.htm è la selezione predefinita. Se si seleziona index come nome della home page, sarà più facile accedervi e impedire agli utenti di visualizzare un elenco di file che costituiscono il sito Web.

  7. Quando richiesto, scegliere OK.

Pubblicare un sito Web mediante FTP

Prima di iniziare questa procedura, contattare l'amministratore di sistema o ISP per ottenere le informazioni necessarie per pubblicare un sito FTP. È inoltre necessario creare un sito FTP in Percorsi FTP.

Procedura

Prima di aggiungere un sito FTP all'elenco di Percorsi FTP, è necessario accedere a Internet o a una Intranet.

In Windows Vista

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nella finestra di dialogo Pubblica sul Web fare clic su Strumenti, quindi su Connetti unità di rete.

  3. Nella finestra di dialogo Connetti unità di rete effettuare le operazioni seguenti:

    • Nell'elenco Unità selezionare un'unità di rete. È possibile scegliere qualsiasi lettera disponibile.

    • Per connettersi ogni volta che si accede al computer, selezionare la casella di controllo Riconnetti all'avvio.

    • Fare clic su Connessione a un sito Web per l'archiviazione di documenti e immagini.

  4. Nell'Aggiunta guidata risorse di rete scegliere Avanti, fare clic su Scegliere un percorso di rete personalizzato, quindi scegliere Avanti.

  5. Nella casella Indirizzo Internet o di rete digitare l'indirizzo del sito FTP, ad esempio ftp://ftp.microsoft.com, quindi scegliere Avanti.

    Nota : Se non è possibile connettersi a un'unità di rete o a una cartella, è possibile che il computer sia spento o che non si disponga delle autorizzazioni corrette. Se non è possibile connettersi, contattare l'amministratore di rete o l'ISP.

  6. Se non si desidera accedere come utente anonimo, deselezionare la casella di controllo Accesso anonimo, digitare un nome utente nella casella Nome utente, quindi scegliere Avanti.

  7. Inserire il nome di questa risorsa di rete, quindi scegliere Avanti.

  8. Fare clic su Fine.

In Microsoft Windows XP

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nell'elenco Salva in fare clic sulla freccia, quindi scegliere Percorsi FTP.

  3. Fare doppio clic su Aggiungi/modifica percorsi FTP.

  4. Nella casella Nome del sito FTP, digitare il nome del sito FTP, ad esempio ftp.microsoft.com.

  5. Eseguire una delle operazioni seguenti:

    • Se si desidera accedere a un sito FTP che consente l'accesso anonimo, selezionare l'opzione Anonima nella casella di gruppo Connessione.

    • Se si desidera accedere a un sito FTP per cui si dispone di autorizzazioni utente, selezionare l'opzione Utente nella casella di gruppo Connessione, quindi inserire la password nella casella Password.

  6. Fare clic su Aggiungi.

  7. Fare clic su OK.

  1. Scegliere Pubblica sul Web dal menu File.

  2. Scegliere Percorsi FTP dall'elenco Salva in.

  3. Nell'elenco di siti FTP fare doppio clic sul sito desiderato, quindi doppio clic sulla cartella in cui si desidera pubblicare il sito Web.

    Nota : Se l'ISP richiede l'utilizzo di un programma specifico per caricare il sito Web o se si pubblica il sito Web su una intranet aziendale, è necessario salvare una versione del sito Web in un formato di file specifico HTML e seguire una procedura diversa per pubblicare il sito Web. Per informazioni su come salvare e pubblicare il sito Web, rivolgersi all'ISP o all'amministratore di sistema.

Pubblicare un sito Web in una cartella del computer in uso

In Windows Vista

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nella Barra degli indirizzi fare clic sull'unità o sulla cartella in cui si desidera pubblicare il sito Web, ad esempio la cartella Documenti.

    Nota : Se si desidera aggiungere il sito Web a una nuova cartella, è necessario crearla, facendo clic su Nuova cartella sulla barra degli strumenti, quindi digitare un nome per la cartella, infine premere INVIO.

  3. Nella casella Nome file selezionare index come nome predefinito per la home page e quindi fare clic su Salva.

    Nota : Index.htm è la selezione predefinita. Se si seleziona index come nome della home page, sarà più facile accedervi e impedire agli utenti di visualizzare un elenco di file che costituiscono il sito Web.

In Windows XP

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nell'elenco Salva in fare clic sull'unità o sulla cartella in cui si desidera pubblicare il sito Web, ad esempio la cartella Documenti.

    Nota : Se si desidera aggiungere il sito Web a una nuova cartella, fare clic con il pulsante destro del mouse nel percorso in cui si desidera aggiungere la nuova cartella, quindi scegliere Nuovo e fare clic su Cartella per crearla, digitare un nome per la nuova cartella nella casella Nome, infine fare clic su Apri.

  3. Nella casella Nome file selezionare index come nome predefinito per la home page e quindi fare clic su Salva.

    Nota : Index.htm è la selezione predefinita. Se si seleziona index come nome della home page, sarà più facile accedervi e impedire agli utenti di visualizzare un elenco di file che costituiscono il sito Web.

Torna all'inizio

Gestire il sito Web

Dopo avere pubblicato il sito Web, sarà possibile aggiornarlo con nuove informazioni ogni volta che sarà necessario. I file HTML filtrati non possono tuttavia essere aperti in Publisher, bensì è necessario aprire la pubblicazione Web originale, apportarvi le modifiche necessarie, quindi ripubblicare il sito sul Web.

Nota : Non tentare di aggiornare i file HTML filtrati utilizzando un editor di testo, ad esempio Microsoft WordPad o il Blocco note. Sebbene infatti ciò risulti possibile, il codice HTML generato da Publisher è estremamente complesso e risulterà probabilmente difficile modificarlo manualmente. Per ottenere risultati migliori, aggiornare sempre il sito Web di Publisher utilizzando la pubblicazione Web e pubblicare di nuovo il sito.

Pubblicare solo le modifiche

In Office Publisher 2007, è possibile pubblicare gli aggiornamenti di un sito Web già pubblicato rapidamente utilizzando incrementale pubblicano sul Web, che pubblica solo le pagine che è stato aggiornato. Se si prevede di aggiornare spesso il sito Web, o se il sito Web è grande e complesso, incrementale, pubblicazione sul Web può velocizzare l'attività di aggiornamento del sito Web.

Se si apportano modifiche al sito Web direttamente su un server WebOffice Publisher 2007, tuttavia, attivando incrementale di fuori di pubblicazione sul Web può impedire la pubblicazione di aggiornamenti successivi al sito Web utilizzando il comando Pubblica sul Web. Se si prevede di gestire i file del sito Web direttamente sul server Web (ad esempio tramite un programma separato, FTP ), è consigliabile disattivare la pubblicazione sul Web.

Nota : In Publisher, la pubblicazione incrementale sul Web è attivata per impostazione predefinita.

Per attivare o disattivare la pubblicazione incrementale sul Web

  1. Scegliere Opzioni dal menu Strumenti, quindi scegliere la scheda Web.

  2. Nella casella di gruppo Salvataggio, procedere in uno dei seguenti modi:

    • Per disattivare la pubblicazione incrementale sul Web, deselezionare la casella di controllo Consenti pubblicazione incrementale sul Web.

    • Per attivare la pubblicazione incrementale sul Web, selezionare la casella di controllo Consenti pubblicazione incrementale sul Web.

Pubblicare le modifiche al sito Web

La pubblicazione degli aggiornamenti di un sito Web è leggermente diversa rispetto alla pubblicazione di un intero sito Web per la prima volta. Dopo avere pubblicato un sito in un percorso sul Web o in rete, in Risorse di rete verrà infatti visualizzato un collegamento al server Web o al server di rete.

In Windows Vista

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nel riquadro di spostamento della finestra di dialogo Pubblica sul Web fare clic su Computer.

  3. Nell'elenco di file fare doppio clic sul collegamento alla cartella del server Web o del server di rete in cui si trova il sito pubblicato.

  4. Fare doppio clic sulla cartella in cui si desidera salvare il file.

  5. Nella casella Nome file digitare il nome del file che si sta aggiornando, quindi fare clic su Salva.

In Windows XP

  1. Scegliere Pubblica sul Web dal menu File.

  2. Nella finestra di dialogo Pubblica sul Web fare clic su Risorse di rete.

  3. Fare doppio clic sul collegamento alla cartella del server Web o del server di rete in cui si trova il sito pubblicato.

  4. Fare doppio clic sulla cartella in cui si desidera salvare il file.

  5. Nella casella Nome file digitare il nome del file che si sta aggiornando, infine fare clic su Salva.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×