Per decodificare il codice sorgente di Microsoft Visual C++ 6.0

  1. Personalizzare Visual C++.

    how

    1. In Visual C++ scegliere Customize dal menu Tools.

    2. Nella finestra di dialogo Customize fare clic sulla scheda Add-Ins And Macro Files.

    3. Nell'elenco Add-Ins And Macro Files selezionare Componente aggiuntivo UML di Visio.

      Accanto all'opzione Componente aggiuntivo UML di Visio verrà visualizzato un segno di spunta.

    4. Fare clic su Chiudi.

      Verrà visualizzata la barra degli strumenti mobile Componente aggiuntivo UML di Visio con cinque pulsanti.

    5. Se si desidera che la barra degli strumenti sia disponibile ogni volta che si avvia Visual C++, ancorarla trascinandola nell'area delle barre degli strumenti.

      Suggerimento : Se si desidera creare scelte rapide da tastiera per ciascuno dei pulsanti sulla barra degli strumenti Componente aggiuntivo UML di Visio, scegliere Customize dal menu Tools, fare clic sulla scheda Keyboard, quindi scegliere la categoria Add-Ins.

      Per specificare in dettaglio i file di sistema che si desidera decodificare (MFC, ATL o di inclusione), fare clic sul pulsante Opzioni UML di Visio UML Options button image .

  2. Generare un file con le informazioni di visualizzazione.

    how

    1. In Visual C++ scegliere Settings dal menu Project.

    2. Nella finestra di dialogo Project Settings scegliere il tipo di configurazione desiderato, fare clic sulla scheda C/C++ e selezionare Generate Browse Info.

    3. Fare clic sulla scheda Browse Info per specificare il nome e il percorso del file di informazioni, selezionare Build Browse Info File e scegliere OK.

  3. Creare il progetto in Visual C++.

    Nota : Se si apportano modifiche a un progetto di Visual C++ dopo la decodificazione, per visualizzare le modifiche sarà necessario creare di nuovo il progetto, quindi decodificarlo nel programma Visio.

  4. In Visual C++ fare clic sul pulsante Decodificazione modello UML UML Reverse Engineer button image sulla barra degli strumenti Componente aggiuntivo UML di Visio.

    Se nell'area di lavoro di Visual C++ sono presenti più progetti, nella finestra di dialogo Seleziona progetto selezionare il progetto che si desidera decodificare, quindi scegliere OK.

    Se nella gerarchia del progetto sono presenti più file con le informazioni di visualizzazione, nella finestra di dialogo Seleziona file con le informazioni di visualizzazione selezionare il file desiderato, quindi scegliere OK.

    L'estrazione delle informazioni sulla classe dal file con le informazioni di visualizzazione può richiedere alcuni secondi. Al termine verrà aperto UML - Diagramma modello di Visio con una pagina di disegno con il diagramma della struttura statica vuoto e una struttura in Esplora modelli con le icone che riflettono le definizioni delle classi nel codice sorgente.

  5. In UML - Diagramma modello di Visio trascinare le icone dalla struttura nella pagina di disegno per creare un diagramma della struttura statica che rappresenta una vista del modello.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×