Passare ad Access 2010

Panoramica

Passare ad Access 2010 da una versione precedente Questo corso è rivolto agli utenti che hanno già esperienza con Access. Nel corso viene illustrato come passare ad Access 2010 da una versione precedente. Vengono fornite informazioni su come eseguire attività comuni in Access 2010, ad esempio utilizzare database esistenti, creare nuovi database, creare tabelle e creare o modificare maschere e report.

Al termine di questo corso si sarà in grado di:

  • Utilizzare la visualizzazione Backstage per aprire database esistenti e creare nuovi database.

  • Salvare un database esistente come file di Access 2010.

  • Utilizzare la barra multifunzione per attivare la visualizzazione Struttura per tabelle, maschere, report e query.

  • Utilizzare la visualizzazione Layout per modificare maschere e report.

  • Utilizzare la visualizzazione Layout per raggruppare dati nei report.

Questo corso include:

  • Una lezione per l'apprendimento autogestito.

  • Un breve test alla fine della lezione. Per il test non è prevista l'assegnazione di punteggi.

  • Una scheda di riferimento rapido che è possibile stampare al termine del corso.

Questo corso è rivolto a utenti che hanno un certo livello di esperienza con Access, che hanno già creato qualche database e che comprendono le nozioni di base sulla progettazione di database e le relazioni tra tabelle. Se non si conosce Access, vedere Introduzione ad Access 2010.

Versione offline (71,1 MB)

Introduzione ad Access 2010

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Avviare operazioni dal riquadro di spostamento

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Introduzione alla barra multifunzione

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Utilizzare file creati nelle versioni precedenti di Access

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Introduzione rapida a modelli e database Web

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Progettare in modo semplice con la visualizzazione Layout

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Procedure di esercitazione suggerite

Questo corso è rivolto a utenti che hanno un certo livello di esperienza con Access 2003 o versioni precedenti, ovvero che abbiano gestito qualche database in tali applicazioni. Di seguito vengono fornite alcune indicazioni su come esercitarsi con le nozioni acquisite nel corso.

Importante    Per eseguire questi passaggi è necessario avere installato Access 2010 nel computer in uso ed essere connessi a Internet.

Creare un nuovo database vuoto.

Per eseguire questi passaggi, è possibile utilizzare uno schema di database che si è già creato in precedenza.

  1. Avviare Access 2010. La visualizzazione Backstage verrà aperta automaticamente.

  2. Fare clic sulla scheda Nuovo. Il modello Database vuoto è già selezionato.

  3. Nella parte destra della scheda immettere un nome per il nuovo database nella casella Nome file.

  4. È inoltre possibile fare clic sull'icona della cartella disponibile a destra della casella Nome file.

    Verrà aperta la finestra di dialogo Salva nuovo database, che è possibile utilizzare per selezionare un percorso diverso per il database.

  5. Fare clic su Download.

    Il database verrà aperto e nella visualizzazione Foglio dati verrà visualizzata una tabella vuota nella quale sarà possibile aggiungere campi.

Aggiungere campi a una tabella

In Access è possibile aggiungere campi a una tabella in diversi modi. Di seguito vengono indicati i più comuni.

  1. Con la tabella aperta nella visualizzazione Foglio dati, verificare di essere posizionati nella scheda Campi, altrimenti fare clic su di essa.

  2. Nel gruppo Aggiungi ed elimina aprire l'elenco Altri campi.

  3. Nella parte inferiore dell'elenco, in Avvio rapido, fare clic su Nome.
    Elenco Altri campi

  4. Fare clic sull'intestazione di campo vuota a destra dei nuovi campi (le parole Fare clic per aggiungere) e quindi ripetere il passaggio 4 per aggiungere i campi IndirizzoeTelefonoalla tabella.

  5. Fare clic con il pulsante destro del muse sull'intestazione di campo vuota (le parole Fare clic per aggiungere) e selezionare Memo nell'elenco che verrà visualizzato.

    In tal modo verrà impostato il tipo di dati per il campo e l'intestazione del campo verrà resa scrivibile.

  6. Nell'intestazione del campo immettere Commenti, quindi fare clic su un punto esterno all'intestazione per salvare le modifiche.

Utilizzare il riquadro di spostamento

Nota    Per eseguire questi passaggi è necessario essere connessi a Internet. Scaricare il database di esempio Northwind. Per eseguire questa operazione, fare clic sulla scheda Nuovo e quindi su Modelli di esempio. Impostare il database come attendibile facendo clic su Abilita contenuto sulla barra dei messaggi gialla e accedere al database.

  1. Per questo modello il riquadro di spostamento è chiuso, pertanto fare clic sulla doppia freccia per aprirlo.

    Pulsante di apertura/chiusura del riquadro di spostamento

  2. Nel riquadro fare clic sulla barra Report per espandere il gruppo corrispondente.

    Si noti che nel gruppo viene visualizzato un set di collegamenti agli oggetti di database. In tal modo è possibile assicurarsi che si stia visualizzando una categoria o un gruppo personalizzato.

  3. Fare clic sulla barra sulla parte superiore del riquadro (dove è presente il nome Northwind Traders) e fare clic su Tipo oggetto. Verrà visualizzato un elenco degli oggetti presenti nel database.

  4. Fare clic su Maschere, fare clic con il pulsante destro del mouse sulla maschera Elenco clienti e quindi fare clic su Visualizzazione Layout.

  5. Fare clic sul gruppo Tabelle per espanderlo e quindi fare doppio clic sulla tabella Clienti.

  6. Fare clic con il pulsante destro del mouse sulla barra sulla parte superiore del riquadro e quindi fare clic su Barra di ricerca.

    Per rendere visibile la barra di ricerca ripetere questo passaggio.

  7. Dopo aver reso visibile la barra di ricerca, espandere tutti i gruppi e, nella casella di ricerca, immettere lentamente la parola cliente. Si noti come l'elenco di oggetti venga filtrato automaticamente mentre si digitano i caratteri.

Utilizzare la barra multifunzione

Provare i passaggi seguenti con un database quale Northwind.

  • Aprire una tabella nella visualizzazione Foglio dati, verificare quali schede contestuali vengono visualizzate e controllare quali comandi sono disponibili in tali schede.

  • Aprire una query nella visualizzazione Struttura, verificare quali schede contestuali vengono visualizzate e controllare quali comandi sono disponibili in tali schede.

  • Aprire una maschera nella visualizzazione Layout verificare quali schede contestuali vengono visualizzate e controllare anche tali schede.

Passaggi aggiuntivi

  1. Con qualsiasi oggetto di database aperto e con la scheda Home visualizzata, premere ALT.

    Verrà visualizzato un set di suggerimenti tasti di scelta.

    Suggerimenti tasti di scelta

    In Access è disponibile un suggerimento tasto di scelta per ogni scheda della barra multifunzione e un suggerimento tasto di scelta per i comandi di ogni scheda.

  2. Premere nuovamente ALT e verificare come i suggerimenti tasti di scelta vengano nascosti.

  3. Premere ALT+C per passare alla scheda Crea.

    Dato che si è passati alla scheda Crea dalla scheda Home, verrà visualizzato un set di suggerimenti tasti di scelta per ogni comando presente nella scheda Crea.

  4. Premere nuovamente ALT e verificare come i suggerimenti tasti di scelta vengano nascosti.

  5. A questo punto premere ALT+C e verificare come i suggerimenti tasti di scelta vengano visualizzati nuovamente.

    Se si chiudono involontariamente i suggerimenti tasti di scelta per una determinata scheda, è possibile premere ALT e quindi la lettera corrispondente a tale scheda per visualizzare nuovamente i suggerimenti tasti di scelta.

  6. Premere QU per aprire Progettazione query.

  7. Dopo aver aperto Progettazione query, premere ALT+H per passare alla scheda Home.

    Si noti che per i comandi disabilitati anche i suggerimenti tasti di scelta sono disabilitati (visualizzati in grigio).

Pubblicare un database Web

Scaricare uno dei modelli di database Web, ad esempio Database Web Beni. Per eseguire questa operazione, fare clic sulla scheda Nuovo e quindi su Modelli di esempio. Impostare il database come attendibile facendo clic su Abilita contenuto sulla barra dei messaggi gialla e accedere al database.

  1. Nella visualizzazione Backstage fare clic sulla scheda Salva e pubblica.

  2. Fare clic su Pubblica in Access Services.

  3. Fare clic su Esegui Verifica compatibilità.

  4. Fare clic su per chiudere eventuali oggetti aperti e consentire l'esecuzione di Verifica compatibilità.

    Se lo strumento Verifica compatibilità non rileva errori o visualizza solo avvisi, il database è pronto per la pubblicazione.

  5. Immettere l'URL del server e un nome per il sito. Richiedere l'URL all'amministratore di sistema.

  6. Fare clic su Pubblica in Access Services.

    Sarà necessario attendere il termine del processo di pubblicazione e il termine dell'elaborazione del nuovo sito da parte del server.

  7. Avviare il browser, passare al sito, aprire la maschera Beni correnti e immettere qualche dato.

Modificare un database Web e salvare le modifiche sul Web

  1. Aprire il database Web Beni in Access.

  2. Aprire la maschera Principale in visualizzazione Layout.

  3. Fare clic con il pulsante destro del mouse sulla scheda Guida introduttiva nella maschera, fare clic su Elimina e quindi premere CTRL+S per salvare le modifiche.

  4. Fare clic sulla scheda File per passare alla visualizzazione Backstage.

  5. Nella scheda Informazioni fare clic su Sincronizza tutto per salvare le modifiche sul Web

    Pulsante Sincronizza tutto

Test

Rispondere alle domande seguenti per verificare il livello di comprensione del materiale presentato. Le risposte sono per uso personale e per il test non è prevista l'assegnazione di punteggi.

È possibile utilizzare la visualizzazione Struttura per modificare maschere e report in un database Web.

Vero.

Risposta errata. È possibile utilizzare la visualizzazione Struttura solo per maschere o report che non verranno pubblicati in Access Services. Per un database Web, utilizzare la visualizzazione Layout per creare e modificare maschere e report.

Falso.

Risposta corretta. Per modificare maschere e report in un database Web, è possibile utilizzare la visualizzazione Layout, ma non la visualizzazione Struttura.

In un database di Access 97 aperto in Access 2010 è possibile immettere dati e apportare modifiche alla progettazione.

Vero.

Risposta errata. In un database di Access 97 aperto in Access 2010 è possibile solo leggere dati.

Falso.

Risposta corretta. È possibile solo leggere dati. Per eseguire altre operazioni, salvare il file nel formato di Access 2010.

È possibile pubblicare un database Web in qualsiasi sito Web.

Vero.

Risposta errata. È possibile pubblicare database Web solo in server SharePoint in cui è in esecuzione Access Services.

Falso.

Risposta corretta. Nel server SharePoint 2010 deve essere in esecuzione Access Services.

Nel riquadro di spostamento per aprire una maschera per immettere dati si esegue l'operazione seguente:

Clic con il pulsante destro del mouse sulla maschera e quindi clic sulla visualizzazione Struttura.

Risposta errata. Con tale operazione si apre la maschera per modifiche alla struttura ma non per un utilizzo normale.

Doppio clic sulla maschera

Risposta corretta. È inoltre possibile fare clic con il pulsante destro del mouse su un oggetto e quindi fare clic su Apri.

Non si utilizza il riquadro di spostamento. Si utilizza il comando Apri nella scheda Home della barra multifunzione.

Risposta errata. Il riquadro di spostamento può essere utilizzato per aprire oggetti su cui lavorare.

Quando si salva un file MDB nel nuovo formato di file (ad esempio come file ACCDB), è possibile aprire tale nuovo file in Access 2003.

Vero.

Risposta errata. Non è possibile aprire file ACCDB in Access 2003.

Falso.

Risposta corretta. È possibile aprire file ACCDB solo in Access 2007 o 2010. È inoltre opportuno tenere presente che qualsiasi caratteristica presente solo in Access 2010 non funziona nella versione 2007.

Commenti e suggerimenti

Scheda di riferimento rapido

Altre risorse di formazione

Informazioni per principianti

Progettare tabelle per un nuovo database

Vedere anche

Personalizzare la barra multifunzione

Cartella di lavoro di mapping della barra multifunzione di Access

Visualizzare o nascondere il riquadro di spostamento

Finestra di dialogo Opzioni di spostamento

Convertire un database di Access 2010 in un formato di file precedente

Scegliere la visualizzazione da utilizzare: Layout o Struttura

Utilizzare la visualizzazione Backstage

  • In Access 2010 viene introdotto l'utilizzo della visualizzazione Backstage. Per aprire o chiudere la visualizzazione Backstage è possibile fare clic sulla scheda File.

  • È possibile aprire un database facendo clic sul nome di tale database in File oppure facendo clic sulla scheda Recente.

  • Nella scheda Nuovo è possibile creare nuovi database, compresi modelli e database vuoti:

  • Nella scheda Salva e invia è possibile salvare un database in un formato di file diverso, creare un pacchetto di un database e applicare una firma digitale a un database, compilare un database come file eseguibile e pubblicare un database in un server SharePoint 2010 in cui è in esecuzione Access Services.

  • Fare clic su Opzioni per aprire la finestra di dialogo Opzioni di Access e impostare opzioni per i database e per Access.

Creare un nuovo database vuoto.

  1. Fare doppio clic sul modello desiderato.

  2. Accettare il nome predefinito o digitare un nome diverso.

  3. Fare clic su Crea.

Utilizzare il riquadro di spostamento

  • Fare doppio clic su un oggetto per aprirlo e utilizzarlo.

  • Fare clic con il pulsante destro del mouse su un oggetto per apportare modifiche alla struttura dell'oggetto, per esportarlo, per rinominarlo o per aprire la relativa finestra delle proprietà.

Modificare le modalità di categorizzazione degli oggetti nel riquadro

  1. Fare clic sulla barra sulla parte superiore del riquadro. Verrà aperto un elenco di categorie e gruppi.

  2. Selezionare una categoria nella metà superiore dell'elenco o un gruppo nella metà inferiore.

Impostare le opzioni per il riquadro

  • Fare clic con il pulsante destro del mouse sulla barra sulla parte superiore del riquadro e quindi fare clic su Opzioni di spostamento.

Cercare oggetti

  1. Se la barra di ricerca non è visibile, fare clic con il pulsante destro del mouse sulla barra sulla parte superiore del riquadro di spostamento e quindi fare clic su Barra di ricerca.

  2. Immettere il nome completo dell'oggetto o parte di esso nella casella Cerca. L'elenco di oggetti viene filtrato automaticamente mentre si digitano i caratteri.

Per evitare che gli oggetti di database si nascondano a vicenda

  1. Nella visualizzazione Backstage fare clic su Opzioni.

  2. Fare clic su Database corrente.

  3. Selezionare Documenti a schede e Visualizza schede documento.

  4. Chiudere e riaprire il database per visualizzare le modifiche.

Utilizzare la barra multifunzione

  • La barra multifunzione non è statica, infatti cambia in base all'oggetto selezionato o all'attività che si sta eseguendo.

  • Nella barra multifunzione i comandi sono disponibili in un set di schede e tali schede sono suddivise in gruppi.

  • Nella scheda Home sono disponibili i comandi più comuni.

  • Nella barra di accesso rapido, visualizzata nell'angolo in alto a sinistra nella finestra di Access, sono disponibili i comandi che si utilizzano più spesso. La barra di accesso rapido rimane sempre uguale, indipendentemente dalla scheda della barra multifunzione che si sta utilizzando.

  • È possibile personalizzare sia la barra di accesso rapido che la barra multifunzione.

Utilizzare i suggerimenti tasti di scelta

  • Premere ALT per visualizzare i suggerimenti tasti di scelta per ogni scheda della barra multifunzione. Per aprire una scheda, è sufficiente premere ALT e quindi la lettera assegnata a tale scheda.

  • Quando si utilizzano i suggerimenti tasti di scelta per passare a una scheda, vengono inoltre visualizzati i suggerimenti tasti di scelta per ogni comando della scheda. Per utilizzare un comando, è sufficiente premere il numero, la lettera o le lettere corrispondenti. Se i suggerimenti tasti di scelta per i comandi di una scheda scompaiono, premere ALT e quindi la lettera assegnata a tale scheda.

Personalizzare la barra di accesso rapido

  1. Fare clic sulla freccia a destra della barra per aprire un menu di comandi.

  2. Selezionare il comando che si desidera aggiungere alla barra.

  3. Se il comando desiderato non è visualizzato, fare clic su Altri comandi. Verrà aperta la finestra di dialogo Opzioni di Access.

  4. Aggiungere al riquadro di destra i comandi disponibili nel riquadro di sinistra.

Personalizzare la barra multifunzione

Quando si personalizza la barra multifunzione, le modifiche si applicano ad Access non a un singolo database.

Importante    Quando si inserisce un comando in una scheda o in un gruppo personalizzato della barra multifunzione, viene interrotto il collegamento tra tale comando e il relativo argomento della Guida accessibile tramite F1.

  1. Fare clic sulla scheda File per passare alla visualizzazione Backstage e quindi fare clic su Opzioni.

  2. Fare clic su Personalizzazione barra multifunzione.

  3. Sotto al riquadro di sinistra fare clic su Nuova scheda, Nuovo gruppo o Rinomina in base all'operazione che si desidera eseguire.

  4. Nel riquadro di sinistra immettere un nome per la scheda o per il gruppo.

  5. Se si sta creando una nuova scheda o un nuovo gruppo, selezionare il comando desiderato nel riquadro di sinistra e quindi fare doppio clic sul comando oppure fare clic su Aggiungi per spostare il comando nel riquadro di destra.

Regole per l'utilizzo di file creati nelle versioni precedenti di Access

  • I database creati in Access 2000, Access 2002 e Access 2003 vengono aperti in Access 2010, tuttavia alcune caratteristiche non funzionano, ad esempio la finestra del database e la replica.

  • I file di Access 97 vengono aperti in Access 2010, tuttavia è possibile solo visualizzare oggetti e aggiungere record. Non è possibile salvare modifiche alla struttura, a meno che non si converta il database nel formato di file di Access 2010.

  • Dopo aver salvato un database di una versione precedente come file ACCDB, è possibile utilizzarlo solo in Access 2007 o 2010.

  • Se si apre un database di Access 2010 in Access 2007, le caratteristiche disponibili solo in Access 2010 non funzionano.

Utilizzare modelli e database Web

In Access sono disponibili due categorie di modelli, ovvero locali e online. I modelli locali vengono installati nel computer durante l'installazione di Access. I modelli online sono disponibili se si dispone di una connessione a Internet.

Per utilizzare i modelli online:

  1. Nella visualizzazione Backstage nella scheda Nuovo fare clic su Modelli di esempio oppure fare doppio clic su una delle categorie di modelli disponibili in Modelli da Office.com.

  2. Assegnare un nome al nuovo database, se necessario scegliere un percorso e quindi fare clic su Crea per scaricare e aprire il modello.

  3. Abilitare eventuale contenuto bloccato e iniziare a immettere dati, oppure modificare il modello in base alle proprie esigenze.

Per pubblicare un database Web

  1. Nella visualizzazione Backstage fare clic sulla scheda Salva e pubblica, se non è già selezionata, e quindi fare clic su Pubblica in Access Services.

  2. Fare clic su Esegui Verifica compatibilità.

  3. Fare clic su per chiudere eventuali oggetti aperti e consentire l'esecuzione di Verifica compatibilità.

  4. Se non vengono rilevati errori, il database è pronto per la pubblicazione.

  5. Immettere l'URL del server e un nome per il sito.

  6. Fare clic su Pubblica in Access Services.
    Al termine del processo di pubblicazione, le tabelle del database diventano elenchi SharePoint e le maschere hanno lo stesso aspetto e funzionamento di quando vengono aperte in Access.

Utilizzare la visualizzazione Layout

La visualizzazione Layout è uno strumento di progettazione visivo per maschere e report in Access 2010. Si tratta inoltre dell'unico strumento di progettazione per maschere e report disponibile per un database Web.

Per utilizzare la visualizzazione Layout

  • Nel riquadro di spostamento fare clic con il pulsante destro del mouse su una maschera o un report e quindi fare clic su Visualizzazione Layout .
    - Oppure -
    Fare clic con il pulsante destro del mouse sulla scheda del documento per qualsiasi maschera o report aperto e fare clic su Visualizzazione Layout.

Modifiche rapide che è possibile apportare nella visualizzazione Layout

  • Selezionare un singolo controllo o etichetta e trascinarlo per ridimensionare tutti i controlli o le etichette nella colonna specifica.

  • Selezionare un'etichetta, fare clic sulla scheda Formato e utilizzare i comandi disponibili nella scheda per cambiare tipo o colore del carattere oppure l'allineamento del testo.

  • Premere CTRL, selezionare più etichette e formattarle.

  • Per apportare modifiche globali a un layout, fare clic sul selettore di layout, ovvero la croce nell'angolo in alto a sinistra del layout. Ad esempio, selezionare l'intero layout. Nella scheda Struttura fare clic su Finestra delleproprietà per aprire le proprietà della maschera e impostare un'altezza diversa per i controlli.

Per spostare o posizionare controlli aggiungendo righe e colonne vuote a un layout

  1. Nella scheda Struttura fare clic su Aggiungi campi esistenti.

  2. Trascinare nel layout i campi che si desidera utilizzare.

  3. Trascinare i controlli separatamente dalle rispettive etichette e rilasciarli nella posizione desiderata, in base alle necessità. Una barra di colore arancione indica la destinazione.

Per raggruppare e ordinare dati nei report

  1. Nella scheda Struttura fare clic su Raggruppa e ordina.

  2. Nel riquadro Raggruppamento, ordinamento e totale fare clic su Aggiungi gruppo e quindi fare clic sul campo in base al quale si desidera raggruppare i dati. Le modifiche verranno visualizzate immediatamente.
    È possibile impostare fino a sette livelli di raggruppamento.

Si applica a: Access 2010



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua