Passaggio 4 - Condividere la macro con altri utenti

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Uno degli aspetti più importanti da comprendere riguardo la condivisione di macro è che sono archiviate nel file di Office, quindi è necessario condividere tale file con altri. Se si è creata una macro in Word, occorrerà condividere il file in formato Modello di Word con attivazione macro (*.dotm) o Documento di Word con attivazione macro (*.docm). Se si è creata la macro in Excel, occorrerà condividere il file in formato Cartella di lavoro con attivazione macro di Excel (*.xlsm) o Modello con attivazione macro di Excel (*.xltm).

Nel caso di una macro di Word, è necessario eseguire alcuni passaggi aggiuntivi per condividerla:

Creare il modello di Word vuoto

  1. Aprire un nuovo documento di Word.

  2. Scegliere Salva con nome dal menu File.

  3. Assegnare al file il nome global_macros.dotm.

  4. Nell'elenco a discesa Formato selezionare Modello di Word con attivazione macro (*.dotm) come Formato.

  5. Scegliere il percorso di rete in cui archiviare il file.

  6. Fare clic su Salva e quindi chiudere il modello.

Esportare la macro di Word dal documento

Con la macro registrata al Passaggio 1, eseguire i passaggi seguenti per esportare la macro:

  1. Aprire il documento o il modello che contiene la macro da esportare.

  2. Nel menu Strumenti scegliere Macro e quindi fare clic su Macro.

  3. Selezionare la macro da esportare e fare clic su Modifica. Selezionare l'azione di Macro da esportare

  4. In Visual Basic Editor fare clic su File > Esporta file.

  5. Salvare la macro nella stessa cartella del modello con attivazione macro, global_macros.dotm.

Importare la macro di Word nel nuovo modello vuoto

  1. Aprire global_macros.dotm e fare clic su Strumenti > Macro > Visual Basic Editor.

  2. Per importare la macro, fare clic su File > Importa file, passare alla cartella in cui è stata esportata la macro, selezionare il file e fare clic su Apri.

  3. Salvare il modulo, uscire da Visual Basic Editor e quindi da Word.

Ora è possibile condividere la macro con altri utenti, indicando loro di eseguire i passaggi seguenti per installare la macro nel loro computer.

Installare il modello: configurare Word per l'uso della macro

  1. Posizionare il file global_macro.dotm nel percorso seguente:

    • Word per Mac 2011: Macintosh HD: Utenti: Nome utente: Libreria: Application Support: Microsoft: Office: Modelli utente: Modelli personali

    • Word 2003 per Windows o versioni sucessive: C:\Documents and Settings\nomeutente\Application Data\Microsoft\Word\STARTUP

      Nota :  nomeutente è il nome di accesso dell'utente.

  2. In Word fare clic su Word > Preferenze.

Preferenze di Word

  1. Nella sezione Impostazioni personali fare clic su Percorsi file

  2. Selezionare Avvio nell'elenco Percorsi file e quindi fare clic su Modifica.

Percorso file

  1. Verificare che Word usi la stessa cartella Avvio in cui è stato inserito il file global_macro.dotm.

  2. Fare clic su Chiudi per chiudere la finestra di dialogo Scegli una cartella, quindi su OK per chiudere la finestra di dialogo Percorsi file.

L'ultimo passaggio consiste nell'indicare a Word di usare il file global_macros.dotm all'avvio.

  1. In Word fare clic su Strumenti > Modelli e componenti aggiuntivi.

  2. Selezionare il file global_macros.dotm nell'elenco e fare clic su OK.

    Suggerimento :  Se il modello non è presente nell'elenco, significa che il file global_macros.dotm non è nella cartella di avvio di Word. Tornare al passaggio 1 in questa sezione e verificare che la cartella Avvio corrisponda a quella in cui è stato copiato il file global_macros.dotm.

Imposta il modello globale in Word

 Passaggio 1 - Iniziare a usare il registratore macro

Passaggio 2 - Leggere e comprendere il codice

Passaggio 3 - Apprendere le basi della programmazione

Passaggio 4 - Condividere la macro con altri utenti

Passaggio 5 - Esempi di scenari reali

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×