Novità di Visio 2010

In questo articolo viene fornita una panoramica delle funzionalità disponibili nella versione Technical Preview di Visio 2010. Alcune funzionalità sono incomplete e soggette a modifica.

Se si è abituati a utilizzare Visio 2007, si scopriranno diverse nuove caratteristiche introdotte in Microsoft Visio 2010 e si noterà che alcune caratteristiche già note sono state aggiornate. Per consentire un rapido apprendimento di queste novità, in questo articolo vengono illustrati i miglioramenti e le modifiche principali.

Contenuto dell'articolo

Interfaccia Office Fluent con la barra multifunzione

Avvio di un nuovo diagramma

Aggiornamento della finestra Forme con le forme rapide

Ricerca di ulteriori forme

Anteprima dinamica

Ridimensionamento automatico

Inserimento ed eliminazione di forme con adattamento automatico

Allineamento e spaziatura automatici

Connessione automatica migliorata

Possibilità di rendere più chiara la struttura dei diagrammi

Contenitori

Alcuni contenitori gestiscono set di forme

Callout

Legende degli elementi grafici dati

Griglia, allineamento e aggancio avanzati

Possibilità di incollare le forme copiate con maggiore controllo

Incollare le forme nella stessa posizione della pagina originale

Fare clic con il pulsante destro del mouse per incollare in corrispondenza del puntatore

Funzionalità della scheda della pagina migliorata

Possibilità di cambiare visualizzazione mediante gli strumenti di spostamento della barra di stato

Convalida dei diagrammi di processo

Processi secondari

Flussi di lavoro di SharePoint

Archivio processi di SharePoint

Gestione delle corsie migliorata nei diagrammi di flusso interfunzionali

Diagrammi BPMN (Business Process Modeling Notation)

Diagramma Six Sigma

Diagrammi reticolo

Diagrammi del flusso di lavoro di SharePoint

Compatibilità AutoCAD aggiornata

Creazione dei diagrammi semplificata

Interfaccia Office Fluent con la barra multifunzione

Visio 2010 ora dispone dell'interfaccia Microsoft Office Fluent, che include la barra multifunzione. Tale barra mantiene visibili i comandi di utilizzo più frequente durante il lavoro invece di nasconderli in menu o barre degli strumenti. I comandi ancora non noti sono inoltre più facili da individuare.

Immagine del manuale

I comandi sono disponibili all'interno di schede e raggruppati in base al relativo utilizzo. Nella scheda Home sono presenti numerosi comandi di utilizzo comune, mentre nelle altre schede si trovano comandi utilizzati per scopi speciali. Ad esempio, per progettare e formattare il diagramma, fare clic sulla scheda Progettazione per trovare temi, impostazioni di pagina, sfondi, bordi, titoli e altri elementi.

The Design tab

Avvio di un nuovo diagramma

Quando si avvia Visio, viene visualizzata una finestra Nuova in una nuova parte dell'interfaccia utente Microsoft Office Fluent. Nella finestra Nuova sono disponibili i modelli che è possibile utilizzare per iniziare a creare un diagramma.

Start a new diagram

Molti dei comandi in precedenza inclusi nel menu File ora si trovano in quest'area. Quando si avvia un nuovo diagramma da uno qualsiasi dei modelli, tale spazio si chiude e viene aperta la finestra di disegno. Per tornare a quest'area per salvare il file, stampare, pubblicare, impostare le opzioni di Visio o eseguire altre azioni non correlate alla creazione di un diagramma, fare clic sul pulsante Microsoft Backstage.

Finestra di dialogo Categorie a colori in Outlook 2007

Aggiornamento della finestra Forme con le forme rapide

Nella finestra Forme vengono visualizzati tutti gli stencil attualmente aperti nel documento. Le barre del titolo di tutti gli stencil aperti sono nella parte superiore della finestra. Fare clic su una barra del titolo per visualizzare le forme disponibili nello stencil corrispondente.

Intestazioni di colonna e intestazioni di riga

La nuova area Forme rapide nella parte superiore di ogni stencil (al di sopra della sottile linea di divisione) è stata progettata per inserire le forme utilizzate più frequentemente. Per aggiungere o rimuovere forme, è sufficiente trascinarle all'interno o all'esterno dell'area Forme rapide. È inoltre possibile ridisporre le forme in qualsiasi punto dello stencil trascinandole nella posizione desiderata.

Se vi sono diversi stencil aperti e si è certi di dover utilizzare solo alcune forme di ognuno, fare clic sulla scheda Forme rapide per visualizzare insieme in un'unica posizione le forme rapide di tutti gli stencil aperti.

Icona del pulsante

Ricerca di ulteriori forme

Nella finestra Forme è ora disponibile il menu Altre forme, pertanto non è necessario chiuderlaper aprire un nuovo stencil.

.

Per impostazione predefinita, la casella di ricerca è nascosta per lasciare più spazio alle forme e agli stencil. Per aprire questa casella, fare clic su Altre forme e quindi scegliere Cerca forme. Tale funzionalità si avvale del motore di ricerca di Windows per trovare le forme nel computer, pertanto per poterla utilizzare è necessario che Windows Search sia attivato. Per ricercare forme in Internet, scegliere Trova forme online.

Gli otto ruoli svolti dalle immagini in una presentazione

Anteprima dinamica

L'anteprima dinamica consente di visualizzare l'effetto delle opzioni di formattazione, ad esempio dei tipi di carattere e dei temi, prima di impostarle definitivamente. Lo stile su cui si posiziona il puntatore del mouse viene infatti applicato temporaneamente per consentire di provare rapidamente diverse opzioni.

Gruppo delle cinque opzioni per incollare grafici di Excel in Word

Ridimensionamento automatico

Grazie al ridimensionamento automatico, la pagina visibile con il formato carta della stampante nella superficie di disegno di Visio viene sostituita da una pagina espandibile che rende più agevole la creazione di diagrammi di dimensioni maggiori. Quando il ridimensionamento automatico è attivato e si rilascia una forma all'esterno della pagina corrente, la pagina si estende in modo da contenere il diagramma diventato più grande. Le divisioni corrispondenti al formato carta della stampante sono rappresentate da linee tratteggiate.

Backup

Inserimento ed eliminazione di forme con adattamento automatico

Se il diagramma è già stato creato ma si desidera aggiungere o rimuovere alcune forme, la connessione e il riposizionamento verranno eseguiti automaticamente da Visio. Inserire una forma in un diagramma rilasciandola su un connettore.

Drop a shape onto a connector.

Le forme circostanti si sposteranno automaticamente per fare spazio alla nuova forma e alla sequenza viene aggiunto un nuovo connettore.

Pulsante Condividi

Quando si elimina una forma connessa in una sequenza, come la forma centrale dell'esempio precedente, i due connettori vengono sostituiti automaticamente da un unico connettore tra le forme restanti. In questo caso però le forme non si sposteranno per ridurre la spaziatura perché tale azione potrebbe non essere appropriata in tutte le situazioni. Per adattare la spaziatura, è possibile selezionare le forme e fare clic su Allineamento e spaziatura automatici.

Gli outer join restituiscono tutti i dati dalla tabella di base e solo i dati corrispondenti dalla tabella secondaria

Allineamento e spaziatura automatici

Utilizzando il pulsante Allineamento e spaziatura automatici, è possibile apportare modifiche all'allineamento e alla spaziatura delle forme. A tale scopo, è possibile modificare contemporaneamente tutte le forme di un diagramma oppure selezionare solo le forme che si desidera modificare.

  • Per modificare l'allineamento e la spaziatura, nella scheda Home fare clic su Allineamento e spaziatura automatici.

  • Per modificare separatamente l'allineamento, la spaziatura o l'orientamento, nella scheda Home fare clic su Posizione e quindi sul comando desiderato.

Pulsante Allineamento e spaziatura automatici

Connessione automatica migliorata

La funzionalità Connessione automatica facilita la connessione delle forme:

  • Quando si posiziona il puntatore del mouse su una freccia di connessione automatica blu, viene visualizzata una barra di formattazione rapida contenente fino a quattro forme dell'area forme rapide dello stencil attualmente selezionato.

  • Se le forme si trovano già nella pagina, è possibile trascinare un connettore da una freccia di connessione automatica blu di una forma e rilasciarlo su un'altra forma. Connettendo le forme in questo modo, non è necessario passare allo strumento Connettore.

Posizionare il puntatore del mouse su una forma nella barra di formattazione rapida per visualizzare un'anteprima dinamica nella pagina e fare clic per aggiungere la forma, già connessa

Disegnare una tabella

Possibilità di rendere più chiara la struttura dei diagrammi

Contenitori

Un contenitore è una forma che contiene visivamente altre forme nella pagina. I contenitori facilitano pertanto la visualizzazione di gruppi di forme logicamente correlate tra loro.

Dati business in un database di Access

I contenitori consentono inoltre di gestire la posizione delle forme del gruppo spostandole, copiandole o eliminandole insieme al contenitore. Per proteggere le forme, è possibile bloccare il contenuto di un contenitore in modo che non possano essere eliminate o aggiunte.

Il tempo sommato che supera le 24 ore restituisce un risultato imprevisto di 4:15

I contenitori possono espandersi automaticamente man mano che vengono aggiunte forme, nonché rimpicciolirsi per adattarsi al contenuto dopo la rimozione di forme.

Automatic Resize for containers

Alcuni contenitori gestiscono set di forme

Alcuni contenitori consentono di gestire set ordinati di forme non connesse, facilitando l'aggiunta, la rimozione e il riordino delle voci dell'elenco. Alcuni esempi di queste forme sono rappresentati da Controllo albero in Diagramma reticolo e da Corsia in Diagramma di flusso e Diagramma di flusso interfunzionale. È possibile aggiungere la forma predefinita a questo tipo di contenitore facendo clic sulla freccia di inserimento blu che viene visualizzata posizionando il puntatore del mouse su un angolo del contenitore.

Layout di elemento grafico SmartArt: Blocchi immagini in evidenza

Callout

Utilizzare i callout per spiegare o descrivere le forme presenti nel diagramma. I callout in genere sono associati a una determinata forma e si spostano con essa durante gli adattamenti manuali e automatici.

Insert callouts from Callout gallery.

Legende degli elementi grafici dati

Le legende hanno la funzione di spiegare il significato delle icone e dei colori all'interno dei diagrammi in cui vengono utilizzati elementi grafici dati, in modo che il diagramma sia facilmente comprensibile anche senza la presenza di etichette di testo accanto a ognuno di tali elementi.

Anteprima della guida per il passaggio da Excel 2007 a Office 365

Fare clic sul pulsante Inserisci legenda. La legenda verrà generata automaticamente in base agli elementi grafici dati presenti nella pagina.

Riga totali con le funzioni di somma e conteggio

Griglia, allineamento e aggancio avanzati

Quando le forme sono allineate e spaziate in modo uniforme, vengono visualizzate nuove guide. Punti di aggancio basati sull'allineamento e la spaziatura consentono il posizionamento nel punto corretto.

Screenshot della scheda Formato testo che contiene numerosi pulsanti per la formattazione del testo

Possibilità di incollare le forme copiate con maggiore controllo

In Visio 2010 è possibile procedere in due modi per incollare le forme nel punto desiderato:

  • Incollare le forme nella stessa posizione della pagina originale.

  • Fare clic con il pulsante destro del mouse per incollare in corrispondenza del puntatore.

Incollare le forme nella stessa posizione della pagina originale

Impostare la priorità del messaggio

Quando si copiano una o più forme da una pagina e quindi si utilizza il pulsante Incolla oppure CTRL+V per incollarle in un'altra pagina, le forme vengono incollate nella stessa posizione relativa all'interno della nuova pagina.

Fare clic con il pulsante destro del mouse per incollare in corrispondenza del puntatore

Per avere maggiore controllo quando si incolla, fare clic con il pulsante destro del mouse sulla pagina in cui si desidera posizionare la forma e quindi scegliere Incolla. La forma verrà incollata nella pagina con il centro in corrispondenza del punto in cui si è fatto clic.

Right-click to paste a copied shape at the click location.

Funzionalità della scheda della pagina migliorata

È disponibile una nuova scheda Inserisci pagina che consente di aggiungere una nuova pagina con un clic.

The Insert Page tab at the bottom of the document.

È inoltre possibile accedere alle opzioni Imposta pagina per una pagina direttamente dal menu di scelta rapida della scheda della pagina.

Page tab right-click menu.

Possibilità di cambiare visualizzazione mediante gli strumenti di spostamento della barra di stato

Nella barra di stato sono disponibili alcuni strumenti che consentono di spostarsi in diagrammi e documenti. Tali strumenti sono Schermo intero, Livello di zoom per cui è possibile impostare una percentuale, un dispositivo di scorrimento Zoom, un pulsante Adatta la pagina alla finestra corrente, un pulsante per aprire la finestra Zoom e dettaglio e un pulsante Cambia finestra per passare da una finestra all'altra.

Comando Segna come completata sulla barra multifunzione

Servizi Visio

Servizi Visio integra il diagramma con web part di SharePoint per offrire un'esperienza interattiva ad alta fedeltà per una o più persone contemporaneamente, anche se nei relativi computer non è installato Visio. Coloro che visualizzano il diagramma possono eseguire lo zoom e la panoramica, nonché visitare i collegamenti ipertestuali nelle forme.

È possibile pubblicare un diagramma direttamente in SharePoint da Visio 2010. Creare il diagramma in Visio, utilizzare Visio per pubblicarlo nel server e visualizzare il diagramma in un browser.

I diagrammi possono inoltre essere collegati a dati e la visualizzazione può essere aggiornata automaticamente o dall'utente.

Sezione di Power View

Gestione dei processi

Oltre ai miglioramenti relativi alla creazione di diagrammi sopra illustrati, Visio include nuovi strumenti che consentono di modellare, convalidare e riutilizzare diagrammi di processo complessi.

I diagrammi di processo sono visualizzazioni di qualsiasi tipo di processo che prevede una serie di passaggi. Tali diagrammi in genere vengono creati come diagrammi di flusso, con le forme che rappresentano i passaggi del processo collegate da frecce che indicano la direzione per il passaggio successivo.

Convalida dei diagrammi di processo

È ora possibile analizzare automaticamente i diagrammi di processo per verificare che siano costruiti in modo appropriato e siano conformi alla regola Business definita per il documento.

Conservare record sull'IVA

Gli errori di convalida vengono visualizzati per consentirne la risoluzione nella Finestra Problemi.

Immagine della barra multifunzione di Excel

In Visio sono inclusi set di regole specifici per ogni tipo di diagramma di processo.

Preferenze della società

Processi secondari

I diagrammi dei processi secondari consentono di scomporre i processi complessi in parti gestibili. È possibile selezionare una sequenza di forme:

Sito aperto in SharePoint Designer 2010

Fare clic su Crea da selezione:

Moduli Parola chiave nel menu a discesa Nuovo modulo

Le forme selezionate verranno spostate in una nuova pagina e sostituite da una forma Processo secondario che viene collegata automaticamente alla nuova pagina.

The Subprocess shape represents a subprocess that is diagrammed on another page.

Se il processo secondario non è stato ancora disegnato, è possibile fare clic su Crea nuovo per aggiungere una forma Processo secondario alla pagina e una nuova pagina collegata alla forma. Se il processo secondario è già presente nel diagramma in un'altra pagina o in un documento diverso, è possibile rilasciare una forma Processo secondario nella pagina corrente, fare clic su Collega a esistente e passare alla pagina del processo secondario.

Flussi di lavoro di SharePoint

In Visio sono disponibili un modello e forme per progettare flussi di lavoro che è possibile importare in SharePoint Designer. È inoltre possibile ottenere file di flusso di lavoro creati in SharePoint Designer e aprirli in Visio, in modo da generare un diagramma del flusso di lavoro visualizzabile e modificabile. È possibile passare un file dall'una all'altra applicazione senza perdite di dati o funzionalità.

Schermata che mostra il collegamento su cui fare clic per configurare i mapping delle proprietà della pagina

Archivio processi di SharePoint

L'archivio processi è un modello di sito incluso in SharePoint che consente di avere una posizione in cui condividere e collaborare ai diagrammi di processo. L'archivio dispone del controllo dell'accesso e del controllo delle versioni incorporati. Gli utenti possono pertanto visualizzare il diagramma di processo contemporaneamente e modificarlo lasciando invariato l'originale.

Lente di ingrandimento che indica il comando Ricerca, il riquadro Ricerca immediata e un messaggio con testo evidenziato

Tipi di diagrammi nuovi e aggiornati e compatibilità

Gestione delle corsie migliorata nei diagrammi di flusso interfunzionali

Nei diagrammi di flusso interfunzionali vengono utilizzati come nuova funzionalità i contenitori e gli elenchi per migliorare la gestione delle corsie e supportare i concetti di fase e forme sul bordo.

.

Diagrammi BPMN (Business Process Modeling Notation)

È possibile creare diagrammi di flusso conformi allo standard Business Process Modeling Notation 1.2 e utilizzare il nuovo strumento di convalida per individuare problemi che è possibile risolvere prima di terminare il diagramma.

BPMN Diagram template

Diagramma Six Sigma

È possibile creare diagrammi di flusso Six Sigma e diagrammi House of Quality.

Six Sigma diagram template

Diagrammi reticolo

I diagrammi reticolo contengono forme dell'interfaccia utente a media fedeltà per la creazione di prototipi e la progettazione di applicazioni software.

Wireframe diagram template

Diagrammi del flusso di lavoro di SharePoint

Creando il diagramma del flusso di lavoro in Visio con il modello e le forme di SharePoint, è possibile esportarlo in SharePoint Designer per l'implementazione nel sito.

Schermata che mostra il collegamento su cui fare clic per configurare i mapping delle proprietà della pagina

Compatibilità AutoCAD aggiornata

È possibile importare, salvare e utilizzare file CAD di AutoCAD 2008.

Grafico derivato dalla "diapositiva di disegno"

Si applica a: Visio 2010, Visio Premium 2010, Visio Standard 2010



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua