Non è possibile salvare il database replicato nel formato Access 2007

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Sintomi

In Microsoft Office Access 2007 replicate database creati in versioni precedenti di Access (. Formato MDB) non è possibile salvare nel nuovo. Formato di file ACCDB. L'opzione viene visualizzata in grigio (non disponibile) quando si tenta di utilizzare il comando Salva Database con nome (scegliere il Pulsante Microsoft Office Icona del pulsante Office e quindi fare clic sulla freccia accanto a Salva con nome ).

Causa

Il formato di file ACCDB non supporta la replica.

Risoluzione

Utilizzare il database replicato nel formato di file MDB

È possibile continuare a utilizzare il database replicato nel formato di file MDB, in quanto questo formato supporta la funzionalità di replica.

Ricreare manualmente il database nel formato di file Office Access 2007

Se si decide che il nuovo formato di file è caratterizzato da vantaggi non garantiti dalla replica, è possibile creare un nuovo database nel formato Office Access 2007 e ricreare manualmente il database replicato.

Nota : Questa tecnica è valida per qualsiasi database replicato, ma a meno che non venga utilizzata una replica completa precedentemente sincronizzata con tutte le altre repliche incluse nel set di repliche, i dati e i progetti non inclusi nella replica non saranno contenuti nel nuovo database.

Prima di cominciare a ricreare il database, assicurarsi che tutti gli oggetti nascosti e di sistema della replica siano visibili. Questo consente di garantire che sarà possibile accedere ai campi specifici della replica quando questa verrà ricreata.

  1. Aprire la replica che si desidera convertire. A tale proposito è necessario utilizzare la stessa versione di Access in cui la replica è stata creata in origine per poter visualizzare i campi nascosti e di sistema.

  2. Scegliere Opzioni dal menu Strumenti. Verrà aperta la finestra di dialogo Opzioni.

  3. Nella sezione Mostra della scheda Visualizzazione selezionare Oggetti nascosti e Oggetti di sistema. Fare clic su OK per applicare le nuove impostazioni e chiudere la finestra di dialogo Opzioni.

Ricreare manualmente il database

  1. Creare un database vuoto e aprirlo.

    Nota : Verrà creata una nuova tabella vuota denominata Tabella1. Eliminare questa tabella, chiudendola immediatamente prima di apportarvi alcuna modifica. Fare clic con il pulsante destro del mouse sulla relativa scheda degli oggetti e scegliere Chiudi dal menu di scelta rapida.

  2. Nel gruppo Importa della scheda Dati esterni fare clic su accesso.

    Verrà visualizzata la finestra di dialogo Carica dati esterni - Database di Access.

  3. Fare clic su Sfoglia per individuare il database replicato.

  4. Fare clic sul database replicato contenente gli oggetti di database che si desidera ricreare nel nuovo database e quindi fare clic su Apri.

  5. Nella finestra di dialogo Carica dati esterni - Database di Access fare clic su Importa tabelle, query, maschere, report, macro e moduli nel database corrente e quindi su OK.

  6. Fare clic sugli oggetti di database che si desidera importare nel nuovo database. Se si desidera importare tutti gli oggetti, fare clic su Seleziona tutto in ogni scheda.

    Importante    Non selezionare tabelle in questa fase. Le tabelle verranno ricreare in una fase successiva.

  7. Dopo aver selezionato tutti gli oggetti desiderati, fare clic su OK per importarli.

    Nell'ultima pagina della procedura guidata viene offerta la possibilità di salvare i passaggi di importazione per poterli riutilizzare in futuro. A tale proposito, selezionare la casella di controllo Salva passaggi importazione, immettere le informazioni appropriate e fare clic su Salva importazione.

  8. Aprire il database replicato in Office Access 2007. Per ogni tabella presente creare una query di creazione tabella che recuperi tutti i dati della vecchia tabella e li inserisca in una tabella del nuovo database.

    Nota : Se s_GUID è una chiave primaria e chiavi esterne in altre tabelle farvi riferimento, includere il campo s_GUID nella nuova tabella. Se il campo s_GUID non viene utilizzato come chiave primaria, non è necessario mantenerlo nella nuova tabella. Non copiare i campi s_Lineage e s_Generation alla nuova tabella.

    Per impostazione predefinita, i campi s_GUID, s_Lineage e s_Generation sono nascosti. Per visualizzarli, utilizzare la procedura seguente:

    1. Nel database replicato assicurarsi che tutte le tabelle siano chiuse.

    2. Fare clic con il pulsante destro del mouse nella parte superiore del riquadro di spostamento e quindi scegliere Opzioni di spostamento. Verrà visualizzata la finestra di dialogo Opzioni di spostamento.

    3. Nella sezione Opzioni visualizzazione selezionare Mostra oggetti di sistema e fare clic su OK.

      Procedura

      1. Creare una query selezionando le tabelle contenenti i record che si desidera inserire nella nuova tabella.

        Procedura

        1. Nel gruppo Altro della scheda Crea fare clic su Struttura query.

        2. Nella finestra di dialogo Mostra tabella selezionare la scheda contenente l'elenco delle tabelle di cui si desidera utilizzare i dati.

        3. Fare doppio clic sul nome di ogni oggetto che si desidera aggiungere alla query e quindi fare clic su Chiudi.

        4. Aggiungere i campi desiderati nella riga Campo della griglia di struttura.

        5. Per visualizzare i risultati della query, scegliere Visualizzazione Foglio dati dal menu Visualizza.

      2. Nella visualizzazione Struttura della query, nel gruppo Tipo di query della scheda Struttura fare clic su Creazione tabella. Verrà visualizzata la finestra di dialogo Creazione tabella.

      3. Nella casella Nome tabella digitare il nome della tabella che si desidera creare o sostituire.

      4. Selezionare Altro database e quindi digitare il percorso del database in cui si desidera inserire la nuova tabella oppure fare clic su Sfoglia per cercare il database.

      5. Fare clic su OK.

      6. Nel gruppo risultati della scheda Progettazione fare clic su Esegui. In questo modo sarà la nuova tabella.

        Nota : La nuova tabella creata non eredita le proprietà di campo o l'impostazione della chiave primaria della tabella originale.

  9. Per ogni tabella del nuovo database creare lo stesso indice e la stessa chiave primaria utilizzati nella tabella della replica.

    Procedura

    1. Aprire una tabella nella visualizzazione Struttura.

    2. Nella parte superiore della finestra fare clic sul campo per il quale si desidera creare l'indice.

    3. Nella parte inferiore della finestra fare clic sulla casella della proprietà Indicizzato e quindi fare clic su Sì (Duplicati ammessi) oppure Sì (Duplicati non ammessi).

    4. Selezionare il campo o i campi contenenti la chiave primaria.

    5. Nel gruppo Strumenti della scheda Struttura fare clic su Chiave primaria.

  10. Per ogni tabella del nuovo database, creare le relazioni esistenti per tabella della replica.

    Procedura

    Quando si crea una relazione tra tabelle, campi correlati non sono necessario avere lo stesso nome. Tuttavia, i campi correlati devono avere la stessa tipo di dati solo se il campo chiave primaria è un campo numerazione automatica. È possibile associare un campo numerazione automatica con un campo numerico solo se la proprietà Dimensione campo di entrambi i campi corrispondenti corrisponde. Ad esempio, è possibile associare un campo numerazione automatica e un campo numerico se la proprietà Dimensione campo dei campi è Intero lungo. Anche se entrambi i campi corrispondenti sono campi numerici, devono avere la stessa impostazione della proprietà Dimensione campo.

    Definire un uno-a-molti o un tipo di relazione

    1. Chiudere tutte le tabelle aperte. Non è possibile creare o modificare relazioni tra tabelle aperte.

    2. Nel gruppo Mostra/Nascondi della scheda Strumenti database fare clic su Relazioni.

    3. Se nel database non sono ancora state definite relazioni, verrà automaticamente visualizzata la finestra di dialogo Mostra tabella.

      Se è necessario aggiungere le tabelle che si desidera collegare e la finestra di dialogo Mostra tabella non è visualizzata, fare clic sul pulsante Mostra tabella nel gruppo Mostra/Nascondi della scheda Struttura.

    4. Fare doppio clic sui nomi delle tabelle che si desidera correlare, quindi chiudere la finestra di dialogo Mostra tabella. Per creare una relazione nell'ambito della stessa tabella, aggiungere due volte la tabella.

    5. Trascinare il campo che si desidera collegare da una tabella al campo correlato nell'altra tabella.

      Per trascinare più campi, premere il tasto CTRL, fare clic su ogni campo desiderato e quindi trascinare la selezione.

      Nella maggior parte dei casi si trascina il campo chiave primaria (visualizzato in grassetto) da una tabella su un campo simile (spesso con lo stesso nome), detto chiave esterna nell'altra tabella.

    6. Verrà visualizzata la finestra di dialogo Modifica relazioni. Assicurarsi che i nomi dei campi visualizzati nelle due colonne siano quelli desiderati. Se necessario, è possibile modificarli.

      Se necessario, impostare le opzioni di relazione.

    7. Fare clic sul pulsante Crea per creare la relazione.

    8. Ripetere i passaggi da 4 a 7 per ogni coppia di tabelle da collegare.

      Quando si chiude la finestra Relazioni verrà richiesto se si desidera salvare il layout. Le relazioni create verranno salvate comunque nel database, indipendentemente dal fatto che si salvi o meno il layout.

    Definire una relazione molti-a-molti

    1. Creare le due tabelle che verranno collegate tramite una relazione molti-a-molti.

    2. Creare una terza tabella, denominata tabella di collegamento, e aggiungervi i nuovi campi con le stesse definizioni dei campi chiave primaria provenienti da ognuna delle altre due tabelle. Nella tabella di collegamento i campi chiave primaria fungono da chiavi esterne. È possibile aggiungere altri campi alla tabella di collegamento, analogamente a qualsiasi altra tabella.

    3. Nella tabella di congiunzione impostare la chiave primaria per includere tutti i campi chiave primaria presenti nelle altre due tabelle. Nella tabella di congiunzione Dettagli ordini, ad esempio, la chiave primaria sarebbe composta dai campi ID ordine e ID prodotto.

      Procedura

      1. Aprire la tabella nella visualizzazione Struttura.

      2. Selezionare il campo o i campi che si desidera definire come chiave primaria.

        Per selezionare un campo, fare clic sul selettore di riga del campo desiderato.

        Per selezionare più campi, tenere premuto CTRL e quindi fare clic sul selettore di riga di ogni campo.

      3. Nel gruppo Strumenti della scheda Struttura fare clic su Chiave primaria.

        Nota : Se si desidera che l'ordine dei campi in una chiave primaria a più campi sia diverso da quello degli stessi campi nella tabella, fare clic sul pulsante Indici nel gruppo Mostra/Nascondi per visualizzare la finestra Indici e quindi riordinare i nomi dei campi per l'indice denominato ChiavePrimaria.

    4. Definire un relazione uno-a-molti tra le due tabelle principale e la tabella di collegamento.

  11. Salvare il nuovo database.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×