Modificare una relazione

Modificare una relazione

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Se viene modificata la struttura del database di Access, potrebbe essere necessario modificare una relazione tra tabelle. In un database desktop di Access, tale scopo è possibile la relazione nella finestra relazioni e quindi modificarla. Modificare una relazione in un'app web di Access è un processo diverso, come illustrato in seguito, nella sezione modificare una relazione in un'app web di Access.

Per altre informazioni dettagliate sulle relazioni, vedere l'articolo Creare, modificare o eliminare una relazione.

In questo argomento

Modificare una relazione in un database desktop di Access

Modificare una relazione in un'app web di Access

Modificare una relazione in un database desktop di Access

  1. Per visualizzare tutte le relazioni tra tabelle in un database desktop, nella scheda Strumenti Database fare clic su relazioni.

    Comando Relazioni nella scheda Strumenti database

  2. Fare clic su Tutte le relazioni.

    Verranno visualizzate tutte le tabelle per le quali sono state definite relazioni, con le relative linee di relazione.

  3. Posizionare con attenzione il cursore sulla linea di relazione da modificare e quindi fare clic sulla linea per selezionarla.

    Linea di relazione tra i campi di due tabelle

    Quando è selezionata, la linea di relazione risulta più spessa.

  4. Con la linea di relazione selezionata, fare doppio clic su di essa. Verrà visualizzata la finestra di dialogo Modifica relazioni.

    Finestra di dialogo Modifica relazioni

  5. Apportare le modifiche desiderate e quindi fare clic su OK.

    Nella finestra Modifica relazioni è possibile modificare una relazione tra tabelle. In particolare si possono modificare le tabelle, le query o i campi su entrambi i lati della relazione, nonché impostare il tipo di join oppure applicare l'integrità referenziale e scegliere un'opzione di correlazione a catena.

  6. Al termine nella finestra relazioni, fare clic su Salva per salvare tutte le relazioni modifiche al layout.

Modificare una relazione in un'app web di Access

La finestra relazioni non è disponibile in un'app web di Access. Utilizzare un campo in una tabella come origine (campo di ricerca) per i valori nel relativo campo in un'altra tabella.

  1. Aprire la tabella che contiene il campo di ricerca da modificare facendo clic su Modifica tabella.

    Modifica tabella

  2. Selezionare il campo che ottiene i propri valori dall'altra tabella.

  3. Nella scheda Progettazione, in Strumenti tabella, fare clic su Modifica ricerche.

  4. Seguire le indicazioni nella procedura guidata per apportare le modifiche desiderate. È possibile modificare quanto segue:

    • Il campo che rappresenta l'origine dei valori

    • L'ordinamento dei valori

    • La larghezza del campo e se si desidera nascondere la colonna chiave

    • L'etichetta del campo di ricerca

    • Se l'integrità dei dati è abilitata

    • Quando è abilitata l'integrità dei dati, se le eliminazioni sono a catena o limitate

Per informazioni di base sulla creazione o l'eliminazione di relazioni, vedere gli articoli seguenti:

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×