Modificare il linguaggio di programmazione di un modello di modulo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Un modello di modulo può contenere solo script o codice gestito in un unico linguaggio di programmazione. È possibile modificare il linguaggio di programmazione di un modello di modulo rimuovendo lo script o il codice gestito originale, specificando un nuovo linguaggio e riscrivendo lo script o il codice gestito originale nel nuovo linguaggio di programmazione e infine aggiungendo il nuovo script o codice gestito al modello di modulo.

Nota : In InfoPath non è possibile convertire lo script o il codice gestito esistente da un linguaggio di programmazione in un altro.

Contenuto dell'articolo

Panoramica

Modificare il linguaggio di programmazione di un modello di modulo

Panoramica

Quando è necessario utilizzare script o codice gestito per aggiungere una regola business a un modello di modulo, ad esempio per eseguire un calcolo complesso utilizzando i valori immessi dagli utenti nei moduli basati su quel modello di modulo, è possibile effettuare questa operazione utilizzando uno dei molti linguaggi di programmazione disponibili, ad esempio C# o Microsoft Visual Basic. Dopo avere aggiunto script o codice gestito al modello di modulo, sarà necessario utilizzare lo stesso linguaggio di programmazione per apportare eventuali modifiche o aggiungere un nuovo script o codice gestito.

Mentre il modello di modulo si evolve per rispondere a nuove esigenze aziendali, potrebbe rendersi necessario modificare il linguaggio di programmazione utilizzato nel modello di modulo. Si considerino, ad esempio, le situazioni descritte di seguito:

  • In una società è in vigore un nuovo criterio in base al quale per tutti i programmi e tutte le estensioni dei programmi per Microsoft Windows sviluppati internamente deve essere utilizzato il linguaggio di programmazione C#. I modelli di modulo esistenti sono stati progettati con il linguaggio di programmazione Visual Basic. Per rispettare il nuovo criterio, è necessario convertire tutti i modelli di modulo affinché venga utilizzato il linguaggio di programmazione C#.

  • È stato pubblicato un modello di modulo creato in Microsoft Office InfoPath 2003 con script in JScript. Poiché Microsoft Office InfoPath 2007 consente agli utenti di compilare moduli basati su un modello di modulo in un browser Web, è necessario convertire questo modello di modulo in un modello di modulo abilitato per i browser, quindi pubblicarlo su un server che esegue InfoPath Forms Services. In InfoPath Forms Services, tuttavia, è possibile visualizzare modelli di modulo solo con assembly di codice gestito. Infatti non è possibile pubblicare un modello di modulo contenente script su un server che esegue InfoPath Forms Services. Lo script deve essere convertito in un assembly di codice gestito per poter pubblicare il modello di modulo su un server che esegue InfoPath Forms Services.

  • È necessario gestire diversi modelli di modulo progettati da altri, che contengono script in linguaggio JScript. Anche se si è in grado di leggere e scrivere script creati in JScript, si è molto più efficienti nella scrittura di script nel linguaggio di programmazione Microsoft Visual Basic, Scripting Edition (VBScript). Essendo incaricati di gestire questi modelli di modulo, si avrà una maggiore produttività se per lo script viene utilizzato VBScript, quindi si decide di sostituire gli script esistenti scritti in JScript con nuovi script creati con VBScript.

Se è necessario modificare il linguaggio di programmazione utilizzato in un modello di modulo esistente, rimuovere innanzitutto lo script o il codice gestito esistente dal modello di modulo, quindi specificare il nuovo linguaggio di programmazione da utilizzare per quel modello di modulo. Dopo avere modificato il linguaggio di programmazione nel modello di modulo, sarà possibile riscrivere lo script o il codice gestito nel nuovo linguaggio, utilizzando Microsoft Script Editor o Microsoft Visual Studio Tools for Applications, quindi aggiungere il nuovo script al modello di modulo.

Inizio pagina

Modificare il linguaggio di programmazione di un modello di modulo

Prima di modificare il linguaggio di programmazione di un modello di modulo, si consiglia di salvare una copia del codice sorgente originale in un editor di testo, ad esempio il Blocco note Microsoft, qualora fosse necessario fare riferimento al codice originale o utilizzarlo.

Salvare il codice sorgente originale

  1. Aprire il modello di modulo in modalità progettazione.

  2. Scegliere Programmazione dal menu Strumenti, quindi effettuare una delle seguenti operazioni:

    • Se il modello di modulo contiene script, fare clic su Microsoft Script Editor.

    • Se il modello di modulo contiene codice gestito, fare clic su Microsoft Visual Studio Tools for Applications.

  3. Scegliere Seleziona tutto dal menu Modifica di Microsoft Script Editor o Microsoft Visual Studio Tools for Applications.

  4. Scegliere Copia dal menu Modifica.

  5. Incollare il codice copiato in un editor di testo, ad esempio il Blocco note.

  6. Salvare il file dell'editor di testo.

Modificare il linguaggio di programmazione del modello di modulo

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. In Categoria nella finestra di dialogo Opzioni modulo fare clic su Programmazione.

  3. In Linguaggio di programmazione fare clic su Rimuovi codice.

  4. Scegliere nella finestra contenente un messaggio di avviso in cui è indicato che si sta per rimuovere codice dal modello di modulo.

  5. Nell'elenco Linguaggio codice modello di modulo fare clic sul linguaggio che si desidera utilizzare nel modello di modulo.

    Suggerimento : Se si sceglie il linguaggio di programmazione Visual Basic o C#, nella casella Percorso progetto per codice Visual Basic e C# digitare il percorso in cui si desidera salvare i file di progetto.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×