Modificare i dati di origine di una tabella pivot

Modificare i dati di origine di una tabella pivot

Dopo aver creato una tabella pivot, è possibile modificare l'intervallo dei dati di origine, ad esempio espandere i dati di origine in modo da includere più righe di dati. Tuttavia, se i dati di origine sono stati modificati in modo sostanziale, ad esempio aggiungendo o eliminando colonne, è preferibile creare una nuova tabella pivot.

Per modificare l'origine dati di una tabella pivot, se è un intervallo di celle o una tabella di Excel, eseguire le operazioni seguenti:

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

strumenti tabella pivot

  1. Fare clic su Analizza> Cambia origine dati.

pulsante cambia origine dati nella scheda analizza di strumenti tabella pivot

  1. Nella casella Tabella/Intervallo immettere l'intervallo da usare.

Finestra di dialogo Cambia origine dati tabella pivot

Suggerimento : Lasciare aperta la finestra di dialogo e selezionare la tabella o l'intervallo nel foglio di lavoro. Se i dati da includere si trovano in un altro foglio di lavoro, fare clic su tale foglio di lavoro e selezionare la tabella o l'intervallo.

Passare a un'altra origine dati esterna

Per basare la tabella pivot su un'origine esterna diversa, può essere preferibile creare una nuova tabella pivot.

Se il percorso dell'origine dati esterna è cambiato (ad esempio, il database di SQL Server ha ancora lo stesso nome ma è stato spostato in un altro server oppure il database di Access è stato spostato in un'altra condivisione di rete), è possibile modificare la connessione corrente.

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

strumenti tabella pivot

  1. Fare clic su Analizza> Cambia origine dati.

pulsante cambia origine dati nella scheda analizza di strumenti tabella pivot

  1. Fare clic su Seleziona connessione.

Finestra di dialogo Cambia origine dati tabella pivot

  1. Nella casella Mostra mantenere selezionata l'opzione Tutte le connessioni oppure selezionare la categoria di connessione dell'origine dati a cui si desidera connettersi.

finestra di dialogo connessioni esistenti

Se la nuova posizione non è presente nell'elenco, fare clic su Sfoglia e cercare l'origine dati desiderata a cui connettersi nella finestra di dialogo Selezione origine dati. Fare clic su Nuova origine, se necessario, seguire le istruzioni della Connessione guidata dati, quindi tornare alla finestra di dialogo Selezione origine dati.

Finestra di dialogo Selezione origine dati

Se la tabella pivot è basata su una connessione a un intervallo o a una tabella nel Modello di dati, è possibile scegliere un'altra connessione o tabella Modello di dati nella scheda Tabelle. Se invece la tabella pivot è basata sul Modello di dati della cartella di lavoro, non è possibile cambiare l'origine dati.

Scheda Tabelle nella finestra di dialogo Connessioni esistenti

  1. Selezionare la connessione desiderata e fare clic su Apri.

  2. Fare clic su Crea solo connessione.

    opzione crea solo connessione in importa dati

  3. Fare clic su Proprietà e quindi sulla scheda Definizione.

    Proprietà connessione

  4. Se il file di connessione con estensione ODC è stato spostato, selezionare il nuovo percorso nella casella File di connessione.

  5. Se è necessario modificare uno o più valori nella casella Stringa di connessione, contattare l'amministratore del database.

Ulteriori informazioni sulle tabelle pivot

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×