Modifica, eliminazione o inserimento di record in una visualizzazione dati

Dopo aver creato una visualizzazione dati la cui origine dati è costituita da un elenco o una raccolta di SharePoint, un database SQL o un file XML, è possibile aggiungere facilmente collegamenti per la modifica, l'eliminazione o l'inserimento di record nell'origine dati tramite il browser.

Si supponga ad esempio che Northwind Traders, un'azienda distributrice di specialità gastronomiche, tenga traccia delle proprie scorte in un file XML. Quando il livello scorte è basso, un membro del team contatta il fornitore del prodotto e inoltra un ordine. Si suggerisce quindi di aggiungere collegamenti per la modifica della visualizzazione dati in modo da consentire al membro del team che inoltra l'ordine di aggiornare immediatamente il record relativo all'articolo. È inoltre possibile aggiungere alla visualizzazione dati collegamenti per l'inserimento e l'eliminazione, affinché i membri del team possano aggiungere o rimuovere prodotti. Northwind Traders disporrà così sempre delle informazioni più aggiornate sulle scorte correnti.

In questo articolo viene illustrato come aggiungere, modificare, eliminare e inserire collegamenti in una visualizzazione dati esistente. Per creare la visualizzazione dati e i dati utilizzati nell'esempio o per ulteriori informazioni sulle visualizzazioni dati, vedere l'articolo Creazione di una visualizzazione dati.

Contenuto dell'articolo

Operazioni preliminari

Aggiunta di collegamenti per la modifica, l'eliminazione o l'inserimento di record in una visualizzazione dati

Modifica, eliminazione o inserimento di un record tramite il browser

Personalizzazione dei modelli per la modifica o l'inserimento

Operazioni preliminari

Microsoft Office SharePoint Designer 2007 offre due caratteristiche separate che consentono agli utenti di modificare i dati di una visualizzazione dati tramite il browser.

  • Aggiunta di collegamenti a una visualizzazione dati esistente     È possibile aggiungere collegamenti a una visualizzazione dati esistente in modo da consentire agli utenti di modificare, eliminare o inserire record nell'origine dati. Gli utenti possono attivare la modalità di modifica per un elemento facendo clic sul collegamento Modifica relativo al record. Se si aggiungono collegamenti a una visualizzazione dati che è stata inserita come modulo, i collegamenti sostituiscono i pulsanti del modulo. In questo caso, inoltre, per impostazione predefinita la visualizzazione dati non conterrà più campi modulo, ma soltanto dati di una visualizzazione.

  • Inserimento di una visualizzazione dati come modulo     Quando si crea una visualizzazione dati, è possibile scegliere di eseguirne l'inserimento come modulo a elemento singolo o a più elementi. Il modulo si trova sempre in modalità di modifica e contiene uno o più record. Gli utenti possono modificare i record esistenti tramite il browser, ma non inserire o eliminare record. Potrebbe rivelarsi utile scegliere un modulo a più elementi se è probabile che gli utenti desiderino modificare rapidamente i dati in numerosi record contemporaneamente. Per ulteriori informazioni, vedere l'articolo Inserimento di una visualizzazione dati come modulo.

Formati dei dati

In questo esempio viene utilizzato un file XML come origine dati. Poiché un file XML è un file di testo normale, non è possibile specificare i tipi di valori dei singoli campi. Potrebbe quindi accadere, ad esempio, di inserire e salvare testo in un campo che dovrebbe contenere solo numeri.

Se l'origine dati è invece costituita da un database o da un elenco o una raccolta di SharePoint, durante la creazione del database, dell'elenco o della raccolta è possibile specificare i tipi di valori che possono essere contenuti nei singoli campi. In tal caso, se si utilizza il modulo per immettere testo in un campo in cui sono obbligatori numeri e quindi si fa clic su Salva viene visualizzato un messaggio di errore che indica che il controllo origine dati non è stato in grado di eseguire il comando di aggiornamento. Ciò si verifica poiché si immette un valore che non può essere accettato dal campo dell'origine dati. Se viene visualizzato un messaggio di errore di questo tipo, fare clic sul pulsante Indietro del browser. Fare quindi clic su Annulla nel modulo per annullare le modifiche oppure immettere un valore che può essere accettato dall'origine dati.

Durante la progettazione del modulo, potrebbe essere opportuno includere in ogni intestazione di colonna una nota indicante il tipo di dati obbligatorio nel campo.

Torna all'inizio

Aggiunta di collegamenti per la modifica, l'eliminazione o l'inserimento di record in una visualizzazione dati

I collegamenti possono essere aggiunti a qualsiasi visualizzazione dati, indipendentemente dal fatto che sia stata inserita come visualizzazione o come modulo. Se tuttavia si aggiungono i collegamenti a una visualizzazione dati inserita come modulo, i collegamenti inseriti sostituiscono i pulsanti del modulo. In questo caso, inoltre, la visualizzazione dati non conterrà più campi modulo, ma soltanto dati di una visualizzazione. Utilizzando queste caratteristiche non è possibile disporre di una visualizzazione dati contenente sia pulsanti che collegamenti.

  1. Aprire la pagina contenente la visualizzazione dati a cui si desidera aggiungere collegamenti.

    Per seguire l'esempio, utilizzare la visualizzazione dati creata in Creazione di una visualizzazione dati.

    Products.xml nella visualizzazione dati

  2. Fare clic sulla visualizzazione dati, quindi sulla freccia Icona del pulsante nell'angolo superiore destro per visualizzare l'elenco Attività comuni di Visualizzazione dati e infine su Proprietà visualizzazione dati. Fare di nuovo clic sulla freccia per nascondere l'elenco.

    Suggerimento : In alternativa, è possibile fare clic con il pulsante destro del mouse sulla visualizzazione dati e quindi scegliere Mostra attività controlli comuni dal menu di scelta rapida.

  3. Nella finestra di dialogo Proprietà visualizzazione dati fare clic sulla scheda Modifica.

  4. Nella scheda Modifica eseguire una o più delle operazioni seguenti in Opzioni collegamento:

    • Per aggiungere un collegamento per la modifica di un record, selezionare la casella di controllo Mostra collegamenti modifica elementi.

    • Per aggiungere un collegamento per l'eliminazione di un record, selezionare la casella di controllo Mostra collegamenti eliminazione elementi.

    • Per aggiungere un collegamento per l'inserimento di un nuovo record, selezionare la casella di controllo Mostra collegamenti inserimento elementi.

      Ai fini dell'esempio, selezionare le caselle di controllo Mostra collegamenti modifica elementi, Mostra collegamenti eliminazione elementi e Mostra collegamenti inserimento elementi.

      Scheda Modifica della finestra di dialogo Proprietà visualizzazione dati

      Nota : L'esempio precedente riguarda specificamente i file XML. Quando si utilizzano database SQL, la scheda Modifica della finestra di dialogo Proprietà visualizzazione dati contiene inoltre l'opzione Opzioni sincronizzazione automatica comandi. Quando questa opzione è selezionata, i comandi di aggiornamento, eliminazione e inserimento dell'origine dati SQL vengono sincronizzati con i controlli di modifica, eliminazione e inserimento della visualizzazione dati.

  5. Fare clic su OK.

    Ogni record della visualizzazione dati è ora preceduto da un collegamento Modifica e un collegamento Elimina. Nell'angolo inferiore sinistro della visualizzazione dati è disponibile un collegamento Inserisci.

    Visualizzazione dati a più elementi con collegamenti per l'inserimento, la modifica e l'eliminazione

  6. Scegliere Salva con nome dal menu File.

  7. Nella finestra di dialogo Salva con nome digitare un nome per il file nella casella Nome file e quindi fare clic su Salva.

Torna all'inizio

Modifica, eliminazione o inserimento di un record tramite il browser

Dopo aver salvato la pagina contenente il modulo, è possibile visualizzarla in anteprima nel browser e modificare i dati del modulo.

Visualizzare l'anteprima della visualizzazione dati nel browser

  • In Office SharePoint Designer 2007 scegliere Visualizza anteprima nel browser dal menu File e quindi scegliere il tipo di browser e la risoluzione da utilizzare.

    Scelta rapida da tastiera  Fare clic sulla pagina da visualizzare in anteprima nell'Elenco cartelle e quindi premere F12.

    La visualizzazione dati con i collegamenti verrà visualizzata nel browser.

    Visualizzazione dati con collegamenti nel browser

Modificare un record

  1. Fare clic sul collegamento Modifica relativo al record che si desidera modificare.

    Per seguire l'esempio, fare clic sul collegamento Modifica relativo a Chai. Verrà visualizzata una visualizzazione dati contenente un modulo dati per il record Chai.

    Singolo record in di una visualizzazione dati in modalità di modifica

    Note : 

    • Quando si utilizzano elenchi e raccolte di SharePoint, i controlli di modifica non sono costituiti da caselle di testo, bensì da controlli campo modulo di SharePoint.

    • Quando si utilizzano campi di sola lettura, ad esempio un ID in un elenco SharePoint o un database SQL, il campo viene visualizzato solo come testo e non come campo modificabile.

    È ora possibile modificare qualsiasi informazione contenuta nel record Chai.

  2. Modificare i dati del record e quindi fare clic su Salva per salvare le modifiche o su Annulla per annullare le modifiche e tornare alla visualizzazione dati.

    Per seguire l'esempio, nella casella della colonna UnitsOnOrder digitare 40 e quindi fare clic su Salva a sinistra del record Chai.

    Verrà visualizzata la visualizzazione dati con il record aggiornato.

    Record con il valore di UnitsOnOrder

Eliminare un record

  • Fare clic sul collegamento Elimina a sinistra del record che si desidera eliminare.

    Importante : Quando si elimina un record tramite il browser, non viene visualizzata alcuna richiesta di conferma dell'azione e non è possibile annullare l'eliminazione del record.

    Per seguire l'esempio, fare clic sul collegamento Elimina a sinistra di Chang nell'elenco ProductName. Verrà visualizzata una visualizzazione dati contenente soltanto quattro record.

    Visualizzazione dati contenente soltanto 4 record

Inserire un record

  1. Fare clic sul collegamento Inserisci nell'angolo inferiore sinistro della visualizzazione dati.

    Verrà visualizzato un record con campi modulo vuoti.

    Record con campi modulo vuoti visualizzato facendo clic sul collegamento per l'inserimento

    È ora possibile inserire un nuovo record.

  2. Immettere i dati del record e quindi fare clic su Salva per salvare le modifiche o su Annulla per annullare le modifiche e tornare alla visualizzazione dati.

    Per seguire l'esempio, digitare Grandma's Boysenberry Spread nella casella della colonna ProductName, 120 nella casella della colonna UnitsInStock, 0 nella casella della colonna UnitsOnOrder e 25 nella casella della colonna ReorderLevel. Fare clic su Salva. Verrà visualizzata una visualizzazione dati con il nuovo record.

    Visualizzazione del nuovo record nella visualizzazione dati

Torna all'inizio

Personalizzazione dei modelli per la modifica o l'inserimento

L'utilizzo di una visualizzazione dati per l'inserimento o la modifica di record presenta un funzionamento leggermente diverso rispetto, ad esempio, all'utilizzo di moduli elenco come NewForm.aspx o EditForm.aspx per l'aggiunta o la modifica di elementi in un elenco SharePoint. Mentre per un elenco o una raccolta viene visualizzata agli utenti una pagina diversa in caso di aggiunta o modifica di elementi, con una visualizzazione dati viene visualizzata una modalità diversa. Ogni modalità dispone tuttavia di un modello completamente personalizzabile. Se ad esempio si personalizza il modello per la modifica, le personalizzazioni verranno visualizzate agli utenti solo facendo clic sul collegamento per la modifica per attivare la modalità di modifica della visualizzazione dati.

Potrebbe essere opportuno personalizzare il modello di ogni modalità se ad esempio si desidera offrire agli utenti istruzioni specifiche in caso di inserimento o modifica di record. È possibile inserire facilmente una nuova riga sotto le intestazioni di colonna e quindi utilizzare tale riga per immettere testo e specificare il tipo di dati da immettere in ogni colonna e il formato richiesto, ad esempio testo, numeri e così via.

  1. Fare clic sulla visualizzazione dati e quindi sulla freccia Icona del pulsante nell'angolo superiore destro per visualizzare l'elenco Attività comuni di Visualizzazione dati.

    Suggerimento : In alternativa, è possibile fare clic con il pulsante destro del mouse sulla visualizzazione dati e quindi scegliere Mostra attività controlli comuni dal menu di scelta rapida.

  2. Nell'elenco Anteprima visualizzazione dati fare clic su Modello per la modifica o Modello per l'inserimento.

    Verrà visualizzato il modello per la modalità. È possibile personalizzare l'aspetto del modello modificando il tipo di carattere, la formattazione o il layout del modulo.

  3. Per salvare le modifiche apportate, scegliere Salva dal menu File.

  4. Per visualizzare l'anteprima del modello nel browser, scegliere Visualizza anteprima nel browser dal menu File e quindi fare clic sul tipo di browser e sulla dimensione da utilizzare.

    Scelta rapida da tastiera  Fare clic sulla pagina di cui si desidera visualizzare l'anteprima nell'Elenco cartelle e quindi premere F12.

Aprendo la visualizzazione dati nel browser e quindi facendo clic su Modifica o Inserisci verrà visualizzato il modello personalizzato che è stato creato.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×