MATR.SOMMA.PRODOTTO (funzione MATR.SOMMA.PRODOTTO)

Questo articolo descrive la sintassi della formula e l'uso della funzione MATR.SOMMA.PRODOTTO in Microsoft Excel.

Descrizione

Moltiplica gli elementi corrispondenti nelle matrici specificate e restituisce la somma dei relativi prodotti.

Sintassi

MATR.SOMMA.PRODOTTO(matrice1; [matrice2]; [matrice3]; ...)

Gli argomenti della sintassi della funzione MATR.SOMMA.PRODOTTO sono i seguenti:

  • Matrice1     Obbligatorio. Il primo argomento matrice di cui si desidera moltiplicare e quindi sommare gli elementi.

  • Matrice2; matrice3; ...     Da 2 a 255 argomenti matrice di cui si desidera moltiplicare e quindi sommare gli elementi.

Osservazioni

  • Gli argomenti matrice devono avere le stesse dimensioni. In caso contrario, MATR.SOMMA.PRODOTTO restituirà il valore di errore #VALORE!.

  • MATR.SOMMA.PRODOTTO considera gli elementi non numerici delle matrici come degli zeri.

Esempio

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, è possibile regolare la larghezza delle colonne per visualizzare tutti i dati.

Matrice 1

Matrice 2

3

4

2

7

8

6

6

7

1

9

5

3

Formula

Descrizione

Risultato

=MATR.SOMMA.PRODOTTO(A2:B4; D2:E4)

Moltiplica tutti gli elementi delle due matrici e ne somma i prodotti, ovvero 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×