Inviare i dati del modulo a un database di Microsoft Access

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In questo articolo

Panoramica

Passaggio 1: Abilitare la connessione dati

Passaggio 2: Configurare le opzioni di invio

Panoramica

Quando si progetta un modello di modulo di Microsoft Office InfoPath basato su un Microsoft Office Access (mdb) o un database di Microsoft Office Access 2007 (con estensione accdb), la connessione guidata dati consente di creare una connessione dati al database se le condizioni seguenti sono soddisfatti.

  • Il modello di modulo è progettato in modo che gli utenti devono compilarlo tramite InfoPath. Se il modulo verrà compilato tramite un Web browser, il modulo non è possibile inviare i dati direttamente in un database. Per configurare un modello di modulo compatibile con browser per inviare dati a un database, utilizzare una connessione dati per inviare dati a un servizio Web compatibile con il database.

  • La tabella primaria che viene utilizzata per la connessione dati principale contiene una chiave primaria, un vincolo univoco o un indice univoco.

  • Tutte le altre tabelle di database in uso con la connessione dati principale dispongono di una relazione gerarchica semplice con la tabella primaria.

  • Il database non contiene campi contenenti un tipo di dati binari, ad esempio immagini, di immagini, oggetti OLE, file allegati, il tipo di dati memo Office Access o il tipo di dati testo SQL.

Se il database soddisfa questi requisiti, InfoPath crea connessione dati e viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia al menu File nella maschera.

Nota: Connessioni dati secondarie non è possibile inviare dati a un database. Se si desidera utilizzare una connessione dati a un database come una connessione dati secondaria, identificare un servizio Web compatibile con il database e quindi aggiungere una connessione dati al servizio Web.

Dopo aver attivato la connessione dati, è possibile personalizzare le opzioni di invio del modello di modulo come indicato di seguito.

  • Modificare il testo che viene visualizzato il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Modificare le scelte rapide da tastiera per il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Creare messaggi personalizzati per la visualizzazione agli utenti quando si inviano i moduli.

  • Specificare se si desidera lasciare aperta la maschera, chiudere la maschera o aprire un modulo vuoto dopo l'invio.

Torna all'inizio

Passaggio 1: Abilitare la connessione dati

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic sulla connessione dati principale e quindi fare clic su Modifica.

  3. In Connessione guidata dati fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, selezionare la casella di controllo Consenti invio per la connessione e quindi fare clic su Fine.

Torna all'inizio

Passaggio 2: Configurare le opzioni di invio

Dopo aver attivato la connessione dati, InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia dal menu File. InfoPath consente di configurare anche i moduli basati sul modello di modulo per visualizzare un messaggio agli utenti dopo l'invio dei moduli completati. Questo messaggio indica se il modulo è stato inviato. Per impostazione predefinita, InfoPath anche tiene il modulo aperto dopo l'invio. Per modificare il testo visualizzato sul pulsante Invia, il comportamento si verifica dopo l'invio dei moduli, eseguire le operazioni seguenti:

  1. Dal menu Strumenti fare clic su Opzioni invio.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare Su & v.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×