Inviare dati del modulo in una determinata condizione

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare il modello di modulo in modo da consentire agli utenti di inviare moduli basati su tale modello di modulo solo se nei moduli compilati viene soddisfatta una determinata condizione. Ad esempio, è possibile progettare un modello di modulo di nota spese che gli utenti possono inviare solo se il totale della spesa contenuto nel modulo è superiore a un importo specificato.

Per eseguire questa operazione, configurare il modello di modulo per l'invio del modulo e quindi aggiungere una regola che consente di inviare il modulo solo se viene soddisfatta una determinata condizione. Dopo aver aggiunto la regola, è possibile selezionare la connessione dati per invio da utilizzare quando la condizione imposta dalla regola viene soddisfatta.

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati dei loro moduli, in Microsoft Office InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File durante la compilazione del modulo.

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati dei loro moduli in una determinata condizione, è inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia della barra degli strumenti Standard e nel comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia della barra degli strumenti Standard e per il comando Invia del menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Aggiungere una regola per l'invio dei dati del modulo in una determinata condizione

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

    Nota : Quando viene selezionata questa casella di controllo, in InfoPath durante la compilazione del modulo viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File.

  3. Fare clic su Esegui azione personalizzata tramite regole e quindi su Regole.

  4. Nella finestra di dialogo Regole per l'invio di moduli fare clic su Aggiungi.

  5. Nella casella Nome digitare il nome della regola creata che descrive il percorso di invio. Ad esempio, se si desidera consentire agli utenti di inviare i moduli tramite messaggi di posta elettronica solo se il valore di uno specifico campo è superiore a 50€, digitare Invio tramite posta elettronica per valori superiori a 50€.

  6. Nella finestra di dialogo Regola fare clic su Imposta condizione.

  7. Nella finestra di dialogo Condizione specificare quando deve essere utilizzata la connessione dati e quindi fare clic su OK.

  8. Nella finestra di dialogo Regola fare clic su Aggiungi azione.

  9. Nell'elenco Azione fare clic su Invia tramite una connessione dati, nell'elenco Connessione dati selezionare la connessione dati che si desidera utilizzare per l'invio e quindi fare clic su OK.

  10. Fare clic su OK due volte.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  11. Per impedire agli utenti di utilizzare il comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante della barra degli strumenti per l'invio.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×