Inviare dati del modulo in un messaggio di posta elettronica

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile aggiungere secondario connessione dati al modello di modulo che consente agli utenti di inviare i dati del modulo in un messaggio di posta elettronica. È possibile usare valori statici, i valori in base ai dati del modulo o una formula per specificare gli indirizzi di posta elettronica inviati al modulo, l'oggetto del messaggio di posta elettronica e il nome del modulo. È inoltre possibile specificare se si vuole che il modulo nel corpo del messaggio di posta elettronica o come allegato al messaggio.

Se si configura il modello di modulo per includere il modulo come allegato al messaggio di posta elettronica, è anche possibile allegare il modello di modulo per il messaggio di posta elettronica. Includendo la maschera e il modello di modulo come allegati al messaggio di posta elettronica, si possono contribuire a garantire che i destinatari possono aprire il modulo in Microsoft Office InfoPath, anche se non hanno il modello di modulo cache nei propri computer. Per i destinatari aprire gli allegati, è necessario che InfoPath installato nel computer.

Quando gli utenti inviano i dati del modulo in un messaggio di posta elettronica, InfoPath crea un messaggio di posta elettronica con i dati del modulo e invia il messaggio ai destinatari di posta elettronica specificato al momento della creazione della connessione dati. Se le persone che ricevono moduli completati usano Microsoft Office Outlook 2007, possono aggiungere una cartella Posta in arrivo per contenere tutti i moduli di InfoPath che ricevono e configurare la cartella per visualizzare i dati dei moduli in colonne in Outlook.

Dopo aver aggiunto la connessione dati, configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo. Di conseguenza, quando si apre il modulo, InfoPath aggiunge automaticamente un pulsante Invia nella barra degli strumenti Standard e un comando Invia dal menu File. È anche possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo che viene visualizzato il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Creare messaggi personalizzati per la visualizzazione agli utenti quando si inviano i moduli.

  • Specificare se si desidera lasciare aperta la maschera, chiudere la maschera o aprire un modulo vuoto dopo l'utente ha inviato il modulo.

Torna all'inizio

Aggiungere una connessione dati

  1. Dal menu Strumenti fare clic su Opzioni invio.

  2. Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati del modulo a una singola destinazione e quindi nell'elenco fare clic su posta elettronica.

  4. Fare clic su Aggiungi.

  5. In connessione guidata dati nelle caselle appropriate digitare gli indirizzi di posta elettronica dei destinatari, l'oggetto che si desidera venga visualizzato il messaggio di posta elettronica e il testo introduttivo che si desidera e quindi fare clic su Avanti.

    Suggerimento: È anche possibile specificare un campo o usare una formula per creare il valore per ogni casella ad eccezione della casella Introduzione.

    Procedura

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

      • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

      • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

        Suggerimento: Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Aggiungi

    +

    Sottrarre

    -

    Moltiplicare

    *

    Dividere

    /

    • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

    • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

      Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

  6. Nella pagina successiva della procedura guidata, eseguire una delle operazioni seguenti:

    1. Per visualizzare il modulo nel corpo del messaggio di posta elettronica, fare clic su Invia solo la visualizzazione attiva del modulo senza allegati.

    2. Per inviare i dati del modulo come allegato al messaggio di posta elettronica, fare clic su Invia i dati del modulo come allegato, selezionare la casella di controllo Connetti il modello di modulo per garantire che gli utenti possono aprire la maschera e quindi digitare un nome per il modulo in nome dell'allegato casella. È anche possibile specificare un campo o utilizzare una formula per verificare che ogni nome maschera sia univoco.

      Procedura

      1. Fare clic su Inserisci Formula Icona del pulsante .

      2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

        • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

        • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

          Suggerimento: Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

        • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

      Operazione

      Simbolo

      Aggiungi

      +

      Sottrarre

      -

      Moltiplicare

      *

      Dividere

      /

      • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

      • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

        Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

      Nota: Le persone che ricevono i dati del modulo come allegato di un messaggio di posta elettronica necessario InfoPath installata nei propri computer aprire l'allegato.

  7. Fare clic su Avanti.

  8. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  9. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  10. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×