Inviare dati del modulo a una raccolta documenti

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile archiviare e organizzare tutti i moduli degli utenti in una raccolta documenti in un server in cui è in esecuzione Microsoft Windows SharePoint Services. Gli utenti possono compilare i moduli basati sul modello di modulo direttamente nella raccolta documenti ed esportare i dati dei moduli completati in Microsoft Office Excel 2003 o Microsoft Office Excel 2007, oppure unire i dati di più moduli in un unico modulo.

Per consentire agli utenti di inviare moduli basati sul modello di modulo a una raccolta documenti, è possibile aggiungere al modello di modulo una connessione dati secondaria per l'invio dei dati. Dopo aver aggiunto la connessione dati per invio, è possibile configurare il modello di modulo per consentire agli utenti di inviare i dati dei moduli compilati alla raccolta documenti. Quando vengono eseguite queste operazioni, in Microsoft Office InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File del modulo. È inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia della barra degli strumenti Standard e nel comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia della barra degli strumenti Standard e per il comando Invia del menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Aggiungere una connessione dati per invio

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati modulo a una destinazione sola e quindi selezionare Raccolta documenti di SharePoint nell'elenco.

  4. Fare clic su Aggiungi.

  5. In Connessione guidata dati nella casella Raccolta documenti digitare il percorso della raccolta documenti di SharePoint.

  6. Nella casella Nome file digitare un nome da utilizzare per identificare il modulo nella raccolta documenti.

    Suggerimento : È anche possibile utilizzare una formula per verificare che ogni nome di modulo sia univoco.

    Procedura

    1. Fare clic su Inserisci formula icona del pulsante .

    2. Nella finestra di dialogo Inserisci formula eseguire una delle operazioni seguenti:

      • Per includere un campo nella formula, fare clic su Inserisci campo o gruppo, nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che si desidera utilizzare e quindi fare clic su OK.

      • Per includere una funzione nella formula, fare clic su Inserisci funzione, nella finestra di dialogo Inserisci funzione selezionare la funzione che si desidera utilizzare e quindi fare clic su OK.

        Suggerimento : Se la funzione richiede l'inserimento di parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK e quindi nella casella Formula nella finestra di dialogo Inserisci formula, fare doppio clic sulla funzione aggiunta e fare clic su un campo o gruppo. Per ulteriori informazioni sulle funzioni, vedere i collegamenti nella sezione Vedere anche.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Addizione

    +

    Sottrazione

    -

    Moltiplicazione

    *

    Divisione

    /

    • Nota : Se nella formula viene utilizzato l'operatore di divisione (/), verificare di lasciare uno spazio prima e dopo l'operatore. In caso contrario, il simbolo "/" può essere interpretato in InfoPath come separatore dei passi delle espressioni di percorso XPath e non come operatore di divisione.

    • Per verificare la correttezza della sintassi della formula, nella finestra di dialogo Inserisci formula fare clic su Verifica formula.

      Per ulteriori informazioni sulle formule, vedere i collegamenti nella sezione Vedere anche.

  7. Per sovrascrivere moduli esistenti con lo stesso nome nella raccolta documenti, selezionare la casella di controllo Sovrascrivi se il file esiste.

  8. Fare clic su Avanti.

  9. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  10. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  11. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      1. Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      2. Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      3. Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×