Inviare dati del modulo a un servizio Web

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Se si desidera consentire agli utenti di inviare i dati dei propri moduli a un servizio Web, è possibile aggiungere al modello di modulo una connessione dati per invio come connessione dati secondaria. In base al tipo di dati accettato dal servizio Web, è possibile configurare la connessione per l'invio dei dati contenuti in un campo specifico, dei dati di tutti i campi di un gruppo o di tutti i dati del modulo.

Dopo aver aggiunto la connessione dati per invio, è possibile configurare il modello di modulo per consentire agli utenti di inviare i dati dei moduli compilati al servizio Web. Quando vengono eseguite queste operazioni, in Microsoft Office InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File del modulo. È inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia della barra degli strumenti Standard e nel comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia della barra degli strumenti Standard e per il comando Invia del menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Aggiungere una connessione dati per invio

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati modulo a una destinazione sola e quindi selezionare Servizio Web nell'elenco.

  4. Fare clic su Aggiungi.

  5. In Connessione guidata dati digitare il percorso del servizio Web a cui si desidera inviare i dati degli utenti e quindi fare clic su Avanti.

    Suggerimento : Se si desidera cercare il servizio Web in un server UDDI (Universal Description, Discovery, and Integration), fare clic su Cerca UDDI, immettere il server UDDI in cui eseguire la ricerca, specificare se eseguire la ricerca in base al provider o ai servizi offerti, immettere una parola chiave per la ricerca e quindi fare clic su Cerca. I servizi Web che corrispondono ai criteri di ricerca verranno visualizzati nell'elenco Risultati ricerca.

  6. Nella pagina successiva della procedura guidata, nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web che si desidera utilizzare per ricevere i dati e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata per selezionare i dati del modulo da inviare per ogni parametro del servizio Web, eseguire una delle operazioni seguenti:

    Inviare i dati di un campo o gruppo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni parametro fare clic su Campo o gruppo.

    3. Fare clic su Modifica icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su Solo testo ed elementi figlio per inviare solo i dati del campo selezionato e gli elementi figlio del campo o gruppo, oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati contenuti nel campo e gli elementi figlio del gruppo o campo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come stringa

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come stringa.

      Nota : In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

    Dettagli tecnici degli oggetti DataSet di Microsoft ADO.NET

    Se il servizio Web richiede un oggetto DataSet ADO.NET, durante la configurazione della connessione dati selezionare un nodo DataSet. Se si utilizza un tipo di nodo diverso per una connessione dati a un servizio Web che richiede un DataSet ADO.NET, l'azione di invio avrà esito negativo.

  8. Fare clic su Avanti.

  9. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  10. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

  11. Per consentire agli utenti di utilizzare il comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, selezionare la casella di controllo Mostra il comando di menu e il pulsante della barra degli strumenti per l'invio.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      1. Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      2. Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      3. Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×