Inviare dati del modulo a un database di Microsoft SQL Server

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Panoramica

Passaggio 1: Abilitare la connessione dati

Passaggio 2: Configurare le opzioni di invio

Informazioni generali

Quando si progetta un modello di modulo basato su un database di Microsoft SQL Server, è possibile utilizzare Connessione guidata dati per attivare una connessione dati per invio al database se vengono soddisfatte le condizioni seguenti:

  • I moduli basati su tale modello di modulo devono essere compilati con Microsoft Office InfoPath. Se un modulo viene compilato con un browser, non sarà possibile inviare direttamente i dati al database. Per configurare un modello di modulo compatibile con browser per l'invio dei dati a un database, utilizzare una connessione dati che consente di inviare dati a un servizio Web compatibile con il database.

  • La tabella di database primaria utilizzata nella connessione dati principale contiene una chiave primaria, un vincolo univoco o un indice univoco.

  • Tutte le altre tabelle di database utilizzate nella connessione dati principale hanno una relazione semplice con la tabella primaria.

Se il database soddisfa tali requisiti, in InfoPath viene attivata la connessione dati per invio e viene aggiunto il pulsante Invia nella barra degli strumenti Standard e il comando Invia nel menu File del modulo.

È possibile scegliere di disattivare la connessione dati per invio nella procedura guidata quando si progetta un modello di modulo basato su un database. Se si disattiva la connessione dati per invio nella procedura guidata e successivamente si decide di utilizzarla, è possibile attivarla nuovamente modificando la connessione dati principale. In questo articolo viene descritto come attivare la connessione dati per invio.

Nota : È possibile disporre di una connessione dati per invio solo nella connessione dati principale a un database. Non è possibile aggiungere una connessione dati per invio a un modello di modulo come connessione dati secondaria a un database. Se si desidera utilizzare una connessione dati per invio a un database come connessione dati secondaria, utilizzare un servizio Web compatibile con il database e quindi aggiungere una connessione dati per invio a tale servizio Web.

Dopo aver attivato la connessione dati per invio, è inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia della barra degli strumenti Standard e nel comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia della barra degli strumenti Standard e per il comando Invia del menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Torna all'inizio

Passaggio 1: Attivare la connessione dati per invio

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic sulla connessione dati principale e quindi su Modifica.

  3. In Connessione guidata dati fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata selezionare la casella di controllo Consenti invio per questa connessione e quindi fare clic su Fine.

Torna all'inizio

Passaggio 2: Configurare le opzioni di invio

In seguito all'attivazione della connessione dati per invio, in InfoPath vengono aggiunti il pulsante Invia nella barra degli strumenti Standard e il comando Standard nel menu File. I moduli basati sul modello di modulo vengono inoltre configurati in modo da visualizzare un messaggio dopo che gli utenti inviano i moduli completati, per indicare l'esito positivo o negativo dell'invio. Per impostazione predefinita, i moduli rimangono aperti in InfoPath dopo l'invio da parte degli utenti. Per modificare il testo visualizzato nel pulsante Invia e per definire il comportamento dell'applicazione in seguito all'invio dei moduli da parte degli utenti, eseguire le operazioni seguenti:

  1. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×