Inviare dati del modulo a più percorsi

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile progettare il modello di modulo in modo che quando gli utenti fanno clic sul pulsante Invia i dati dei moduli vengano inviati a percorsi diversi.

Contenuto dell'articolo

Panoramica

Passaggio 1: Aggiungere le connessioni dati invia

Passaggio 2: Configurare il modello di modulo per l'invio

Informazioni generali

Per consentire agli utenti di inviare i dati dei moduli a più percorsi, è necessario aggiungere al modello di modulo un'apposita connessione dati secondaria per ciascun percorso di destinazione desiderato. Dopo aver aggiunto tutte le connessioni dati per invio desiderate, è necessario configurare il modello di modulo per l'invio dei dati a più percorsi utilizzando una regola. In questo modo, in Microsoft Office InfoPath quando gli utenti compilano il modulo viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File. I dati dei moduli vengono inviati alle connessioni dati secondarie in base all'ordine stabilito nella regola. Non è possibile configurare la regola per utilizzare contemporaneamente tutte le connessioni dati per invio.

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati dei loro moduli, è inoltre possibile personalizzare le opzioni di invio nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia della barra degli strumenti Standard e nel comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia della barra degli strumenti Standard e per il comando Invia del menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Torna all'inizio

Passaggio 1: Aggiungere connessioni dati per invio

Per configurare il modello di modulo in modo da consentire l'invio dei moduli completati a più percorsi, è necessario aggiungere al modello di modulo le connessioni dati per invio necessarie. È possibile aggiungere connessioni per i percorsi seguenti:

  • Un servizio Web

  • Una raccolta documenti in un server in cui è in esecuzione Microsoft Windows SharePoint Services

  • Un messaggio di posta elettronica

    Nota : Per inviare i dati dei moduli in un messaggio di posta elettronica, gli utenti devono disporre di Microsoft Office Outlook installato nei loro computer.

Di seguito vengono illustrate le procedure da eseguire per aggiungere connessioni dati per invio a tali percorsi.

Aggiungere una connessione dati per inviare dati a un servizio Web

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su A un servizio Web e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare il percorso del servizio Web a cui verranno inviati i moduli degli utenti e quindi fare clic su Avanti.

    Se si desidera cercare il servizio Web in un server UDDI (Universal Description, Discovery, and Integration), fare clic su Cerca UDDI, immettere il server UDDI in cui eseguire la ricerca, specificare se eseguire la ricerca in base al provider o ai servizi offerti, immettere una parola chiave per la ricerca e quindi fare clic su Cerca. I servizi Web che corrispondono ai criteri di ricerca verranno visualizzati nell'elenco Risultati ricerca.

  6. Nella pagina successiva della procedura guidata, nell'elenco Selezionare un'operazione selezionare l'operazione del servizio Web a cui verranno inviati i dati dei moduli e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata eseguire una delle operazioni seguenti:

    Inviare i dati in un campo o gruppo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni parametro fare clic su Campo o gruppo.

    3. Fare clic su Modifica Pulsante Origine dati .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su Solo testo ed elementi figlio per inviare solo il contenuto e gli elementi figlio del campo o del gruppo oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare sia il contenuto che il campo o il gruppo selezionato.

    Inviare tutti i dati del modulo

    1. Fare clic su Intero modulo (documento XML, incluse istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Selezionare la casella di controllo Invia dati come stringa.

      In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

  8. Fare clic su Avanti.

  9. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  10. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

Aggiungere una connessione dati per inviare dati a una raccolta documenti

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su A una raccolta documenti in un sito di SharePoint e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata nella casella Raccolta documenti digitare il percorso della raccolta documenti di SharePoint.

  6. Nella casella Nome file digitare un nome da utilizzare per identificare il modulo nella raccolta documenti. È anche possibile utilizzare una formula per verificare che ogni nome di modulo sia univoco.

    Procedura

    1. Fare clic su Inserisci formula icona del pulsante .

    2. Nella finestra di dialogo Inserisci formula eseguire una delle operazioni seguenti:

      • Per includere un campo nella formula, fare clic su Inserisci campo o gruppo, nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che si desidera utilizzare e quindi fare clic su OK.

      • Per includere una funzione nella formula, fare clic su Inserisci funzione, nella finestra di dialogo Inserisci funzione selezionare la funzione che si desidera utilizzare e quindi fare clic su OK.

        Se la funzione richiede l'inserimento di parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK e quindi nella casella Formula nella finestra di dialogo Inserisci formula, fare doppio clic sulla funzione aggiunta e fare clic su un campo o gruppo. Per ulteriori informazioni sulle funzioni, vedere i collegamenti nella sezione Vedere anche.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Addizione

    +

    Sottrazione

    -

    Moltiplicazione

    *

    Divisione

    /

    • Nota : Se nella formula viene utilizzato l'operatore di divisione (/), verificare di lasciare uno spazio prima e dopo l'operatore. In caso contrario, il simbolo "/" può essere interpretato in InfoPath come separatore dei passi delle espressioni di percorso XPath e non come operatore di divisione.

    • Per verificare la correttezza della sintassi della formula, nella finestra di dialogo Inserisci formula fare clic su Verifica formula.

      Per ulteriori informazioni sulle formule, vedere i collegamenti nella sezione Vedere anche.

  7. Per sovrascrivere moduli esistenti con lo stesso nome nella raccolta documenti, selezionare la casella di controllo Sovrascrivi se il file esiste.

  8. Fare clic su Avanti.

  9. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  10. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

Aggiungere una connessione dati per inviare dati in un messaggio di posta elettronica

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Come messaggio di posta elettronica e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare nelle caselle appropriate gli indirizzi di posta elettronica dei destinatari del messaggio, l'oggetto che si desidera visualizzare nel messaggio ed eventuale testo introduttivo e quindi fare clic su Avanti. È inoltre possibile utilizzare una formula per ogni casella ad eccezione della casella Introduzione.

    Procedura

    1. Fare clic su Inserisci formula icona del pulsante .

    2. Nella finestra di dialogo Inserisci formula eseguire una delle operazioni seguenti:

      • Per includere un campo nella formula, fare clic su Inserisci campo o gruppo, nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che si desidera utilizzare e quindi fare clic su OK.

      • Per includere una funzione nella formula, fare clic su Inserisci funzione, nella finestra di dialogo Inserisci funzione selezionare la funzione che si desidera utilizzare e quindi fare clic su OK.

        Se la funzione richiede l'inserimento di parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK e quindi nella casella Formula nella finestra di dialogo Inserisci formula, fare doppio clic sulla funzione aggiunta e fare clic su un campo o gruppo. Per ulteriori informazioni sulle funzioni, vedere i collegamenti nella sezione Vedere anche.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Addizione

    +

    Sottrazione

    -

    Moltiplicazione

    *

    Divisione

    /

    • Nota : Se nella formula viene utilizzato l'operatore di divisione (/), verificare di lasciare uno spazio prima e dopo l'operatore. In caso contrario, il simbolo "/" può essere interpretato in InfoPath come separatore dei passi delle espressioni di percorso XPath e non come operatore di divisione.

    • Per verificare la correttezza della sintassi della formula, nella finestra di dialogo Inserisci formula fare clic su Verifica formula.

      Per ulteriori informazioni sulle formule, vedere i collegamenti nella sezione Vedere anche.

  6. Nella pagina successiva della procedura guidata eseguire una delle operazioni seguenti:

    1. Per visualizzare il modulo nel corpo del messaggio di posta elettronica, fare clic su Invia solo la visualizzazione attiva del modulo senza allegati.

    2. Per inviare i dati del modulo come allegato al messaggio di posta elettronica, fare clic su Invia i dati del modulo come allegato, selezionare la casella di controllo Connetti il modello di modulo per garantire che gli utenti possono aprire la maschera e quindi digitare un nome per il modulo nella casella Nome dell'allegato. È anche possibile specificare un campo o utilizzare una formula per verificare che ogni nome maschera sia univoco. Questa opzione è disponibile solo se il modello di modulo configurato per determinare automaticamente il livello di sicurezza o a livello di protezione con restrizioni o attendibilità completa.

      Procedura

      1. Fare clic su Inserisci formula icona del pulsante .

      2. Nella finestra di dialogo Inserisci formula eseguire una delle operazioni seguenti:

        • Per includere un campo nella formula, fare clic su Inserisci campo o gruppo, nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che si desidera utilizzare e quindi fare clic su OK.

        • Per includere una funzione nella formula, fare clic su Inserisci funzione, nella finestra di dialogo Inserisci funzione selezionare la funzione che si desidera utilizzare e quindi fare clic su OK.

          Se la funzione richiede l'inserimento di parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK e quindi nella casella Formula nella finestra di dialogo Inserisci formula, fare doppio clic sulla funzione aggiunta e fare clic su un campo o gruppo. Per ulteriori informazioni sulle funzioni, vedere i collegamenti nella sezione Vedere anche.

        • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

      Operazione

      Simbolo

      Addizione

      +

      Sottrazione

      -

      Moltiplicazione

      *

      Divisione

      /

      • Nota : Se nella formula viene utilizzato l'operatore di divisione (/), verificare di lasciare uno spazio prima e dopo l'operatore. In caso contrario, il simbolo "/" può essere interpretato in InfoPath come separatore dei passi delle espressioni di percorso XPath e non come operatore di divisione.

      • Per verificare la correttezza della sintassi della formula, nella finestra di dialogo Inserisci formula fare clic su Verifica formula.

        Per ulteriori informazioni sulle formule, vedere i collegamenti nella sezione Vedere anche.

      Per aprire l'allegato contenente i dati del modulo, i destinatari devono disporre di InfoPath installato nei loro computer.

  7. Fare clic su Avanti.

  8. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  9. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

Torna all'inizio

Passaggio 2: Configurare il modello di modulo per l'invio

Dopo avere aggiunto le necessarie connessioni dati secondarie al modello di modulo, è necessario configurare il modello di modulo per consentire agli utenti di inviare i propri dati del modulo. A tale scopo, in InfoPath vengono aggiunti un comando Invia nel menu File e un pulsante Invia nella barra degli strumenti Standard quando gli utenti compilano il modulo. È quindi possibile configurare l'azione eseguita quando l'utente fa clic sul pulsante Invia. In questo caso, è necessario aggiungere una regola per l'invio dei dati del modulo a ogni connessione dati per invio quando l'utente sceglie Invia dal menu File o fa clic sul pulsante Invia sulla barra degli strumenti Standard.

Nella stessa finestra di dialogo è possibile configurare le opzioni di invio.

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

    Quando viene selezionata questa casella di controllo, in InfoPath durante la compilazione del modulo viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File.

  3. Fare clic su Esegui azione personalizzata tramite regole e quindi su Regole.

  4. Nella finestra di dialogo Regole per l'invio di moduli fare clic su Aggiungi.

  5. Fare clic su Aggiungi azione.

  6. Nella casella Azione fare clic su Invia tramite una connessione dati, nell'elenco Connessione dati selezionare la connessione dati che si desidera utilizzare per l'invio e quindi fare clic su OK.

  7. Ripetere i passaggi 5 e 6 per ogni connessione dati per invio aggiunta al modello di modulo.

  8. Dopo aver impostato le condizioni di tutte le connessioni dati per invio del modello di modulo, fare clic su OK due volte.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  9. Per impedire agli utenti di utilizzare il comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante della barra degli strumenti per l'invio.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×