Introduzione alle query

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Quando si desidera esaminare, aggiungere, modificare o eliminare dati dal database si consiglia di utilizzare una query.

Con una query è possibile ottenere risposte a domande molto specifiche sui dati che sarebbe difficile ottenere osservando direttamente i dati della tabella. È possibile utilizzare le query per filtrare i dati, eseguire calcoli e riepilogare i dati. Le query consentono inoltre di automatizzare molte attività di gestione dei dati e di esaminare le modifiche apportate ai dati prima di confermarle.

Nota : Funzioni di query di aggregazione, ad esempio somma o conteggio, non sono disponibili nelle query Web.

L'utilizzo delle query semplifica molte attività di database

In questo articolo

Panoramica

Osservazione di un sottoinsieme di dati in una tabella

Analisi simultanea dei dati da più tabelle

Chiedere varianti di una domanda utilizzando parametri

Esecuzione di calcoli basati sui dati

Osservazione di dati riepilogati o aggregati

Creazione di una nuova tabella utilizzando dati da altre tabelle

Aggiunta di dati a una tabella utilizzando dati da altre tabelle

Modifica automatica dei dati

Eliminazione automatica dei dati

Panoramica

In questo articolo fornisce informazioni di base sulle query e vengono forniti esempi dei diversi tipi di query.

Una query è una richiesta di risultati dei dati, di azione sui dati o entrambe. È possibile utilizzare una query per rispondere a una semplice domanda, eseguire calcoli, combinare dati da diverse tabelle oppure aggiungere, modificare o eliminare dati delle tabelle. Le query utilizzate per recuperare dati da una tabella o eseguire calcoli sono dette query di selezione. Le query utilizzate per aggiungere, modificare o eliminare dati sono dette query di comando.

È inoltre possibile utilizzare una query per fornire dati per una maschera o un report. In un database ben progettato i dati che si desidera presentare utilizzando una maschera o un report si trovano spesso in diverse tabelle. Con una query è possibile assemblare i dati che si desidera utilizzare prima di progettare la maschera o il report.

Per ulteriori informazioni sull'utilizzo di una query per fornire dati per maschere e report, fare clic sui collegamenti disponibili nella sezione Vedere anche oppure vedere la Guida.

Aprire una query esistente

Se non si ha familiarità con il riquadro di spostamento, è possibile che non si sappia come aprire una query già esistente. Il riquadro di spostamento è una caratteristica che sostituisce la finestra del database presente nelle versioni precedenti ad Access 2007. Il riquadro di spostamento è visualizzato lungo il lato sinistro dello schermo.

Per aprire un qualsiasi oggetto di database, inclusa una query, è possibile fare doppio clic sull'oggetto nel riquadro di spostamento.

Utilizzare il database Northwind per procedere con gli esempi

Nota : Negli esempi contenuti in questo articolo viene utilizzato un database creato in base al modello di database Northwind 2010.

  1. Fare clic sulla scheda File e quindi su Nuovo.

  2. Nel riquadro centrale fare clic su Modelli di esempio in Modelli disponibili e quindi su Northwind.

  3. Nel riquadro di destra verificare il nome del file di database nella casella Nome file e, se necessario, modificarlo. È inoltre possibile cercare il file in un altro percorso facendo clic sull'icona a forma di cartella.

  4. Fare clic su Crea.

  5. Seguire le istruzioni visualizzate nella pagina Northwind Traders della scheda Schermata iniziale per aprire il database e quindi chiudere la Finestra di dialogo di accesso.

Inizio pagina

Esaminare un sottoinsieme di dati in una tabella

In alcuni casi può essere utile esaminare tutti i dati da una tabella, mentre in altri può essere utile esaminare solo i dati di campi specifici o i dati di certi campi che rispondono a determinati criteri. Per esaminare alcuni dati di una tabella, è necessario utilizzare una query di selezione.

Si supponga di voler esaminare un elenco di prodotti e i relativi prezzi. È possibile creare una query che restituisca informazioni sui prodotti e sui prezzi eseguendo le operazioni seguenti:

  1. Aprire il database di esempio Northwind configurato tramite questa procedura.

  2. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  3. Nella finestra di dialogo Mostra tabella fare doppio clic su Prodotti nella scheda Tabelle.

  4. Chiudere la finestra di dialogo Mostra tabella.

  5. Nella tabella Prodotti fare doppio clic su Nome prodotto e su Prezzo di listino per aggiungere questi campi alla griglia di struttura della query.

  6. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    La query verrà eseguita e verrà visualizzato un elenco di prodotti e prezzi.

Inizio pagina

Analisi simultanea dei dati da più tabelle

Tra le tabelle di un database ben progettato sono presenti relazioni logiche basate sui campi comuni delle tabelle stesse. Per esaminare i dati dalle tabelle correlate, è necessario utilizzare una query di selezione.

Si supponga di voler esaminare gli ordini per i clienti residenti in una città particolare. I dati sugli ordini e sui clienti sono memorizzati in due tabelle nello stesso database. In ogni tabella è presente un campo ID cliente, che costituisce la base di una relazione uno-a-molti tra le due tabelle. È possibile creare una query che restituisca gli ordini per i clienti di una città particolare attenendosi alla seguente procedura:

  1. Aprire il database di esempio Northwind configurato tramite questa procedura.

  2. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  3. Nella finestra di dialogo Mostra tabella fare doppio clic su Prodotti e Ordini nella scheda Tabelle.

  4. Chiudere la finestra di dialogo Mostra tabella.

    Osservare la linea, detta join, che connette il campo ID nella tabella Clienti e il campo ID cliente nella tabella Ordini. Questa linea indica la relazione tra le due tabelle.

  5. Nella tabella Clienti fare doppio clic su Società e Città per aggiungere questi campi alla griglia di struttura della query.

  6. Nella griglia di struttura della query, nella colonna Città, deselezionare la casella di controllo riga Mostra.

  7. Nella riga Criteri della colonna Città digitare Bologna.

    Deselezionando la casella di controllo Mostra impedisce che la query venga visualizzata la città nei risultati e digitare Bologna nella riga criteri specifica che si desidera visualizzare solo i record in cui il valore del campo città è Las Vegas. In questo caso, la query restituirà solo i clienti che si trovano Las Vegas, L e società AA.

    Non è necessario visualizzare un campo per utilizzarlo con un criterio.

  8. Nella tabella Ordini fare doppio clic su ID ordine e Data ordine per aggiungere questi campi alle due colonne successive della griglia di struttura della query.

  9. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    La query verrà eseguita e quindi verrà visualizzato un elenco degli ordini per i clienti di Bologna.

  10. Premere MAIUSC+F12 per salvare la query.

    Verrà visualizzata la finestra di dialogo Salva con nome.

  11. Nella casella Nome query digitare Ordini per città e scegliere OK.

Inizio pagina

Chiedere di varianti di una domanda utilizzando parametri

A volte può essere utile eseguire una query solo leggermente diversa da una query esistente. È possibile modificare la query originale in modo da utilizzare il nuovo criterio, ma se si desidera eseguire frequentemente variazioni di una particolare query, si consiglia di utilizzare una query con parametri. Quando si esegue questo tipo di query, viene chiesto di specificare i valori di campo, che vengono quindi utilizzati per creare i criteri per la query.

Nell'esempio precedente è stata creata una query che restituisce gli ordini per i clienti residenti a Bologna. È possibile modificare la query in modo che venga chiesto di specificare la città ogni volta che si esegue la query attenendosi alla seguente procedura:

  1. Aprire il database di esempio Northwind configurato tramite questa procedura.

  2. Premere F11 per visualizzare il riquadro di spostamento.

    Nota : Questo passaggio non è necessario se il riquadro di spostamento è già visualizzato.

  3. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla query denominata Ordini per città creata nella sezione precedente, quindi scegliere Visualizzazione Struttura dal menu di scelta rapida.

  4. Nella griglia di struttura della query, nella riga criteri della colonna Città eliminare Bolognae quindi digitare [per quale city?].

    La stringa [per quale city?] è il prompt del parametro. Utilizzare le parentesi quadre indica che la query per richiedere input e il testo (in questo caso, per quale città?) è la domanda che consente di visualizzare il prompt del parametro.

    Nota : Nel testo di una richiesta di parametri non è possibile utilizzare punti (.) o punti esclamativi (!).

  5. Selezionare la casella di controllo nella riga Mostra della colonna Città, in modo che nei risultati della query venga visualizzata la città.

  6. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    Durante l'esecuzione della query verrà chiesto di immettere un valore per Città.

  7. Digitare Reggio Emilia, quindi premere INVIO.

    La query viene eseguita, quindi vengono visualizzati gli ordini per i clienti di Reggio Emilia.

    Se tuttavia non si conoscono i valori che è possibile specificare, per rendere più flessibile il parametro è possibile utilizzare caratteri jolly nella richiesta:

  8. Nel gruppo Visualizzazioni della scheda Home fare clic su Visualizza e quindi su Visualizzazione Struttura.

  9. Nella riga Criteri della colonna Città digitare Like [Per quale città?]&"*".

    In questo parametro prompt dei comandi, la parola chiave Like , la e commerciale (&), e l'asterisco (*) racchiuso tra virgolette consente all'utente di digitare una combinazione di caratteri, inclusi i caratteri jolly, per ottenere diversi risultati. Ad esempio, se l'utente digita *, la query restituisce tutte le città; Se l'utente digita L, la query restituisce tutte le città che iniziano con la lettera "L"; e, se l'utente digita * s *, la query restituisce tutte le città che contengono la lettera "s".

  10. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    Alla richiesta della query digitare Reggio e quindi premere INVIO.

  11. La query viene eseguita, quindi vengono visualizzati gli ordini per i clienti di Reggio Emilia.

Specificare i tipi di dati del parametro

È possibile inoltre specificare il tipo di dati che dovrà essere accettato da un parametro. È possibile impostare il tipo di dati per qualsiasi parametro, ma è particolarmente importante impostare il tipo di dati per i dati numerici, valuta o data/ora. Quando si specifica il tipo di dati che dovrà essere accettato da un parametro, verrà visualizzato un messaggio di errore più utile qualora venga immesso il tipo di dati errato, ad esempio testo quando è prevista una valuta.

Nota : Se si imposta un parametro affinché accetti dati di testo, qualsiasi tipo di input verrà interpretato come testo e non verranno visualizzati messaggi di errore.

Per specificare il tipo di dati per i parametri in una query, attenersi alla seguente procedura:

  1. Con la query aperta in visualizzazione Struttura, nel gruppo Mostra/Nascondi della scheda Struttura fare clic su Parametri.

  2. Nella colonna Parametro della finestra di dialogo Parametri query digitare la richiesta per ogni parametro per cui si desidera specificare il tipo di dati. Assicurarsi che ogni parametro corrisponda alla richiesta che si desidera utilizzare nella riga Criteri della griglia di struttura della query.

  3. Nella colonna Tipo di dati selezionare il tipo di dati per ogni parametro.

Inizio pagina

Esecuzione di calcoli basati sui dati

Le tabelle non vengono quasi mai utilizzate per memorizzare valori calcolati basati sui dati contenuti nello stesso database. Ad esempio, nella tabella Dettagli sugli ordini in Northwind 2007 non sono memorizzati i subtotali dei prodotti, poiché il subtotale per qualsiasi prodotto specifico viene calcolato utilizzando i dati memorizzati nei campi Quantità, Prezzo unitario e Sconto della tabella Dettagli sugli ordini.

In alcuni casi i valori calcolati possono diventare obsoleti in quando in valore su cui si basano viene modificato. Ad esempio, non è consigliabile memorizzare in una tabella l'età di una persona, perché ogni anno sarebbe necessario aggiornare il valore. Si memorizzerà invece la data di nascita di quella persona e si utilizzerà un'espressione per calcolare l'età.

Utilizzare la procedura riportata di seguito per creare una query che calcoli i subtotali dei prodotti in base ai dati contenuti nella tabella Dettagli sugli ordini.

  1. Aprire il database di esempio Northwind configurato tramite questa procedura.

  2. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  3. Nella finestra di dialogo Mostra tabella fare doppio clic su Dettagli sugli ordini nella scheda Tabelle.

  4. Chiudere la finestra di dialogo Mostra tabella.

  5. Nella tabella Dettagli sugli ordini fare doppio clic su ID prodotto per aggiungere questo campo alla prima colonna della griglia di struttura della query.

  6. Nella seconda colonna della griglia fare clic con il pulsante destro del mouse sulla riga Campo, quindi scegliere Zoom dal menu di scelta rapida.

  7. Nella casella Zoom digitare o incollare quanto segue:

    Subtotale: ([Quantità]*[Prezzo unitario])-([Quantità]*[Prezzo unitario]*[Sconto])

    Fare clic su OK.

    Questo è il campo calcolato. Il campo calcolato Moltiplica la quantità di ogni prodotto per il prezzo unitario per quel prodotto Moltiplica la quantità di ogni prodotto per il prezzo unitario e sconto corrispondente a tale prodotto e sottrarne totale sconto dal prezzo unitario totale.

  8. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    La query viene eseguita e viene visualizzato un elenco di prodotti e subtotali per ordine.

  9. Premere CTRL + S per salvare la query e quindi assegnare un nome la query Subtotali prodotti.

Inizio pagina

Osservazione di dati riepilogati o aggregati

Quando si utilizzano le tabelle per registrare transazioni o memorizzare dati numerici ricorrenti, è utile poter osservare i dati aggregati, ad esempio somme o medie.

Access consente di esaminare semplici aggregare i dati in qualsiasi foglio dati mediante l'aggiunta di una riga totale. Una riga totale è una riga alla fine del foglio dati in grado di visualizzare un totale parziale o un altro valore aggregato.

Nota : Non è possibile aggiungere una riga Totale al foglio dati di una query Web.

È possibile aggiungere una riga Totale alla query Subtotali prodotti creata nell'esempio precedente eseguendo le operazioni seguenti:

  1. Eseguire la query Subtotali prodotti e lasciare i risultati aperti in visualizzazione Foglio dati.

  2. Nel gruppo Record della scheda Home fare clic su Totali.

    Nella parte inferiore del foglio dati verrà visualizzata una nuova riga con la parola Totale nella prima colonna.

  3. Fare clic sulla cella nell'ultima riga del foglio dati denominato Totale.

    Notare che nella cella verrà visualizzata una freccia.

  4. Fare clic sulla freccia per visualizzare la funzione di aggregazione disponibile.

    Poiché la colonna contiene dati di testo, sono disponibili solo due opzioni: Nessuna e Conteggio.

  5. Selezionare Conteggio.

    Il contenuto della cella cambia da Totale nel conteggio dei valori delle colonne.

  6. Fare clic sulla cella adiacente, la seconda colonna.

    Notare che nella cella verrà visualizzata una freccia.

  7. Fare clic sulla freccia, quindi su Somma.

    Nel campo verrà visualizzata una somma dei valori della colonna.

  8. Lasciare la query aperta in visualizzazione Foglio dati.

Creare una query di totalizzazione per riepiloghi più complessi

La riga Totale in un foglio dati risulta molto utile, ma per domande più complesse è opportuno utilizzare una query di totalizzazione, ovvero una query di selezione che consente di raggruppare o riepilogare i dati. Si supponga ad esempio di voler visualizzare le vendite totali per prodotto. A questo scopo, è possibile utilizzare la funzione di aggregazione Somma in una query di totalizzazione.

Nota : Non è possibile utilizzare funzioni di aggregazione in una query Web.

Eseguire le operazioni seguenti per modificare la query Subtotali prodotti in modo che restituisca il riepilogo dei subtotali dei prodotti per prodotto.

  1. Nel gruppo Visualizzazioni della scheda Home fare clic su Visualizza, quindi su Visualizzazione Struttura.

    La query Subtotali prodotti verrà aperta in visualizzazione Struttura.

  2. Nel gruppo Mostra/Nascondi della scheda Struttura fare clic su Totali.

    La riga Totaleè visualizzata nella griglia di struttura della query.

    Nota : Anche se il nome è simile, la riga Totale nella griglia di struttura e la riga Totale in un foglio dati sono diverse:

    • Utilizzando la riga Totale nella griglia di struttura è possibile raggruppare i dati per valori di campo.

    • È possibile aggiungere una riga Totale del foglio dati ai risultati di una query di totalizzazione.

    • Quando si utilizza la riga Totale nella griglia di struttura, è necessario scegliere una funzione di aggregazione per ogni campo. Se non si desidera eseguire un calcolo su un campo, è possibile raggruppare i dati in base al campo.

  3. Nella riga Totale della seconda colonna della griglia di struttura selezionare Somma dall'elenco a discesa.

  4. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    La query verrà eseguita e verrà visualizzato un elenco di prodotti con i subtotali.

  5. Premere MAIUSC+F12 per salvare la query. Lasciare la query aperta.

Creare una query a campi incrociati per aggiungere un altro livello di raggruppamento

Si supponga a questo punto di voler esaminare i subtotali dei prodotti, ma anche di aggregare i dati per mese, in modo che in ogni riga vengano visualizzati i subtotali per un prodotto e in ogni colonna i subtotali dei prodotti per un mese. Per visualizzare i subtotali per un prodotto e i subtotali dei prodotti per un mese, utilizzare una query a campi incrociati.

Nota : Impossibile visualizzare una query a campi incrociati in un web browser.

È possibile modificare di nuovo la query Subtotali prodotti in modo che restituisca righe di subtotali dei prodotti e colonne di subtotali mensili.

  1. Nel gruppo Visualizzazioni della scheda Home fare clic su Visualizza, quindi su Visualizzazione Struttura.

  2. Nel gruppo Imposta query fare clic su Mostra tabella.

  3. Nella finestra di dialogo Mostra tabella fare doppio clic su Ordini, quindi scegliere Chiudi.

  4. Nel gruppo Tipo di query della scheda Struttura fare clic su A campi incrociati.

    Nella griglia di struttura la riga Mostra è nascosta e la riga Campi incrociati è visualizzata.

  5. Nella terza colonna della griglia fare clic con il pulsante destro del mouse sulla riga Campo, quindi scegliere Zoom dal menu di scelta rapida. Verrà aperta la casella Zoom.

  6. Nella casella Zoom digitare o incollare quanto segue:

    Mese: "Mese" & DatePart("m", [Data ordine])

  7. Fare clic su OK.

  8. Nella riga Campi incrociati selezionare i seguenti valori dall'elenco a discesa: Intestazione riga per la prima colonna, Valore per la seconda colonna e Intestaz. colonna per la terza colonna.

  9. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    La query verrà eseguita e verranno visualizzati i subtotali dei prodotti aggregati per mese.

  10. Premere MAIUSC+F12 per salvare la query.

Inizio pagina

Creazione di una nuova tabella utilizzando dati da altre tabelle

Per creare una nuova tabella dai dati memorizzati in altre tabelle, è possibile utilizzare una query di creazione tabella.

Nota : Non è possibile eseguire una query di creazione tabella in un web browser.

Si supponga ad esempio di voler inviare i dati per gli ordini di Messina a un partner commerciale di Messina che utilizza Access per preparare i report. Anziché inviare tutti i dati degli ordini, si desidera limitare i dati da inviare a specifici ordini di Messina.

Per creare una query di selezione contenente i dati degli ordini di Messina e quindi utilizzarla per creare una nuova tabella, eseguire le operazioni seguenti:

  1. Aprire il database di esempio Northwind configurato tramite questa procedura.

  2. Se il database non è attendibile all'apertura, per eseguire una query di creazione tabella potrebbe essere necessario abilitare il contenuto del database tramite la barra dei messaggi che viene visualizzata sotto la barra multifunzione.

    Come abilitare il database

    • Sulla barra dei messaggi fare clic su Abilita contenuto.

    Se il database è in un percorso attendibile, la barra dei messaggi non verrà visualizzata e non sarà necessario abilitare il contenuto.

  3. Chiudere la maschera Finestra di dialogo di accesso.

  4. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  5. Nella finestra di dialogo Mostra tabella fare doppio clic su Dettagli ordini e su Ordini.

  6. Chiudere la finestra di dialogo Mostra tabella.

  7. Nella tabella Ordini fare doppio clic su ID cliente e Città destinatario per aggiungere questi campi alla griglia di struttura.

  8. Nella tabella Dettagli ordini fare doppio clic su ID ordine, ID prodotto, Quantità, Prezzo unitarioe Sconto per aggiungere questi campi alla griglia di struttura.

  9. Nella colonna Città destinatario della griglia di struttura deselezionare la casella nella riga Mostra. Nella riga Criteri digitare 'Messina' (includendo le virgolette singole).

    Verificare i risultati della query prima di utilizzarli per creare la tabella.

  10. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

  11. Premere MAIUSC+F12 per salvare la query.

    Verrà visualizzata la finestra di dialogo Salva con nome.

  12. Nella casella Nome query digitare Query ordini di Messina e scegliere OK.

  13. Nel gruppo Visualizzazioni della scheda Home, fare clic su Visualizza, quindi su Visualizzazione Struttura.

  14. Nel gruppo Tipo di query della scheda Struttura, fare clic su Creazione tabella.

    Viene visualizzata la finestra di dialogo Creazione tabella.

  15. Nella finestra di dialogo Creazione tabella digitare Ordini di Messina nella casella Nome tabella e quindi fare clic su OK.

  16. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

  17. Nella finestra di dialogo di conferma fare clic su per confermare.

    La nuova tabella viene creata e aperta nel riquadro di spostamento.

    Nota : Se esiste già una tabella con lo stesso nome specificato, verrà eliminata prima dell'esecuzione della query.

  18. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    Poiché la tabella Ordini di Messina esiste già, verrà visualizzata una finestra di dialogo di avviso.

  19. Scegliere No per annullare l'azione e chiudere la finestra di dialogo.

Inizio pagina

Aggiunta di dati a una tabella utilizzando dati da altre tabelle

Per recuperare dati da una o più tabelle e aggiungerli a un'altra tabella, è possibile utilizzare una query di accodamento.

Nota : Una query di accodamento non è possibile eseguire in un web browser.

Si supponga di avere creato una tabella da condividere con un partner commerciale di Messina, ma poiché il partner lavora anche con clienti nell'area di Firenze, si desidera aggiungere alla tabella righe con i dati dell'area di Firenze prima di condividerla con il partner.

È possibile aggiungere i dati dell'area di Firenze alla tabella ordini di Messina creata nell'esempio precedente attenendosi alla seguente procedura:

  1. Aprire la query "Query ordini di Messina" in visualizzazione Struttura.

  2. Nel gruppo Tipo di Query della scheda Progettazione fare clic su Aggiungi. Verrà visualizzata la finestra di dialogo Accodamento.

  3. Nella finestra di dialogo Accodamento fare clic sulla freccia nella casella Nome tabella, quindi selezionare Ordini Messina dall'elenco a discesa.

  4. Fare clic su OK.

    La finestra di dialogo Accodamento viene chiusa. Nella griglia di struttura la riga Mostra viene nascosta e viene visualizzata la riga Accoda a.

  5. Nella griglia di struttura eliminare 'Messina' nella riga Criteri della colonna Città destinazione e digitare 'Firenze'.

  6. Nella riga Accoda a selezionare il campo appropriato per ogni colonna.

    In questo esempio i valori della riga Accoda a dovranno corrispondere ai valori della riga Campo, tuttavia questa corrispondenza non è indispensabile per il funzionamento delle query di accodamento.

  7. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

Nota :  Durante l'esecuzione di una query che restituisce una grande quantità di dati è possibile che venga visualizzato un messaggio di errore in cui si informa che non sarà possibile annullare la query. Provare ad aumentare il limite del segmento di memoria fino a 3 MB per consentire il completamento della query.

Inizio pagina

Modifica automatica dei dati

È possibile utilizzare una query di aggiornamento per modificare i dati nelle tabelle e per immettere i criteri che specificano quali righe dovranno essere aggiornate. Una query di aggiornamento consente di esaminare i dati aggiornati prima di eseguire l'aggiornamento.

Importante : Non è possibile annullare una query di comando, quindi è opportuno effettuare una copia di backup delle tabelle che verranno aggiornate con una query di aggiornamento.

Nota : Non è possibile eseguire una query di aggiornamento in un web browser.

Nell'esempio precedente sono state aggiunte righe alla tabella Ordini di Messina. In questa tabella nel campo ID prodotto è indicato l'ID prodotto numerico. Per rendere i dati più utili per i report, si consiglia di sostituire gli ID prodotto con i nomi dei prodotti. A questo scopo è necessario innanzitutto modificare il tipo di dati del campo ID prodotto della tabella Ordini di Messina da Numero a Testo, in modo che il campo ID prodotto accetti i nomi dei prodotti.

È possibile aggiornare i valori nella tabella Ordini di Messina attenendosi alla seguente procedura:

  1. Aprire la tabella Ordini di Messina in visualizzazione Struttura.

  2. Nella riga ID prodotto modificare il tipo di dati da Numero in Testo.

  3. Salvare e chiudere la tabella Ordini di Messina.

  4. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  5. Nella finestra di dialogo Mostra tabella fare doppio clic su Ordini di Messina e su Prodotti.

  6. Chiudere la finestra di dialogo Mostra tabella.

  7. Nel gruppo Tipo di query della scheda Struttura fare clic su Aggiornamento.

    Nella griglia di struttura le righe Ordina e Mostra vengono nascoste e viene visualizzata la riga Aggiorna a.

  8. Nella tabella Ordini di Messina fare doppio clic su ID prodotto per aggiungere il campo alla griglia di struttura.

  9. Nella griglia di struttura, nella riga Aggiorna a della colonna ID prodotto, digitare o incollare il seguenti:

    [Prodotti].[Nome prodotto]

    Suggerimento : È possibile utilizzare una query di aggiornamento per eliminare i valori dei campi mediante una stringa vuota ("") o immettendo NULL nella riga Aggiorna a.

  10. Nella riga Criteri digitare o incollare quanto segue:

    [ID prodotto] Like ([Prodotti].[ID])

    La parola chiave Like è necessaria perché i campi che si desidera confrontare contengono diversi tipi di dati (ID prodotto sono i dati di testo, l'ID è dati numerici).

  11. È possibile verificare quali valori verranno modificati da una query di aggiornamento visualizzando la query in visualizzazione Foglio dati.

    Fare clic su Visualizza nel gruppo Risultati della scheda Struttura, quindi fare clic su Visualizzazione Foglio dati.

    La query restituisce un elenco degli ID prodotto che verranno aggiornati.

  12. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

    Quando si apre la tabella Ordini di Messina, si noterà che i valori numerici nel campo ID prodotto sono stati sostituiti dai nomi dei prodotti dalla tabella Prodotti.

Inizio pagina

Eliminazione automatica dei dati

È possibile utilizzare una query di eliminazione per eliminare i dati dalle tabelle e per immettere i criteri che specificano quali righe dovranno essere eliminate. Una query di eliminazione consente di esaminare le righe che verranno eliminate prima di procedere all'eliminazione.

Nota : Non è possibile eseguire una query di eliminazione in un web browser.

Si supponga di prepararsi a inviare la tabella Ordini di Messina, aggiornata nell'esempio precedente, al partner commerciale di Messina e di notare che alcune righe contengono numerosi campi vuoti. Prima di inviare la tabella si desidera rimuovere le righe contenenti i campi vuoti. È possibile aprire semplicemente la tabella ed eliminare manualmente le righe, ma può risultare utile utilizzare una query di eliminazione se le righe da eliminare sono molte e i criteri in base ai quali eliminare determinate righe sono chiari.

È possibile utilizzare una query per eliminare le righe nella tabella Ordini di Messina privi di valore nel campo ID ordine, attenendosi alla seguente procedura:

  1. Nel gruppo Query della scheda Crea fare clic su Struttura query.

  2. Nella finestra di dialogo Mostra tabella fare doppio clic su Ordini di Messina.

  3. Chiudere la finestra di dialogo Mostra tabella.

  4. Nel gruppo Tipo di query della scheda Struttura fare clic su Elimina.

    Nella griglia di struttura le righe Ordina e Mostra vengono nascoste e viene visualizzata la riga Elimina.

  5. Nella tabella Ordini di Messina fare doppio clic su ID ordine per aggiungere il campo alla griglia.

  6. Nella riga Criteri della colonna ID ordine della griglia di struttura digitare Is Null.

  7. Nel gruppo Risultati della scheda Struttura fare clic su Esegui.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×