Introduzione all'impostazione del layout di un modello di modulo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Durante la progettazione di un modello di modulo di Microsoft Office InfoPath è necessario considerare come impostare il layout ovvero come disporre gli elementi nel modello di modulo.

In genere, è necessario organizzare le diverse parti del modello di modulo in modo che gli utenti che lo compilano possono spostarsi nel modulo in modo logico. Inoltre, è consigliabile allineare caselle di testo, caselle di controllo e altri elementi lungo le linee orizzontali e verticali di una griglia immaginaria. È possibile utilizzare le tabelle layout per definire i bordi della griglia e allineare gli elementi nel modello di modulo.

In questo articolo

Tabelle layout e riquadro attività Layout

Controlli correlati al layout

Suggerimenti relativi al layout

Tabelle layout e riquadro attività Layout

Teoricamente si dovrebbe progettare un modello di modulo che abbia un aspetto accattivante e allo stesso tempo sia facile da utilizzare. Le tabelle layout consentono di raggiungere entrambi gli obiettivi.

Il riquadro attività Layout include una raccolta di tabelle layout preconfigurate che è possibile utilizzare nella progettazione di un modello di modulo per impostarne la struttura visiva.

Riquadro attività Layout

Le tabelle layout sono simili alle altre tabelle con la differenza che vengono utilizzate solo per attività di layout e non per la presentazione di dati. Diversamente dalle altre tabelle, per impostazione predefinita le tabelle layout non dispongono inoltre di bordi visibili. Quando un modello di modulo viene progettato in modalità progettazione, i bordi della tabella layout sono rappresentati da linee tratteggiate per indicare l'area di lavoro disponibile all'interno della tabella. Tuttavia, quando gli utenti compilano un modulo basato su tale modello di modulo, i bordi non vengono visualizzati.

Ad esempio, è possibile utilizzare le tabelle layout per organizzare i controlli, per separare una sezione dall'altra, per creare sezioni di intestazione e piè di pagina e per posizionare loghi e altri elementi grafici.

Nell'esempio seguente una tabella layout viene utilizzata per organizzare le caselle di testo all'interno di una sezione in un modello di modulo.

Sezione interna di una tabella layout in un modello di modulo

1. Questa tabella layout contiene due righe.

2. Nella seconda riga sono presenti tre colonne. La colonna centrale viene utilizzata solo per scopi di spaziatura.

Per aggiungere o rimuovere righe e colonne da una tabella layout, è possibile fare clic sulle opzioni desiderate nell'elenco Unisci e dividi celle nel riquadro attività. Se le tabelle layout nel riquadro attività Layout non sono appropriate per esigenze particolari, è possibile inserire una tabella layout personalizzata costituita dal numero esatto di righe e colonne desiderato.

È anche possibile utilizzare il riquadro attività Layout per inserire rapidamente le aree scorrevoli e aree orizzontali nel modello di modulo che sono descritti in dettaglio nella sezione seguente.

Inizio pagina

Controlli correlati al layout

Oltre alle tabelle layout, è possibile utilizzare i controlli correlati al layout, ad esempio sezioni o le sezioni ripetute, che consentono di progettare il modello di modulo. Quando si inserisce un controllo correlata al layout nel modello di modulo, si inserisce in effetti contenitori vuoti per la memorizzazione di altri controlli.

Nella tabella seguente vengono descritti in breve i controlli più comunemente utilizzati per l'impostazione del layout.

Controllo

Descrizione

Sezione

Controllo che contiene altri controlli. Ad esempio, in un modello di modulo di denuncia di sinistro per l'assicurazione, è possibile utilizzare una sezione per raggruppare un insieme di caselle di testo per raccogliere informazioni dagli assicurati.

Sezione facoltativa

Controllo che contiene altri controlli e che viene visualizzato nel modulo solo se aggiunto esplicitamente dall'utente. In un modulo per la valutazione delle prestazioni, ad esempio, tutti i membri del team del progetto potrebbero utilizzare la sezione per l'impostazione degli obiettivi, mentre il manager del progetto potrebbe essere l'unico a utilizzare la sezione facoltativa relativa agli obiettivi dei dirigenti.

Controllo ripetuto

Controllo, ad esempio una sezione ripetuta o una tabella ripetuta, che consente agli utenti di espandere il contenuto di un modulo durante la compilazione e visualizzare solo il numero di voci necessarie di una serie. Ad esempio, è possibile utilizzare una tabella ripetuta per raccogliere voci di spesa dettagliate in un modello di modulo di nota spese.

Area scorrevole

Controllo che contiene altri controlli, conservato dimensioni fisse e include le barre di scorrimento in modo che gli utenti possono scorrere per visualizzare le informazioni dalla visualizzazione. Utilizzare lo scorrimento aree può essere utile quando una sezione di un modello di modulo contiene una quantità elevata di dati e gli utenti non necessaria visualizzare tutti i dati in una sola volta. Ad esempio, se si utilizza una tabella ripetuta per visualizzare numerosi record da un database, è possibile inserire la tabella ripetuta all'interno di un'area di scorrimento per visualizzare solo alcuni dei record alla volta. Poiché le aree scorrevoli vengono utilizzate esclusivamente per il layout, non sono associati a campi o gruppi nell'origine dati. Le aree scorrevoli non sono supportate nei modelli di modulo compatibile con browser.

Area orizzontale

Controllo che contiene altri controlli e che può essere collocato in una formazione orizzontale in un modello di modulo. Ad esempio, quando più aree orizzontali vengono poste una accanto all'altro, vengono riversate o disposte automaticamente sulla riga successiva al mutare delle dimensioni dello schermo. Le aree orizzontali sono controlli destinati esclusivamente all'utilizzo per attività di layout e pertanto non sono associate a campi o gruppi nell'origine dati. I controlli area orizzontale non sono supportati nei modelli di modulo compatibili con browser.

Gruppo di scelta

Controllo che presenta un insieme di si escludono a vicenda agli utenti. Un gruppo di scelta contiene sezioni di scelta, uno dei quali viene visualizzato come opzione predefinita in un modulo. Le sezioni di scelta contengono altri controlli. Ad esempio, informazioni sugli indirizzi in un modello di modulo informazioni dipendente può essere formattati come gruppo di scelta contenente sezioni di scelta. Ogni sezione di scelta contiene controlli con la sintassi indirizzo corretto per uno specifico paese o area geografica. Quando i dipendenti compilano i moduli basati sul modello di modulo, possono sostituire la sezione predefinita con quella appropriata per il paese o area geografica.

Inizio pagina

Suggerimenti relativi al layout

I suggerimenti riportati di seguito consentono di mettere a punto l'aspetto, le dimensioni e altre caratteristiche delle tabelle layout e dei controlli correlati al layout.

  • Prima di progettare un nuovo modello di modulo completamente vuoto, è utile determinare innanzitutto il layout desiderato. Se risulta difficile definire chiaramente un layout, provare a tracciare sulla carta uno schizzo preliminare. Per dare una forma più finita a un'idea e creare bozze dell'interfaccia utente del modello di modulo, è anche possibile utilizzare un programma specifico, ad esempio Microsoft Office Visio. Dopo aver delineato il progetto, è possibile inserire una tabella preconfigurata selezionata dal riquadro attività Layout e personalizzarla in base alle esigenze.

  • In modalità progettazione i bordi delle tabelle layout sono rappresentati da linee tratteggiate che consentono di individuare le singole righe e colonne. Questa griglia viene nascosta durante la compilazione di un modulo basato sul modello di modulo in questione in modo da disporre di un'organizzazione più chiara e meno complessa. Se si preferisce nascondere la griglia anche in modalità progettazione, è possibile disattivarla scegliendo Nascondi griglia dal menu Tabella.

  • Per impostazione predefinita, le tabelle layout e i controlli correlati al layout, come sezioni e aree scorrevoli, vengono inseriti con una larghezza corrispondente a quella della pagina stampata. Per modificare questa impostazione predefinita, nel menu Visualizza fare clic su Proprietà visualizzazione. Nella scheda Generale in Impostazioni layout selezionare la casella di controllo Usa larghezza personalizzata per modello di modulo e quindi digitare un numero diverso nella casella Larghezza personalizzata.

  • Evitare di impostare una larghezza di layout personalizzata per tabelle layout e controlli layout più larga dell'area stampabile del modello di modulo. Per verificare rapidamente la larghezza della pagina stampata e quindi se lo spazio nella pagina è sufficiente per il contenuto del modello di modulo, scegliere Guida larghezza pagina dal menu Visualizza. Questo comando consente di visualizzare una guida verticale tratteggiata lungo il bordo destro dello schermo, che indica il margine destro della pagina stampata, in base alla stampante predefinita impostata per il computer in uso.

  • Per cambiare il bordo o il colore di controlli correlati al layout o di tabelle layout, selezionare i controlli o le tabelle su cui si desidera intervenire, scegliere Bordi e sfondo dal menu Formato e quindi apportare le modifiche necessarie.

  • Per impostazione predefinita, una tabella layout viene allineata sul lato sinistro del modello di modulo. Per allineare l'intera tabella sul lato destro o al centro, selezionare la tabella, nel menu Tabella fare clic su Proprietà tabella e quindi nella scheda Tabella scegliere A destra o Centrato in base alle preferenze.

  • La spaziatura interna è la quantità di spazio che circonda il contenuto di una cella. È paragonabile allo spazio di margine che esiste tra la cella e il testo contenuto al suo interno. La modifica della spaziatura interna in genere offre un maggior controllo rispetto all'aggiunta di ulteriore spazio eseguita premendo INVIO. Per modificare la spaziatura interna di una cella, selezionare le opzioni della scheda Cella nella finestra di dialogo Proprietà tabella.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×