Introduzione ai report in Access

I report costituiscono un modo semplice per visualizzare, formattare e riepilogare le informazioni del database di Microsoft Access. È ad esempio possibile creare un report semplice per visualizzare i numeri di telefono di tutti i contatti oppure un report di riepilogo relativo al totale delle vendite in aree e periodi diversi.

In questo articolo viene fornita una panoramica sui report in Access e vengono illustrate le nozioni di base per creare un report, utilizzare opzioni quali ordinamento, raggruppamento e riepilogo dei dati, nonché per visualizzare l'anteprima e stampare il report.

Nota    Le informazioni di questo articolo sono valide solo con database desktop di Access.

Contenuto dell'articolo

Panoramica

Operazioni eseguibili con un report

Parti di un report

Creare un report

Passaggio 1: Scegliere un'origine record

Passaggio 2: Scegliere uno strumento Report

Passaggio 3: Creare il report

Aggiungere raggruppamenti, ordinamenti o totali

Evidenziare i dati con la formattazione condizionale

Personalizzare colore e tipi di carattere

Aggiungere un logo o un'immagine di sfondo

Visualizzare in anteprima e stampare un report

Visualizzare in anteprima un report

Stampare un report

Panoramica

Operazioni eseguibili con un report

Un report è un oggetto di database che risulta utile quando si desidera presentare le informazioni di un database per uno degli scopi seguenti:

  • Visualizzare o distribuire un riepilogo dei dati.

  • Archiviare istantanee dei dati.

  • Fornire dettagli su singoli record.

  • Creare etichette.

Parti di un report

È possibile creare report "non associati" in cui non vengono visualizzati dati, tuttavia, ai fini del presente articolo si presuppone che un report sia associato a un'origine dati, ad esempio una tabella o una query. La struttura di un report è suddivisa in sezioni che è possibile visualizzare in visualizzazione Struttura. Una corretta comprensione del funzionamento di ogni sezione consente di creare report professionali. Ad esempio, la sezione in cui si decide di inserire un controllo calcolato definisce la modalità di calcolo dei risultati da parte di Access. Di seguito è riportato un riepilogo dei tipi di sezione e del relativo utilizzo:

Sezione

Visualizzazione della sezione nella stampa

Posizione in cui è possibile utilizzare la sezione

Intestazione di report

All'inizio del report.

Utilizzare l'intestazione di report per includere informazioni in genere riportate su una copertina, ad esempio il logo, il titolo e la data. Se nell'intestazione di report viene inserito un controllo calcolato che utilizza la funzione di aggregazione Somma, verrà calcolata la somma per l'intero report. L'intestazione di report viene stampata prima dell'intestazione di pagina.

Intestazione di pagina

Nella parte superiore di ogni pagina.

Utilizzare un'intestazione di pagina per ripetere il titolo del report su ogni pagina.

Intestazione di gruppo

All'inizio di ogni nuovo gruppo di record.

Utilizzare l'intestazione di gruppo per stampare il nome del gruppo. In un report raggruppato per prodotto utilizzare, ad esempio, l'intestazione di gruppo per stampare il nome del prodotto. Se nell'intestazione di gruppo viene inserito un controllo calcolato che utilizza la funzione di aggregazione Somma, verrà calcolata la somma relativa al gruppo corrente. In un report è possibile utilizzare più sezioni intestazione di gruppo, a seconda del numero di livelli di gruppo aggiunti. Per ulteriori informazioni sulla creazione di intestazioni e piè di pagina di gruppo, vedere la sezione Aggiungere raggruppamenti, ordinamenti o totali.

Corpo

Viene visualizzata una sola volta per ogni riga nell'origine record.

In questa sezione vengono inseriti i controlli che compongono la parte principale del report.

Piè di pagina di gruppo

Alla fine di ogni gruppo di record.

Utilizzare un piè di pagina di gruppo per stampare le informazioni di riepilogo per un gruppo. In un report è possibile utilizzare più sezioni piè di pagina di gruppo, a seconda del numero di livelli di gruppo aggiunti.

Piè di pagina

Nella parte inferiore di ogni pagina.

Utilizzare un piè di pagina per stampare il numero di pagina oppure informazioni specifiche per ogni pagina.

Piè di pagina di report

Alla fine del report.

Nota    In visualizzazione Struttura il piè di pagina di report è posizionato sotto il piè di pagina. Tuttavia, in tutte le altre visualizzazioni, ad esempio la visualizzazione Layout, o quando si esegue la stampa o l'anteprima del report, il piè di pagina del report viene riportato sopra il piè di pagina, subito dopo l'ultimo piè di pagina di gruppo oppure l'ultima riga della sezione Corpo nella pagina finale.

Utilizzare il piè di pagina di report per stampare i totali oppure altre informazioni di riepilogo per l'intero report.

Si scoprirà che è molto più facile creare report significativi quando il database è basato su una struttura di tabella e su relazioni ben progettate. Per informazioni introduttive sulla pianificazione e progettazione di un database, vedere l'articolo Nozioni fondamentali sulla progettazione di database.

Torna all'inizio

Creare un report

Per creare report per il database desktop di Access, eseguire le operazioni seguenti:

Passaggio 1: Scegliere un'origine record

L'origine record di un report può essere una tabella, una query denominata o una query incorporata. Nell'origine record devono essere presenti tutte le righe e tutte le colonne di dati che si desidera visualizzare nel report.

  • Se i dati sono contenuti in una tabella o una query esistente, selezionare la tabella o la query nel riquadro di spostamento e quindi continuare con il Passaggio 2.

  • Se non è disponibile un'origine record, eseguire una delle operazioni seguenti:

    • Continuare con il Passaggio 2 e utilizzare lo strumento Report vuoto.

      Oppure

    • Creare la tabella o la query contenente i dati necessari. Selezionare la tabella o la query nel riquadro di spostamento e quindi continuare con il Passaggio 2.

Passaggio 2: Scegliere uno strumento Report

Gli strumenti Report sono disponibili nel gruppo Report della scheda Crea sulla barra multifunzione. Nella tabella seguente vengono descritte le opzioni.

Strumento

Descrizione

Report

Viene creato un semplice report tabulare contenente tutti i campi dell'origine record selezionati nel riquadro di spostamento.

Struttura report

Viene aperto un report vuoto in visualizzazione Struttura, al quale è possibile aggiungere i campi e i controlli obbligatori.

Report vuoto

Viene aperto un report vuoto in visualizzazione Layout e visualizza il riquadro attività Elenco campi in cui è possibile aggiungere campi al report.

Creazione guidata report

Viene visualizzata una creazione guidata a più passaggi che consente di specificare campi, livelli di gruppo/ordinamento e opzioni di layout.

Etichette

Viene visualizzata una creazione guidata che consente di selezionare dimensioni di etichetta standard o personalizzate, nonché i campi che si desidera visualizzare e la relativa modalità di ordinamento.

Passaggio 3: Creare il report

  1. Fare clic sul pulsante corrispondente allo strumento che si desidera utilizzare. Se viene visualizzata una creazione guidata, seguire i relativi passaggi e fare clic su Fine nell'ultima pagina.
    Il report verrà visualizzato automaticamente in visualizzazione Layout.

  2. Formattare il report in modo che abbia l'aspetto desiderato:

    • Ridimensionare i campi e le etichette selezionandoli e quindi trascinandone i bordi finché non assumono le dimensioni desiderate.

    • Spostare un campo selezionandolo, e selezionando la relativa etichetta se presente, e quindi trascinarlo nella nuova posizione.

    • Fare clic con il pulsante destro del mouse su un campo e utilizzare i comandi del menu di scelta rapida per unire o dividere le celle, eliminare o selezionare campi ed eseguire altre operazioni di formattazione.

      È inoltre possibile utilizzare le caratteristiche descritte nelle sezioni seguenti per rendere il proprio report più accattivante e facilitarne la lettura.

Torna all'inizio

Aggiungere raggruppamenti, ordinamenti o totali

Per aggiungere il più rapidamente possibile raggruppamenti, ordinamenti o totali a un report di database desktop, fare clic con il pulsante destro del mouse sul campo al quale si desidera applicare il gruppo, l'ordinamento o il totale e quindi scegliere il comando desiderato dal menu di scelta rapida.

È inoltre possibile aggiungere raggruppamenti, ordinamenti o totali utilizzando il riquadro Raggruppamento, ordinamento e totale mentre il report è aperto in visualizzazione Layout o Struttura:

  1. Se il riquadro Raggruppamento, ordinamento e totale non è giù aperto, fare clic su Raggruppa e ordina nel gruppo Raggruppamento e totali della scheda Progettazione.

  2. Fare clic su Aggiungi gruppo o Aggiungi ordinamento e quindi selezionare il campo a cui si desidera applicare il raggruppamento o l'ordinamento.

  3. Fare clic su Altro su una riga di raggruppamento o di ordinamento per impostare ulteriori opzioni e per aggiungere totali.

Per ulteriori informazioni sul raggruppamento, l'ordinamento e i totali durante la creazione di un report con raggruppamenti o di riepilogo, vedere l'articolo Create a grouped or summary report (informazioni in lingua inglese).

Torna all'inizio

Evidenziare i dati con la formattazione condizionale

In Access sono disponibili strumenti per evidenziare i dati in un report. È possibile aggiungere regole di formattazione condizionale per ogni controllo o gruppo di controlli. Inoltre nei report client è possibile aggiungere barre dei dati per effettuare il confronto di dati.

Per aggiungere la formattazione condizionale ai controlli

  1. Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout.

  2. Selezionare i controlli obbligatori e nel gruppo Formattazione controlli della scheda Formato fare clic su Formattazione condizionale.

    Suggerimento    Per selezionare più controlli, tenere premuto CTRL e fare clic sui controlli.

  3. Nella finestra di dialogo Gestione regole formattazione condizionale fare clic su Nuova regola.

  4. Nella finestra di dialogo Nuova regola di formattazione selezionare un valore in Selezionare un tipo di regola:

    • Per creare una regola che venga valutata per ogni singolo record, selezionare Controlla i valori nel record corrente o utilizza un'espressione.

    • Per creare una regola per effettuare il confronto tra record mediante barre dei dati, fare clic su Confronta con altri record.

  1. In Modificare la descrizione della regola specificare la regola che determinerà quando applicare la formattazione, oltre al tipo di formattazione da applicare e quindi fare clic su OK.

  2. Per creare una regola aggiuntiva per lo stesso controllo o set di controlli, ripetere questa procedura dal passaggio 4.

Torna all'inizio

Personalizzare colore e tipi di carattere

Provare una delle opzioni di Applica tema per personalizzare il colore e i tipi di carattere.

  1. Aprire un report in visualizzazione Layout facendo clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout.

  2. Nelle opzioni di Strumenti layout report fare clic su Temi nella scheda Progettazione e scorrere con il cursore sui diversi temi della raccolta per visualizzare un'anteprima degli effetti. Fare clic su un tema per selezionarlo e quindi salvare il report.

  3. Utilizzare la raccolta Colori o Tipi di carattere per impostare colori e tipi di carattere separatamente.


Torna all'inizio

Aggiungere un logo o un'immagine di sfondo

È possibile aggiungere un logo o un'immagine di sfondo in un report. Se si aggiorna l'immagine, l'aggiornamento verrà applicato indipendentemente dalla posizione in cui l'immagine viene utilizzata nel database.

Per aggiungere o rimuovere un'immagine:

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report e quindi scegliere Visualizzazione Layout.

  2. Fare clic sulla posizione nel report in cui si desidera aggiungere l'immagine e quindi nel gruppo Intestazione/Piè di pagina della scheda Progettazione fare clic su Logo.

  3. Individuare l'immagine e fare clic su Apri per aggiungerla al report.

  4. Per rimuovere l'immagine, fare clic con il pulsante destro del mouse sull'immagine e scegliere Elimina dal menu di scelta rapida.

Per aggiungere un'immagine di sfondo:

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report e quindi scegliere Visualizzazione Layout.

  2. Nel gruppo Sfondo della scheda Formato fare clic su Immagine di sfondo.

  3. Selezionare un'immagine nell'elenco Raccolta immagini oppure fare clic su Sfoglia, selezionare un'immagine e quindi fare clic su OK.

Torna all'inizio

Visualizzare in anteprima e stampare un report

Visualizzare in anteprima un report

  1. Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Anteprima di stampa. È possibile utilizzare i comandi disponibili nella scheda Anteprima di stampa per eseguire una delle operazioni seguenti:

    • Stampare il report

    • Modificare le dimensioni della pagina o il layout

    • Eseguire lo zoom avanti o indietro o visualizzare più pagine contemporaneamente

    • Aggiornare i dati nel report

    • Esportare il report in un altro formato di file.

  2. Fare clic su Chiudi anteprima di stampa.

Stampare un report

Per stampare un report senza visualizzarlo in anteprima:

  • Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Stampa. Il report verrà inviato alla stampante predefinita.

    Nota    Se si seleziona il report nel riquadro di spostamento e si sceglie Stampa nella scheda File, è possibile selezionare altre opzioni di stampa, ad esempio il numero di pagine, nonché specificare una stampante.

    • Per aprire una finestra di dialogo nella quale selezionare una stampante, specificare il numero di copie e così via, fare clic su Stampa.

Torna all'inizio

Si applica a: Access 2010, Access 2013



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua