Introduzione ai report

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per visualizzare, formattare e riepilogare dati in un database si usano generalmente i report. Si può ad esempio creare un report di tipo elenco per visualizzare i numeri di telefono di tutti i contatti oppure un report di riepilogo per sommare le vendite della società in aree e periodi diversi.

Questo articolo offre una panoramica dei report di Microsoft Access 2010 e presenta le caratteristiche nuove o migliorate relative ai report. Spiega inoltre come creare un report, ordinare, raggruppare e riepilogare dati e come visualizzare in anteprima e stampare un report.

Si scoprirà che è molto più facile creare report significativi se il database è basato su una struttura di tabella e su relazioni ben progettate. Per informazioni introduttive sulla pianificazione e progettazione di un database, vedere l'articolo Nozioni fondamentali sulla progettazione di database.

In questo articolo

Panoramica

Novità

Creare un nuovo report

Aggiungere raggruppamenti, ordinamenti o totali

Evidenziare valori usando la formattazione condizionale

Ottenere un aspetto professionale con i temi

Aggiungere immagini

Visualizzare in anteprima e stampare un report

Panoramica

Un report è un oggetto di database usato per visualizzare e riepilogare dati. Può essere usato per distribuire o archiviare snapshot dei dati, stampandoli, convertendoli in file PDF o XPS oppure esportandoli in altri formati di file.

Report Dipendenti in Anteprima di stampa

I report possono offrire dettagli relativi a singoli record, riepiloghi con molti record o entrambi. È anche possibile usare i report di Access per creare etichette per l'invio postale o per altri scopi.

Si possono creare report "non associati" in cui non vengono visualizzati dati, tuttavia ai fini del presente articolo si presuppone che un report sia associato a un'origine dati, come una tabella o una query.

Report client e report Web

In Access 2010 è disponibile una nuova caratteristica che consente di creare un "database Web" mediante la pubblicazione di un database di Access su un server SharePoint in cui è in esecuzione Access Services. Quando si crea un database Web, i report di Access vengono visualizzati nel browser tramite SQL Server Reporting Services. Questa conversione introduce limitazioni alle caratteristiche che è possibile usare nei report visualizzati nel browser. Se però non si è interessati alla visualizzazione del report nel browser, è possibile usare l'intero set di caratteristiche offerte da Progettazione report di Access.

Parti di un report

In Access la struttura di un report è suddivisa in sezioni. Per visualizzare le sezioni di un report in un database client, occorre aprire il report in visualizzazione Struttura. In visualizzazione Layout le sezioni non sono così evidenti, ma sono comunque presenti e possono essere selezionate tramite l'elenco a discesa nel gruppo Selezione della scheda Formato. Per creare report utili, è necessario conoscere in dettaglio le caratteristiche di ogni sezione. Ad esempio, la sezione in cui si decide di inserire un controllo calcolato definisce la modalità di calcolo dei risultati in Access. Ecco un riepilogo dei tipi di sezione e del relativo utilizzo:

  • Intestazione report   Questa sezione viene stampata una sola volta all'inizio del report. Usare l'intestazione report per includere informazioni in genere riportate su una copertina, come il logo, il titolo o la data. Se nell'intestazione report viene inserito un controllo calcolato che usa la funzione di aggregazione Somma, viene calcolata la somma per l'intero report. L'intestazione report viene stampata prima dell'intestazione pagina.

  • Intestazione pagina   Questa sezione viene stampata nella parte superiore di ogni pagina. Ad esempio, usare un'intestazione pagina per ripetere il titolo del report su ogni pagina.

  • Intestazione gruppo   Questa sezione viene stampata all'inizio di ogni nuovo gruppo di record. Usare l'intestazione gruppo per stampare il nome del gruppo. Ad esempio, in un report raggruppato per prodotto usare l'intestazione gruppo per stampare il nome del prodotto. Se nell'intestazione gruppo viene inserito un controllo calcolato che usa la funzione di aggregazione Somma, viene calcolata la somma relativa al gruppo corrente. In un report è possibile usare più sezioni intestazione gruppo, a seconda del numero di livelli di gruppo aggiunti. Per altre informazioni sulla creazione di intestazioni e piè di pagina di gruppo, vedere la sezione Aggiungere raggruppamenti, ordinamenti o totali.

  • Corpo   Questa sezione viene stampata una volta per ogni riga nell'origine record. In questa sezione vengono inseriti i controlli che costituiscono il corpo principale del report.

  • Piè di pagina gruppo   Questa sezione viene stampata alla fine di ogni gruppo di record. Usare un piè di pagina gruppo per stampare le informazioni di riepilogo per un gruppo. In un report è possibile usare più sezioni di piè di pagina gruppo, a seconda del numero di livelli di gruppo aggiunti.

  • Piè di pagina   Questa sezione viene stampata alla fine di ogni pagina. Usare un piè di pagina per stampare il numero di pagina oppure informazioni specifiche per ogni pagina.

  • Piè di pagina report    Questa sezione viene stampata una sola volta alla fine del report. Usare il piè di pagina report per stampare i totali oppure altre informazioni di riepilogo per l'intero report.

Nota :  In visualizzazione Struttura il piè di pagina report è posizionato sotto il piè di pagina. Tuttavia, in tutte le altre visualizzazioni, ad esempio la visualizzazione Layout, o quando si esegue la stampa o l'anteprima del report, il piè di pagina del report viene riportatosopra il piè di pagina, subito dopo l'ultimo piè di pagina gruppo o l'ultima riga della sezione Corpo nella pagina finale.

Inizio documento

Novità

La procedura per creare un report in Access 2010 è molto simile a quella usata in Access 2007, con la differenza che in Access 2010 sono disponibili alcune nuove caratteristiche che riguardano i report:

  • Raccolta immagini condivisa   In Access 2010 è possibile allegare un'immagine a un database e quindi usarla in più oggetti. Quando si aggiorna la singola immagine, questa viene aggiornata automaticamente ovunque è usata nell'intero database.

  • Temi di Office   In Access 2010 è possibile usare i temi standard di Microsoft Office per applicare contemporaneamente set di caratteri e colori dall'aspetto professionale a tutti i report e tutte le maschere di Access.

  • Formattazione condizionale più avanzata   Access 2010 offre strumenti più avanzati per evidenziare i dati in un report. È possibile aggiungere fino a 50 regole di formattazione condizionale per ogni controllo o gruppo di controlli. Inoltre nei report client è possibile aggiungere barre dei dati per effettuare il confronto di dati tra i record.

  • Layout più flessibili   In Access 2010 il metodo di progettazione predefinito per i report consiste nell'inserire i controlli nei layout. Queste griglie facilitano l'allineamento e il ridimensionamento dei controlli e sono necessarie per tutti i report che si vuole visualizzare in un browser. Anche se i layout stessi non sono una novità in Access 2010, sono state apportate modifiche per quanto riguarda il modo di usarli per spostare, allineare e ridimensionare i controlli. Per altre informazioni e un'introduzione ai layout di maschere e report, vedere il video Introduzione ai layout di maschere e report.

Inizio documento

Creare un nuovo report

Passaggio 1: Scegliere un'origine record

L'origine record di un report può essere una tabella, una query denominata o una query incorporata. Nell'origine record devono essere presenti tutte le righe e tutte le colonne di dati che si desidera visualizzare nel report.

Per altre informazioni sulla creazione di tabelle o query, vedere gli articoli Introduzione alle tabelle e Introduzione alle query.

Per altre informazioni sulla creazione e sulla selezione di origini record, vedere l'articolo Impostare l'origine record per un report.

Passaggio 2: Scegliere uno strumento report

Gli strumenti report sono disponibili nel gruppo Report della scheda Crea sulla barra multifunzione. La tabella seguente offre una breve descrizione del funzionamento di ognuno:

Report compatibili con il Web

I report creati tramite questi strumenti sono compatibili con la caratteristica Pubblica in Access Services e verranno visualizzati in un browser. Si noti che gli oggetti compatibili con il Web sono indicati da un globo sull'icona dell'oggetto.

Icona del pulsante

Strumento

Descrizione

Icona del pulsante

Report

Viene creato un semplice report tabulare contenente tutti i campi dell'origine record selezionati nel riquadro di spostamento.

Icona del pulsante

Report vuoto

Viene aperto un report vuoto in visualizzazione Layout con il riquadro attività Elenco campi. Quando si trascinano campi dal riquadro Elenco campi nel report, Access crea una query per l'origine record.

Per altre informazioni sulla caratteristica Pubblica in Access Services, vedere l'articolo Creare un database di Access da condividere sul Web.

Report client

I report creati tramite questi strumenti non sono compatibili con la caratteristica Pubblica in Access Services. L'aggiunta di report client a un database Web non impedirà la pubblicazione del database, tuttavia tali report non saranno disponibili nel browser. I report client possono comunque essere usati quando il database è aperto in Access.

Icona del pulsante

Strumento

Descrizione

Icona del pulsante

Report

Viene creato un semplice report tabulare contenente tutti i campi dell'origine record selezionati nel riquadro di spostamento.

Icona del pulsante

Struttura report

Viene aperto un report vuoto in visualizzazione Struttura, al quale è possibile aggiungere solo i campi e i controlli desiderati.

Icona del pulsante

Report vuoto

Viene aperto un report vuoto in visualizzazione Layout con il riquadro attività Elenco campi. Mentre si trascinano campi dal riquadro Elenco campi nel report, viene creata automaticamente una query incorporata che viene quindi archiviata nella proprietà Origine record del report.

Icona del pulsante

Creazione guidata report

Viene visualizzata una creazione guidata a più passaggi che consente di specificare campi, livelli di gruppo/ordinamento e opzioni di layout. In base alle selezioni effettuate, viene creato automaticamente un report.

Icona del pulsante

Etichette

Viene visualizzata una creazione guidata che consente di selezionare dimensioni di etichetta standard o personalizzate, nonché i campi che si desidera visualizzare e la relativa modalità di ordinamento. In base alle selezioni effettuate, viene creato automaticamente il report di etichette.


Passaggio 3: Creare il report

  1. Fare clic sul pulsante corrispondente allo strumento che si vuole usare. Se viene visualizzata una creazione guidata, seguire i relativi passaggi e fare clic su Fine nell'ultima pagina.

    Access visualizza il report in visualizzazione Layout.

  2. Formattare il report finché non avrà l'aspetto desiderato:

    • Ridimensionare i campi e le etichette selezionandoli e quindi trascinandone i bordi finché non assumono le dimensioni desiderate.

    • Spostare un campo selezionandolo, e selezionando la relativa etichetta se presente, e quindi trascinarlo nella nuova posizione.

    • Fare clic con il pulsante destro del mouse su un campo e utilizzare i comandi del menu di scelta rapida per unire o dividere le celle, eliminare o selezionare campi ed eseguire altre operazioni di formattazione.

      È inoltre possibile utilizzare le caratteristiche descritte nelle sezioni seguenti per rendere il proprio report più accattivante e facilitarne la lettura.

Inizio documento

Aggiungere raggruppamenti, ordinamenti o totali

Per aggiungere il più rapidamente possibile raggruppamenti, ordinamenti o totali a un report, fare clic con il pulsante destro del mouse sul campo al quale si vuole applicare il raggruppamento, l'ordinamento o il totale e quindi scegliere il comando desiderato dal menu di scelta rapida.

È inoltre possibile aggiungere raggruppamenti, ordinamenti o totali utilizzando il riquadro Raggruppamento, ordinamento e totale mentre il report è aperto in visualizzazione Layout o Struttura:

  1. Se il riquadro Raggruppamento, ordinamento e totale non è giù aperto, fare clic su Raggruppa e ordina nel gruppo Raggruppamento e totali della scheda Progettazione.

  2. Fare clic su Aggiungi gruppo o Aggiungi ordinamento e quindi selezionare il campo a cui si desidera applicare il raggruppamento o l'ordinamento.

  3. Fare clic su Altro su una riga di raggruppamento o di ordinamento per impostare ulteriori opzioni e per aggiungere totali.

Per altre informazioni sul raggruppamento, l'ordinamento e il calcolo dei totali, vedere l'articolo Creare un report con raggruppamenti o di riepilogo.

Inizio documento

Evidenziare valori usando la formattazione condizionale

Access 2010 offre strumenti più avanzati per evidenziare i dati in un report. È possibile aggiungere fino a 50 regole di formattazione condizionale per ogni controllo o gruppo di controlli. Inoltre nei report client è possibile aggiungere barre dei dati per effettuare il confronto di dati tra i record.

Per aggiungere la formattazione condizionale :

  1. Aprire il report in visualizzazione Layout facendo clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout.

  2. Selezionare tutti i controlli a cui si vuole applicare la formattazione condizionale. Per selezionare più controlli, tenere premuto MAIUSC o CTRL e fare clic sui controlli desiderati.

  3. Nel gruppo Formattazione controlli della scheda Formato fare clic su Formattazione condizionale.

    Access apre la finestra di dialogo Gestione regole formattazione condizionale.

  4. Nella finestra di dialogo Gestione regole formattazione condizionale fare clic su Nuova regola.

  5. Nella finestra di dialogo Nuova regola di formattazione selezionare un valore in Selezionare un tipo di regola:

    • Per creare una regola che venga valutata per ogni singolo record, selezionare Controlla i valori nel record corrente o utilizza un'espressione.

    • Per creare una regola per effettuare il confronto tra record mediante barre dei dati, fare clic su Confronta con altri record.

Nota :  L'opzione Confronta con altri record non è disponibile nei database Web.


  1. In Modificare la descrizione della regola specificare la regola che determinerà quando applicare la formattazione, oltre al tipo di formattazione da applicare quando i criteri della regola sono soddisfatti.

  2. Fare clic su OK per tornare alla finestra di dialogo Gestione regole formattazione condizionale.

  3. Per creare una regola aggiuntiva per questo controllo o set di controlli, ripetere questa procedura dal passaggio 4. Altrimenti, fare clic su OK per chiudere la finestra di dialogo.

Per altre informazioni sull'aggiunta della formattazione condizionale in un report, vedere il video Usare la formattazione condizionale nei report.

Inizio documento

Ottenere un aspetto professionale con i temi

È possibile applicare i temi di Office 2010 a un database di Access per creare più facilmente uno stile coerente in tutti i documenti di Office.

Importante :  Se si sceglie un tipo di carattere, un colore o un tema di Office, questo viene applicato a tutte le maschere e a tutti i report del database, non solo all'elemento che si sta usando.

  1. Aprire un report in visualizzazione Layout facendo clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout.

  2. Nel gruppo Temi della scheda Progettazione selezionare il tema, il colore o il tipo di carattere desiderato:

    Informativa criteri di gestione delle informazioni visualizzata nella barra messaggi

    • Usare la raccolta Tema per impostare contemporaneamente colori e tipi di carattere su uno schema predefinito.

    • Utilizzare la raccolta Colori o Tipi di carattere per impostare colori e tipi di carattere separatamente.


Per altre informazioni sull'uso dei temi di Office, vedere il video che spiega come usare i temi di Office per rendere le maschere e i report di Access più uniformi e accattivanti.

Inizio documento

Aggiungere immagini

Solitamente le immagini in Access sono associate a singoli controlli immagine in maschere o report. Per modificare un'immagine usata di frequente in più maschere e report, è necessario modificare manualmente ogni controllo immagine. In Access 2010, tuttavia, è possibile allegare un'immagine a un database una sola volta e quindi usarla in più oggetti. Quando si aggiorna la singola immagine, questa viene aggiornata automaticamente ovunque è usata nell'intero database. Questa caratteristica è molto utile per alcuni oggetti, come il logo della società o le immagini di sfondo che vengono usate nell'intero database.

Aggiungere un'immagine

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report al quale si vuole aggiungere l'immagine e quindi scegliere Visualizzazione Layout.

  2. Fare clic sul report nel punto in cui si vuole aggiungere l'immagine.

  3. Nel gruppo Controlli della scheda Struttura fare clic su Inserisci immagine.

  4. Eseguire una delle operazioni seguenti:

    • Usare un'immagine esistente   Se l'immagine desiderata è già presente nella raccolta, fare clic su di essa per aggiungerla al report.

    • Caricare una nuova immagine   Nella parte inferiore della raccolta fare clic su Sfoglia. Nella finestra di dialogo Inserisci immagine spostarsi sull'immagine che si vuole usare e fare clic su Apri.

      L'immagine selezionata viene aggiunta automaticamente al report.

Aggiungere un'immagine di sfondo

Nota :  Le immagini di sfondo non possono essere aggiunte ai report compatibili con il Web.

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report al quale si vuole aggiungere l'immagine di sfondo e quindi scegliere Visualizzazione Layout.

  2. Nel gruppo Sfondo della scheda Formato fare clic su Immagine di sfondo.

  3. Eseguire una delle operazioni seguenti:

    • Usare un'immagine esistente   Se l'immagine desiderata è già presente nella raccolta, fare clic su di essa per aggiungerla al report.

    • Caricare una nuova immagine   Nella parte inferiore della raccolta fare clic su Sfoglia. Nella finestra di dialogo Inserisci immagine spostarsi sull'immagine che si vuole usare e fare clic su Apri.

      L'immagine selezionata viene aggiunta automaticamente al report.

Inizio documento

Visualizzare in anteprima e stampare un report

Visualizzare in anteprima un report

  1. Aprire il report che si vuole visualizzare in anteprima o selezionarlo semplicemente nel riquadro di spostamento.

  2. Nella scheda File fare clic su Stampa e quindi su Anteprima di stampa.

    Access apre il report in Anteprima di stampa. È possibile usare i comandi disponibili nella scheda Anteprima di stampa per eseguire una delle operazioni seguenti:

    • Stampare il report

    • Modificare le dimensioni della pagina o il layout

    • Eseguire lo zoom avanti o indietro o visualizzare più pagine contemporaneamente

    • Aggiornare i dati nel report

    • Esportare il report in un altro formato di file

  3. Per tornare all'area di lavoro del database, nel gruppo Chiudi anteprima della scheda Anteprima di stampa fare clic su Chiudi anteprima.

Stampare un report

Oltre a stampare un report da Anteprima di stampa, è possibile stamparlo anche senza visualizzarlo in anteprima:

  1. Aprire il report che si vuole visualizzare in anteprima o selezionarlo semplicemente nel riquadro di spostamento.

  2. Nella scheda File fare clic su Stampa.

    • Per inviare il report direttamente alla stampante predefinita senza impostare le opzioni di stampa, fare clic su Stampa immediata.

    • Per aprire una finestra di dialogo nella quale selezionare una stampante, specificare il numero di copie e così via, fare clic su Stampa.

Inizio documento

Try Office 2010 today!

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Queste informazioni sono risultate utili?

Che cosa possiamo migliorare?

Che cosa possiamo migliorare?

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti