Accedi

Introduzione a SharePoint Designer 2010

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Microsoft SharePoint Designer 2010 un Web e il programma di progettazione di applicazioni utilizzate per la progettazione, creare, personalizzare i siti Web in esecuzione su SharePoint Foundation 2010 e Microsoft SharePoint Server 2010. Con SharePoint Designer 2010, è possibile creare pagine Web in formato RTF di dati, creare potenti soluzioni basate su flusso di lavoro e progettare l'aspetto del sito.

Utilizzare i collegamenti seguenti per altre informazioni sull' SharePoint Designer 2010 attraverso articoli, video e altre risorse di formazione. Usare le procedure descritte di seguito per informazioni sulle attività di base che è possibile eseguire in SharePoint Designer 2010.

Logo dell'introduzione

Ciò che è wan t

A chi g o

Si desidera ottenere informazioni specifiche sulle nuove caratteristiche   

Conoscere le novità di questa versione e scoprire come ottenere il massimo vantaggio dalle nuove caratteristiche.

Novità di SharePoint Designer 2010

Per conoscere i menu e i comandi della versione 2007   

Consultare questa cartella di lavoro di mapping contenente una tabella con i comandi dei menu e delle barre degli strumenti della versione 2007 e le rispettive nuove posizioni.

Guide di mapping per le applicazioni di Microsoft Office

Per gli utenti che non hanno mai utilizzato SharePoint Designer   

Informazioni su quali SharePoint Designer 2010 è basato sui e su come sfruttare al meglio è all'interno dell'organizzazione.

Introduzione a SharePoint Designer 2010

Per ricevere formazione per sé e per altri membri del team   

Diventare più produttivi in questa versione di formazione su SharePoint Designer 2010.

Corsi di formazione per Microsoft Office

Attività di base in SharePoint Designer 2010

Aprire e creare siti di SharePoint

Creare elenchi, raccolte e connessioni a origini dati

Creare visualizzazione e moduli personalizzati

Creare flussi di lavoro personalizzati

Progettare pagine sito, pagine master e layout di pagina

Salvare come modello

Aprire e creare siti di SharePoint

In SharePoint Designer 2010, è possibile aprire i siti di SharePoint esistenti sul server e avvia la personalizzazione ed è possibile creare nuovi siti in base a modelli di sito di SharePoint o siti di nuovi e vuoti personalizzabile da zero.

Aprire siti

Per aprire un sito esistente, fare clic sulla scheda File, scegliere Siti ed eseguire una delle operazioni seguenti:

  • Fare clic su Apri sito per sfogliare i siti disponibili sul server.

  • Fare clic su Personalizza sito personale per aprire e personalizzare il sito personale.

  • In Siti recenti selezionare un sito utilizzato in precedenza.

Creare siti

Per creare un nuovo sito, fare clic sulla scheda File, scegliere Siti ed eseguire una delle operazioni seguenti:

  • Fare clic su Nuovo sito Web vuoto per creare un sito di SharePoint vuoto.

  • Fare clic su Aggiungi sito secondario a sito personale per creare un nuovo sito in Sito personale.

  • In Modelli di sito selezionare un modello per creare un nuovo sito basato su un modello di SharePoint.

Nota : Oltre alle apertura e la creazione di siti SharePoint Designer 2010, è possibile aprire un sito di SharePoint tramite un browser e quindi aprire il sito in SharePoint Designer 2010 mediante i collegamenti disponibili nel menu Azioni sito, la barra multifunzione e da altre posizioni in SharePoint.

Inizio pagina

Creare elenchi, raccolte e connessioni a origini dati

In SharePoint Designer 2010, è possibile creare elenchi e raccolte, in genere utilizzate come origine dati per i siti di SharePoint, ed è possibile creare connessioni a origini dati in file XML, database esterni e servizi Web.

Elenchi e raccolte SharePoint

Per creare un elenco o una raccolta SharePoint, fare clic su Elenchi e raccolte nel riquadro di spostamento e scegliere una delle opzioni seguenti nella scheda Elenchi e raccolte:

  • Fare clic su Elenco personalizzato per creare un elenco vuoto da zero.

  • Fare clic su Elenco SharePoint per creare un elenco basato su un modello di elenco di SharePoint.

  • Fare clic su Raccolta documenti per creare una raccolta basata su un modello di raccolta di SharePoint.

  • Fare clic su Elenco esterno per creare un elenco esterno basato su un tipo di contenuto esterno. I tipi di contenuto esterno sono illustrati più avanti.

  • Fare clic su Elenco da foglio di calcolo per creare un elenco basato su un foglio di calcolo importato.

Connessioni all'origine dati

Per creare una connessione all'origine dati, fare clic su Origini dati nel riquadro di spostamento e scegliere una delle opzioni seguenti nella scheda Origini dati.

  • Fare clic su Origine dati collegata per creare una connessione dati a più origini dati.

  • Fare clic su Connessione di database per creare una connessione dati a un database che supporta il protocollo OLE DB o ODBC.

  • Fare clic su Connessione a servizio SOAP per creare una connessione a un servizio Web XML utilizzando SOAP (Simple Object Access Protocol).

  • Fare clic su Connessione a servizio REST per creare una connessione a uno script sul lato server utilizzando REST (Representational State Transfer).

  • Fare clic su Connessione a file XML per creare una connessione a un file di origine XML.

Tipi di contenuto esterno

Tramite i tipi di contenuto esterno è possibile connettersi a origini dati business esterne e integrare tali origini nel sito di SharePoint e nelle applicazioni client supportate. Dopo la creazione di un tipo di contenuto esterno, è possibile creare elenchi esterni che consentono agli utenti di interagire con i dati come se provenissero da un elenco o da una raccolta SharePoint.

Per creare un tipo di contenuto esterno, eseguire questi passaggi.

  1. Fare clic su Tipi di contenuto esterno nel riquadro di spostamento.

  2. Nella scheda Tipi di contenuto esterno fare clic su Tipo di contenuto esterno e quindi progettare le operazioni, i campi e gli altri elementi del tipo di contenuto esterno.

Inizio pagina

Creare visualizzazione e moduli personalizzati

In SharePoint Designer 2010, è possibile creare visualizzazioni e moduli personalizzati per le origini dati, acquisire l'interfaccia per leggere e scrivere dati a tali origini dati.

Viste

Una visualizzazione è una visualizzazione dinamica personalizzabile di un'origine dati che può essere aggiunti in qualsiasi pagina di SharePoint. In SharePoint Designer 2010 è possibile creare visualizzazioni elenco (che utilizzano la Web Part visualizzazione elenco XSLT) e visualizzazioni dati (che utilizzano la Web Part modulo dati). Eseguire una delle operazioni seguenti per creare una visualizzazione dati o elenco.

  • Nel riquadro di spostamento fare clic su Elenchi e raccolte, selezionare l'elenco per il quale si desidera creare una visualizzazione e quindi nella scheda Impostazioni elenco fare clic su Visualizzazione elenco.

    Nota : Verrà creata una visualizzazione associata all'elenco o alla raccolta. Di conseguenza, gli utenti vedranno la visualizzazione e potranno personalizzarla tramite il gruppo Gestione visualizzazioni nella barra multifunzione di SharePoint.

  • Nel riquadro di spostamento fare clic su Pagine sito, modificare la pagina in cui si desidera creare la visualizzazione, fare clic sulla scheda Inserisci, scegliere Visualizzazione dati e quindi scegliere l'elenco o la raccolta SharePoint che si desidera utilizzare per la visualizzazione.

Moduli

La maschera è una visualizzazione personalizzabile di un'origine dati da utilizzare per inviare o rispondere all'origine dati. In SharePoint Designer 2010 è possibile creare moduli elenco e moduli di dati (che utilizzano entrambi la Web Part modulo dati). Eseguire una delle operazioni seguenti per creare un modulo dati o elenco.

  • Nel riquadro di spostamento fare clic su Elenchi e raccolte, selezionare l'elenco per il quale si desidera creare un modulo e quindi nella scheda Impostazioni elenco fare clic su Modulo elenco.

  • Nel riquadro di spostamento fare clic su Pagine sito, modificare la pagina in cui si desidera creare il modulo, fare clic sulla scheda Inserisci, scegliere Modulo nuovo elemento, Modulo modifica elementi oppure Modulo visualizzazione elementi e selezionare l'origine dati che si desidera utilizzare per il modulo.

Nota : Oltre a utilizzare gli strumenti di progettazione di moduli in SharePoint Designer 2010, è possibile creare e personalizzare i moduli di SharePoint tramite Microsoft InfoPath 2010.

Inizio pagina

Creare flussi di lavoro personalizzati

In SharePoint Designer 2010, è possibile gestire i processi aziendali tramite flussi di lavoro altamente personalizzati. Flussi di lavoro può essere usati per gestire i processi di applicazione e i processi di collaborazione umani. Sono disponibili diverse opzioni di creazione di flussi di lavoro.

Creare flussi di lavoro in SharePoint Designer 2010

Quando si crea un flusso di lavoro, è possibile crearne uno basato su un elenco o una raccolta SharePoint, creare un flusso di lavoro riutilizzabile che può essere applicato a qualsiasi elenco o raccolta oppure creare un flusso di lavoro sito che funzioni a livello di sito.

Per creare questi flussi di lavoro, fare clic su Flussi di lavoro nel riquadro di spostamento e quindi nella scheda Flussi di lavoro eseguire uno dei passaggi seguenti:

  • Fare clic su Flusso di lavoro elenco e scegliere l'elenco al quale si desidera associare il flusso di lavoro.

  • Fare clic su Flusso di lavoro riutilizzabile per creare un flusso di lavoro riutilizzabile che può essere associato a qualsiasi elenco o raccolta.

  • Fare clic su Flusso di lavoro sito per creare un flusso di lavoro che può essere applicato a livello di sito.

Dopo la creazione del flusso di lavoro, utilizzare Progettazione flussi di lavoro per strutturarne le condizioni, le azioni e i passaggi. Utilizzare Progettazione flussi di lavoro per gestire gli eventi associati a ogni attività.

Importare i flussi di lavoro da Microsoft Visio 2010

Oltre a creare flussi di lavoro in SharePoint Designer 2010, è possibile importare un flusso di lavoro progettato in Microsoft Visio 2010 utilizzando il flusso di lavoro fornito stencil e modelli.

Per importare un flusso di lavoro, fare clic su Flussi di lavoro nel riquadro di spostamento e quindi nella scheda Flussi di lavoro eseguire i passaggi seguenti:

  1. Fare clic su Importa da Visio e quindi cercare nel file system o nella raccolta documenti di SharePoint il file Visio Workflow Interchange (con estensione vwi).

  2. Scegliere se associare il flusso di lavoro a un elenco o se renderlo riutilizzabile e fare clic su Fine.

  3. Iniziare a personalizzare il flusso di lavoro in SharePoint Designer.

Inizio pagina

Progettare pagine sito, pagine master e layout di pagina

In SharePoint Designer 2010, è possibile creare e personalizzare pagine del sito, pagine master e layout di pagina. Sebbene ognuna di queste pagine svolge un ruolo diverso, la modifica esperienza della pagina è simile. È possibile aggiungere e rimuovere testo, immagini, collegamenti, tabelle, le Web part, controlli server e altro. Applicare le definizioni di stile e fogli di stile CSS per le pagine master e layout di pagina per modificare l'aspetto del sito o personalizzare in modo che corrisponda l'identità aziendale.

Pagine del sito

Per creare una pagina del sito, fare clic su Pagine sito nel riquadro di spostamento e quindi nella scheda Pagine eseguire uno dei passaggi seguenti:

  • Fare clic su Pagina web part per creare una pagina che contiene web part di intestazione e corpo e che verrà anche associata alla pagina master del sito.

  • Fare clic su Pagina e scegliere ASPX o HTML per creare una pagina del sito vuota, non associata alla pagina master del sito.

Pagine master

  • Fare clic su Pagine master nel riquadro di spostamento e quindi nella scheda Pagine master scegliere Pagina master vuota.

Layout di pagina

  • Fare clic su Layout di pagina nel riquadro di spostamento e quindi nella scheda Layout di pagina fare clic su Nuovo layout di pagina e scegliere il gruppo di tipi di contenuto e il nome per il layout di pagina.

Nota : Pagine master e layout di pagina sono disabilitate per impostazione predefinita per tutti gli utenti ad eccezione di amministratori della raccolta siti. Se l'opzione per visualizzare o modificare le pagine master o layout di pagina in SharePoint Designer 2010 non è visualizzata, contattare l'amministratore del sito sull'attivazione di queste opzioni.

Inizio pagina

Salvare come modello

Al termine della personalizzazione del sito, è possibile salvare il sito o parti di esso come modello in modo che altre persone nell'organizzazione possano utilizzarlo per creare elenchi, visualizzazioni, flussi di lavoro, pagine sito e altro ancora.

È inoltre possibile utilizzare il modello per personalizzare ulteriormente il sito in un altro ambiente o da parte di altri utenti, ad esempio nel browser o in Microsoft Visual Studio.

Cercare l'opzione Salva come modello in SharePoint Designer 2010 sfruttare questa funzionalità.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.



Queste informazioni sono risultate utili?

Che cosa possiamo migliorare?

Che cosa possiamo migliorare?

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti