Inserire una tabella ripetuta orizzontale

Quando si desidera consentire agli utenti di aggiungere colonne a una tabella, è possibile utilizzare una tabella ripetuta orizzontale nel modello di modulo di Microsoft Office InfoPath.

Contenuto dell'articolo

Quando utilizzare una tabella ripetuta orizzontale

Esperienza dell'utente

Considerazioni sulla compatibilità

Inserire una tabella ripetuta orizzontale

Suggerimenti relativi al layout

Quando utilizzare una tabella ripetuta orizzontale

Una tabella ripetuta orizzontale può essere utilizzata quando si desidera che i dati vengano inseriti o visualizzati in formato tabulare strutturato e per permettere agli utenti di aggiungere ulteriori colonne di dati, se necessario. È possibile ad esempio utilizzare una tabella ripetuta orizzontale per raccogliere i dati sulle vendite di ogni trimestre. Se il modello di modulo è associato a un database, è altresì possibile utilizzare una tabella ripetuta orizzontale per visualizzare o lavorare con i record di quel database.

Una tabella ripetuta orizzontale è composta da una sezione ripetuta all'interno di una tabella layout. La sezione ripetuta presenta l'impostazione Ripeti orizzontalmente abilitata, che simula una colonna di una tabella.

Nell'esempio seguente, gli utenti possono aggiungere ulteriori colonne alla tabella se desiderano registrare i dati di vendita per i vari trimestri.

Dati di vendita inseriti in tabella ripetuta orizzontale nel modulo

Una tabella ripetuta orizzontale è composta da due parti:

  • Colonna di intestazione    Quando si inserisce una tabella ripetuta orizzontale in un nuovo modello di modulo vuoto, la colonna di intestazione viene visualizzata per impostazione predefinita. Questa colonna è generalmente utilizzata per inserire le etichette visualizzate lungo il lato sinistro della tabella. Se le etichette non sono necessarie, fare clic con il pulsante destro del mouse all'interno della colonna, scegliere Elimina dal menu di scelta rapida e quindi fare clic su Colonne.

  • Colonna di dati    La colonna di dati è la colonna che può essere ripetuta tutte le volte che è necessario. Chi progetta il modello di modulo vede una sola colonna in modalità progettazione quando inserisce una tabella ripetuta orizzontale. L'utente che compila un modulo basato sul modello di modulo può aggiungere più colonne nel modulo premendo CTRL+INVIO, facendo clic sui comandi del menu di scelta rapida oppure facendo clic sul testo informativo Inserisci elemento nel modulo che desidera personalizzare.

Controlli correlati

In InfoPath sono disponibili altri controlli simili alle tabelle ripetute orizzontali, ma utilizzati per scopi diversi. Per decidere quale di questi controlli fa al caso proprio, leggere attentamente l'elenco seguente:

Tabella ripetuta    Se si desidera consentire agli utenti di aggiungere righe anziché colonne a una tabella, utilizzare una tabella ripetuta anziché una tabella ripetuta orizzontale.

Sezione ripetuta    Per creare una sezione che gli utenti possano inserire più volte in un modulo, ad esempio un record di database, utilizzare una sezione ripetuta o un altro controllo ripetuto. Quando gli utenti inseriscono una sezione ripetuta in un modulo, le singole sezioni vengono inserite in verticale, ovvero una al di sotto dell'altra nel senso della lunghezza del modulo. Questo comportamento è diverso rispetto a quello delle sezioni ripetute di una tabella ripetuta orizzontale, dove le singole sezioni vengono inserite in orizzontale, ovvero una di fianco all'altra nel senso della larghezza del modulo.

Torna all'inizio

Esperienza dell'utente

Quando gli utenti posizionano il puntatore in corrispondenza di una colonna di una tabella ripetuta orizzontale, viene visualizzato un pulsante del menu di scelta rapida. Facendo clic su questo pulsante viene visualizzato un menu di scelta rapida contenente i comandi per inserire o rimuovere una colonna.

Menu di scelta rapida per tabella ripetuta orizzontale

Gli utenti possono inserire una nuova colonna anche facendo clic sul testo informativo Inserisci elemento visualizzato al di sotto della tabella ripetuta orizzontale nel modulo. È possibile personalizzare o rimuovere questo testo in fase di progettazione del modello di modulo. Qualsiasi colonna che supera la larghezza della tabella layout contenente il controllo sezione ripetuta andrà a capo sulla riga successiva.

Torna all'inizio

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo in InfoPath, è possibile scegliere di realizzare un modello di modulo compatibile con browser. In questo caso i controlli tabella ripetuta orizzontale non saranno disponibili nel riquadro attività Controlli in quanto si tratta di controlli che non possono essere visualizzati in un browser.

Torna all'inizio

Inserire una tabella ripetuta orizzontale

La procedura di inserimento di una tabella ripetuta orizzontale si differenzia leggermente a seconda che si progetti un nuovo modello di modulo vuoto o che si basi la progettazione del modello di modulo su un database o su altra origine dati esterna.

Nella figura seguente viene illustrato l'aspetto di una tabella ripetuta orizzontale quando si posiziona il puntatore al di sopra della tabella in modalità progettazione.

Sezione ripetuta selezionata in tabella ripetuta orizzontale

I controlli possono essere associati o non associati. Un controllo associato è collegato a un campo o a un gruppo nell'origine dati affinché i dati immessi nel controllo vengano salvati nel file del modulo (xml) sottostante. Un controllo non associato non è collegato a un campo o a un gruppo e i dati immessi non vengono salvati. Quando si seleziona un controllo o vi si sposta il puntatore sopra, nell'angolo superiore destro del controllo vengono visualizzati un testo e un'icona di associazione. Il testo indica il gruppo o il campo cui è associato il controllo nell'origine dati. L'icona indica se il controllo è associato in modo corretto al gruppo o campo. Quando l'associazione è corretta, viene visualizzata un'icona verde. In caso di problemi relativi all'associazione, viene invece visualizzata un'icona blu o rossa.

L'origine dati del modello di modulo è composta da campi e gruppi organizzati gerarchicamente nel riquadro attività Origine dati. Le tabelle ripetute orizzontali sono solitamente associate a gruppo ripetuto nell'origine dati del modello di modulo, sebbene possano essere associate anche a campo ripetuto.

Nell'esempio seguente, la tabella presente nel modello di modulo è associata al gruppo ripetuto quarter nel riquadro attività Origine dati. I controlli casella di testo contenuti nella tabella, Golf, Tennis e Windsurf, sono associati a campi che appartengono al gruppo ripetuto quarter.

Relazione tra tabella ripetuta orizzontale nel modello di modulo e gruppo ripetuto corrispondente nell'origine dati

Inserire una tabella ripetuta orizzontale in un nuovo modello di modulo vuoto

Quando si progetta un nuovo modello di modulo vuoto, la casella di controllo Crea automaticamente origine dati nel riquadro attività Controlli è selezionata per impostazione predefinita. In questo modo, tramite InfoPath vengono automaticamente creati campi e gruppi nell'origine dati man mano che si aggiungono controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.

  1. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il controllo.

  2. Se il riquadro attività Controlli non è visualizzato, scegliere Altri controlli dal menu Inserisci oppure premere ALT+I, C.

  3. In Inserisci controlli fare clic su Tabella ripetuta orizzontale.

  4. Nella casella Numero di righe immettere il numero di righe predefinite per la tabella.

  5. Nella tabella ripetuta orizzontale viene inserita una casella di testo in ogni colonna di dati. Per convertire la casella di testo in un tipo di controllo diverso, fare clic con il pulsante destro del mouse sul controllo, scegliere Cambia in dal menu di scelta rapida e quindi fare clic sul controllo desiderato.

Inserire una tabella ripetuta orizzontale in un modello di modulo basato su un'origine dati esistente

Se si basa la progettazione del modello di modulo su un file, un database o un servizio Web (Extensible Markup Language) esistente, i campi e i gruppi del riquadro attività Origine dati verranno derivati dall'origine dati esistente. In questo scenario è possibile inserire una tabella ripetuta orizzontale trascinando un gruppo ripetuto dal riquadro attività Origine dati direttamente nel modello di modulo oppure inserendo una tabella ripetuta orizzontale dal riquadro attività Controlli come descritto nella procedura seguente:

  1. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il controllo.

  2. Se il riquadro attività Controlli non è visualizzato, scegliere Altri controlli dal menu Inserisci oppure premere ALT+I, C.

  3. Nel gruppo Inserisci controlli fare clic su Tabella ripetuta orizzontale.

  4. Nella prima pagina della procedura guidata Associazione tabella ripetuta fare clic sull'origine dati che si desidera utilizzare nell'elenco Origine dati e quindi sul gruppo ripetuto Icona del pulsante a cui associare le righe della tabella.

    Suggerimento : Per creare un nuovo gruppo ripetuto, fare clic con il pulsante destro del mouse sul gruppo a cui si desidera aggiungere il gruppo ripetuto, scegliere Aggiungi dal menu di scelta rapida e nella finestra di dialogo Aggiungi campo o gruppo specificare le proprietà del gruppo ripetuto.

  5. Fare clic su Avanti.

  6. Nella seconda pagina della procedura guidata Associazione tabella ripetuta fare doppio clic sui campi dell'elenco Associazione dati che si desidera aggiungere come colonne alla tabella.

    Suggerimento : Per creare un nuovo campo, nell'elenco Associazione dati fare clic con il pulsante destro del mouse sul gruppo a cui è associata la tabella ripetuta orizzontale, scegliere Aggiungi dal menu di scelta rapida e infine nella finestra di dialogo Aggiungi campo o gruppo specificare le proprietà per il campo.

  7. Per riordinare le colonne, selezionare una colonna nell'elenco Righe nella tabella e quindi fare clic su Sposta prima o Sposta dopo.

Torna all'inizio

Suggerimenti relativi al layout

I suggerimenti riportati di seguito aiutano a perfezionare l'aspetto, le dimensioni e altri elementi di una tabella ripetuta orizzontale e dei controlli al suo interno:

  • Tenere sempre presente che una tabella ripetuta orizzontale è composta da una sezione ripetuta contenuta all'interno di una tabella layout. Il bordo destro della tabella layout definisce il punto in cui le colonne della tabella vanno a capo sulla riga successiva quando l'utente inserisce colonne aggiuntive. Per controllare la disposizione delle colonne, è possibile trascinare verso destra o verso sinistra il bordo destro della cella della tabella layout che racchiude il controllo sezione ripetuta.

  • Una tabella ripetuta orizzontale può essere utile in fase di stampa. Il fatto che le colonne del controllo vadano a capo sulla riga successiva nel modello di modulo garantisce infatti che tutte le informazioni contenute nella tabella vengano stampate. Se invece il modello di modulo è destinato principalmente alla visualizzazione su schermo, valutare la possibilità di inserire la tabella ripetuta orizzontale all'interno di un'area scorrevole nel modello di modulo. In questo modo, se nella tabella ripetuta orizzontale vengono inseriti molti dati, sarà possibile scorrere l'area per visualizzarli anziché doverli comprimere tutti nel modulo.

  • Per modificare le dimensioni di più caselle di testo contemporaneamente, selezionare le caselle di testo su cui si desidera intervenire, premere ALT+INVIO e apportare le modifiche necessarie nella scheda Dimensioni.

  • Ridimensionare le caselle di testo nel modello di modulo in modo che contengano tutto il testo che gli utenti inseriranno.

  • Per cambiare il bordo o il colore di più caselle di testo contemporaneamente, selezionare le caselle di testo su cui si desidera intervenire, scegliere Bordi e sfondo dal menu Formato, fare clic sulla scheda Bordi e quindi apportare le modifiche necessarie.

  • Per personalizzare il testo visualizzato in una casella di testo, utilizzare le caselle Tipo di carattere e Dimensione carattere sulla barra degli strumenti Formattazione. Per modificare contemporaneamente il tipo di carattere e la dimensione del testo di tutte le caselle di testo presenti nel modello di modulo, fare clic sulla casella di testo che presenta la formattazione desiderata e scegliere Applica tipo di carattere a tutti i controlli Casella di testo dal menu Formato.

  • Per vedere l'aspetto che le caselle di testo assumeranno dopo avere inserito il testo, scegliere Dati di esempio dal menu Visualizza. Questo consente di farsi un'idea dell'aspetto che il modulo avrà una volta compilato dall'utente.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×