Inserire una tabella ripetuta

Se si desidera che gli utenti possano inserire informazioni in una tabella, è possibile aggiungere una tabella ripetuta al modello di modulo di Microsoft Office InfoPath. Nelle tabelle ripetute viene visualizzata una sola riga per impostazione predefinita. In fase di compilazione di un modulo basato sul modello di modulo, gli utenti possono tuttavia inserire ulteriori righe nella tabella a seconda delle esigenze. Se il modello di modulo include una connessione dati a un'origine dati esterna, ad esempio un database, sarà possibile utilizzare una tabella ripetuta per visualizzare automaticamente più record nel modulo.

Contenuto dell'articolo

Quando utilizzare una tabella ripetuta

Esperienza dell'utente

Inserire una tabella ripetuta

Suggerimenti relativi al layout

Quando utilizzare una tabella ripetuta

Una tabella ripetuta può essere utilizzata quando si desidera:

  • Consentire agli utenti di immettere dati in formato tabulare strutturato.

  • Raccogliere voci, dati numerici e altri tipi di dati adatti a essere organizzati in una tabella.

  • Conservare lo spazio nel modello di modulo visualizzando solo le righe contenenti dati effettivi.

  • Visualizzare o utilizzare record di un database, un servizio Web o altra origine dati all'interno di una tabella nel modello di modulo.

Nella figura seguente, una tabella ripetuta è utilizzata per raccogliere voci in un modulo nota spese.

Tabelle ripetute utilizzate per raccogliere voci di una nota spese

Le tabelle ripetute sono composte da tre parti:

  • Riga di intestazione    Quando si inserisce una tabella ripetuta in un nuovo modello di modulo vuoto, per impostazione viene visualizzata la riga di intestazione, utilizzata solitamente per contenere le intestazioni di colonna. Se le intestazioni di colonna non sono necessarie, deselezionare la casella di controllo Includi intestazione nella finestra di dialogo Proprietà - Tabella ripetuta.

  • Riga di dati    La riga di dati è la riga che può essere ripetuta nel modulo tutte le volte che è necessario. Chi progetta il modello di modulo vede una sola riga in modalità progettazione quando inserisce una tabella ripetuta, mentre l'utente che compila un modulo basato sul modello di modulo può aggiungere più righe nel modulo premendo CTRL+INVIO, facendo clic sui comandi del menu di scelta rapida oppure facendo clic sul testo informativo Inserisci elemento al di sotto dell'ultima riga della tabella.

  • Riga di piè di pagina    È possibile utilizzare la riga di piè di pagina per aggiungere caselle di testo o caselle di espressione in cui sommare i valori di una colonna. La riga di piè di pagina non è visualizzata nella tabella ripetuta per impostazione predefinita. Per abilitare la visualizzazione della riga di piè di pagina, selezionare la casella di controllo Includi piè di pagina nella finestra di dialogo Proprietà - Tabella ripetuta.

Controlli correlati

In Microsoft Office InfoPath sono disponibili altri controlli simili alle tabelle ripetute, ma utilizzati per scopi diversi. Per decidere quale di questi controlli fa al caso proprio, leggere attentamente l'elenco seguente:

Sezione ripetuta    Per creare una sezione meno strutturata, che gli utenti possano inserire più volte in un modulo, come ad esempio un record di database, utilizzare una sezione ripetuta anziché una tabella ripetuta.

Tabella ripetuta orizzontale    Quando si desidera che gli utenti possano aggiungere a una tabella ulteriori colonne anziché righe, utilizzare una tabella ripetuta orizzontale anziché una tabella ripetuta normale.

Torna all'inizio

Esperienza dell'utente

Quando gli utenti posizionano il puntatore in corrispondenza di una riga di una tabella ripetuta, viene visualizzato il pulsante del menu di scelta rapida. Facendo clic su questo pulsante viene visualizzato un menu di scelta rapida contenente i comandi per inserire o rimuovere una riga.

Shortcut menu for repeating table

Gli utenti possono inserire una nuova riga anche facendo clic sul testo informativo Inserisci elemento visualizzato al di sotto della tabella ripetuta nel modulo. È possibile personalizzare o rimuovere questo testo in fase di progettazione del modello di modulo.

Torna all'inizio

Inserire una tabella ripetuta

La procedura per inserire una tabella ripetuta si differenzia leggermente a seconda che si progetti un nuovo modello di modulo vuoto o che si basi la progettazione del modello di modulo su un database o su altra origine dati esterna.

Nella figura seguente viene illustrato l'aspetto di una tabella ripetuta in modalità progettazione.

Repeating table in design mode

I controlli possono essere associati o non associati. Un controllo associato è collegato a un campo o a un gruppo nell'origine dati affinché i dati immessi nel controllo vengano salvati nel file del modulo (xml) sottostante. Un controllo non associato non è collegato a un campo o a un gruppo e i dati immessi non vengono salvati. Quando si seleziona un controllo o vi si sposta il puntatore sopra, nell'angolo superiore destro del controllo vengono visualizzati un testo e un'icona di associazione. Il testo indica il gruppo o il campo cui è associato il controllo nell'origine dati. L'icona indica se il controllo è associato in modo corretto al gruppo o campo. Quando l'associazione è corretta, viene visualizzata un'icona verde. In caso di problemi relativi all'associazione, viene invece visualizzata un'icona blu o rossa.

L'origine dati del modello di modulo è composta da campi e gruppi organizzati gerarchicamente nel riquadro attività Origine dati. Le tabelle ripetute sono solitamente associate a gruppo ripetuto nell'origine dati del modello di modulo, sebbene possano essere associate anche a campo ripetuto.

Nell'esempio seguente, la tabella Dettagli spese nel modulo è associata al gruppo ripetuto item nel riquadro attività Origine dati. I controlli casella di testo contenuti nella tabella, Data, Descrizione, Categoria e Costo, sono associati a campi appartenenti al gruppo ripetuto item.

Relationship between repeating table on form template and repeating group in data source

Inserire una tabella ripetuta in un nuovo modello di modulo vuoto

Quando si progetta un nuovo modello di modulo vuoto, la casella di controllo Crea automaticamente origine dati nel riquadro attività Controlli è selezionata per impostazione predefinita. In questo modo, tramite InfoPath vengono automaticamente creati campi e gruppi nell'origine dati man mano che si aggiungono controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.

  1. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il controllo.

  2. Se il riquadro attività Controlli non è visualizzato, scegliere Altri controlli dal menu Inserisci oppure premere ALT+I, C.

  3. Nel gruppo Inserisci controlli fare clic su Tabella ripetuta.

  4. Nella colonna Numero di colonne immettere il numero di colonne che la tabella deve avere.

  5. Nella tabella ripetuta viene inserita una casella di testo in ogni colonna. Per convertire una casella di testo in un tipo di controllo diverso, fare clic con il pulsante destro del mouse sulla casella di testo, scegliere Cambia in dal menu di scelta rapida e quindi fare clic sul controllo desiderato.

Inserire una tabella ripetuta in un modello di modulo basato su un'origine dati esistente

Se si basa la progettazione del modello di modulo su un file, un database o un servizio Web (Extensible Markup Language) esistente, i campi e i gruppi del riquadro attività Origine dati verranno derivati dall'origine dati esistente. In questo scenario è possibile inserire una tabella ripetuta trascinando un gruppo ripetuto dal riquadro attività Origine dati nel modello di modulo oppure inserendo una tabella ripetuta dal riquadro attività Controlli come descritto nella procedura seguente:

  1. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il controllo.

  2. Se il riquadro attività Controlli non è visualizzato, scegliere Altri controlli dal menu Inserisci oppure premere ALT+I, C.

  3. Nel gruppo Inserisci controlli fare clic su Tabella ripetuta.

  4. Nella prima pagina della procedura guidata Associazione tabella ripetuta fare clic sull'origine dati che si desidera utilizzare nell'elenco Origine dati e quindi fare clic sul gruppo ripetuto Icona del pulsante a cui si desidera associare le righe della tabella.

    Suggerimento : Per creare un nuovo gruppo ripetuto, fare clic con il pulsante destro del mouse sul gruppo a cui si desidera aggiungere il gruppo ripetuto, scegliere Aggiungi dal menu di scelta rapida e nella finestra di dialogo Aggiungi campo o gruppo specificare le proprietà del gruppo ripetuto.

  5. Fare clic su Avanti.

  6. Nella seconda pagina della procedura guidata Associazione tabella ripetuta fare doppio clic sui campi presenti nell'elenco Associazione dati e che si desidera aggiungere come colonne alla tabella.

    Suggerimento : Per creare un nuovo campo, nell'elenco Associazione dati fare clic con il pulsante destro del mouse sul gruppo a cui è associata la tabella ripetuta, scegliere Aggiungi dal menu di scelta rapida e infine nella finestra di dialogo Aggiungi campo o gruppo specificare le proprietà per il campo.

  7. Per modificare l'ordine delle colonne, selezionare una colonna nell'elenco Colonne nella tabella e quindi fare clic su Sposta su o Sposta giù.

Torna all'inizio

Suggerimenti relativi al layout

I suggerimenti riportati di seguito aiutano a perfezionare l'aspetto, le dimensioni e altri elementi dei controlli all'interno di una tabella ripetuta:

  • Per modificare le dimensioni di più caselle di testo contemporaneamente, selezionare le caselle di testo su cui si desidera intervenire, scegliere Proprietà dal menu Formato e infine apportare le modifiche necessarie nella scheda Dimensioni.

  • Ridimensionare le caselle di testo nel modello di modulo in modo che contengano tutto il testo che gli utenti inseriranno nelle caselle.

  • Per cambiare il bordo o il colore dei controlli contenuti in una tabella ripetuta, selezionare le caselle di testo su cui si desidera intervenire, scegliere Bordi e sfondo dal menu Formato, fare clic sulla scheda Bordi e quindi apportare le modifiche necessarie.

  • Per personalizzare il testo visualizzato in una casella di testo all'interno di una tabella ripetuta, utilizzare le caselle Tipo di carattere e Dimensione carattere sulla barra degli strumenti Formattazione. Per modificare contemporaneamente il tipo di carattere e la dimensione del testo di tutte le caselle di testo del modello di modulo, fare clic sulla casella di testo che presenta la formattazione desiderata e scegliere Applica tipo di carattere a tutti i controlli Casella di testo dal menu Formato.

  • Per vedere l'aspetto che le caselle di testo assumeranno una volta inserito il testo, scegliere Dati di esempio dal menu Visualizza. Questo consente di farsi un'idea dell'aspetto che il modulo basato sul modello di modulo avrà una volta compilato dall'utente.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×