Inserire una casella di riepilogo a selezione multipla

Una casella di riepilogo a selezione multipla presenta un insieme di opzioni organizzato in forma di elenco scorrevole di caselle di controllo. In questo elenco gli utenti possono selezionare il numero di caselle di controllo desiderato. A seconda della progettazione della casella di riepilogo a selezione multipla, è anche possibile consentire agli utenti di immettere una voce di elenco personalizzata accanto a una delle caselle di controllo.

In questo articolo

Quando usare una casella di riepilogo a selezione multipla

Esperienza utente

Considerazioni sulla compatibilità

Inserire una casella di riepilogo a selezione multipla

Suggerimenti per il layout

Quando usare una casella di riepilogo a selezione multipla

Si può usare una casella di riepilogo a selezione multipla per:

  • Consentire agli utenti di selezionare più elementi da un elenco.

  • Consentire agli utenti di digitare un valore personalizzato in un elenco.

  • Visualizzare la maggior parte o tutte le voci di un elenco nel modulo per impostazione predefinita.

  • Visualizzare i valori recuperati da un elenco fisso, dall'origine dati del modello di modulo o da un'origine dati esterna, ad esempio un database o un elenco di Microsoft Windows SharePoint Services.

Nella figura seguente, gli utenti possono assegnare voci di spesa a più categorie in un modulo nota spese selezionando le caselle di controllo all'interno di una casella di riepilogo a selezione multipla. Chi ha progettato il modulo ha scelto di offrire agli utenti la possibilità di specificare categorie personalizzate. Gli utenti possono pertanto inserire un valore in una casella vuota accanto all'ultima casella di controllo dell'elenco.

Valore personalizzato aggiunto all'elenco di opzioni in una casella di riepilogo a selezione multipla

Dopo aver inserito una casella di riepilogo a selezione multipla in un modello di modulo, è necessario specificare i valori che dovranno essere visualizzati al suo interno. In caso contrario, quando gli utenti apriranno un modulo basato sul modello di modulo vedranno una casella vuota. Nella finestra di dialogo Proprietà - Casella di riepilogo a selezione multipla è possibile digitare direttamente le voci dell'elenco oppure configurare la casella di riepilogo a selezione multipla i modo che queste vengano recuperate da un database o da un'altra origine dati.

Controlli correlati

Microsoft Office InfoPath include controlli simili alle caselle di riepilogo a selezione multipla, ma che servono ad altri scopi. Per identificare il controllo ottimale per il proprio modello di modulo, fare riferimento all'elenco seguente:

Casella di riepilogo    In maniera analoga a una casella di riepilogo a selezione multipla, una casella di riepilogo standard consente agli utenti di selezionare valori da un elenco. Nel caso di una casella di riepilogo standard tuttavia, gli utenti possono selezionare una sola voce dall'elenco. Come in una casella di riepilogo a selezione multipla, anche in una casella di riepilogo standard vengono visualizzate tutte le voci dell'elenco per impostazione predefinita.

Casella di riepilogo a discesa    Analogamente a qualsiasi altro elenco, una casella di riepilogo a discesa offre agli utenti un elenco di scelte, che rimane però nascosto nel modulo finché gli utenti non fanno clic sul controllo. Gli utenti possono selezionare una sola voce da un elenco a discesa.

Casella combinata    Se si vuole consentire agli utenti di immettere valori personalizzati oppure di scegliere un valore da un elenco predefinito, è consigliabile usare una casella combinata anziché una casella di riepilogo a selezione multipla. In una casella combinata gli utenti possono selezionare una sola voce.

Pulsanti di opzione    Analogamente a una casella di riepilogo a selezione multipla, un gruppo di pulsanti di opzione consente agli utenti di effettuare una selezione da un elenco di opzioni. A differenza di quanto avviene per le caselle di riepilogo a selezione multipla, gli utenti possono selezionare una sola opzione in un gruppo di pulsanti di opzione. In più, per effettuare una scelta è necessario fare clic su un cerchiolino anziché su un elemento contenuto in una casella di riepilogo.

Inizio pagina

Esperienza utente

Nelle caselle di riepilogo a selezione multipla gli utenti effettuano le proprie scelte selezionando o deselezionando caselle di controllo all'interno di una casella nel modulo. Se il numero delle caselle di controllo supera l'altezza del controllo, sul lato destro della casella viene visualizzata una barra di scorrimento che vedere le opzioni restanti.

Si può progettare il modello di modulo in modo da consentire agli utenti di immettere ulteriori voci nell'elenco, se necessario. In questo caso, l'ultimo elemento dell'elenco sarà una casella di controllo con una casella di modifica.

Casella vuota in casella di riepilogo a selezione multipla

Per immettere un valore personalizzato, gli utenti devono selezionare la casella di controllo accanto alla casella di modifica e digitare il valore desiderato nell'area accanto alla casella di controllo Per consentire questa operazione, è necessario selezionare la casella di controllo Consenti agli utenti di immettere valori personalizzati nella finestra di dialogo Proprietà - Casella di riepilogo a selezione multipla quando si inserisce la casella di riepilogo a selezione multipla nel modello di modulo.

Inizio pagina

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo in InfoPath, è possibile scegliere di realizzare un modello di modulo compatibile con browser. In questo caso i controlli casella di riepilogo a selezione multipla non saranno disponibili nel riquadro attività Controlli, in quanto si tratta di controlli che non possono essere visualizzati in un Web browser.

Inizio pagina

Inserire una casella di riepilogo a selezione multipla

La procedura per inserire una casella di riepilogo a selezione multipla varia leggermente a seconda che si progetti un nuovo modello di modulo vuoto oppure che ci si basi su un database o un'altra origine dati esterna.

La figura seguente mostra l'aspetto di una casella di riepilogo a selezione multipla selezionata in modalità progettazione, prima dell'aggiunta manuale delle voci della casella di riepilogo da parte di chi progetta il modello di modulo.

Casella di riepilogo a selezione multipla vuota selezionata in modalità progettazione

I controlli possono essere associati o non associati. I controlli associati sono connessi a un campo o a un gruppo nell'origine dati, in modo che i dati immessi al loro interno vengano salvati in un file di modulo (con estensione xml) sottostante. I controlli non associati non sono connessi a un campo o a un gruppo, quindi i dati immessi al loro interno non vengono salvati. Se si seleziona o si sposta il puntatore su un controllo, nell'angolo superiore destro del controllo vengono visualizzati il testo e un'icona di associazione. Il testo indica il gruppo o il campo a cui il controllo è associato nell'origine dati. L'icona indica se il controllo è correttamente associato a tale gruppo o campo. Se l'associazione è corretta, viene visualizzata un'icona verde. Se invece c'è un errore, verrà visualizzata un'icona blu o rossa.

L'origine dati del modello di modulo è composta da campi e gruppi organizzati gerarchicamente nel riquadro attività Origine dati. Le caselle di riepilogo a selezione multipla sono sempre associate a campo ripetuto all'interno di un gruppo. I campi ripetuti consentono di archiviare più di un valore nel campo. Nell'esempio seguente, la casella di riepilogo a selezione multipla Categoria nel modello di modulo è associata al campo category nel riquadro attività Origine dati.

Relazione tra casella di riepilogo a selezione multipla nel modello di modulo e campo corrispondente nell'origine dati

Quando si progetta un nuovo modello di modulo vuoto, per impostazione predefinita è selezionata la casella di controllo Crea automaticamente origine dati del riquadro attività Controlli. In questo modo InfoPath può creare automaticamente campi e gruppi nell'origine dati quando vengono aggiunti controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.

Se il progetto del modello di modulo si basa su un file XML (Extensible Markup Language), un database o un servizio Web esistente, InfoPath ricava i campi e i gruppi del riquadro attività Origine dati da questa origine dati esistente.

Inserire una casella di riepilogo a selezione multipla

  1. Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Nel riquadro attività Controlli eseguire una delle operazioni seguenti:

    • Per creare automaticamente nell'origine dati un campo ripetuto associato alla casella di riepilogo a selezione multipla, selezionare la casella di controllo Crea automaticamente origine dati.

    • Per associare la casella di riepilogo a selezione multipla a un campo ripetuto esistente, deselezionare la casella di controllo Crea automaticamente origine dati.

      Nota : Se la casella di controllo non è disponibile, significa che l'origine dati è bloccata. Se ad esempio il progetto del modello di modulo si basa su un XML Schema, potrebbe non essere possibile aggiungere nuovi campi o gruppi all'origine dati in InfoPath. Questa restrizione impedisce di apportare modifiche involontarie allo schema che potrebbero renderlo non valido.

  4. In Inserisci controlli fare clic su Casella di riepilogo a selezione multipla.

  5. Se nel passaggio 3 è stata deselezionata la casella di controllo Crea automaticamente origine dati, nella finestra di dialogo Associazione casella di riepilogo a selezione multipla selezionare un campo ripetuto a cui associare la casella di riepilogo a selezione multipla.

  6. Nel modello di modulo digitare il testo dell'etichetta al di sopra o alla sinistra della casella di riepilogo a selezione multipla, seguito da due punti (:).

  7. Per specificare i valori da usare come voci dell'elenco, fare doppio clic sulla casella di riepilogo a selezione multipla.

  8. Fare clic sulla scheda Dati.

  9. Eseguire una delle operazioni seguenti per popolare la casella di riepilogo:

    Digitare manualmente i valori della casella di riepilogo

    Questa opzione è utile se si ha un insieme limitato e predeterminato di valori e non si prevede che tali valori cambino in futuro. Se i valori cambiano, è necessario pubblicare una versione aggiornata del modello di modulo, in modo che gli utenti possano vedere e usare le voci dell'elenco più recenti.

    1. Fare clic su Aggiungi.

    2. Nella casella Valore digitare il testo da archiviare se un utente seleziona questa voce.

    3. Nella casella Nome visualizzato digitare il testo da visualizzare per la voce, quindi fare clic su OK.

    4. Ripetere i passaggi da 1 a 3 per ogni voce da aggiungere alla casella di riepilogo.

    5. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

    Usare i valori di un'altra parte del modulo

    Questa opzione è utile se si vuole che i valori dell'elenco cambino in base ad altri valori immessi dagli utenti nel loro modulo.

    1. In Voci casella di riepilogo fare clic su Cerca valori nell'origine dati del modulo.

      Le voci della casella di riepilogo devono essere associate a uno specifico gruppo ripetuto o campo ripetuto nel modello di modulo.

    2. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul campo ripetuto o sul gruppo ripetuto che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    3. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento : Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

    Usare i valori di un database, un servizio Web, un documento XML o un sito di SharePoint

    Questa opzione è utile se si vuole che i valori di una casella di riepilogo vengano aggiornati regolarmente. I valori vengono in genere archiviati in un database o in un'altra origine dati esterna e vengono recuperati ogni volta che si apre il modulo.

    1. Fare clic su Cerca valori in un'origine dati esterna.

    2. Eseguire una delle operazioni seguenti:

      • Se è già stata aggiunta una connessione dati, selezionarla nella casella Connessione dati.

      • Per aggiungere una nuova connessione dati, fare clic su Aggiungi e quindi seguire le istruzioni della Connessione guidata dati.

        Le voci della casella di riepilogo devono essere associate a uno specifico campo ripetuto o gruppo ripetuto.

    3. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul gruppo o sul campo che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento : Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

  10. Se si vuole che gli utenti possano digitare valori personalizzati nella parte inferiore della casella di riepilogo a selezione multipla, selezionare la casella di controllo Consenti agli utenti di immettere valori personalizzati.

Inizio pagina

Suggerimenti per il layout

Usare i suggerimenti seguenti per perfezionare l'aspetto, le dimensioni e altri componenti della casella di riepilogo a selezione multipla:

  • Per cambiare la larghezza di diverse caselle di riepilogo a selezione multipla contemporaneamente, selezionare quelle con le dimensioni da cambiare, premere ALT+INVIO, fare clic sulla scheda Dimensioni e quindi digitare un nuovo numero nella casella Larghezza.

  • Per cambiare il colore di sfondo di diverse caselle di riepilogo a selezione multipla contemporaneamente, selezionare quelle da modificare. Nel menu Formato fare clic su Bordi e sfondo e quindi apportare le necessarie modifiche nella scheda Sfondo.

  • Per personalizzare il tipo di carattere che appare accanto alle caselle di controllo in una casella di riepilogo a selezione multipla, usare le caselle Tipo di carattere e Dimensioni carattere della barra degli strumenti Formattazione. Per cambiare contemporaneamente il tipo di carattere e le dimensioni del testo di tutte le caselle di riepilogo a selezione multipla presenti nel modello di modulo, fare clic sulla casella che contiene la formattazione desiderata e quindi scegliere Applica tipo di carattere a tutti i controlli Casella di riepilogo a selezione multipla dal menu Formato.

  • Per regolare la spaziatura tra una casella di riepilogo a selezione multipla e gli oggetti circostanti presenti nel modello di modulo, modificare le impostazioni dei margini nella scheda Dimensioni della finestra di dialogo Proprietà - Casella di riepilogo a selezione multipla. L'uso dei margini per aumentare o ridurre la spaziatura offre un miglior controllo rispetto all'impiego delle interruzioni di paragrafo.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×