Inserire una casella di riepilogo a discesa

È possibile usare un elenco a discesa in un modello di modulo di Microsoft Office InfoPath per presentare all'utente un elenco di opzioni che si escludono a vicenda. Questo elenco è nascosto finché l'utente non fa clic sulla freccia a destra dell'elenco a discesa.

In questo articolo

Quando usare un elenco a discesa

Esperienza utente

Inserire un elenco a discesa

Suggerimenti per il layout

Quando usare un elenco a discesa

Usare un elenco a discesa se si vuole:

  • Consentire agli utenti di effettuare una singola selezione in un elenco di elementi predefiniti.

  • Nascondere le voci dell'elenco nel modulo per impostazione predefinita.

  • Visualizzare i valori recuperati da un elenco fisso, dall'origine dati del modello di modulo o da un'origine dati esterna, ad esempio un database o un elenco di Microsoft Windows SharePoint Services.

Nella figura seguente gli utenti classificano le spese in un modulo di nota spese selezionando valori predefiniti in un elenco a discesa aperto.

Elemento selezionato in una casella di riepilogo a discesa aperta

Dopo aver inserito un elenco a discesa in un modello di modulo, è necessario specificare i valori che dovranno essere visualizzati al suo interno. In caso contrario, gli utenti vedranno un elenco vuoto quando fanno clic sulla freccia accanto all'elenco a discesa. Nella finestra di dialogo Casella di riepilogo a discesa - Proprietà è possibile immettere le voci manualmente oppure configurare l'elenco a discesa in modo che vengano recuperate da un database o da un'altra origine dati.

Controlli correlati

InfoPath include controlli simili agli elenchi a discesa ma che servono ad altri scopi. Per identificare il controllo ottimale per il proprio modello di modulo, fare riferimento all'elenco seguente:

Casella di riepilogo    Analogamente a un elenco a discesa, la casella di riepilogo consente agli utenti di selezionare un valore in un elenco. Tuttavia, a differenza dell'elenco a discesa, la casella di riepilogo visualizza l'intero elenco nel modulo. Se lo spazio non costituisce un problema nel modello di modulo, è consigliabile usare una casella di riepilogo, in quanto consente di cercare e selezionare più facilmente gli elementi.

Casella combinata    Analogamente a un elenco a discesa, la casella combinata consente agli utenti di selezionare un valore in un elenco. L'elenco è nascosto finché gli utenti non scelgono di visualizzarlo. Tuttavia, in una casella combinata gli utenti possono digitare un valore nell'elenco, oltre a effettuare una scelta tra i valori predefiniti.

Casella di riepilogo a selezione multipla    Se si vuole dare agli utenti la possibilità di scegliere più di un elemento di un elenco, è possibile usare una casella di riepilogo a selezione multipla al posto di un elenco a discesa. Le caselle di riepilogo a selezione multipla hanno la forma di due o più caselle di controllo all'interno di un elenco che è possibile scorrere.

Pulsanti di opzione    Analogamente a un elenco a discesa, i pulsanti di opzione consentono di effettuare una selezione in un elenco di opzioni che si escludono a vicenda. Tuttavia, con i pulsanti di opzione gli utenti fanno clic su un piccolo cerchio per effettuare una selezione invece che su un elemento di un elenco.

Inizio pagina

Esperienza utente

Le caselle di riepilogo sono simili di aspetto alle caselle combinate. Se si immettono manualmente gli elementi dell'elenco nella finestra di dialogo Casella di riepilogo a discesa - Proprietà quando si crea l'elenco a discesa, InfoPath visualizza il testo Seleziona come voce predefinita dell'elenco. In questo modo si indica agli utenti che devono effettuare una selezione nell'elenco a discesa. Se gli elementi dell'elenco provengono da valori di altre parti del modulo o da un'origine dati secondaria, il testo Seleziona viene omesso.

Quando gli utenti aprono per la prima volta un modulo, gli elementi dell'elenco degli elenchi a discesa sono nascosti. Per selezionare un elemento nell'elenco, gli utenti devono fare clic su una freccia accanto all'elenco a discesa e quindi sull'elemento desiderato.

Inizio pagina

Inserire un elenco a discesa

La procedura per inserire un elenco a discesa varia leggermente a seconda che venga progettato un nuovo modello di modulo vuoto oppure che ci si basi su un database o un'altra origine dati esterna.

La figura seguente mostra un elenco a discesa così come appare quando viene selezionato in modalità progettazione.

Casella di riepilogo a discesa selezionata in modalità progettazione

I controlli possono essere associati o non associati. I controlli associati sono connessi a un campo o a un gruppo nell'origine dati, in modo che i dati immessi al loro interno vengano salvati in un file di modulo (con estensione xml) sottostante. I controlli non associati non sono connessi a un campo o a un gruppo, quindi i dati immessi al loro interno non vengono salvati. Se si seleziona o si sposta il puntatore su un controllo, nell'angolo superiore destro del controllo vengono visualizzati il testo e un'icona di associazione. Il testo indica il gruppo o il campo a cui il controllo è associato nell'origine dati. L'icona indica se il controllo è correttamente associato a tale gruppo o campo. Se l'associazione è corretta, viene visualizzata un'icona verde. Se invece c'è un errore, verrà visualizzata un'icona blu o rossa.

L'origine dati per il modello di modulo è costituito da campi e gruppi disposti in una visualizzazione gerarchica nel riquadro attività Origine dati. Gli elenchi a discesa sono sempre associati a campi. Nell'esempio seguente l'elenco a discesa Categoria del modello di modulo è associato al campo category del riquadro attività Origine dati.

Relazione tra casella di riepilogo a discesa nel modello di modulo e campo corrispondente nell'origine dati

Quando si progetta un nuovo modello di modulo vuoto, per impostazione predefinita è selezionata la casella di controllo Crea automaticamente origine dati del riquadro attività Controlli. In questo modo InfoPath può creare automaticamente campi e gruppi nell'origine dati quando vengono aggiunti controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.

Se il progetto del modello di modulo si basa su un file XML (Extensible Markup Language), un database o un servizio Web esistente, InfoPath ricava i campi e i gruppi del riquadro attività Origine dati da questa origine dati esistente.

Inserire un elenco a discesa

  1. Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Nel riquadro attività Controlli eseguire una delle operazioni seguenti:

    • Per creare automaticamente un campo nell'origine dati associato alla casella di riepilogo, selezionare la casella di controllo Crea automaticamente origine dati.

    • Per associare la casella di riepilogo a un campo esistente, deselezionare la casella di controllo Crea automaticamente origine dati.

      Nota: Se la casella di controllo non è disponibile, significa che l'origine dati è bloccata. Se ad esempio il progetto del modello di modulo si basa su un XML Schema, potrebbe non essere possibile aggiungere nuovi campi o gruppi all'origine dati in InfoPath. Questa restrizione impedisce di apportare modifiche involontarie allo schema che potrebbero renderlo non valido.

  4. In Inserisci controlli fare clic su Casella di riepilogo a discesa.

  5. Se nel passaggio 3 è stata deselezionata la casella di controllo Crea automaticamente origine dati, nella finestra di dialogo Associazione casella di riepilogo a discesa selezionare un campo a cui associare la casella di riepilogo.

  6. Per aggiungere un'etichetta al controllo, digitare il testo sopra o a sinistra del controllo, seguito da due punti (:).

  7. Per specificare i valori da usare come voci dell'elenco, fare doppio clic sull'elenco a discesa.

  8. Fare clic sulla scheda Dati.

  9. Eseguire una delle operazioni seguenti per popolare la casella di riepilogo:

    Digitare manualmente i valori della casella di riepilogo

    Questa opzione è utile se si ha un insieme limitato e predeterminato di valori e non si prevede che tali valori cambino in futuro. Se i valori cambiano, è necessario pubblicare una versione aggiornata del modello di modulo, in modo che gli utenti possano vedere e usare le voci dell'elenco più recenti.

    1. Fare clic su Aggiungi.

    2. Nella casella Valore digitare il testo da archiviare se un utente seleziona questa voce.

    3. Nella casella Nome visualizzato digitare il testo da visualizzare per la voce, quindi fare clic su OK.

    4. Ripetere i passaggi da 1 a 3 per ogni voce da aggiungere alla casella di riepilogo.

    5. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

    Usare i valori di un'altra parte del modulo

    Questa opzione è utile se si vuole che i valori dell'elenco cambino in base ad altri valori immessi dagli utenti nel loro modulo.

    1. In Voci casella di riepilogo fare clic su Cerca valori nell'origine dati del modulo.

      Le voci della casella di riepilogo devono essere associate a uno specifico gruppo ripetuto o campo ripetuto nel modello di modulo.

    2. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul campo ripetuto o sul gruppo ripetuto che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    3. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento: Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

    Usare i valori di un database, un servizio Web, un documento XML o un sito di SharePoint

    Questa opzione è utile se si vuole che i valori di una casella di riepilogo vengano aggiornati regolarmente. I valori vengono in genere archiviati in un database o in un'altra origine dati esterna e vengono recuperati ogni volta che si apre il modulo.

    1. Fare clic su Cerca valori in un'origine dati esterna.

    2. Eseguire una delle operazioni seguenti:

      • Se è già stata aggiunta una connessione dati, selezionarla nella casella Connessione dati.

      • Per aggiungere una nuova connessione dati, fare clic su Aggiungi e quindi seguire le istruzioni della Connessione guidata dati.

        Le voci della casella di riepilogo devono essere associate a uno specifico campo ripetuto o gruppo ripetuto.

    3. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul gruppo o sul campo che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento: Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

Inizio pagina

Suggerimenti per il layout

Usare i suggerimenti seguenti per perfezionare l'aspetto, le dimensioni e altri componenti dell'elenco a discesa:

  • È consigliabile allargare l'elenco a discesa in modo che sia poco più grande della larghezza media degli elementi dell'elenco. In questo modo, gli elementi dell'elenco non verranno parzialmente nascosti.

  • Per cambiare la larghezza di diversi elenchi a discesa contemporaneamente, selezionare quelli con le dimensioni da cambiare, premere ALT+INVIO, fare clic sulla scheda Dimensioni e quindi digitare un nuovo numero nella casella Larghezza.

  • Per cambiare il colore di sfondo di diversi elenchi a discesa contemporaneamente, selezionare quelli da cambiare. Nel menu Formato fare clic su Bordi e sfondo e quindi apportare le necessarie modifiche nella scheda Sfondo.

  • Per personalizzare il tipo di carattere che appare nell'elenco a discesa, usare le caselle Tipo di carattere e Dimensioni carattere della barra degli strumenti Formattazione. Per cambiare il tipo e le dimensioni del carattere per tutti gli elenchi a discesa del modello di modulo contemporaneamente, fare clic su quelli che contengono la formattazione desiderata e quindi scegliere Applica tipo di carattere a tutti i controlli di tipo elenco a discesa dal menu Formato.

  • Se si vuole aumentare la spaziatura tra un elenco a discesa e gli oggetti circostanti nel modello di modulo, è possibile regolare le impostazioni dei margini nella finestra di dialogo Casella di riepilogo a discesa - Proprietà (scheda Dimensioni). L'uso dei margini per aumentare la spaziatura offre un controllo maggiore rispetto all'uso delle interruzioni di paragrafo.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×