Inserire una casella di riepilogo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile utilizzare una casella di riepilogo in un modello di modulo di Microsoft Office InfoPath per presentare all'utente un elenco di opzioni che si escludono a vicenda.

Contenuto dell'articolo

Quando utilizzare una casella di riepilogo

Esperienza dell'utente

Inserire una casella di riepilogo

Suggerimenti relativi al layout

Quando utilizzare una casella di riepilogo

Una casella di riepilogo può essere utilizzata quando si desidera:

  • Consentire agli utenti di scegliere una sola opzione da un elenco di elementi predefiniti.

  • Visualizzare i valori recuperati da un elenco fisso, dall'origine dati del modello di modulo oppure da un'origine dati esterna, ad esempio un database o un elenco Microsoft Windows SharePoint Services.

Nella figura seguente, gli utenti classificano le spese in un modulo nota spese selezionando i valori appropriati da una casella di riepilogo.

Elemento selezionato in una casella di riepilogo

Dopo avere inserito una casella di riepilogo nel modello di modulo, è necessario specificare i valori che si desidera verranno visualizzati nella casella. In caso contrario, quando gli utenti apriranno un modulo basato sul modello di modulo vedranno un elenco vuoto. Nella finestra di dialogo Proprietà - Casella di riepilogo è possibile digitare direttamente le voci dell'elenco oppure configurare la casella di riepilogo in modo che vengano recuperate da un database o da altra origine dati.

Controlli correlati

In Microsoft Office InfoPath sono disponibili altri controlli simili alle caselle di riepilogo, ma utilizzati per scopi diversi. Per decidere quale di questi controlli fa al caso proprio, leggere attentamente l'elenco seguente:

Casella di riepilogo a discesa    In maniera analoga a una casella di riepilogo, una casella di riepilogo a discesa offre agli utenti un elenco di opzioni, che tuttavia rimane nascosto nel modulo fino a quando l'utente non fa clic sulla freccia accanto alla casella di riepilogo a discesa. Se si ha intenzione di presentare agli utenti un numero elevato di scelte all'interno dell'elenco oppure se lo spazio all'interno del modello di modulo è limitato, è consigliabile utilizzare una casella di riepilogo a discesa.

Casella combinata    In maniera analoga a una casella di riepilogo, una casella combinata offre agli utenti un elenco di opzioni, che tuttavia rimane nascosto nel modulo fino a quando l'utente non fa clic sulla freccia accanto alla casella combinata. In una casella combinata, oltre a effettuare una scelta all'interno di un elenco di voci predefinite, gli utenti possono anche digitare delle voci personalizzate.

Casella di riepilogo a selezione multipla    Se si desidera che gli utenti possano scegliere più di un'opzione da un elenco, è possibile utilizzare una casella di riepilogo a selezione multipla anziché una casella di riepilogo. In una casella di riepilogo a selezione multipla gli utenti effettuano le proprie scelte selezionando una o più caselle di controllo anziché facendo clic su un valore in un elenco. Come nel caso delle caselle di riepilogo standard, le voci presenti in una casella di riepilogo a selezione multipla sono visibili la prima volta che gli utenti aprono il modulo.

Pulsante di opzione    In maniera analoga a una casella di riepilogo, un gruppo di pulsanti di opzione consente agli utenti di effettuare una selezione all'interno di un elenco di opzioni che si escludono a vicenda. Nel caso dei pulsanti di opzione tuttavia gli utenti devono fare clic su un cerchiolino per effettuare una scelta anziché su un'opzione in una casella di riepilogo.

Inizio pagina

Esperienza dell'utente

Le caselle di riepilogo sono uno dei controlli più ampiamente utilizzati nei moduli e in quanto tali presentano il vantaggio che il loro funzionamento è noto alla maggior parte degli utenti.

Per selezionare un'opzione in una casella di riepilogo, gli utenti devono semplicemente fare clic sull'elemento desiderato. La casella di riepilogo è sempre "aperta", pertanto gli utenti possono vedere l'elenco delle opzioni senza bisogno di dover fare clic sul controllo. Se le opzioni nell'elenco superano l'altezza della casella che le contiene, sul lato destro del controllo sarà disponibile una barra di scorrimento. Se gli utenti utilizzano la tastiera per compilare il modulo, potranno premere freccia SU o freccia GIÙ per scorrere l'elenco degli elementi all'interno della casella di riepilogo.

Inizio pagina

Inserire una casella di riepilogo

La procedura di inserimento di una casella di riepilogo si differenzia leggermente a seconda che si progetti un nuovo modello di modulo vuoto o che si basi la progettazione del modello di modulo su un database o su altra origine dati esterna.

Nella figura seguente viene illustrato l'aspetto di una casella di riepilogo selezionata in modalità progettazione, prima dell'aggiunta di un'etichetta e delle voci di elenco.

Casella di riepilogo selezionata in modalità progettazione

I controlli possono essere associati o non associati. I controlli associati sono connessi a un campo o a un gruppo nell'origine dati, in modo che i dati immessi al loro interno vengano salvati in un file di modulo (con estensione xml) sottostante. I controlli non associati non sono connessi a un campo o a un gruppo, quindi i dati immessi al loro interno non vengono salvati. Se si seleziona o si sposta il puntatore su un controllo, nell'angolo superiore destro del controllo vengono visualizzati il testo e un'icona di associazione. Il testo indica il gruppo o il campo a cui il controllo è associato nell'origine dati. L'icona indica se il controllo è correttamente associato a tale gruppo o campo. Se l'associazione è corretta, viene visualizzata un'icona verde. Se invece c'è un errore, verrà visualizzata un'icona blu o rossa.

L'origine dati per il modello di modulo è costituito da campi e i gruppi visualizzati in una visualizzazione gerarchica nel riquadro attività Origine dati. Caselle di riepilogo sono sempre associate ai campi. Nell'esempio seguente, la casella di riepilogo categoria nel modello di modulo è associata al campo categoria nel riquadro attività Origine dati.

relazione tra casella di riepilogo nel modello di modulo e campo corrispondente nell'origine dati

Quando si progetta un nuovo modello di modulo vuoto, per impostazione predefinita è selezionata la casella di controllo Crea automaticamente origine dati del riquadro attività Controlli. In questo modo InfoPath può creare automaticamente campi e gruppi nell'origine dati quando vengono aggiunti controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.

Se il progetto del modello di modulo si basa su un file XML (Extensible Markup Language), un database o un servizio Web esistente, InfoPath ricava i campi e i gruppi del riquadro attività Origine dati da questa origine dati esistente.

Inserire una casella di riepilogo

  1. Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Nel riquadro attività Controlli eseguire una delle operazioni seguenti:

    • Per creare automaticamente un campo nell'origine dati associato alla casella di riepilogo, selezionare la casella di controllo Crea automaticamente origine dati.

    • Per associare la casella di riepilogo a un campo esistente, deselezionare la casella di controllo Crea automaticamente origine dati.

      Nota : Se la casella di controllo non è disponibile, significa che l'origine dati è bloccata. Se ad esempio il progetto del modello di modulo si basa su un XML Schema, potrebbe non essere possibile aggiungere nuovi campi o gruppi all'origine dati in InfoPath. Questa restrizione impedisce di apportare modifiche involontarie allo schema che potrebbero renderlo non valido.

  4. Nel gruppo Inserisci controlli fare clic su Casella di riepilogo.

  5. Se nel passaggio 3 è stata deselezionata la casella di controllo Crea automaticamente origine dati, nella finestra di dialogo Associazione Casella di riepilogo selezionare un campo a cui si desidera associare la casella di riepilogo.

  6. Per aggiungere un'etichetta alla casella di riepilogo, nel modello di modulo digitare il testo desiderato al di sopra o alla sinistra della casella di riepilogo, seguito da due punti (:).

  7. Per specificare i valori che si desidera utilizzare come voci dell'elenco, fare doppio clic sulla casella di riepilogo.

  8. Fare clic sulla scheda Dati.

  9. Per popolare la casella di riepilogo a selezione multipla eseguire una delle operazioni seguenti:

    Digitare i valori nella casella di riepilogo

    Questa opzione è utile se si ha un insieme limitato e predeterminato di valori e non si prevede che tali valori cambino in futuro. Se i valori cambiano, è necessario pubblicare una versione aggiornata del modello di modulo, in modo che gli utenti possano vedere e usare le voci dell'elenco più recenti.

    1. Fare clic su Aggiungi.

    2. Nella casella Valore digitare il testo da archiviare se un utente seleziona questa voce.

    3. Nella casella Nome visualizzato digitare il testo da visualizzare per la voce, quindi fare clic su OK.

    4. Ripetere i passaggi da 1 a 3 per ogni voce da aggiungere alla casella di riepilogo.

    5. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

    Utilizzare valori provenienti da un'altra parte del modulo

    Questa opzione è utile se si vuole che i valori dell'elenco cambino in base ad altri valori immessi dagli utenti nel loro modulo.

    1. In Voci casella di riepilogo fare clic su Cerca valori nell'origine dati del modulo.

      Le voci della casella di riepilogo devono essere associate a uno specifico gruppo ripetuto o campo ripetuto nel modello di modulo.

    2. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul campo ripetuto o sul gruppo ripetuto che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    3. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    4. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento : Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

    Utilizzare valori provenienti da un database, un servizio Web, un documento XML o un sito di SharePoint

    Questa opzione è utile se si vuole che i valori di una casella di riepilogo vengano aggiornati regolarmente. I valori vengono in genere archiviati in un database o in un'altra origine dati esterna e vengono recuperati ogni volta che si apre il modulo.

    1. Fare clic su Cerca valori in un'origine dati esterna.

    2. Eseguire una delle operazioni seguenti:

      • Se è già stata aggiunta una connessione dati, selezionarla nella casella Connessione dati.

      • Per aggiungere una nuova connessione dati, fare clic su Aggiungi e quindi seguire le istruzioni della Connessione guidata dati.

        Le voci della casella di riepilogo devono essere associate a uno specifico campo ripetuto o gruppo ripetuto.

    3. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci e quindi, nella finestra di dialogo Seleziona campo o gruppo, fare clic sul gruppo o sul campo che contiene i campi che forniranno i valori della casella di riepilogo, infine fare clic su OK.

    4. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Valore, fare clic sul campo che contiene i valori possibili per gli elementi della casella di riepilogo, quindi fare clic su OK. Uno di questi valori verrà salvato nel file XML sottostante quando un utente fa clic su un elemento della casella di riepilogo.

    5. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Nome visualizzato, fare clic sul campo che contiene i valori visualizzati nella casella di riepilogo, quindi fare clic su OK.

      Suggerimento : Per evitare che i valori dei nomi visualizzati compaiano più volte nella casella di riepilogo, selezionare la casella di controllo Mostra solo voci con nomi visualizzati univoci.

Inizio pagina

Suggerimenti relativi al layout

I suggerimenti riportati di seguito aiutano a perfezionare l'aspetto, le dimensioni e altri elementi di una casella di riepilogo:

  • Allargare la casella di riepilogo in modo che risulti leggermente più ampia della lunghezza media degli elementi dell'elenco. In questo modo gli elementi dell'elenco non risulteranno parzialmente nascosti.

  • Per modificare la larghezza di più caselle di riepilogo contemporaneamente, selezionare le caselle di cui si desidera modificare la dimensione, premere ALT+INVIO, fare clic sulla scheda Dimensioni e infine digitare un nuovo valore nella casella Larghezza.

  • Per cambiare il colore di sfondo di più caselle di riepilogo contemporaneamente, selezionare le caselle da modificare, scegliere Bordi e sfondo dal menu Formato e apportare le modifiche necessarie nella scheda Sfondo.

  • Per personalizzare il tipo di carattere visualizzato in una casella di riepilogo, utilizzare le caselle Tipo di carattere e Dimensione carattere sulla barra degli strumenti Formattazione. Per modificare contemporaneamente il tipo di carattere e la dimensione del testo di tutte le caselle di riepilogo presenti nel modello di modulo, fare clic sulla casella di riepilogo che presenta la formattazione desiderata e scegliere Applica tipo di carattere a tutti i controlli Casella combinata dal menu Formato.

  • Se si desidera regolare la spaziatura tra una casella di riepilogo e gli oggetti circostanti presenti nel modello di modulo, è possibile modificare le impostazioni dei margini nella scheda Dimensioni della finestra di dialogo Proprietà - Casella di riepilogo. L'utilizzo dei margini per aumentare o ridurre la spaziatura offre un miglior controllo rispetto all'impiego delle interruzioni di paragrafo.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×