Inserire un foglio dati in una maschera

Un foglio dati rappresenta un tipo di visualizzazione semplice in cui i dati sono disposti in righe e colonne. Quando si fa doppio clic su una tabella nel riquadro di spostamento, la tabella viene visualizzata in Microsoft Office Access 2007 come un foglio dati. La struttura molto compatta con cui i dati vengono presentati rende i fogli dati particolarmente adatti a essere utilizzati come sottomaschere per visualizzare i dati del lato "molti" di una relazione uno-a-molti. In questo articolo viene descritto come aggiungere fogli dati alle maschere in Office Access 2007.

Per saperne di più

Visualizzare un esempio di un foglio dati in una maschera

Stabilire relazioni tra le tabelle

Creare una maschera che contiene un foglio dati utilizzando lo strumento Maschera

Creare una maschera contenente un foglio dati utilizzando la visualizzazione Layout

Inserire un foglio dati in una maschera esistente utilizzando la visualizzazione Layout

Inserire un foglio dati in una maschera esistente utilizzando la visualizzazione Struttura

Differenze tra una maschera divisa e una maschera contenente un foglio dati

Visualizzare un esempio di un foglio dati in una maschera

Si supponga che si desideri creare una maschera per visualizzare i dati relativi alle categorie di prodotto e ai prodotti inclusi in tali categorie. I dati della tabella Categorie rappresentano il lato "uno" della relazione e i dati della tabella Prodotti rappresentano il lato "molti" della relazione. Per ogni categoria possono esistere molti prodotti.

Maschera contenente una sottomaschera

1. La maschera principale visualizza i dati del lato "uno" della relazione.

2. Il foglio dati visualizza i dati del lato "molti" della relazione.

Torna all'inizio

Stabilire relazioni tra le tabelle

Prima di procedere alla progettazione di una maschera che contiene un foglio dati, è consigliabile controllare le relazioni che esistono tra le tabelle e aggiungere le eventuali relazioni mancanti per fare in modo che vengano creati automaticamente i collegamenti tra i fogli dati e le maschere principali. Per visualizzare, aggiungere o modificare le relazioni tra le tabelle del database, fare clic su Relazioni nel gruppo Analizza della scheda Strumenti avanzati. Per ulteriori informazioni sulla creazione di relazioni, fare clic sui collegamenti disponibili nella sezione Vedere.

Torna all'inizio

Creare una maschera che contiene un foglio dati utilizzando lo strumento Maschera

Quando si utilizza lo strumento Maschera per creare una maschera basata su una tabella che si trova sul lato "uno" di una singola relazione uno-a-molti, nella maschera viene inserito automaticamente un foglio dati che visualizza i dati del lato "molti" della relazione.

Se si verificano le condizioni seguenti, ad esempio, viene automaticamente inserito un foglio dati che visualizza tutti gli ordini per ogni cliente:

  • Si crea una maschera semplice basata sulla tabella Clienti.

  • Si è definita una relazione uno-a-molti con la tabella Ordini che specifica che un record della tabella Clienti può essere correlato a più record della tabella Ordini.

  • La tabella Clienti non si trova sul lato "uno" di nessun'altra relazione uno-a-molti.

  • Nel riquadro di spostamento fare clic sulla tabella che si trova sul lato "uno" della relazione uno-a-molti.

  • Nel gruppo Maschere della scheda Crea fare clic su Maschera. Icona del pulsante

Nella parte inferiore della maschera che viene creata verrà inserito automaticamente un foglio dati. Se il foglio dati non viene creato, ciò indica che la tabella che è stata utilizzata per la maschera non fa parte di una relazione uno-a-molti o che la tabella fa parte di più relazioni uno-a-molti.

Note : 

  • Oltre a creare la maschera principale, questo processo non consente di creare altri oggetti maschera. Il foglio dati rappresenta una visualizzazione diretta della tabella.

  • Per nascondere una colonna in un foglio dati    Fare clic con il pulsante destro del mouse sulla colonna e quindi scegliere Nascondi colonna. Questa impostazione verrà salvata. Se la maschera viene salvata e chiusa e quindi riaperta, la colonna rimarrà nascosta.

  • Per ripristinare una colonna nascosta in un foglio dati    Fare clic con il pulsante destro del mouse su una qualsiasi intestazione di colonna nel foglio dati e quindi scegliere Scopri colonne. Selezionare la casella di controllo accanto a ogni colonna di cui si desidera ripristinare la visualizzazione e quindi fare clic su Chiudi.

Torna all'inizio

Creare una maschera contenente un foglio dati utilizzando la visualizzazione Layout

Se sono state già definite le relazioni tra le tabelle del database, sarà possibile creare rapidamente una maschera contenente un foglio dati utilizzando la visualizzazione Layout. Quando si aggiunge un campo dal lato "molti" di una relazione a una maschera basata sul lato "uno" della relazione, viene creato automaticamente un foglio dati che visualizza i record correlati.

  1. Nel gruppo Maschere della scheda Crea fare clic su Maschera vuota. Icona del pulsante

    Verrà aperta una maschera vuota in visualizzazione Layout e verrà visualizzato il riquadro Elenco campi.

    Nota : Se il riquadro Elenco campi viene chiuso per errore, è possibile riaprirlo eseguendo una delle operazioni seguenti:

    • Premere ALT+F8.

      In alternativa

      Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti. Icona del pulsante

  2. Fare clic sul segno più accanto alla tabella che si trova sul lato "uno" della relazione uno-a-molti e quindi trascinare il primo campo che si desidera includere nella maschera.

    Si noti che nel riquadro Elenco campi le tabelle risultano suddivise in sezioni: Campi disponibili per la visualizzazione e, al di sotto di questa, Campi disponibili nelle tabelle correlate. Nella parte inferiore del riquadro Elenco campi, le eventuali altre tabelle che non sono correlate direttamente alla tabella principale vengono elencate nella sezione Campi disponibili in altre tabelle.

  3. Dalla sezione Campi disponibili per la visualizzazione trascinare gli eventuali altri campi che si desidera includere nella maschera principale.

  4. Dalla sezione Campi disponibili nelle tabelle correlate trascinare nella maschera il primo campo che si desidera includere nel foglio dati. Verrà creato automaticamente un foglio dati al quale verrà aggiunto il campo.

  5. Per aggiungere altri campi al nuovo foglio dati, è innanzitutto necessario fare clic sul foglio dati per selezionarlo. Si noti che il riquadro Elenco campi viene ridisposto in modo da visualizzare i campi disponibili per il foglio dati nella parte superiore. Dalla sezione Campi disponibili per la visualizzazione trascinare gli eventuali altri campi che si desidera includere nel foglio dati. Quando un campo viene trascinato nel foglio dati, viene automaticamente disegnata una barra di inserimento che indica il punto in cui verrà inserito il campo al rilascio del pulsante del mouse.

  6. Continuare ad aggiungere campi alla maschera principale o al foglio dati facendo prima clic sulla maschera principale o sul foglio dati per selezionarlo e quindi trascinando il campo dal riquadro Elenco campi.

La sezione Campi disponibili in altre tabelle del riquadro Elenco campi contiene tabelle non direttamente correlate alla tabella o alla query sulla quale si basa la maschera o il foglio dati selezionato. Se sono state definite tutte le relazioni valide tra le tabelle nella finestra Relazioni, è possibile che i campi della sezione Campi disponibili in altre tabelle non visualizzino selezioni valide per la maschera che si sta creando. Se si trascina un campo da questa sezione alla maschera, in Access verrà visualizzata la finestra di dialogo Specifica relazione. Prima di continuare, è necessario immettere uno o più campi che consentono di correlare le due tabelle. In questo caso, il riquadro Elenco campi non verrà più ordinato in sezioni in base alle relazioni predefinite. È consigliabile invece fare clic su Annulla in questa finestra di dialogo e riesaminare invece le relazioni tra le tabelle. Per ulteriori informazioni sulle relazioni, vedere l'articolo Creare, modificare o eliminare una relazione.

Torna all'inizio

Inserire un foglio dati in una maschera esistente utilizzando la visualizzazione Layout

Se sono state già state definite le relazioni tra le tabelle nel database, è possibile aggiungere rapidamente un foglio dati a una maschera esistente utilizzando la visualizzazione Layout. Quando si aggiunge un campo del lato "molti" di una relazione a una maschera basata sul lato "uno" della relazione, viene creato automaticamente un foglio dati che visualizza i record correlati.

  1. Aprire la maschera esistente in visualizzazione Layout facendo clic con il pulsante destro del mouse su di essa nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout dal menu di scelta rapida.

    Se il riquadro Elenco campi non è visualizzato:

    • Premere ALT+F8.

      In alternativa

      Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti. Icona del pulsante

      Si noti che nel riquadro Elenco campi le tabelle risultano suddivise in sezioni: Campi disponibili per la visualizzazione e, al di sotto di questa, Campi disponibili nelle tabelle correlate. Nella parte inferiore del riquadro Elenco campi, le eventuali altre tabelle che non sono correlate direttamente alla tabella principale vengono elencate nella sezione Campi disponibili in altre tabelle.

  2. Nella sezione Campi disponibili nelle tabelle correlate espandere la tabella contenente il primo campo che si desidera includere nel foglio dati e trascinare il campo nella maschera. Verrà creato automaticamente un foglio dati al quale verrà aggiunto il campo.

  3. Per aggiungere altri campi al nuovo foglio dati, è innanzitutto necessario fare clic sul foglio dati per selezionarlo. Si noti che in Access il riquadro Elenco campi viene ridisposto in modo da visualizzare i campi disponibili per il foglio dati nella parte superiore. Dalla sezione Campi disponibili per la visualizzazione trascinare gli eventuali altri campi che si desidera includere nel foglio dati. Quando un campo viene trascinato nel foglio dati, viene automaticamente disegnata una barra di inserimento che indica il punto in cui verrà inserito il campo al rilascio del pulsante del mouse.

  4. Continuare ad aggiungere campi alla maschera principale o al foglio dati facendo prima clic sulla maschera principale oppure sul foglio dati per selezionarlo e quindi trascinando il campo dal riquadro Elenco campi.

La sezione Campi disponibili in altre tabelle del riquadro Elenco campi contiene tabelle non direttamente correlate alla tabella o alla query sulla quale si basa la maschera selezionata. Se sono state definite tutte le relazioni valide tra le tabelle nella finestra Relazioni, è possibile che i campi della sezione Campi disponibili in altre tabelle non visualizzino selezioni valide per la maschera che si sta creando. Se si trascina un campo da questa sezione alla maschera, in Access verrà visualizzata la finestra di dialogo Specifica relazione. Prima di continuare, è necessario immettere uno o più campi che consentono di correlare le due tabelle. In questo caso, il riquadro Elenco campi non verrà più ordinato in sezioni in base alle relazioni predefinite. È consigliabile invece fare clic su Annulla in questa finestra di dialogo e riesaminare invece le relazioni tra le tabelle. Per ulteriori informazioni sulle relazioni, vedere l'articolo Creare, modificare o eliminare una relazione.

Torna all'inizio

Inserire un foglio dati in una maschera esistente utilizzando la visualizzazione Struttura

Utilizzare questa procedura per aggiungere un foglio dati basato direttamente su una tabella o query a una maschera esistente in visualizzazione Struttura.

  1. Aprire la maschera in visualizzazione Struttura facendo clic con il pulsante destro del mouse sulla maschera nel riquadro di spostamento e quindi scegliendo Visualizzazione struttura.

  2. Se lo strumento Usa creazioni guidate Controllo è selezionato nel gruppo Controlli della scheda Struttura, fare clic su di esso per deselezionarlo.

    Icona del pulsante

    Motivo

    Se si utilizza lo strumento Creazione guidata Controllo per la sottomaschera, verrà creato un oggetto maschera distinto e il controllo della sottomaschera si baserà su tale oggetto. Al contrario, questa procedura crea un foglio dati basato direttamente su una tabella o query anziché su una maschera.

  3. Nel gruppo Controllidella scheda Struttura fare clic su Sottomaschera/Sottoreport Icona del pulsante . Icona del pulsante

  4. Nella griglia di struttura della maschera fare clic nel punto in cui si desidera inserire il foglio dati.

  5. Riposizionare e ridimensionare il controllo Sottomaschera trascinando i quadratini di ridimensionamento posti sui bordi e agli angoli del controllo.

  6. Per modificare l'etichetta associata al controllo Sottomaschera fare clic sull'etichetta, quindi fare doppio clic per selezionarne il testo e infine digitare la nuova etichetta. Se si desidera eliminare l'etichetta, fare clic sull'etichetta una volta e quindi premere CANC.

  7. Se la finestra delle proprietà non è già visualizzata, premere F4 per aprirla.

  8. Se il controllo Sottomaschera non è selezionato, fare clic su di esso per selezionarlo.

  9. Nella scheda Dati della finestra delle proprietà, fare clic sull'elenco a discesa Oggetto origine e quindi fare clic sulla tabella o sulla query che si desidera visualizzare nel foglio dati. Se ad esempio si desidera visualizzare i dati della tabella Ordini, fare clic su Tabella.Ordini.

  10. Se le relazioni sono state impostate correttamente prima di eseguire questa procedura, le proprietà Collega campi figlio e Collega campi master verranno impostate automaticamente sui valori corretti che consentiranno di collegare la maschera principale al foglio dati.

    Proprietà Collega campi figlio e Collega campi master vuote

    Se Access non è in grado di stabilire la modalità di collegamento del controllo Sottomaschera alla maschera principale, le proprietà Collega campi figlio e Collega campi master del controllo Sottomaschera verranno lasciate vuote e sarà pertanto necessario impostarle eseguendo le operazioni seguenti:

    1. Aprire la maschera principale in visualizzazione Struttura.

    2. Fare clic sul controllo Sottomaschera per selezionarlo.

    3. Se la finestra delle proprietà non è visualizzata, premere F4.

    4. Nella scheda Dati della finestra delle proprietà fare clic sul pulsante ... accanto alla casella della proprietà Collega campi secondari.

      Verrà visualizzata la finestra di dialogo Collegamento campi sottomaschera.

    5. Negli elenchi a discesa Campi master e Campi secondari selezionare i campi con cui si desidera collegare le maschere. In caso di dubbi sui campi da utilizzare, fare clic su Suggerisci per fare in modo che i campi di collegamento vengano determinati automaticamente. Al termine, fare clic su OK.

      Se il campo che si desidera utilizzare per collegare le maschere non è visualizzato, potrebbe essere necessario modificare l'origine record della maschera master o della maschera figlio per verificare che il campo sia incluso. Ad esempio, se la maschera è basata su una query, è consigliabile verificare che il campo di collegamento sia presente nei risultati della query.

    6. Salvare la maschera principale e passare alla visualizzazione Maschera per verificare che la maschera funzioni nel modo previsto.

  11. Salvare la maschera facendo clic su Salva Icona del pulsante sulla barra di accesso rapido o premendo CTRL+S.

  12. Passare alla visualizzazione Maschera e verificare che il funzionamento del foglio dati sia quello previsto.

Torna all'inizio

Differenze tra una maschera divisa e una maschera contenente un foglio dati

Una maschera che contiene un foglio dati visualizza i dati di origini dati diverse, ma in genere correlate. È ad esempio possibile che una maschera visualizzi i nomi dei dipendenti e che contenga un foglio dati che visualizza tutte le attività assegnate a ogni dipendente. Il foglio dati ha un'origine dati diversa dalla maschera che la contiene. Al contrario, una maschera divisa è composta da due sezioni, ovvero una maschera e un foglio dati, ma in entrambe le sezioni vengono visualizzati gli stessi dati. Le due sezioni sono sincronizzate tra loro e offrono due diverse visualizzazioni dei dati contemporaneamente.

Per ulteriori informazioni sulla creazione e l'utilizzo di una maschera divisa, vedere l'articolo Creare una maschera divisa.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×