Inserire un'area orizzontale

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Se si desidera posizionare due aree side-by nel modello di modulo di Microsoft Office InfoPath, è possibile utilizzare un'area orizzontale. Quando vengono ridimensionati moduli basati sul modello di modulo, l'area orizzontale aumenta o diminuisce in base allo spazio disponibile.

In questo articolo

Quando utilizzare un'area orizzontale

Considerazioni sulla compatibilità

Inserire un'area orizzontale

Suggerimenti per il layout

Quando utilizzare un'area orizzontale

Utilizzare un'area orizzontale quando si desidera organizzare un set di controlli correlati in una formazione orizzontale. Quando più aree orizzontali sono posizionati side-by-side, le aree a capo o flusso alla riga successiva quando le dimensioni dello schermo viene ridimensionata.

Quando si inserisce un'area orizzontale nel modello di modulo, si inserisce in effetti un contenitore vuoto. Per l'area geografica essere utile, è necessario inserire altri controlli al suo interno. Questi controlli possono includere le caselle di testo, caselle di riepilogo o sezioni. L'illustrazione seguente mostra due aree orizzontali in modalità progettazione.

Aree orizzontali contenenti etichette e caselle di testo

È anche possibile utilizzare le tabelle layout per disporre i controlli in modo analogo. Ad esempio, è possibile posizionare due caselle di testo side-by nelle celle di tabella diverso. Tuttavia, diversamente da quanto succede aree orizzontali le celle delle tabelle layout non a capo alla riga successiva se la schermata viene ridimensionata; Se, tuttavia, i controlli nella cella sono nascosto.

Nell'esempio seguente, le caselle Nome e indirizzo di posta elettronica vengono visualizzati vicine in aree orizzontali separate nella maschera.

Aree orizzontali prima del ridimensionamento della finestra

Tuttavia, se l'utente ridimensiona la finestra, le aree orizzontali spostare automaticamente alla riga successiva, come illustrato nella figura seguente.

Aree orizzontali dopo il ridimensionamento della finestra

Suggerimento: Per impostazione predefinita, i bordi di un'area orizzontale non sono visibili nel modulo. Se si desidera una struttura per visualizzare l'area, è possibile applicare un bordo a tale nella finestra di dialogo bordi e sfondo.

Controlli correlati

InfoPath include altri controlli simili alle aree orizzontali ma utilizzati per diversi scopi. Per decidere quale di questi controlli funziona meglio il modello di modulo, consultare l'elenco seguente.

  • Area scorrevole    Se si desidera l'area geografica per includere le barre di scorrimento in modo che gli utenti possono scorrere per visualizzare le informazioni dalla visualizzazione, utilizzare un'area scorrevole invece di un'area orizzontale.

  • Sezione    Se non è necessario l'area del ritorno a capo durante il ridimensionamento della maschera, è possibile utilizzare una sezione invece di un'area orizzontale. Diversamente da quanto succede aree orizzontali sono i controlli non associati, le sezioni sono associate ai gruppi di origine dati.

Torna all'inizio

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo, è possibile progettare un modello di modulo compatibile con browser. Quando si progetta un modello di modulo compatibile con browser, i controlli area orizzontale non sono disponibili nel riquadro attività controlli, perché non possono essere visualizzate in un Web browser.

Torna all'inizio

Inserire un'area orizzontale

Poiché le aree orizzontali vengono utilizzate esclusivamente per il layout, non sono associati a campi o gruppi nell'origine dati.

  1. Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. In Inserisci controlli fare clic su Area orizzontale.

  4. Per aggiungere controlli per l'area orizzontale, trascinare il controllo desiderato dal riquadro attività controlli per l'area orizzontale.

Torna all'inizio

Suggerimenti per il layout

Utilizzare i suggerimenti seguenti per perfezionare l'aspetto, dimensioni e altri elementi di un'area orizzontale e i controlli in essa contenuti.

  • Per modificare il colore del bordo o uno sfondo di un'area orizzontale, selezionarla. Nel menu formato fare clic su bordi e sfondo e quindi apportare le modifiche necessarie nella finestra di dialogo bordi e sfondo.

  • Per modificare le dimensioni di più aree orizzontali contemporaneamente, selezionarle, premere ALT + INVIO e quindi apportare le modifiche necessarie nella finestra di dialogo proprietà (selezione multipla).

  • Per impostazione predefinita, le aree orizzontali viene inserita una larghezza corrispondente a quella della pagina stampata. Per modificare questa impostazione predefinita, nel menu Visualizza fare clic su Visualizza proprietà. Nella scheda Generale, in impostazioni di Layout, selezionare la casella di controllo Usa larghezza personalizzata per il modello di modulo e quindi digitare un numero diverso nella casella larghezza personalizzata.

  • Se si specifica una larghezza di layout personalizzato per le aree orizzontali, assicurarsi che non è più ampio di area di stampa del modello di modulo. Per verificare rapidamente la larghezza della pagina stampata, e se lo spazio sufficiente il contenuto del modello di modulo nella pagina, nel menu Visualizza fare clic su Guida larghezza pagina. Quando si fa clic su questo comando, viene visualizzata una guida verticale tratteggiata sul lato destro dello schermo. Questa guida indica il margine destro della pagina stampata, in base alla stampante predefinita per il computer.

  • È possibile perfezionare la spaziatura in e intorno all'area orizzontale modificando la spaziatura interna, ossia la quantità di spazio di buffer adiacente contenuto dell'area, oppure modificando i margini, ovvero la quantità di spazio tra il bordo dell'area e qualsiasi adiacente testo o controlli nel modello di modulo. Per modificare la spaziatura per un'area orizzontale, fare doppio clic su esso. Nella finestra di dialogo Proprietà area orizzontale fare clic sulla scheda dimensioni e quindi modificare i margini e spaziatura opzioni in base alle esigenze.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×