Iniziare a programmare con Microsoft Access

La creazione di un nuovo database inizia in genere creando alcuni oggetti di database, ad esempio tabelle, maschere e report. Col tempo si arriverà al punto in cui sarà necessario aggiungere alcuni elementi di programmazione per automatizzare determinati processi e collegare tra loro gli oggetti di database. Il contenuto di questo articolo consente di orientarsi rispetto agli strumenti di programmazione disponibili in Microsoft Office Access 2007 e di indirizzare l'utente ad alcune risorse contenenti ulteriori informazioni sulla programmazione.

In questo articolo

Che cos'è la programmazione

Utilizzare le macro o il codice VBA

Utilizzare la Creazione guidata Pulsante di comando per eseguire attività di programmazione comuni

Informazioni sulle macro

Informazioni sul codice VBA

Convertire le macro in codice VBA

Utilizzo del sistema della Guida

Che cos'è la programmazione

In Office Access 2007 la programmazione è il processo che consente di aggiungere funzionalità al database mediante macro di Microsoft Access o codice VBA (Visual Basic, Applications Edition). Si supponga, ad esempio, di aver creato una maschera e un report e che si desideri aggiungere un pulsante di comando alla maschera, in modo che la scelta di tale pulsante di comando determini l'apertura del report. In questo caso, la programmazione è rappresentata dal processo di creazione di una macro o di una routine VBA e dalla successiva impostazione della proprietà eventoSuClic, in modo che la scelta del pulsante di comando determini l'esecuzione della macro o della routine. Per l'esecuzione di un'operazione semplice, ad esempio l'apertura di un report, è possibile utilizzare la Creazione guidata Pulsante di comando oppure è possibile disattivare la procedura guidata ed eseguire le operazioni di programmazione manualmente.

Nota   In molte applicazioni di Microsoft Office viene utilizzato il termine macro per fare riferimento al codice VBA. Ciò potrebbe creare confusione tra gli utenti di Microsoft Access, poiché in questo programma il termine macro fa riferimento a un insieme denominato di azioni di macro che è possibile assemblare utilizzando il Generatore di macro. Le azioni di macro di Microsoft Access rappresentano solo un sottoinsieme dei comandi disponibili in VBA. Il Generatore di macro offre un'interfaccia più strutturata rispetto a quella di Visual Basic Editor, consentendo all'utente di aggiungere controlli e oggetti senza dover necessariamente conoscere il codice VBA. È importante ricordare che negli argomenti della Guida di Microsoft Access, alle macro di Microsoft Access viene fatto riferimento con il termine macro. Al codice VBA viene invece fatto riferimento con i termini codice VBA, codice, funzione o routine. Il codice VBA è incluso nei moduli di classe, che fanno parte di maschere o report individuali e contengono in genere solo il codice per tali oggetti, e nei moduli, che non sono associati a oggetti specifici e contengono in genere codice globale che può essere utilizzato in tutto il database.

Gli oggetti, ad esempio le maschere e i report, e i controlli, ad esempio il pulsanti di comando e le caselle di testo, dispongono di numerose proprietà di evento alle quali è possibile collegare macro e routine. Ogni proprietà di evento è associata a un evento specifico, ad esempio il clic del mouse, per l'apertura di una maschera o la modifica di dati in una casella di testo. Gli eventi possono essere inoltre attivati da fattori esterni a Microsoft Access, ad esempio eventi di sistema, oppure da macro o routine collegate ad altri eventi. È possibile che la complessità del database aumenti se si aggiungono numerose macro o routine a diverse proprietà di evento per un gran numero di oggetti, ma nella maggior parte dei casi è possibile ottenere i risultati desiderati utilizzando un numero ridotto di elementi di programmazione.

Torna all'inizio

Utilizzare le macro o il codice VBA

La scelta di utilizzare le macro o il codice VBA deve basarsi sulla valutazione di due aspetti, ovvero la protezione e la funzionalità richieste. La protezione rappresenta un problema poiché il codice VBA può essere utilizzato per compromettere la protezione dei dati o danneggiare i file nel computer. Quando si utilizza un database creato da un altro utente, è consigliabile attivare il codice VBA solo se si è certi che il database provenga da un'origine attendibile. Quando si crea un database che verrà utilizzato da altri utenti, è consigliabile evitare di includere strumenti di programmazione che richiedono all'utente di concedere in modo specifico lo stato di attendibilità al database. Più avanti in questa sezione verranno illustrate le tecniche generali che consentono di evitare all'utente di dover considerare attendibile il database.

Per ulteriori informazioni sull'attivazione o la disattivazione di contenuto non sicuro, vedere l'articolo Attivazione o disattivazione di macro nei documenti di Office. Come già menzionato in questo articolo, la gran parte delle altre applicazioni di Microsoft Office utilizza il termine macro per fare riferimento al codice VBA, termine da non confondere con le macro di Microsoft Access.

Per motivi di protezione del database, è consigliabile tentare di utilizzare le macro quando possibile e ricorrere alla programmazione VBA solo per le operazioni che non possono essere eseguite mediante azioni di macro. È inoltre consigliabile tentare di utilizzare solo azioni di macro che non richiedono la concessione dello stato di attendibilità al database per poter essere eseguito. Limitando in questo modo l'uso di azioni di macro si garantirà agli utenti l'assenza di elementi di programmazione nel database che potrebbero danneggiare i dati o di altri file nei loro computer.

Al fine di incoraggiare in parte un utilizzo più ampio delle macro, in Office Access 2007 sono disponibili molte nuove azioni di macro che consentono all'utente di creare macro più potenti di quanto non fosse possibile con le versioni precedenti di Microsoft Access. In questa versione è ad esempio possibile creare e utilizzare variabili temporanee globali mediante le azioni di macro e gestire gli errori in modo più efficace utilizzando le nuove azioni di macro per la gestione degli errori. Nelle versioni precedenti di Microsoft Access, questi tipi di funzionalità sono disponibili solo mediante VBA. In Access 2007 è inoltre possibile incorporare una macro direttamente nella proprietà di evento di un oggetto o controllo. Una macro incorporata diventa parte dell'oggetto o del controllo e vi rimane associata anche quando l'oggetto o il controllo viene spostato o copiato. Nelle versioni precedenti di Microsoft Access è invece necessario gestire le macro come oggetti separati, rendendo talvolta più difficile la gestione del database.

Quando si aggiunge un elemento di programmazione a un oggetto o controllo, è consigliabile valutare l'utilizzo degli elementi seguenti nell'ordine di preferenza indicato:

  1. Una macro contenente unicamente azioni che non richiedono la concessione dello stato di attendibilità al database per poter essere eseguito.

  2. Una macro contenente azioni che richiedono la concessione dello stato di attendibilità al database per poter essere eseguito.

  3. Una routine VBA.

Quando si crea una macro, è possibile passare dall'elenco di azioni più breve relativo alle azioni che non richiedono la concessione dello stato di attendibilità al database per poter essere eseguito all'elenco più lungo contenente tutte le azioni di macro, facendo clic su Mostra tutte le azioni nel Generatore di macro. Facendo clic su Mostra tutte le azioni verrà inoltre visualizzato l'elenco completo degli argomenti per l'azione di macro EseguiComando. Per ulteriori informazioni sulla creazione di macro, vedere la sezione Informazioni sulle macro oppure fare clic sui collegamenti disponibili nella sezione Vedere anche.

Le macro rappresentano un metodo semplice per la gestione di molte attività di programmazione, ad esempio l'apertura e la chiusura di maschere e l'esecuzione di report. Gli oggetti di database creati possono essere collegati tra loro in modo semplice e rapido, poiché è sufficiente ricordare poche regole di sintassi. Gli argomento per ogni azione vengono visualizzati nel Generatore di macro.

Oltre che per soddisfare le esigenze di maggiore protezione e facilità d'uso, è necessario utilizzare le macro quando si desidera:

  • Assegnare un'azione o un gruppo di azioni a un tasto. A tale scopo, è necessario creare un gruppo di macro denominate AutoKeys.

  • Eseguire un'azione o una serie di azioni alla prima apertura del database. A tale scopo, è necessario creare una macro denominata AutoExec.

    Nota    La macro AutoExec viene eseguita prima di qualsiasi altra macro o codice VBA, anche se è stata definita una maschera di avvio nella finestra di dialogo Opzioni di Access e collegata una macro o del codice VBA all'evento SuApertura o SuCaricamento di tale maschera.

È consigliabile utilizzare la programmazione VBA anziché le macro se si desidera eseguire le operazioni seguenti:

  • Utilizzare funzioni incorporate o creare funzioni personalizzate.    In Microsoft Access sono incluse molte funzioni incorporate, ad esempio la funzione IPmt che consente di calcolare il pagamento di un interesse. È possibile utilizzare queste funzioni incorporate per eseguire calcoli senza dover creare espressione complesse. Mediante il codice VBA è inoltre possibile creare funzioni personalizzate per eseguire calcoli che superano le capacità di un'espressione o per sostituire espressioni complesse. È infine possibile utilizzare le funzioni create nelle espressioni per applicare un'operazione comune a più oggetti.

  • Creare o modificare oggetti    Nella maggior parte dei casi si scoprirà che il modo più facile per creare e modificare consiste nell'eseguire queste operazioni nella visualizzazione Struttura di tale oggetto. In alcune situazioni, è tuttavia possibile che si desideri modificare la definizione di un oggetto nel codice. L'utilizzo di VBA consente di modificare tutti gli oggetti inclusi in un database, oltre al database stesso.

  • Eseguire azioni a livello di sistema    È possibile eseguire l'azione EseguiApplicazione in una macro per eseguire un altro programma, ad esempio Microsoft Office Excel 2007, dall'interno di Microsoft Access, ma non è possibile utilizzare una macro per eseguire molte altre operazioni all'esterno di Microsoft Access. Tramite VBA è invece possibile verificare la presenza di un file nel computer, utilizzare l'automazione o lo Dynamic Data Exchange (DDE) per comunicare con altri programmi basati su Microsoft Windows, ad esempio Office Excel 2007, nonché chiamare funzioni in DLL di Windows.

  • Modificare i record uno alla volta    È possibile utilizzare VBA per scorrere un set di record un record alla volta ed eseguire un'operazione in ogni record. Al contrario, le macro operano su interi set di record contemporaneamente.

Se non si utilizza il codice VBA in un database che viene distribuito ad altri utenti, è consigliabile creare un pacchetto del database e firmarlo, in modo da garantire agli utenti che il codice proviene da un'origine attendibile. Per ulteriori informazioni sulla creazione e la firma di un pacchetto del database, vedere l'articolo Proteggere un database di Access 2007.

Torna all'inizio

Utilizzare la Creazione guidata Pulsante di comando per eseguire attività di programmazione comuni

Quando si aggiunge un pulsante di comando a una maschera, è possibile utilizzare la Creazione guidata Pulsante di comando per iniziare a programmare. La procedura guidata consente di creare un pulsante di comando per l'esecuzione di un'attività specifica. In un file di Office Access 2007, con estensione accdb, la procedura guidata consentirà di creare una macro incorporata nella proprietà SuClic del pulsante di comando. In un file con estensione mdb o adp, la procedura guidata consentirà invece di creare codice VBA, poiché le macro incorporate non sono disponibili in questi formati di file. In entrambi i casi sarà quindi possibile modificare o migliorare la macro o il codice VBA in base alle esigenze specifiche.

  1. Fare clic sul pulsante Microsoft Office  Pulsante Microsoft Office , quindi su Apri.

  2. Nella finestra di dialogo Apri selezionare e aprire il database.

  3. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla maschera alla quale si desidera aggiungere il pulsante di comando, quindi scegliere Visualizzazione Struttura.

  4. Nel gruppo Controlli della scheda Progettazione verificare che sia selezionato Usa creazioni guidate Controllo Icona del pulsante.

    Icona del pulsante

  5. Nel gruppo Controlli della scheda Struttura fare clic su Pulsante.

    Icona del pulsante

  6. Nella griglia di struttura della maschera fare clic nel punto in cui si desidera posizionare il pulsante.

    Verrà avviata la Creazione guidata Pulsante di comando.

  7. Nella prima pagina della procedura guidata fare clic su ogni categoria nell'elenco Categorie per visualizzare le azioni eseguibili dal pulsante di comando che è possibile programmare con la procedura guidata. Nell'elenco Azioni selezionare l'azione desiderata, quindi fare clic su Avanti.

  8. Fare clic sull'opzione Testo oppure sull'opzione Immagine, a seconda che nel pulsante di comando si desideri visualizzare del testo o un'immagine.

    • Se si desidera visualizzare del testo, sarà possibile modificare il testo presente nella casella accanto all'opzione Testo.

    • Se si desidera visualizzare un'immagine, verrà proposta automaticamente un'immagine inclusa nell'elenco. Se si desidera selezionare un'immagine diversa, selezionare la casella di controllo Mostra tutte le immagini per visualizzare le immagini di tutti i pulsanti di comando disponibili in Office Access 2007 oppure fare clic su Sfoglia per selezionare un'immagine memorizzata in un'altra posizione.

      Fare clic su Avanti.

  9. Immettere un nome significativo per il pulsante di comando. Questo è un passaggio facoltativo e il nome immesso non verrà visualizzato nel pulsante di comando. È tuttavia consigliabile immettere un nome significativo per facilitare i successivi riferimenti al pulsante di comando. Se, ad esempio, si sta impostando l'ordine di tabulazione per i controlli della maschera, sarà più facile distinguere i vari pulsanti di comando. Se si tratta di un pulsante di comando che consente di chiudere la maschera, sarà ad esempio possibile assegnare al comando il nome cmdChiudi oppure ComandoChiudi.

  10. Fare clic su Fine.

    Il pulsante di comando verrà posizionato nella maschera.

  11. Per vedere i risultati della programmazione eseguita tramite la procedura guidata, effettuare i seguenti passaggi facoltativi:

    1. Se la finestra delle proprietà non è visualizzata, premere F4 per visualizzarla.

    2. Fare clic sulla scheda Evento nella finestra delle proprietà.

    3. Nella casella della proprietà Su clic fare clic su Icona del pulsante.

      Verrà avviato il Generatore di macro e visualizzata la macro creata tramite la procedura guidata. Se lo si desidera, sarà possibile modificare la macro. Per ulteriori informazioni sulla modifica di una macro, vedere la sezione Informazioni sulle macro oppure fare clic sui collegamenti disponibili nella sezione Vedere anche. Al termine della modifica, fare clic su Chiudi nel gruppo Chiudi della scheda Struttura per chiudere il Generatore di macro. Se viene visualizzato in messaggio per richiedere di salvare le modifiche e aggiornare la proprietà, fare clic su per salvare le modifiche oppure su No per non salvarle.

  12. Fare clic su Visualizza nel gruppo Visualizzazioni della scheda Struttura, quindi fare clic su Visualizzazione Maschera. Fare clic sul nuovo pulsante di comando per verificare che il funzionamento del pulsante di comando corrisponda a quello previsto.

Torna all'inizio

Informazioni sulle macro

Una macro è uno strumento che consente di automatizzare attività e aggiungere funzionalità a maschere, report e controlli. Se, ad esempio, viene aggiunto un pulsante di comando a una maschera, verrà associata la proprietà dell'evento SuClic a una macro contenente i comandi che si desidera vengano eseguiti ogni volta che il pulsante viene premuto.

È possibile paragonare le macro di Microsoft Access a un linguaggio di programmazione semplificato, in cui il codice viene creato attraverso la composizione di un elenco di azione da eseguire. Quando si crea una macro, ogni azione viene selezionata in un elenco a discesa e per ogni azione vengono quindi immesse le informazioni necessarie. Grazie alle macro, è possibile aggiungere funzionalità a maschere, report e controlli senza scrivere codice in un modulo VBA. Le macro offrono inoltre un sottoinsieme dei comandi disponibili in VBA. Molti utenti considerano pertanto più semplice creare una macro anziché scrivere codice VBA.

Per creare una macro, è necessario utilizzare il Generatore di macro, illustrato nell'immagine seguente.

Generatore di macro

Per visualizzare il generatore di macro:

  • Nel gruppo Altro della scheda Crea fare clic su Macro. Se questo comando non è disponibile, fare clic sulla freccia al di sotto del pulsante Modulo o del pulsante Modulo di classe, quindi fare clic su Macro.Icona del pulsante

Per ulteriori informazioni sulla creazione di macro, fare clic sui collegamenti disponibili nella sezione Vedere anche di questo articolo.

Torna all'inizio

Informazioni sul codice VBA

VBA è un linguaggio di programmazione che è possibile utilizzare per creare applicazioni efficaci in Microsoft Access. VBA include centinaia di comandi che permettono di eseguire operazioni molto più complesse rispetto a quelle che è possibile eseguire con le macro di Microsoft Access.

È possibile estendere le prestazioni di VBA utilizzando controlli di terze parti ed è inoltre possibile scrivere funzioni e routine personalizzate in base alle esigenze specifiche. È infine possibile utilizzare VBA per integrare Microsoft Access con altre applicazioni.

Un modo per iniziare immediatamente a utilizzare la programmazione VBA consiste nel creare innanzitutto una macro di Microsoft Access e quindi convertirla in codice VBA. Le istruzioni per eseguire questa operazione sono incluse nella sezione Convertire le macro in codice VBA. Questa funzionalità consente di creare un nuovo modulo contenente una routine Function di VBA che consente di eseguire le stesse operazioni specificate nella macro, nonché di aprire Visual Basic Editor in modo da poter modificare la routine. Quando si utilizza Visual Basic Editor, è possibile fare clic sulle parole chiave e premere F1 per aprire la Guida per sviluppatori e ottenere ulteriori informazioni su ogni parola chiave. È quindi possibile esplorare la Guida per sviluppatori e scoprire i nuovi comandi che consentono di eseguire le attività di programmazione desiderate.

Torna all'inizio

Convertire le macro in codice VBA

È possibile utilizzare Office Access 2007 per convertire automaticamente le macro in moduli VBA o moduli di classe. È possibile convertire le macro collegate a una maschera o a un report, indipendentemente dal fatto che queste esistano come oggetti separati o macro incorporate. È inoltre possibile convertire macro globali che non sono collegate a una maschera o a un modulo specifico.

Convertire le macro collegate a una maschera o un report

Questo processo consente di convertire in VBA qualsiasi macro alla quale venga fatto riferimento da una maschera o da un report o che sia incorporata in una maschera o in un report, nonché nei relativi controlli, e di aggiungere codice VBA al modulo di classe della maschera o del report. Il modulo di classe diventa parte della maschera o del report con cui viene spostato, nel caso in cui la maschera o il report venga spostato o copiato.

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla maschera o sul report, quindi scegliere visualizzazione Struttura.

  2. Nella scheda Strumenti database del gruppo Macro fare clic su Converti macro della maschera in Visual Basic oppure su Converti macro del report in Visual Basic.

  3. Nella finestra di dialogo Converti da macro o Converti macro di report specificare se si desidera aggiungere il codice per la gestione degli errori alle funzioni generate da Microsoft Access. Inoltre, nel caso in cui le macro contengano commenti, specificare se si desidera includere tali commenti nelle funzioni. Fare clic su Converti per continuare.

    Se non esiste alcun modulo di classe per la maschera o il report, ne verrà creato uno automaticamente e una routine verrà aggiunta al modulo per ogni macro associata alla maschera o al report. Le proprietà di evento del modulo o del report verranno inoltre modificate automaticamente, in modo da determinare l'esecuzione delle nuove routine VBA anziché delle macro.

  4. Per visualizzare e modificare il codice VBA:

    1. Con la maschera o il report ancora aperti in Visualizzazione Struttura, se la finestra delle proprietà non è visualizzata, premere F4 per visualizzarla.

    2. Nella scheda Evento della finestra delle proprietà fare clic sulla casella di una proprietà in cui sia visualizzato [Routine evento], quindi fare clic su Icona del pulsante. Per visualizzare le proprietà di evento per un controllo specifico, fare clic sul controllo per selezionarlo. Per visualizzare le proprietà di evento per l'intera maschera o report, selezionare Maschera o Report nell'elenco a discesa nella parte superiore della finestra delle proprietà.

      Verrà aperto Visual Basic Editor e visualizzata la routine evento nel relativo modulo di classe. È possibile scorrere verso l'alto o verso il basso per visualizzare le eventuali altre routine incluse nello stesso modulo di classe.

Convertire macro globali

  1. Nel riquadro di spostamento fare clic sul nome della macro che si desidera convertire.

  2. Nel gruppo Macro della scheda Strumenti database fare clic su Converti macro in Visual Basic.

  3. Nella finestra di dialogo Converti macro selezionare le opzioni desiderate, quindi fare clic su Converti.

    La macro verrà convertita e verrà aperto Visual Basic Editor.

  4. Per visualizzare e modificare il codice VBA:

    1. In Visual Basic Editor, se il riquadro Explorer del progetto non è visualizzato, scegliere Explorer del progetto dal menu Visualizza.

    2. Espandere la struttura sotto il nome del database che si sta utilizzando.

    3. In Moduli fare doppio clic sul modulo Macronome macroconvertita.

      Il modulo verrà aperto in Visual Basic Editor.

Collegare una funzione VBA a una proprietà di evento

Quando si converte una macro globale in VBA, il codice VBA viene inserito in un modulo standard. A differenza di un modulo di classe, un modulo standard non fa parte di una maschera o di un report. È probabile che si desideri associare la funzione a una proprietà di evento in una maschera, in un report o in un controllo, in modo che il codice venga eseguito esattamente nel momento e nella posizione desiderati. A tale scopo, è possibile copiare il codice VBA in un modulo di classe e quindi associarlo a una proprietà di evento oppure creare una chiamata speciale dalla proprietà di evento al modulo standard utilizzando la procedura seguente.

  1. In Visual Basic Editor annotare il nome della funzione. Se, ad esempio, è stata convertita una macro denominata MiaMacro, il nome della funzione sarà MiaMacro().

  2. Chiudere Visual Basic Editor.

  3. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla maschera o sul report al quale si desidera associare la funzione, quindi scegliere Visualizzazione Struttura.

  4. Fare clic sul controllo o sulla sezione a cui si desidera associare la funzione.

  5. Se la finestra delle proprietà non è visualizzata, premere F4 per visualizzarla.

  6. Nella scheda Evento della finestra delle proprietà fare clic sulla casella della proprietà di evento alla quale si desidera associare la funzione.

  7. Nella casella della proprietà digitare un segno di uguale (=) seguito dal nome della funzione, ad esempio =MiaMacro(). Verificare di includere le parentesi.

  8. Salvare la maschera o il report facendo clic su Salva Icona del pulsante sulla barra di accesso rapido.

  9. Nel riquadro di spostamento fare doppio clic sulla maschera o sul report e controllare che il codice venga eseguito come previsto.

Sono stati illustrate le procedure di base per l'aggiunta di codice VBA al database. In questo articolo vengono descritte solo le nozioni fondamentali che consentono di iniziare a programmare. Per migliorare le proprie capacità di programmazione, sono disponibili diversi materiali di riferimento e risorse in linea.

Torna all'inizio

Utilizzo del sistema della Guida

In Office Access 2007 è possibile utilizzare diversi modi per ottenere assistenza nella programmazione. In qualsiasi momento è possibile fare clic sul pulsante ? nell'angolo superiore destro della finestra di Microsoft Access.

Punto di ingresso della Guida

In Microsoft Access verrà visualizzata la finestra della Guida.

Durante la creazione di macro o routine VBA, è inoltre possibile fare clic su un'azione di macro, una parola chiave oppure sul nome di una funzione incorporata e premere F1. Nella maggior parte dei casi, in Microsoft Access verrà visualizzato l'argomento della Guida relativo all'elemento selezionato.

Con la finestra della Guida aperta, utilizzare i pulsanti di spostamento sulla barra degli strumenti per spostarsi tra le pagine.

Barra degli strumenti del visualizzatore della Guida

Ad esempio, fare clic su Home per visualizzare il sommario, quindi scegliere i pulsanti Indietro, Avanti, Interrompi o Aggiorna per spostarsi tra i vari argomenti o per ricaricare un argomento specifico. Nel sistema della Guida è inoltre possibile eseguire la ricerca di informazioni specifiche, immettendo i termini di ricerca nella casella immediatamente sotto la barra degli strumenti, quindi premendo INVIO o facendo clic su Cerca.

Nella ricerca di informazioni sulla programmazione, risulta in genere utile esplorare la Guida gli sviluppatori oltre alla Guida di Microsoft Access.

Passare alla Guida per sviluppatori

  1. Fare clic sulla freccia in giù accanto al pulsante Cerca.

    Pulsante Cerca nella Guida

    Nella finestra della Guida verranno visualizzati gli argomenti della Guida che è possibile selezionare.

    Elenco di ricerca nella Guida

  2. Se si è connessi a Internet, in Contenuto di Office Online fare clic su Guida per sviluppatori. È consigliabile utilizzare questo metodo, poiché il contenuto del sito Web Microsoft Office Online è sempre più aggiornato. Se non si è connessi a Internet o se l'amministratore di sistema ha disattivato la possibilità di visualizzare in linea la finestra della Guida, sarà comunque possibile visualizzare la Guida per sviluppatori facendo clic su Guida per sviluppatori in Contenuto di questo computer.

  3. È possibile sfogliare la Guida utilizzando i collegamenti disponibili nel sommario oppure immettendo i termini di ricerca nella casella posta immediatamente sotto la barra degli strumenti e premendo INVIO.

  4. Per tornare alla Guida di Microsoft Access, fare clic sulla freccia in giù accanto al pulsante Cerca, quindi scegliere Guida di Access in Contenuto di Office Online o Contenuto di questo computer.

Per ulteriori informazioni sull'utilizzo in linea o non in linea della Guida, fare clic sul menu Stato connessione nell'angolo inferiore destro della finestra della Guida, quindi scegliere Spiega opzioni.

Messaggio Stato di connessione nel visualizzatore della Guida

Torna all'inizio

Si applica a: Access 2007



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua