Importare o collegare dati di una cartella di lavoro di Excel

Importare o collegare dati di una cartella di lavoro di Excel

I dati di una cartella di lavoro di Excel possono essere inseriti in Access in numerosi modi. È possibile copiare i dati da un foglio di lavoro aperto e incollarli in un foglio dati di Access, importare un foglio di lavoro in una tabella nuova o esistente oppure collegare un database di Access a un foglio di lavoro.

Questo argomento spiega dettagliatamente come importare o collegare dati di Excel da database desktop di Access.

Note : 

  • Non è possibile importare dati mentre un database Web di Access 2010 è in esecuzione in un browser. Se si desidera importare dati in un database Web, è innanzitutto necessario aprire il database Web tramite Access.

  • Le tabelle collegate non sono compatibili con i database Web di Access 2010. Per usare dati esterni in un database Web, è necessario importare i dati anziché collegarli. Per ulteriori informazioni sui database Web, vedere l'articolo Creare un database di Access da condividere sul Web.

Per saperne di più

Informazioni sull'importazione di dati da Excel

Importare dati da Excel

Risolvere i problemi relativi a valori mancanti o non corretti

Eseguire il collegamento a dati di Excel

Risolvere i problemi relativi a #Num! e ad altri valori non corretti in una tabella collegata

Informazioni sull'importazione di dati da Excel

Se si prevede di memorizzare alcuni o tutti i dati di uno o più fogli di lavoro di Excel in Access, è consigliabile importare il contenuto del foglio di lavoro in un database nuovo o esistente di Access. Quando si importano dati, in Access viene creata una copia dei dati in una tabella nuova o esistente senza modificare il foglio di lavoro di Excel di origine.

Scenari comuni per l'importazione di dati di Excel in Access

  • Dopo aver utilizzato per lungo tempo Excel, si desidera iniziare a utilizzare Access per gestire i dati, spostando i dati dei fogli di lavoro di Excel in uno o più nuovi database di Access.

  • Il reparto o il gruppo di lavoro utilizza Access, ma si ricevono talvolta dati in formato Excel che devono essere uniti ai database di Access. Si desidera importare tali fogli di lavoro di Excel nel database appena vengono ricevuti.

  • Access viene utilizzato per gestire i dati, ma i report settimanali ricevuti dal resto del team sono costituiti da cartelle di lavoro di Excel. Si desidera semplificare il processo di importazione affinché tali dati vengano importati nel database ogni settimana a un'ora specifica.

Esecuzione dell'importazione di dati da Excel per la prima volta

  • Non è possibile salvare una cartella di lavoro di Excel come database di Access. Excel non offre funzionalità per la creazione di un database di Access da dati di Excel.

  • Quando si apre una cartella di lavoro di Excel in Access, impostando l'opzione File Microsoft Office Excel nella casella di riepilogo Tipo file e selezionando il file desiderato nella finestra di dialogo Apri file, Access crea un collegamento alla cartella di lavoro, anziché importare i dati corrispondenti. Il collegamento a una cartella di lavoro presenta differenze fondamentali rispetto all'importazione di un foglio di lavoro in un database. Per ulteriori informazioni sul collegamento, vedere la sezione Eseguire il collegamento a dati di Excel più avanti in questo articolo.

Importare dati da Excel

Le procedure in questa sezione descrivono come preparare ed eseguire un'operazione di importazione, nonché come salvare le impostazioni di importazione come specifica per riutilizzarle in seguito. Tenere presente che è consentita l'importazione di dati da un solo foglio di lavoro alla volta. Non è possibile importare contemporaneamente tutti i dati di un'intera cartella di lavoro.

Preparare il foglio di lavoro

  1. Individuare il file di origine e selezionare il foglio di lavoro contenente i dati da importare in Access. Per importare solo una parte di un foglio di lavoro, è possibile definire un intervallo denominato contenente soltanto le celle da importare.

    Definire un intervallo denominato (facoltativo)   

    1. Passare a Excel e aprire il foglio di lavoro contenente i dati da importare.

    2. Selezionare l'intervallo delle celle che contengono i dati che si desidera importare.

    3. Fare clic con il pulsante destro del mouse all'interno dell'intervallo selezionato e quindi scegliere Inserisci nome intervallo o Definisci nome.

    4. Nella finestra di dialogo Nuovo nome specificare un nome per l'intervallo nella casella Nome e quindi fare clic su OK.

      Si ricordi che durante un'operazione di importazione, è possibile importare un solo foglio di lavoro per volta. Per importare i dati di più fogli di lavoro, ripetere l'operazione di importazione per ogni foglio di lavoro.

  2. Rivedere i dati di origine e intervenire come descritto nella tabella seguente.

    Elemento

    Descrizione

    Numero di colonne

    Il numero delle colonne di origine da importare non può essere superiore a 255, poiché Access non supporta più di 255 campi in una tabella.

    Omissione di colonne e righe

    È consigliabile includere soltanto le righe e le colonne da importare nell'intervallo definito o nel foglio di lavoro di origine.

    Righe    Non è possibile filtrare o omettere righe durante l'operazione di importazione.

    Colonne    Non è possibile omettere colonne durante l'operazione se è stato scelto di aggiungere i dati a una tabella esistente.

    Formato tabulare

    Verificare che le celle siano in formato tabulare. Se il foglio di lavoro o l'intervallo definito include celle unite, il contenuto della cella viene inserito nel campo corrispondente alla colonna più a sinistra e gli altri campi vengono lasciati vuoti.

    Colonne, righe e celle vuote

    Eliminare tutte le colonne e le righe vuote non necessarie del foglio di lavoro o dell'intervallo. Se il foglio di lavoro o l'intervallo contiene celle vuote, provare ad aggiungere i dati mancanti. Se si intende accodare i record a una tabella esistente, verificare che il campo corrispondente della tabella accetti valori Null (mancanti o sconosciuti). Un campo accetta valori Null se la relativa proprietà Richiesto è impostata su No e l'impostazione della proprietà Valido se non impedisce l'utilizzo di valori Null.

    Valori di errore

    Se una o più celle del foglio di lavoro o dell'intervallo contengono valori di errore, ad esempio #NUM e #DIV, correggerli prima di avviare l'operazione di importazione. Se un foglio di lavoro o un intervallo di origine contiene valori di errore, in Access verrà inserito un valore Null nel campo corrispondente della tabella. Per ulteriori informazioni sulle procedure per la correzione di questo tipo di errori, vedere la sezione Risolvere i problemi relativi a valori mancanti o non corretti di seguito in questo articolo.

    Tipo di dati

    Per evitare errori durante l'importazione, verificare che ogni colonna di origine contenga lo stesso tipo di dati in ogni riga. In Access vengono infatti analizzate le prime otto righe di origine per determinare il tipo di dati dei campi della tabella. È consigliabile verificare che le prime otto righe di origine non contengano una combinazione di valori di tipi di dati diversi in una o più colonne. In caso contrario, alla colonna potrebbe non venire assegnato automaticamente il tipo di dati corretto.

    È inoltre opportuno formattare ogni colonna di origine in Excel e assegnare uno specifico formato di dati a ogni colonna prima di avviare l'operazione di importazione. La formattazione è consigliabile se una colonna include valori di tipi di dati diversi. La colonna N. volo di un foglio di lavoro può ad esempio contenere valori numerici e di testo, quali 871, AA90 e 171. Per evitare valori mancanti o non corretti, eseguire le operazioni seguenti:

    1. Fare clic con il pulsante destro del mouse sull'intestazione di colonna e quindi scegliere Formato celle.

    2. Nella scheda Numero selezionare un formato in Categoria. Per la colonna N. volo si sceglierà probabilmente Testo.

    3. Fare clic su OK.

    Se le colonne di origine sono formattate ma contengono tuttavia valori misti nelle righe successive all'ottava, è comunque possibile che alcuni valori vengano omessi o convertiti in modo non corretto nell'operazione di importazione. Per informazioni sulla risoluzione dei problemi, vedere la sezione Risolvere i problemi relativi a valori mancanti o non corretti.

    Prima riga

    Se la prima riga del foglio di lavoro o dell'intervallo definito contiene i nomi delle colonne, è possibile specificare che durante l'operazione di importazione i dati della prima riga vengano considerati da Access come nomi dei campi. Se il foglio di lavoro o l'intervallo di origine non include i nomi, è opportuno aggiungerli all'origine prima di avviare l'operazione di importazione.

    Nota : Se si intende accodare i dati a una tabella esistente, verificare che il nome di ogni colonna corrisponda esattamente al nome del campo corrispondente. Se il nome di una colonna è diverso dal nome del campo corrispondente della tabella, l'operazione di importazione avrà esito negativo. Per visualizzare i nomi dei campi, aprire la tabella in visualizzazione Struttura all'interno di Access.

  3. Chiudere la cartella di lavoro di origine, se aperta. Se tale file rimane aperto, potrebbero verificarsi errori di conversione dei dati durante l'operazione di importazione.

Preparare il database di destinazione

  1. Aprire il database di Access in cui verranno memorizzati i dati importati. Verificare che il database non sia di sola lettura e di disporre delle autorizzazioni necessarie per apportare modifiche al database.

    -oppure-

    Se non si desidera memorizzare i dati in uno dei database esistenti, creare un database vuoto. A tale scopo:

    Fare clic sulla scheda File, scegliere Nuovo e quindi fare clic su Database vuoto. Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Nuovo.

  2. Prima di avviare l'operazione di importazione, decidere se si desidera memorizzare i dati in una tabella nuova o esistente.

    Creare una nuova tabella    Se si sceglie di memorizzare i dati in una nuova tabella, in Access viene creata una tabella alla quale vengono aggiunti i dati importati. Se esiste già una tabella con il nome specificato, il contenuto della tabella verrà sovrascritto con i dati importati.

    Accodare i dati a una tabella esistente    Se si sceglie di aggiungere i dati a una tabella esistente, le righe del foglio di lavoro di Excel vengono accodate alla tabella specificata.

    È opportuno tenere presente che la maggior parte degli errori durante le operazioni di accodamento è causata dalla non corrispondenza tra i dati di origine e le impostazioni della struttura e dei campi della tabella di destinazione. Per evitare il problema, aprire la tabella di destinazione in visualizzazione Struttura e verificare quanto segue:

    • Prima riga    Se la prima riga del foglio di lavoro o dell'intervallo definito di origine non contiene intestazioni di colonna, verificare che la posizione e il tipo di dati di ogni colonna del foglio di lavoro di origine corrispondano a quelli del campo corrispondente della tabella. Se la prima riga contiene intestazioni di colonna, non è necessario che l'ordine delle colonne e dei campi corrisponda, ma il nome e il tipo di dati di ogni colonna deve corrispondere esattamente al rispettivo campo.

    • Campi mancanti o aggiuntivi    Se uno o più campi nel foglio di lavoro di origine non esistono nella tabella di destinazione, aggiungerli prima di avviare l'operazione di importazione. Se invece la tabella contiene campi non esistenti nell'origine, non sarà necessario eliminarli dalla tabella purché accettino valori Null.

      Suggerimento : Un campo accetta valori Null se la relativa proprietà Richiesto è impostata su No e l'impostazione della proprietà Valido se non impedisce l'utilizzo di valori Null.

    • Chiave primaria    Se la tabella contiene un campo chiave primaria, il foglio di lavoro o l'intervallo di origine deve disporre di una colonna contenente valori compatibili con il campo chiave primaria e i valori di chiave importati devono essere univoci. Se un record importato contiene un valore di chiave primaria già esistente nella tabella di destinazione, durante l'operazione di importazione verrà visualizzato un messaggio di errore.

    • Campi indicizzati    Se la proprietà Indicizzato di un campo della tabella è impostata su Sì (Duplicati non ammessi), la colonna corrispondente del foglio di lavoro o dell'intervallo di origine deve contenere valori univoci.

      Procedere con i passaggi successivi per eseguire l'operazione di importazione.

Avviare l'operazione di importazione

  1. La posizione dell'Importazione guidata/Collegamento guidato varia leggermente in base alla versione di Access. Scegliere la procedura corrispondente alla versione di Access:

    • Se si usa la versione più recente di Access inclusa nell'abbonamento a Office 365, nel gruppo Importa e collega della scheda Dati esterni fare clic su Nuova origine dati > Da File > Excel.

    • Se si usa Access 2016, Access 2013 o Access 2010, fare clic su Excel nel gruppo Importa e collega della scheda Dati esterni.

    • Se si usa Access 2007, fare clic su Excel nel gruppo Importa della scheda Dati esterni.

    Nota : La scheda Dati esterni è disponibile solo se è aperto un database.

  2. Nella casella Nome file della finestra di dialogo Carica dati esterni - Foglio di calcolo di Excel specificare il nome del file di Excel contenente i dati da importare.

    -oppure-

    Fare clic su Sfoglia e utilizzare la finestra di dialogo Apri file per individuare il file che si desidera importare.

  3. Specificare la modalità di memorizzazione dei dati importati.

    Per memorizzare i dati in una nuova tabella, selezionare Importa dati di origine in una nuova tabella nel database corrente. Verrà in seguito richiesto di assegnare un nome alla tabella.

    Per accodare i dati a una tabella esistente, selezionare Accoda una copia dei record alla tabella e quindi selezionare una tabella nell'elenco a discesa. Questa opzione non è disponibile se nel database non sono presenti tabelle.

    Per eseguire il collegamento all'origine dati creando una tabella collegata, vedere la sezione Eseguire il collegamento a dati di Excel più avanti in questo articolo.

  4. Fare clic su OK.

    Verrà avviata l'Importazione guidata Foglio di calcolo, che consente di eseguire in modo semplificato il processo di importazione. Procedere con i passaggi successivi.

Utilizzare l'Importazione guidata Foglio di calcolo

  1. Nella prima pagina della procedura guidata selezionare il foglio di lavoro contenente i dati che si desidera importare e quindi fare clic su Avanti.

  2. Nella seconda pagina della procedura guidata, fare clic su Mostra fogli di lavoro o Mostra intervalli definiti, selezionare il foglio di lavoro o l'intervallo definito che si desidera importare e quindi fare clic su Avanti.

  3. Se la prima riga del foglio di lavoro o dell'intervallo di origine contiene i nomi dei campi, selezionare Intestazioni di colonne nella prima riga e quindi fare clic su Avanti.

    In caso di importazione dei dati in una nuova tabella di Access, le intestazioni di colonna vengono utilizzate per assegnare un nome ai campi della tabella. Tali nomi possono essere modificati durante o dopo l'operazione di importazione. In caso di accodamento di dati a una tabella esistente, verificare che le intestazioni di colonna nel foglio di lavoro di origine corrispondano esattamente ai nomi dei campi nella tabella di destinazione.

    In caso di accodamento di dati a una tabella esistente, andare direttamente al passaggio 6. In caso di aggiunta dei dati a una nuova tabella, eseguire i passaggi rimanenti.

  4. Verrà richiesto di verificare le proprietà dei campi. Fare clic su una colonna nella metà inferiore della pagina per visualizzare le proprietà del campo corrispondente. Facoltativamente, eseguire una delle operazioni seguenti:

    • Verificare e modificare, se necessario, il nome e il tipo di dati del campo di destinazione.

      Le prime otto righe di ogni colonna vengono esaminate in Access per suggerire il tipo di dati per il campo corrispondente. Se nelle prime otto righe di una colonna del foglio di lavoro sono contenuti tipi diversi di valori, ad esempio testo e numeri, verrà suggerito un tipo di dati compatibile con tutti i valori della colonna, in genere il tipo di dati Testo. Nonostante sia possibile scegliere un tipo di dati diverso, tenere presente che i valori non compatibili con il tipo di dati scelto verranno ignorati o convertiti in modo non corretto durante il processo di importazione. Per ulteriori informazioni sulle procedure per la correzione dei valori mancanti o non corretti, vedere la sezione Risolvere i problemi relativi a valori mancanti o non corretti di seguito in questo articolo.

    • Per creare un indice basato sul campo, impostare la proprietà Indicizzato su .

    • Per omettere completamente una colonna di origine, selezionare la casella di controllo Non importare campo (salta).

      Fare clic su Avanti dopo aver selezionato tutte le opzioni desiderate.

  5. Nella schermata successiva, specificare una chiave primaria per la tabella. Se si seleziona Chiave primaria aggiunta automaticamente, verrà aggiunto un campo di tipo Contatore come primo campo della tabella di destinazione e tale campo verrà popolato automaticamente con valori di ID univoci a partire da 1. Fare clic su Avanti.

  6. Nella schermata finale della procedura guidata specificare un nome per la tabella di destinazione. Nella casella Importa nella tabella digitare un nome per la tabella. Se la tabella esiste già, verrà richiesto se si desidera sovrascrivere il contenuto esistente della tabella. Fare clic su per continuare oppure su No per specificare un nome diverso per la tabella di destinazione e quindi fare clic su Fine per importare i dati.

    Se l'importazione di alcuni o di tutti i dati con Access riesce, viene visualizzata una pagina della procedura guidata contenente lo stato dell'operazione di importazione. È anche possibile salvare i dettagli dell'operazione come specifica in modo da poterli usare in futuro. Se invece l'operazione ha esito completamente negativo, viene visualizzato il messaggio Errore nel tentativo di importare il file.

  7. Fare clic su per salvare i dettagli dell'operazione per utilizzi futuri. Il salvataggio dei dettagli consente di ripetere in seguito l'operazione senza dover completare ogni volta i passaggi della procedura guidata.

Per informazioni su come salvare i dettagli di una specifica salvata, vedere Salvare i dettagli di un'operazione di importazione o esportazione come specifiche.

Per informazioni su come eseguire le specifiche di importazione o collegamento salvate, vedere Eseguire una specifica salvata di importazione o esportazione.

Per informazioni su come pianificare le attività di importazione e collegamento in modo che vengano eseguite in orari specifici, vedere Pianificare una specifica di importazione o esportazione.

Risolvere i problemi relativi a valori mancanti o non corretti

La visualizzazione del messaggio Errore nel tentativo di importare il file indica che l'operazione di importazione ha avuto esito completamente negativo. Se invece nel corso dell'importazione viene visualizzata una finestra di dialogo in cui viene richiesto di salvare i dettagli dell'operazione, significa è stato possibile importare alcuni o tutti i dati. Nel messaggio di stato viene inoltre specificata la tabella del log degli errori contenente la descrizione degli eventuali errori che si sono verificati durante l'operazione di importazione.

Importante : Anche se nel messaggio di stato viene indicato che l'operazione è stata completata correttamente, è consigliabile esaminare il contenuto e la struttura della tabella per verificarne la correttezza prima di iniziare a utilizzarla.

  • Aprire la tabella di destinazione in visualizzazione Foglio dati per controllare se tutti i dati sono stati aggiunti alla tabella.

  • Aprire la tabella in visualizzazione Struttura per verificare il tipo di dati e le altre impostazioni delle proprietà dei campi.

Nella tabella seguente vengono descritti i passaggi che è possibile eseguire per correggere valori mancanti o non corretti.

Suggerimento : Quando si risolvono i problemi relativi ai risultati, se si riscontrano soltanto alcuni valori mancanti è possibile aggiungerli manualmente alla tabella. Se invece si riscontra la mancanza o l'importazione non corretta di intere colonne o di un numero elevato di valori, è consigliabile correggere il problema nel file di origine. Dopo aver corretto tutti i problemi noti, ripetere l'operazione di importazione.

Problema

Risoluzione

Elementi grafici

Gli elementi grafici, ad esempio logo, grafici e immagini, non possono essere importati. Aggiungerli manualmente al database al termine dell'operazione di importazione.

Valori calcolati

Vengono importati i risultati di celle o colonne calcolate, ma non la formula sottostante. Durante l'operazione di importazione, è possibile specificare un tipo di dati compatibile con i risultati della formula, ad esempio Numerico.

Valori VERO/FALSO e -1/0

Se il foglio di lavoro o l'intervallo di origine include una colonna contenente soltanto valori VERO o FALSO, in Access viene creato un campo Sì/No per la colonna e nel campo vengono inseriti valori -1 o 0. Se tuttavia il foglio di lavoro o l'intervallo di origine include una colonna contenente soltanto valori -1 o 0, per la colonna viene creato un campo numerico per impostazione predefinita. Per evitare il problema, è possibile modificare il tipo di dati del campo in Sì/No durante l'operazione di importazione.

Campi multivalore

Quando si importano dati in una nuova tabella o si accodano dati a una tabella esistente, in Access il supporto di più valori in un campo non è abilitato, anche se la colonna di origine contiene un elenco di valori separati da punto e virgola (;). L'elenco dei valori viene considerato come un valore singolo e inserito in un campo di testo.

Dati troncati

Se i dati risultano troncati in una colonna della tabella di Access, provare a incrementare la larghezza della colonna in visualizzazione Foglio dati. Se il problema non viene risolto, i dati di una colonna numerica di Excel superano le dimensioni consentite per il campo di destinazione in Access. È ad esempio possibile che la proprietà Dimensione campo del campo di destinazione sia impostata su Byte in un database di Access ma che i dati di origine contengano un valore superiore a 255. Correggere i valori nel file di origine e riprovare a eseguire l'importazione.

Formato di visualizzazione

Potrebbe essere necessario impostare la proprietà Formato di determinati campi in visualizzazione Struttura per garantire la corretta visualizzazione dei valori in visualizzazione Foglio dati. Ad esempio:

  • In visualizzazione Foglio dati, al termine dell'operazione di importazione, un campo Sì/No contiene -1 e 0. Per risolvere il problema, al termine dell'operazione di importazione impostare la proprietà Formato del campo su Sì/No per visualizzare invece caselle di controllo.

  • È possibile che in Access le date estese e brevi vengano visualizzate in cifre. Per risolvere il problema, in Access aprire la tabella di destinazione in visualizzazione Struttura e impostare la proprietà Formato del campo di data su Data estesa o Data breve.

Nota : Se il foglio di lavoro di origine contiene testo formattato, ad esempio in grassetto, sottolineato o in corsivo, il testo viene importato ma la formattazione non viene mantenuta.

Valori duplicati (errore di violazione di chiave)

È possibile che i record importati contengano valori duplicati che non possono essere memorizzati nel campo chiave primaria della tabella di destinazione o in un campo la cui proprietà Indicizzato è impostata su Sì (Duplicati non ammessi). Eliminare i valori duplicati nel file di origine e riprovare a eseguire l'importazione.

Valori di dati con differenza di 4 anni

È possibile che i campi di data importati da un foglio di lavoro di Excel differiscano di quattro anni. Excel per Windows utilizza infatti il sistema data 1900, in cui i numeri seriali sono compresi tra 1 e 65.380 e corrispondono alle date dall'1 gennaio 1900 al 31 dicembre 2078. Excel per Macintosh utilizza invece il sistema data 1904, in cui i numeri seriali sono compresi tra 0 e 63.918 e corrispondono alle date dall'1 gennaio 1904 al 31 dicembre 2078.

Prima di importare i dati, modificare il sistema data della cartella di lavoro di Excel oppure, dopo l'accodamento dei dati, eseguire una query di aggiornamento con l'espressione [nome campo data] + 1462 per correggere le date.

Valori Null

È possibile che al termine dell'operazione di importazione venga visualizzato un messaggio di errore relativo a dati eliminati o persi durante l'operazione oppure è possibile riscontrare alcuni valori vuoti nei campi all'apertura della tabella in visualizzazione Foglio dati. Se le colonne di origine di Excel non sono formattate o se le prime otto righe di origine contengono valori di tipi di dati diversi, aprire il foglio di lavoro di origine ed eseguire le operazioni seguenti:

  • Formattare le colonne di origine.

  • Spostare le righe in modo che le prime otto righe di ogni colonna non contengano valori di tipi di dati diversi.

  • Durante l'operazione di importazione, selezionare il tipo di dati appropriato per ogni campo. Se il tipo di dati non è corretto, al termine dell'operazione di importazione verranno visualizzati valori Null o non corretti nell'intera colonna.

I passaggi precedenti consentono di ridurre al minimo la presenza di valori Null. Nella tabella seguente sono elencati i casi in cui vengono comunque visualizzati valori Null.

Tipo valori mancanti

Destinazione importazione

Tipo campo di destinazione

Risoluzione

Testo

Nuova tabella

Data

Sostituire tutti i valori di testo con valori di data e quindi riprovare a eseguire l'importazione.

Testo

Tabella esistente

Numerico o data

Sostituire tutti i valori di testo con valori corrispondenti al tipo di dati del campo di destinazione e quindi riprovare a eseguire l'importazione.

Valori di data sostituiti da valori numerici

Anziché i valori di data effettivi, verranno visualizzati numeri di cinque cifre apparentemente casuali nelle situazioni seguenti:

  • La colonna di origine del foglio di lavoro contiene solo valori numerici nelle prime otto righe, ma alcuni valori di data nelle righe successive. Questi valori di data verranno convertiti in modo non corretto.

  • La colonna di origine contiene valori di data in alcune delle prime otto righe e si è tentato di eseguirne l'importazione in un campo numerico. Questi valori di data verranno convertiti in modo non corretto.

    Per evitare il problema, sostituire i valori di data con valori numerici nella colonna di origine e riprovare a eseguire l'importazione.

    Se una colonna contenente per la maggior parte valori di data contiene anche alcuni valori di testo, è possibile che tutti i valori di data vengano visualizzati come numeri di cinque cifre apparentemente casuali. Per evitare il problema, sostituire i valori di testo con valori di data e quindi riprovare a eseguire l'importazione.

Valori numerici sostituiti da valori di data

Anziché i valori numerici effettivi, verranno visualizzati valori di data apparentemente casuali nelle situazioni seguenti:

  • La colonna di origine contiene solo valori di data nelle prime otto righe, ma alcuni valori numerici nelle righe successive. Questi valori numerici verranno convertiti in modo non corretto.

  • La colonna di origine contiene valori numerici in alcune delle prime otto righe e si è tentato di eseguirne l'importazione in un campo di data. Questi valori numerici verranno convertiti in modo non corretto.

Per evitare il problema, sostituire i valori numerici con valori di data nella colonna di origine e riprovare a eseguire l'importazione.

Può inoltre rivelarsi opportuno rivedere la tabella del log degli errori, citata nell'ultima pagina della procedura guidata, in visualizzazione Foglio dati. La tabella dispone dei tre campi Errore, Campo e Riga. Ogni riga contiene informazioni su un errore specifico e il contenuto del campo Errore consentirà di risolvere il problema.

Stringhe di errore e suggerimenti per la risoluzione dei problemi

Errore

Descrizione

Campo troncato

Un valore nel file presenta dimensioni troppo elevate rispetto all'impostazione della proprietà Dimensione campo del campo.

Errore di conversione tra tipi

Il tipo di dati di un valore del foglio di lavoro non è corretto per il campo. Il valore potrebbe risultare mancante o non corretto nel campo di destinazione. Per ulteriori informazioni sulla risoluzione di questo problema, vedere la tabella precedente.

Violazione di chiave

Il valore di chiave primaria del record è un duplicato, ovvero esiste già nella tabella.

Errore di regola di convalida

Un valore viola la regola impostata utilizzando la proprietà Valido se per il campo o la tabella.

Valori Null nel campo Richiesto

Nel campo non è ammesso un valore Null, poiché la relativa proprietà Richiesto è impostata su .

Valore Null nel campo Contatore

I dati importati contengono un valore Null che si è tentato di accodare a un campo Contatore.

Record non analizzabile

Un valore di testo contiene il carattere di delimitazione di testo, generalmente delle virgolette doppie. Ogni volta che un valore contiene il carattere di delimitazione, questo deve essere ripetuto due volte nel file di testo, ad esempio:

Articolo ""Londra""

Inizio pagina

Eseguire il collegamento a dati di Excel

Il collegamento di un database di Access con dati in un'altra applicazione consente di utilizzare gli strumenti per query e report disponibili in Access senza dover mantenere una copia dei dati di Excel nel database.

In caso di collegamento di un foglio di lavoro o un intervallo definito di Excel, in Access viene creata una nuova tabella collegata alle celle di origine. Qualsiasi modifica apportata alle celle di origine in Excel viene visualizzata nella tabella collegata. Non è tuttavia possibile modificare il contenuto della tabella corrispondente in Access. Se si desidera aggiungere, modificare o eliminare dati, è necessario apportare le modifiche nel file di origine.

Scenari comuni per il collegamento a un foglio di lavoro di Excel da Access

In genere, risulta utile collegare un foglio di lavoro di Excel anziché importarlo nei seguenti casi:

  • Si desidera continuare a mantenere i dati in fogli di lavoro di Excel, usufruendo tuttavia delle potenti funzionalità di query e creazione di report offerte da Access.

  • Il reparto o il gruppo di lavoro utilizza Access, ma i dati delle origini esterne utilizzate sono contenuti in fogli di lavoro di Excel. Non si intende mantenere copie dei dati esterni, ma si desidera essere in grado di utilizzarli in Access.

Esecuzione del collegamento a un foglio di lavoro di Excel per la prima volta

  • Non è possibile creare un collegamento a un database di Access da Excel.

  • Quando si esegue il collegamento a un file di Excel, in Access viene creata una nuova tabella, in genere definita tabella collegata. La tabella contiene i dati del foglio di lavoro o dell'intervallo definito di origine, ma non determina l'effettiva memorizzazione dei dati nel database.

  • Non è possibile collegare dati di Excel a una tabella esistente del database. Non è pertanto possibile accodare dati a una tabella esistente eseguendo un'operazione di collegamento.

  • Un database può contenere più tabelle collegate.

  • Qualsiasi modifica apportata ai dati in Excel si riflette automaticamente nella tabella collegata. Il contenuto e la struttura di una tabella collegata in Access, tuttavia, sono di sola lettura.

  • Quando si apre una cartella di lavoro di Excel in Access, impostando l'opzione Microsoft Excel nella casella di riepilogo Tipo file e selezionando il file desiderato nella finestra di dialogo Apri file, in Access verrà creato un database vuoto e verrà avviato automaticamente il Collegamento guidato Foglio di calcolo.

Preparare i dati di Excel

  1. Trovare il file di Excel e il foglio di lavoro oppure un intervallo che contiene i dati a cui collegarsi. Se non si vuole eseguire il collegamento all'intero foglio di lavoro, può essere utile definire un intervallo denominato contenente soltanto le celle da collegare.

    Creare un intervallo denominato in Excel (facoltativo, utile se si vuole collegare solo parte dei dati del foglio di lavoro)   

    1. Passare a Excel e visualizzare il foglio di lavoro in cui si vuole definire un intervallo denominato.

    2. Selezionare l'intervallo delle celle che contengono i dati a cui si desidera eseguire il collegamento.

    3. Fare clic con il pulsante destro del mouse all'interno dell'intervallo selezionato e scegliere Inserisci nome intervallo o Definisci nome.

    4. Nella finestra di dialogo Nuovo nome specificare un nome per l'intervallo nella casella Nome e quindi fare clic su OK.

      Durante un'operazione di collegamento, è possibile eseguire il collegamento soltanto a un foglio di lavoro o un intervallo per volta. Per il collegamento a dati in più posizioni all'interno di una cartella di lavoro, ripetere l'operazione di collegamento per ogni foglio di lavoro o intervallo.

  2. Rivedere i dati di origine e intervenire come descritto nella tabella seguente.

    Elemento

    Descrizione

    Formato tabulare

    Verificare che le celle siano in formato tabulare. Se l'intervallo include celle unite, il contenuto della cella viene inserito nel campo corrispondente alla colonna più a sinistra e gli altri campi vengono lasciati vuoti.

    Omissione di colonne e righe

    Non è possibile omettere colonne e righe di origine durante l'operazione di collegamento. È tuttavia possibile nascondere i campi e filtrare i record aprendo la tabella collegata in visualizzazione Foglio dati dopo l'importazione in Access.

    Numero di colonne

    Il numero delle colonne di origine non può essere superiore a 255, poiché Access non supporta più di 255 campi in una tabella.

    Colonne, righe e celle vuote

    Eliminare tutte le colonne e le righe vuote non necessarie dell'intervallo o del foglio di lavoro di Excel. Se sono presenti celle vuote, provare ad aggiungere i dati mancanti.

    Valori di errore

    Se una o più celle del foglio di lavoro o dell'intervallo contengono valori di errore, correggerli prima di avviare l'operazione di collegamento. Se un foglio di lavoro o un intervallo di origine contiene valori di errore, in Access verrà inserito un valore Null nel campo corrispondente della tabella.

    Tipo di dati

    Non è possibile modificare il tipo di dati o le dimensioni dei campi della tabella collegata. Prima di avviare l'operazione di collegamento, è necessario verificare che ogni colonna contenga dati di un tipo specifico.

    Se una colonna include valori di tipi di dati diversi, è consigliabile eseguirne la formattazione. La colonna N. volo di un foglio di lavoro, ad esempio, può contenere campi numerici e di testo quali 871, AA90 e 171. Per evitare valori mancanti o non corretti, eseguire le operazioni seguenti:

    1. Fare clic con il pulsante destro del mouse sulla colonna e quindi scegliere Formato celle.

    2. Nella scheda Numero selezionare un formato in Categoria.

    3. Fare clic su OK.

    Prima riga

    Se la prima riga del foglio di lavoro o dell'intervallo definito contiene i nomi delle colonne, è possibile specificare che durante l'operazione di collegamento i dati della prima riga vengano considerati da Access come nomi dei campi. Se nel foglio di lavoro non sono presenti nomi di colonna o se uno specifico nome di colonna viola le regole per la denominazione dei campi di Access, in Access verrà assegnato un nome valido per ogni campo corrispondente.

  3. Chiudere il file di origine, se aperto.

Preparare il database di destinazione

  1. Aprire il database in cui si desidera creare il collegamento. Verificare che il database non sia di sola lettura e di disporre delle autorizzazioni necessarie per apportarvi modifiche.

  2. Se non si vuole archiviare il collegamento in uno dei database esistenti, creare un database vuoto: Fare clic sulla scheda File, scegliere Nuovo e quindi fare clic su Database vuoto. Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Nuovo.

È ora possibile avviare l'operazione di collegamento.

Creare il collegamento

  1. La posizione dell'Importazione guidata/Collegamento guidato varia leggermente in base alla versione di Access. Scegliere la procedura corrispondente alla versione di Access:

    • Se si usa la versione più recente di Access inclusa nell'abbonamento a Office 365, nel gruppo Importa e collega della scheda Dati esterni fare clic su Nuova origine dati > Da File > Excel.

    • Se si usa Access 2016, Access 2013 o Access 2010, fare clic su Excel nel gruppo Importa e collega della scheda Dati esterni.

    • Se si usa Access 2007, fare clic su Excel nel gruppo Importa della scheda Dati esterni.

    Nota : La scheda Dati esterni è disponibile solo se è aperto un database.

  2. Nella casella Nome file della finestra di dialogo Carica dati esterni - Foglio di calcolo di Excel specificare il nome del file di Excel di origine.

  3. Selezionare Collega all'origine dati creando una tabella collegata e quindi fare clic su OK.

    Verrà avviato il Collegamento guidato Foglio di calcolo, che consente di eseguire in modo semplificato il processo di collegamento.

  4. Nella prima pagina della procedura guidata selezionare un foglio di lavoro o un intervallo definito e fare clic su Avanti.

  5. Se la prima riga del foglio di lavoro o dell'intervallo di origine contiene i nomi dei campi, selezionare Intestazioni di colonne nella prima riga. Le intestazioni di colonna vengono utilizzate da Access per assegnare un nome ai campi della tabella. Se include determinati caratteri speciali, un nome di colonna non può essere utilizzato come nome di campo in Access. In questi casi, viene visualizzato un messaggio di errore che indica che Access assegnerà un nome valido al campo. Fare clic su OK per continuare.

  6. Nella pagina finale della procedura guidata specificare un nome per la tabella collegata e quindi fare clic su Fine. Se esiste già una tabella con il nome specificato, verrà richiesto se si desidera sovrascrivere la tabella o la query esistente. Fare clic su per sovrascrivere la tabella o la query oppure su No per specificare un nome diverso.

    Verrà eseguito un tentativo di creare la tabella collegata. Se l'operazione ha esito positivo, verrà visualizzato il messaggio Collegamento della tabella completato. Aprire la tabella collegata ed esaminare i campi e i dati per verificare la visualizzazione dei dati corretti in tutti i campi.

    In caso di valori di errore o dati non corretti, sarà necessario risolvere i problemi relativi ai dati di origine. Per ulteriori informazioni sulla risoluzione dei problemi relativi a valori di errore o non corretti, vedere la sezione seguente.

Inizio pagina

Risolvere i problemi relativi a #Num! e ad altri valori non corretti in una tabella collegata

Anche se viene visualizzato il messaggio Collegamento della tabella completato, è consigliabile aprire la tabella in visualizzazione Foglio dati per verificare che righe e colonne contengano i dati corretti.

Se si riscontrano errori o dati non corretti in qualsiasi punto della tabella, intervenire nel modo corretto come descritto nella tabella seguente e quindi riprovare a eseguire il collegamento. Tenere presente che non è possibile aggiungere valori direttamente alla tabella collegata, poiché è di sola lettura.

Problema

Risoluzione

Elementi grafici

Non è possibile eseguire il collegamento agli elementi grafici in un foglio di lavoro di Excel, ad esempio logo, grafici e immagini.

Formato di visualizzazione

Potrebbe essere necessario impostare la proprietà Formato di determinati campi in visualizzazione Struttura per garantire la corretta visualizzazione dei valori in visualizzazione Foglio dati.

Valori calcolati

I risultati di celle o colonne calcolate vengono visualizzati nel campo corrispondente, ma non è possibile visualizzare la formula o l'espressione in Access.

Valori di testo troncati

Incrementare la larghezza della colonna in visualizzazione Foglio dati. Se non viene comunque visualizzato l'intero valore, è possibile che il valore sia di lunghezza superiore a 255 caratteri. Poiché Access supporta il collegamento soltanto dei primi 255 caratteri, è consigliabile importare i dati anziché eseguire il collegamento.

Messaggio di errore di overflow in campo numerico

Nonostante la tabella collegata risulti corretta, quando in seguito si esegue una query sulla tabella potrebbe essere visualizzato un messaggio di errore di overflow in campo numerico, a causa di un conflitto tra il tipo di dati di un campo della tabella collegata e il tipo di dati memorizzato in tale campo.

Valori VERO o FALSO e -1 o 0

Se il foglio di lavoro o l'intervallo di origine include una colonna contenente soltanto valori VERO o FALSO, per la colonna viene creato in Access un campo Sì/No nella tabella collegata. Se tuttavia il foglio di lavoro o l'intervallo di origine include una colonna contenente soltanto valori -1 o 0, per la colonna viene creato un campo numerico per impostazione predefinita e non sarà possibile modificare il tipo di dati del campo corrispondente della tabella. Se si desidera disporre di un campo Sì/No nella tabella collegata, verificare che la colonna di origine includa valori VERO e FALSO.

Campi multivalore

In Access il supporto di più valori in un campo non è abilitato, anche se la colonna di origine contiene un elenco di valori separati da punto e virgola (;). L'elenco dei valori viene considerato come un valore singolo e inserito in un campo di testo.

#Num!

Il valore di errore #Num! viene visualizzato in Access in sostituzione dei dati effettivi di un campo nelle situazioni seguenti:

  • Se una colonna di origine contenente prevalentemente valori di testo include alcuni valori numerici o di data, i valori numerici e di data non vengono collegati.

  • Se una colonna di origine contenente prevalentemente valori numerici include alcuni valori di testo, i valori di testo non vengono collegati.

  • Se una colonna di origine contenente prevalentemente valori di data include alcuni valori di testo, i valori di testo non vengono collegati.

Per ridurre al minimo le istanze di valori Null nella tabella, eseguire le operazioni seguenti:

  1. Verificare che la colonna di origine non contenga valori di tipi di dati diversi.

  2. Formattare le colonne nel foglio di lavoro di Excel.

  3. Durante l'operazione di collegamento, selezionare il tipo di dati appropriato per ogni campo. Se il tipo di dati non è corretto, la colonna risultante potrebbe contenere soltanto valori #Num! in tutte le righe di dati.

Valori numerici anziché valori di data

Se in un campo viene rilevato un numero di cinque cifre apparentemente casuale, verificare se la colonna di origine contiene prevalentemente valori numerici ma include anche alcuni valori di data. I valori di data in colonne numeriche vengono convertiti in modo non corretto in un numero. Sostituire i valori di data con valori numerici e quindi riprovare a eseguire il collegamento.

Valori di data anziché valori numerici

Se in un campo viene rilevato un valore di data apparentemente casuale, verificare se la colonna di origine contiene prevalentemente valori di data ma include anche alcuni valori numerici. I valori numerici in colonne di data vengono convertiti in modo non corretto in una data. Sostituire i valori numerici con valori di data e quindi riprovare il collegamento.


Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×