Guida introduttiva: creare una riunione con InfoPath e SharePoint sistema di note

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Apportando modifiche minime a un modello di modulo di esempio di Microsoft Office InfoPath 2007 e creando una raccolta documenti in un sito di Windows SharePoint Services 3.0, è possibile implementare un sistema per creare Note riunione in modo coerente, inviarle a ogni partecipante alla riunione e archiviarle in una raccolta documenti di SharePoint Services. In questo articolo viene illustrato come creare questo sistema.

In questo articolo

Panoramica

Prima di iniziare

Creare il sistema di Note riunione

Aggiornare il modello di modulo

Panoramica

In InfoPath è incluso un modello di modulo di esempio progettato specificamente per raccogliere i dati comuni delle riunioni, ad esempio le agende, i partecipanti, le discussioni e le attività. Il modello di modulo di esempio è configurato in modo di consentire l'invio tramite posta elettronica di una copia di un modulo basato sul modello a ogni partecipante alla riunione.

Il modello di modulo di esempio è configurato per aiutare colui che crea le note a raccogliere i dati che tipicamente vengono registrati in una riunione. I controlli sono disposti in sezioni logiche per agevolare la raccolta dei dati corretti e anche per evitare di raccogliere dati che possono essere generati automaticamente. Il layout dei controlli presenta inoltre una struttura coerente, in modo che la persona che crea le note non debba ricordare quale tipo di dati raccogliere, ma semplicemente compilare i campi nel corso della riunione.

Sebbene sia possibile modificare il modello di modulo per raccogliere dati aggiuntivi, è consigliabile utilizzare il modello di modulo così com'è con una modifica che consente di salvare i moduli completati in una raccolta documenti di SharePoint. È quindi possibile verificare l'efficacia del sistema e utilizzare ciò che si è appreso dal test per modificare il modello di modulo in base alle esigenze del gruppo.

È possibile utilizzare questo modello di modulo di esempio nel sistema pubblicandolo innanzitutto in una nuova raccolta documenti in un sito di SharePoint. La raccolta documenti verrà creata come parte del processo di pubblicazione. Dopo aver pubblicato il modello di modulo e aver creato la nuova raccolta documenti, si modificherà il modello di modulo in modo che venga salvato un modulo completato nella nuova raccolta documenti e una copia del modulo venga inviata ai partecipanti alla riunione.

Per utilizzare questo sistema, l'utente che crea le note accede alla raccolta documenti e crea un nuovo modulo basato su questo modello di modulo. Durante una riunione egli inserisce i dati nei controlli appropriati del modulo. Al termine della riunione invia il modulo nella raccolta documenti e una copia del modulo a ogni partecipante. Le persone che non hanno partecipato alla riunione possono leggere le note accedendo alla raccolta documenti e aprendo il modulo in InfoPath.

Il modello di modulo di esempio contiene le sezioni seguenti:

modello di modulo agenda riunione con quattro sezioni

1. sezione del titolo contiene controlli per nome, scopo, posizione e riunione date e ore. Il controllo Data Visualizza automaticamente la data di che creazione del modulo. Per impostazione predefinita, il controllo casella di testo di Data/ora fine Visualizza automaticamente un'ora che è un'ora in un secondo momento rispetto all'ora immesso nel controllo casella di testo Ora di inizio.

2. partecipanti ripetuta sezione contiene controlli per i nomi e indirizzi di posta elettronica di ogni partecipante alla riunione. Quando il verbale invia il modulo completato, ogni partecipante elencato in questa sezione riceve una copia della maschera completata.

3. elemento di discussione sezione ripetuta contiene controlli per ogni relatore (un partecipante che conduce una discussione) e le note su ogni elemento di discussione. Il controllo casella di riepilogo relatore consente di visualizzare i nomi dalla sezione dei partecipanti.

4. azione sezione ripetuta contiene controlli per il nome, l'assegnazione e scadenza Data per ogni azione. Il controllo casella di riepilogo delle assegnazioni vengono visualizzati i nomi dalla sezione dei partecipanti.

Se si è nuovi utenti di InfoPath, gli articoli seguenti consentono di capire i concetti importanti e di definire meglio i termini che si incontreranno durante il completamento di ogni attività descritta nell'articolo. Questi collegamenti sono presenti nelle sezioni appropriate dell'articolo nel caso siano necessarie ulteriori informazioni durante il completamento di un'attività.

Inizio pagina

Prima di iniziare

Si sarà necessario Uniform Resource Locator (URL) e almeno delle autorizzazioni progettazione per la raccolta siti del sito di SharePoint che verrà utilizzato per il sistema. Se è possibile creare una raccolta documenti nella raccolta siti, si dispone delle autorizzazioni appropriate. Persone che hanno l'esigenza di trovare le note riunione verranno autorizzazioni di lettura alla raccolta siti. Se sono necessarie le autorizzazioni per creare una raccolta documenti o impostare le autorizzazioni di lettura per la raccolta siti per gli utenti del modulo, contattare l'amministratore della raccolta siti.

Saranno inoltre necessari un indirizzo di posta elettronica a cui inviare una copia del modulo completato e un client di posta elettronica, ad esempio Microsoft Office Outlook 2007, configurato per ricevere messaggi in modo che sia possibile verificare il modello di modulo.

In questo articolo si presuppone che venga utilizzata una configurazione predefinita di SharePoint Services.

Inizio pagina

Creare il sistema di Note riunione

Per creare il sistema, sarà necessario eseguire le operazioni seguenti:

  1. Aprire e salvare il modello di modulo di esempio.

  2. Pubblicare il modello di modulo di esempio per creare una nuova raccolta documenti per le Note riunione.

  3. Modificare il modello di modulo di esempio per salvare i moduli completati nella nuova raccolta documenti e quindi inviarne una copia a ogni partecipante.

  4. Pubblicare il modello di modulo modificato.

  5. Verificare il modello di modulo modificato e la nuova raccolta documenti creando e inviando moduli di prova basati sul modello di modulo.

Aprire e salvare il modello di modulo

  1. Scegliere Progetta modello modulo dal menu File.

  2. In Apri modello di modulo fare clic su Personalizza modulo di esempio.

  3. In Personalizza modulo di esempio fare doppio clic su Esempio - Agenda riunione.

  4. Scegliere Salva dal menu File.

  5. Se viene visualizzato un messaggio relativo alla pubblicazione del modello di modulo, fare clic su OK.

  6. Nella finestra di dialogo Salva con nome specificare il percorso in cui si desidera salvare il modello di modulo.

  7. Nella casella Nome File digitare un nome per il modello di modulo.

  8. Nell'elenco Tipo file selezionare Modello di modulo InfoPath e quindi fare clic su Salva.

Pubblicare il modello di modulo

La raccolta documenti verrà creata come parte del processo di pubblicazione.

Per ulteriori informazioni sulla pubblicazione di un modello di modulo, vedere l'articolo Introduzione alla pubblicazione di un modello di modulo.

  1. Scegliere Pubblica dal menu File.

  2. Nella prima pagina della Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services digitare l'URL della raccolta siti nel sito di SharePoint e quindi fare clic su Avanti. Ad esempio, per utilizzare una raccolta siti con l'URL http://www.adventureworks.com/SoloDipendenti, digitare http://www.adventureworks.com/SoloDipendenti nella casella.

  4. Nella pagina successiva fare clic su Raccolta documenti e quindi su Avanti.

  5. Nella pagina successiva fare clic su Crea nuova raccolta documenti e quindi su Avanti.

  6. Nella pagina successiva digitare un nome e una descrizione per la nuova raccolta documenti e quindi fare clic su Avanti.

  7. Accettare le colonne suggerite e fare clic su Avanti.

  8. Nell'ultima pagina della procedura guidata verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

  9. Scegliere Chiudi.

    Se il modello di modulo viene pubblicato correttamente, nell'ultima pagina della procedura guidata verrà visualizzata una conferma.

Annotare l'URL della nuova raccolta documenti: questa informazione sarà necessaria più avanti in questo articolo. L'URL della nuova raccolta documenti corrisponderà all'URL della raccolta siti seguito da una barra (/) e dal nome della raccolta documenti. Se ad esempio è stata creata una nuova raccolta documenti denominata NoteRiunione nella raccolta siti il cui URL è http://www.adventureworks.com/SoloDipendenti, l'URL della nuova raccolta documenti sarà http://www.adventureworks.com/SoloDipendenti/NoteRiunione.

Modificare il modello di modulo

In questa sezione verrà illustrato come eseguire le operazioni seguenti:

  • Aggiungere una nuova connessione dati per invio per salvare il modulo completato nella nuova raccolta documenti.

    Per ulteriori che informazioni sull'invio di connessioni dati, vedere Introduzione alle connessioni dati.

  • Modificare le opzioni della connessione dati per salvare il modulo completato nella raccolta documenti e inviarne una copia a ogni partecipante alla riunione.

  • Configurare il modello di modulo in modo che il modulo venga chiuso dopo l'invio.

Per ulteriori informazioni sull'invio di un modulo basato su un modello di modulo, vedere l'articolo Introduzione all'invio di dati del modulo.

Aggiungere una nuova connessione dati per invio

In questa sezione verrà creata una nuova connessione dati per invio alla nuova raccolta documenti e la connessione dati verrà configurata in modo tale da salvare il modulo con un nome univoco. Il nome del modulo sarà una combinazione del titolo della riunione e della data in cui è stato creato il modulo.

Iniziare la creazione della connessione dati
  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su in una raccolta documenti in un sito di SharePoint e quindi fare clic su Avanti. Selezione di una destinazione per i dati inviati nella Connessione guidata dati

  5. Nella pagina successiva della procedura guidata, nella casella Raccolta documenti digitare l'URL della raccolta documenti creata nella sezione precedente. Ad esempio, per utilizzare una raccolta documenti con l'URL http://www.adventureworks.com/SoloDipendenti/NoteRiunione, digitare http://www.adventureworks.com/SoloDipendenti/NoteRiunione nella casella Raccolta documenti.

    Nella sezione successiva verrà illustrato il processo di definizione di un nome di modulo univoco, che richiede di rimanere in questa pagina della procedura guidata. Non fare clic su Avanti per il momento.

Definire un nome di modulo univoco

Il modulo viene salvato in una raccolta documenti con un nome predefinito. Se si utilizza il nome predefinito, nella raccolta documenti verrà archiviato solo un modulo completato. In questa sezione verrà configurata la connessione dati per salvare i moduli basati su questo modello di modulo con un nome composto dal titolo e dalla data della riunione. A tale scopo è necessario creare una formula che utilizza una funzione XPath.

Per ulteriori informazioni sulle formule e funzioni, vedere aggiungere una formula per un controllo.

  1. Fare clic su Inserisci formula icona del pulsante .

  2. Nella finestra di dialogo Inserisci formula fare clic su Inserisci funzione.

  3. Nell'elenco Categorie della finestra di dialogo Inserisci funzione fare clic su Testo.

  4. Nell'elenco Funzioni fare clic su concatena e quindi su OK.

  5. Nella casella Formula fare doppio clic la prima istanza di fare doppio clic per inserire un campo.

    Doppio clic per inserire il primo campo da utilizzare come parte del nome del modulo

  6. Nella finestra di dialogo Seleziona campo o gruppo espandere meeting, fare clic su meetingTitle e quindi su OK.

    Selezione del campo meetingTitle nella finestra di dialogo Seleziona campo o gruppo

  7. Nella casella Formula fare clic sulla seconda istanza di fare doppio clic per inserire un campo per selezionarla (non fare doppio clic).

    Clic per inserire una lineetta come parte del nome del modulo

  8. Digitare un segno di virgolette doppie ("), seguito da una lineetta (-), seguito da un altro segno di virgolette doppie.

    Inserimento di una lineetta come parte nel nome del modulo

  9. Fare doppio clic sulla terza istanza di fare doppio clic per inserire un campo.

    doppio clic per inserire un altro campo da utilizzare come parte del nome del modulo

  10. Nella finestra di dialogo Seleziona campo o gruppo espandere meeting, fare clic su meetingDate e quindi su OK.

    Selezione del campo meetingDate nella finestra di dialogo Seleziona campo o gruppo

    La finestra di dialogo Inserisci formula dovrebbe avere l'aspetto seguente:

    formula completata nella finestra di dialogo inserisci formula per generare il nome del modulo

  11. Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

  12. Se la formula non contiene errori, fare clic su OK per chiudere la finestra di dialogo.

Completare l'impostazione della connessione dati
  1. Nella procedura guidata fare clic su Avanti.

  2. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  3. Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

  4. Scegliere Chiudi.

  5. Scegliere Salva dal menu File.

Modificare le opzioni di invio per utilizzare entrambe le connessioni dati per invio

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Esegui azione personalizzata tramite regole e quindi su Regole.

  4. Nella finestra di dialogo Regole per l'invio di moduli fare clic su Aggiungi.

  5. Fare clic su Aggiungi azione.

  6. Nella casella Azione fare clic su Invia.

  7. Nell'elenco Connessione dati fare clic sulla connessione dati alla raccolta documenti creata nella sezione precedente e quindi fare clic su OK.

  8. Fare clic su Aggiungi azione.

  9. Nella casella Azione fare clic su Invia.

  10. Nell'elenco Connessione dati fare clic su Invio principale e quindi su OK.

    La connessione dati Invio principale verrà utilizzata per inviare una copia del modulo a ogni partecipante.

  11. Nella casella Nome della finestra di dialogo Regola digitare Regole di invio per identificare la regola appena creata.

  12. Scegliere due volte OK per chiudere le finestre di dialogo.

Configurare il modello di modulo per chiudere il modulo dopo l'invio

  1. Nella finestra di dialogo Opzioni invio fare clic su Avanzate.

  2. Nell'elenco Dopo l'invio fare clic su Chiudi il modulo.

  3. Fare clic su OK.

  4. Scegliere Salva dal menu File.

Pubblicare il modello di modulo

Dopo aver modificato il modello di modulo, è necessario pubblicarlo nella raccolta documenti per distribuire le modifiche.

  1. Scegliere Pubblica dal menu File.

  2. Nella prima pagina della Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services digitare il percorso della raccolta documenti nella raccolta siti del sito di SharePoint e quindi fare clic su Avanti.

  4. Nella pagina successiva fare clic su Raccolta documenti e quindi su Avanti.

  5. Nella pagina successiva fare clic su Aggiorna il modello di modulo in una raccolta documenti esistente.

  6. Nell'elenco Raccolta documenti da aggiornare fare clic sulla raccolta documenti e quindi su Avanti.

  7. Fare clic su Avanti.

  8. Nella pagina successiva verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

    Se il modello di modulo viene pubblicato correttamente, nell'ultima pagina della procedura guidata verrà visualizzata una conferma.

Verificare il modello di modulo e il sito

  1. Nell'ultima pagina della Pubblicazione guidata fare clic su Apri raccolta documenti e quindi su Chiudi.

  2. Nella raccolta documenti fare clic su Nuovo.

  3. Compilare il modulo come se si stessero prendendo note durante una riunione. Dopo aver inserito un'ora nella casella di testo Ora inizio, premere il tasto TAB per spostarsi nel controllo successivo. Il valore nella casella di testo Ora fine verrà inserito automaticamente.

  4. Immettere l'indirizzo di posta elettronica di un partecipante alla riunione nella casella Posta elettronica della sezione Partecipanti. Per aggiungere altri partecipanti e i relativi indirizzi di posta elettronica, fare clic su Aggiungi partecipante.

  5. Sulla barra degli strumenti di InfoPath fare clic su Invia.

  6. Nella finestra di dialogo verificare che vengano visualizzati gli indirizzi di posta elettronica corretti.

  7. Fare clic su Invia e quindi su OK per chiudere la finestra di dialogo.

Le Note riunione dovrebbero essere visualizzate nella raccolta documenti e arrivare anche nella Posta in arrivo come nuovo messaggio di posta elettronica.

Dopo aver verificato il sistema creando e inviando alcuni moduli basati sul modello di modulo, è possibile iniziare a utilizzare il sistema per archiviare e distribuire le Note riunione.

Inizio pagina

Aggiornare il modello di modulo

Dopo che altri utenti hanno provato il nuovo sistema creando e salvando Note riunione, potrebbe essere necessario modificare la struttura del modello di modulo in base ai loro commenti e suggerimenti. Per apportare modifiche al modello di modulo, è necessario eseguire le operazioni seguenti:

  1. Aprire il modello di modulo dalla raccolta documenti, modificarlo secondo le esigenze e quindi salvare le modifiche.

  2. Confermare le modifiche nella raccolta documenti pubblicando il modello di modulo.

Aprire il modello di modulo dalla raccolta documenti

  1. Aprire la raccolta documenti.

  2. Fare clic su Impostazioni e quindi su Impostazioni Raccolta moduli.

  3. In Impostazioni generali fare clic su impostazioni Avanzate.

  4. Nella casella URL modello della sezione Modello documento fare clic su (Modifica modello).

  5. Se viene visualizzato un messaggio relativo alla pubblicazione del modello di modulo, fare clic su .

Dopo aver modificato il modello di modulo, salvarlo prima di pubblicarlo.

Pubblicare il modello di modulo

Dopo aver effettuato le modifiche, è necessario pubblicare il modello di modulo modificato nella raccolta documenti.

  1. Scegliere Pubblica dal menu File.

  2. Nella prima pagina della Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services digitare il percorso della raccolta documenti nella raccolta siti del sito di SharePoint e quindi fare clic su Avanti.

  4. Nella pagina successiva fare clic su Raccolta documenti e quindi su Avanti.

  5. Nella pagina successiva fare clic su Aggiorna il modello di modulo in una raccolta documenti esistente.

  6. Nell'elenco Raccolta documenti da aggiornare fare clic sulla raccolta documenti e quindi su Avanti.

  7. Fare clic su Avanti.

  8. Nella pagina successiva verificare la correttezza delle informazioni visualizzate e quindi fare clic su Pubblica.

  9. Scegliere Chiudi.

    Se il modello di modulo viene pubblicato correttamente, nell'ultima pagina della procedura guidata verrà visualizzata una conferma.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×