Guida alla progettazione di report

In Microsoft Office Access 2007 sono disponibili numerosi strumenti che consentono di creare velocemente report accattivanti e di facile lettura in cui i dati vengono presentati nel modo più adeguato alle esigenze degli utenti. Per creare un report semplice con un solo clic è possibile utilizzare i comandi disponibili nella scheda Crea. Per creare invece un report più complesso è possibile utilizzare la Creazione guidata Report oppure è possibile creare un report aggiungendo tutti i dati e formattando gli elementi personalmente. Qualunque sia il metodo scelto, è probabile che per visualizzare i dati nel modo desiderato sia necessario apportate alcune modifiche alla struttura del report. In questo articolo verrà descritto il processo generale di progettazione di un report, quindi verrà illustrato come aggiungervi elementi di progettazione specifici.

In questo articolo

Scelta del layout del report

Utilizzo di layout controllo per allineare i dati

Aggiunta o rimozione di sezioni di intestazione e piè di pagina a report o pagine

Suggerimenti per la formattazione di diversi tipi di dati

Scelta del layout del report

Quando si progetta un report, è innanzitutto necessario considerare come si desidera disporre i dati nella pagina e come verranno archiviati i dati nel database. Durante il processo di progettazione potrebbe anche risultare evidente che il modo in cui sono disposti i dati nelle tabelle non consentirà di creare il report desiderato e ciò può essere un'indicazione che le tabelle non sono normalizzate, ovvero i dati non sono archiviati nella maniera più efficiente.

Per ulteriori informazioni sulla normalizzazione, fare clic sul collegamento relativo ai concetti di base sulla progettazione di database disponibile nella sezione Vedere anche.

Creare uno schizzo del report

Questo passaggio non è obbligatorio, infatti è possibile che la Creazione guidata Report o lo strumento Report di Access, entrambi disponibili nel gruppo Report della scheda Crea, fornisca una struttura del report sufficiente per iniziare. Se tuttavia si sceglie di progettare il report senza utilizzare questi strumenti, potrebbe risultare utile creare uno schizzo del report su un foglio, disegnando una casella nel punto in cui sarà inserito ogni campo e scrivendo il nome del campo in ogni casella. In alternativa è possibile utilizzare programmi come Microsoft Office Word 2007 o Microsoft Office Visio 2007 per creare una bozza del report. Qualunque sia il metodo utilizzato, verificare che venga incluso un numero sufficiente di righe per indicare come si ripetono i dati.

Maschera completata sovrapposta allo schizzo preliminare

È possibile, ad esempio, utilizzare una riga per le informazioni sul prodotto, quindi alcune righe ripetute per le vendite di quel prodotto e infine una riga per i totali delle vendite del prodotto. La sequenza viene quindi ripetuta per il prodotto successivo e così via fino alla fine del report. In alternativa il report può essere un semplice elenco dei dati contenuti nelle tabella, nel qual caso si potrà includere nello schizzo solo una serie di righe e colonne.

Nota : Questa tecnica è molto utile anche qualora si debba progettare un report per un'altra persona in quanto, prima di iniziare, si potrà chiedere a quella persona prima di disegnare uno schizzo.

Dopo avere creato lo schizzo, determinare la tabella o le tabelle contenenti i dati che si desidera visualizzare nel report. Se tutti i dati si trovano in un'unica tabella, è possibile basare il report direttamente su quella tabella, ma è molto più probabile che i dati desiderati siano archiviati in più tabelle che dovranno essere unite in una query prima di poterne visualizzare i dati nel report. La query può essere incorporata nelle proprietà OrigineRecord del report oppure è possibile creare una query separata e salvarla per utilizzarla quindi come base per il report.

Per ulteriori informazioni sull'utilizzo di una query come origine record per un report, fare clic sul collegamento disponibile nella sezione Vedere anche.

Stabilire quali dati inserire in ogni sezione del report

In ogni report sono presenti una o più sezioni. La sola sezione presente in tutti i report è la sezione dei dettagli che si ripete una volta per ogni record contenuto nella tabella o nella query su cui è basato il report. Le altre sezioni sono facoltative, si ripetono con minore frequenza e vengono solitamente utilizzate per visualizzare informazioni comuni a un gruppo di record, a una pagina del report o all'intero report.

Nella seguente tabella è descritta la posizione di ogni sezione e il modo in cui viene generalmente utilizzata.

Sezione

Posizione

Contenuto tipico

Intestazione report

Viene visualizzata una sola volta nella parte superiore della prima pagina del report.

  • Titolo del report

  • Logo

  • Data corrente

Piè di pagina report

Viene visualizzata dopo l'ultima riga di dati, sopra la sezione Piè di pagina pagina nell'ultima pagina del report.

Totali del report, come somme, conteggi, medie e così via

Intestazione pagina

Viene visualizzata nella parte superiore di ogni pagina del report.

  • Titolo del report

  • Numero di pagina

Piè di pagina pagina

Viene visualizzata nella parte inferiore di ogni pagina del report.

  • Data corrente

  • Numero di pagina

Intestazione gruppo

Viene visualizzata appena prima di un gruppo di record.

Il campo su cui si basa il raggruppamento

Piè di pagina gruppo

Viene visualizzata appena dopo un gruppo di record.

Totali del gruppo, come somme, conteggi, medie e così via

Per informazioni sull'aggiunta o sulla rimozione di sezioni di intestazione e piè di pagina di report o di pagine, vedere la sezione Aggiunta o rimozione di sezioni di intestazione e piè di pagina a report o pagine in questo articolo. Per aggiungere sezioni di intestazione e piè di pagina di gruppi, utilizzare il riquadro Raggruppamento, ordinamento e totale in visualizzazione Layout o Struttura.

Per ulteriori informazioni sull'utilizzo del riquadro Raggruppamento, ordinamento e totale, fare clic sul collegamento relativo alla creazione di report con raggruppamenti o di riepilogo nella sezione Vedere anche .

Stabilire come disporre i dati dettaglio

La maggior parte dei report presenta un layout tabulare o in pila, ma Office Access 2007 consente di utilizzare in modo flessibile qualsiasi disposizione desiderata per i record e i campo.

Layout tabulare    Un layout tabulare è simile a un foglio di calcolo. Le etichette sono disposte lungo la parte superiore e i dati sono allineati in colonne al di sotto delle etichette. Il termine tabulare si riferisce all'aspetto simile a una tabella che assumono i dati. Questo è il tipo di report che viene creato da Office Access 2007 quando si fa clic su Report nel gruppo Report della scheda Crea. La scelta di un layout tabulare è appropriata se il report contiene un numero relativamente piccolo di campi che si desidera visualizzare in un semplice formato di elenco. Nella figura che segue è illustrato un report dei dipendenti creato utilizzando un layout tabulare.

Report dei dipendenti con un layout tabulare

Layout in pila    Un layout in pila è simile a un modulo che si compila quando si apre un conto bancario o si effettua un acquisto in linea. A ogni singolo dato è associata un'etichetta e i campi sono disposti uno sopra l'altro. Questo layout è appropriato per i report che contengono un numero di campi troppo elevato per essere visualizzati in un formato tabulare, ovvero la larghezza delle colonne supererebbe la larghezza del report. Nella figura che segue è illustrato un report dei dipendenti creato utilizzando un layout in pila.

Report dei dipendenti con un layout in pila

Nota : Nella Creazione guidata Report questo layout è detto layout a colonne.

Layout misto    Gli elementi dei layout tabulare e in pila possono essere utilizzati in combinazione. Ad esempio, per ogni record è possibile disporre alcuni campi in una riga orizzontale nella parte superiore della sezione dei dettagli e gli altri campi dello stesso record in uno o più layout in pila al di sotto della riga superiore. Nella figura che segue è illustrato un report dei dipendenti creato utilizzando un layout misto. I campi ID, Cognome e Nome sono disposti in un layout controllo tabulare, mentre i campi Posizione e Telefono (uff) sono disposti secondo un layout in pila. In questo esempio vengono utilizzate le linee della griglia per applicare una separazione visiva dei campi per ogni dipendente.

Report dei dipendenti con un layout misto

Layout giustificato    Se si utilizza la Creazione guidata Report per creare un report, è possibile scegliere un layout giustificato nel quale, per visualizzare i record nel modo più compatto possibile, viene utilizzata l'intera larghezza della pagina. Naturalmente è possibile ottenere gli stessi risultati senza utilizzare la Creazione guidata Report, tuttavia l'allineamento esatto dei campi può essere un processo impegnativo. Nella figura che segue è illustrato un report dei dipendenti creato utilizzando il layout giustificato della Creazione guidata Report.

Report dei dipendenti con un layout giustificato

La scelta del layout giustificato è appropriata se è necessario visualizzare un numero elevato di campi nel report. Nell'esempio precedente, se si utilizza un layout tabulare per visualizzare gli stessi dati, i campi si estendono oltre il bordo della pagina, se invece si utilizza un layout in pila, ogni record occupa uno spazio verticale molto più esteso che causa uno spreco di carta e rende il report più difficile da leggere.

Per informazioni dettagliate sulla creazione di report in cui vengono utilizzati diversi layout, fare clic sul collegamento relativo alla creazione di un report semplice nella sezione Vedere anche.

Torna all'inizio

Utilizzo di layout controllo per allineare i dati

I layout controllo, una nuova funzionalità di Office Access 2007, sono guide che è possibile aggiungere a un report mentre è aperto in visualizzazione Layout o Struttura. In Access 2007 i layout controllo vengono aggiunti automaticamente quando si utilizza la Creazione guidata Report per creare un report o quando si crea un report facendo clic su Report nel gruppo Report della scheda Crea. Un layout controllo è simile a una tabella in cui ogni cella può contenere un'etichetta, una casella di testo o qualsiasi altro tipo di controllo. Nella figura che segue è illustrato un layout controllo tabulare in un report.

Layout controllo tabulare di base

Le linee arancione indicano le righe e le colonne del layout controllo e sono visibili solo quando il report è aperto in visualizzazione Layout o Struttura. I layout controllo consentono di ottenere un allineamento uniforme dei dati in colonne e righe e facilitano l'aggiunta, il ridimensionamento e la rimozione dei campi. Utilizzando gli strumenti presenti nel gruppo Layout controllo nella scheda Disponi, disponibile in visualizzazione Layout o Struttura, è possibile cambiare un tipo di layout controllo scegliendone un altro e rimuovere i controlli dai layout per posizionarli in qualsiasi parte del report.

Per ulteriori informazioni sull'utilizzo dei layout controllo, fare clic sul collegamento relativo alla modifica e al cambiamento dei report nella sezione Vedere anche.

Torna all'inizio

Aggiunta o rimozione di sezioni di intestazione e piè di pagina a report o pagine

Come accennato precedentemente in questo articolo, le intestazioni e i piè di pagina cono sezioni del report che è possibile utilizzare per visualizzare informazioni comuni all'intero report o a ciascuna pagina di un report. Ad esempio, è possibile aggiungere una sezione Piè di pagina pagina per visualizzare un numero di pagina nella parte inferiore di ogni pagina oppure una sezione Intestazione report per visualizzare un titolo per tutto il report.

Aggiungere sezioni di intestazione e piè di pagina a report o pagine

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report che si desidera modificare, quindi scegliere Visualizzazione Struttura dal menu di scelta rapida.

  2. Verificare quali sezioni sono già presenti nel report. Le sezioni sono separate da barre orizzontali ombreggiate dette selettori di sezione. L'etichetta su ogni selettore di sezione indica qual è la sezione immediatamente sottostante.

    Report in visualizzazione Struttura

    Ogni report include una sezione di dettaglio e può inoltre contenere le sezioni Intestazione report, Intestazione pagina, Piè di pagina pagina e Piè di pagina report. Se, inoltre, nel report sono presenti livelli di raggruppamento, potrebbero essere visualizzate intestazioni o piè di pagina gruppo, come la sezione Intestazione Archivia come visualizzata nella precedente illustrazione. Per impostazione predefinita, le intestazioni e i piè di pagina di gruppo vengono denominati utilizzando il nome di campo o l'espressione che costituisce la base del gruppo. In questo caso il nome del campo di raggruppamento è "Archivia come".

    Per ulteriori informazioni sulla creazione di report con raggruppamenti o di riepilogo, fare clic sul collegamento disponibile nella sezione Vedere anche.

  3. Per aggiungere al report sezioni di intestazione e piè di pagina di report o pagine, fare clic con il pulsante destro del mouse su qualsiasi selettore di sezione, quindi scegliere Intestazione/piè di pagina pagina o Intestazione/piè di pagina report dal menu di scelta rapida.

    Nota : Se la sezione è già presente nel report, verrà visualizzato un avviso per informare l'utente che la sezione esistente e i controlli che contiene saranno eliminati.

    A questo punto è possibile spostare i controlli esistenti o aggiungerne di nuovi alle nuove sezioni.

    Per ulteriori informazioni sull'aggiunta di campi e altri controlli ai report, fare clic sul collegamento disponibile nella sezione Vedere anche.

In Office Access 2007 le sezioni di intestazione e piè di pagina report e pagina vengono sempre aggiunte a coppie, ovvero non è possibile aggiungere una sezione di intestazione pagina o report senza aggiungere anche la corrispondente sezione piè di pagina. Se non sono necessarie entrambe le sezioni, non è possibile eliminarne una, tuttavia la sezione inutilizzata può essere ridimensionata a un'altezza pari a zero (0) in modo da evitare di includere nel report una spaziatura verticale aggiuntiva. Posizionare il puntatore nella parte inferiore della sezione inutilizzata finché non assume la forma di una freccia a due punte Freccia doppia , quindi trascinare la freccia verso l'alto finché la sezione non viene nascosta. Se nella sezione sono presenti controlli, per poter nascondere completamente la sezione sarà necessario eliminarli.

Rimuovere le sezioni di intestazione e piè di pagina report o pagina

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report che si desidera modificare, quindi scegliere Visualizzazione Struttura dal menu di scelta rapida.

  2. Fare clic con il pulsante destro del mouse su qualsiasi selettore di sezione, quindi scegliere Intestazione/piè di pagina pagina o Intestazione/piè di pagina report dal menu di scelta rapida.

Se si rimuove una coppia di intestazione e piè di pagine e in quelle sezioni sono presenti controlli, in Office Access 2007 verrà visualizzato un avviso per indicare che l'eliminazione delle sezioni comporterà l'eliminazione dei controlli e che l'azione non potrà essere annullata. Scegliere per rimuovere le sezioni ed eliminare i controlli oppure scegliere No per annullare l'operazione.

Torna all'inizio

Suggerimenti per la formattazione di diversi tipi di dati

Quando si crea un report utilizzando lo strumento Report, disponibile nel gruppo Report della scheda Crea, oppure la Creazione guidata Report, in Office Access 2007 vengono aggiunti automaticamente i campi al report e viene creato il controllo più appropriato per visualizzare ogni campo in base al tipo di dati del campo. Se si aggiungono manualmente i campi a un report, il metodo preferito consiste nel trascinare ogni campo da Elenco campi nel report. Come quando si utilizza la Creazione guidata Report o lo strumento Report, in Office Access 2007 viene creato automaticamente il controllo più appropriato per ogni campo, a seconda del tipo di dati del campo. Per la maggior parte dei tipi di dati il controllo predefinito più appropriato da utilizzare è la casella di testo.

Nelle seguenti sezioni vengono forniti suggerimenti sulla formattazione di alcuni nuovi tipi di dati di Office Access 2007.

Campi multivalore    Il controllo predefinito per un campo multivalore è una casella combinata. Potrebbe sembrare una scelta inconsueta per un controllo in un report, in quanto non è possibile fare clic sulla freccia di una casella combinata all'interno di un report. Nel contesto di un report, tuttavia, una casella combinata presenta lo stesso comportamento di una casella di testo e la freccia è visibile solo in visualizzazione Struttura.

Se il campo contiene più valori, questi vengono separati da virgole. Se la larghezza della casella combinata non è sufficiente per visualizzare tutti i valori su una sola riga e la proprietà Espandibile della casella combinata è impostata su , i valori andranno a capo automaticamente. In caso contrario verranno troncati. Per impostare la proprietà Espandibile per un controllo, aprire il report in visualizzazione Struttura o Layout, fare clic sul controllo, quindi premere F4 per visualizzare la finestra delle proprietà del controllo. La proprietà Espandibile si trova sia nella scheda Formato che nella scheda Tutto della finestra delle proprietà del controllo.

Campi RTF    Il controllo predefinito per un campo RTF è una casella di testo. Se la larghezza della casella di testo non è sufficiente per visualizzare tutti i valori su una sola riga e la proprietà Espandibile della casella di testo è impostata su , i valori andranno a capo automaticamente. In caso contrario verranno troncati. Per impostare la proprietà Espandibile per un controllo, aprire il report in visualizzazione Struttura o Layout, fare clic sul controllo, quindi premere F4 per visualizzare la finestra delle proprietà del controllo. La proprietà Espandibile si trova sia nella scheda Formato che nella scheda Tutto della finestra delle proprietà del controllo.

Un campo RTF consente di formattare il testo in vari modi. Ad esempio, alcune parole di un campo possono essere sottolineate e altre parole nello stesso campo possono essere formattate in corsivo. È comunque possibile impostare uno stile di formattazione generale per la casella di testo che contiene il testo RTF. La formattazione della casella di testo viene applicata solo al testo che non è stato formattato in modo specifico utilizzando il formato RTF.

Impostare gli stili di formattazione per una casella di testo in cui è visualizzato un campo RTF

  1. Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento, quindi scegliere Visualizzazione Layout dal menu di scelta rapida.

  2. Fare clic sulla casella di testo in cui viene visualizzato il campo RTF, quindi fare clic sullo stile di formattazione che si desidera applicare nel gruppo Carattere della scheda Formato.

    Barra multifunzione di Access

    In Office Access 2007 la formattazione viene applicata a tutto il testo nel campo RTF a cui non è ancora stato applicato quel tipo di formattazione, ma non il valore, in una visualizzazione che supporta l'immissione di dati come la visualizzazione Foglio dati per una tabella o una query oppure la visualizzazione Maschera per una maschera. Ad esempio, se una parte del testo nel campo è formattato con il colore del carattere rosso e si applica il colore del carattere blu alla casella di testo, il colore di tutto il testo viene cambiato da Access 2007 in blu, tranne la parte formattata individualmente in rosso. Per fare un altro esempio, se una parte del testo nel campo è formattata con una dimensione del carattere di 11 punti e si applica la dimensione del carattere di 14 punti alla casella di testo, Access 2007 applica automaticamente la dimensione del carattere di 14 punti a tutto il testo eccetto la parte formattata individualmente con una dimensione di 11 punti.

    Campi degli allegati    Nei campi degli allegati viene utilizzato uno speciale controllo che non viene utilizzato per altri tipi di dati. È possibile allegare più file a un record utilizzando un unico campo degli allegati, tuttavia nel campo possono essere visualizzate informazioni solo su un allegato alla volta. Per impostazione predefinita, nel controllo allegato viene visualizzata un'icona o un'immagine, a seconda del tipo di file dell'allegato attualmente visualizzato dal controllo. È possibile impostare le proprietà per il controllo allegato in modo che tutti i file allegati vengano visualizzati come icona oppure che nel campo venga visualizzata semplicemente un'icona a forma di graffetta con il numero degli allegati. Supponendo che nel report venga già utilizzato un controllo allegato, è possibile eseguire la procedura riportata di seguito per modificare le proprietà del controllo per i diversi utilizzi.

    Per ulteriori informazioni sull'aggiunta di un campo degli allegati a un report, fare clic sul collegamento relativo al modo in cui vengono allegati file e grafica ai record del database nella sezione Vedere anche.

Impostare le proprietà di visualizzazione per un campo degli allegati

  1. Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento, quindi scegliere Visualizzazione Layout dal menu di scelta rapida.

  2. Fare clic sul controllo allegato. Se la finestra delle proprietà non è visualizzata, premere F4 per visualizzarla. Nella finestra delle proprietà fare clic sulla scheda Formato.

    Utilizzare la tabella riportata di seguito come guida per impostare le proprietà del controllo allegato.

Proprietà

Impostazione

Visualizza come

  • Immagine/Icona consente di visualizzare la grafica come immagini e tutti gli altri file come icone. Si tratta dell'impostazione predefinita.

  • Icona consente di visualizzare tutti i file come icone.

  • Graffetta consente di visualizzare un'icona a forma di graffetta seguita dal numero degli allegati tra parentesi.

Immagine predefinita

Per consentire la visualizzazione di un'immagine predefinita nel controllo allegato quando non sono presenti file allegati, fare clic su Builder button nella casella della proprietà, individuare l'immagine desiderata, quindi fare clic su Apri.

Nota : L'immagine predefinita non viene visualizzata se la proprietà Visualizza come è impostata su Graffetta.

Allineamento immagine

selezionare l'allineamento desiderato dall'elenco. L'impostazione predefinita è Centrato. La modifica di questa impostazione può generare risultati imprevisti, a seconda dell'impostazione della proprietà Modalità Ridimens. immagine.

Modalità Ridimens. immagine

Questa impostazione è disponibile solo se la proprietà Visualizza come è impostata su Immagine/Icona.

  • Ritaglia consente di visualizzare l'immagine alle dimensioni effettive. L'immagine viene ritagliata se è troppo grande per essere visualizzata all'interno del controllo.

  • Ridimensiona consente di estendere l'immagine in modo da riempire tutto il controllo.

    Nota : A meno che le dimensioni del controllo allegato siano esattamente uguali a quelle dell'immagine, l'utilizzo di questa impostazione causa una distorsione dell'immagine che apparirà allungata verticalmente o orizzontalmente.

  • Zoom consente di visualizzare l'immagine alle dimensioni massime possibili senza ritagliarla o distorcerla. Si tratta dell'impostazione predefinita.

  1. Se si utilizza il controllo per visualizzare grafica, modificare le dimensioni del controllo allegato in modo da visualizzare il livello di dettaglio desiderato.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×